CRM-Soft

ПАЦИЕНТЫ

Форма "Пациенты"

Форма "Пациенты" предназначена для просмотра и редактирования информации о пациентах.

Форма вызывается с помощь кнопки [image] тулбара программы.

Форма состоит из 5 областей:
[1] - Навигационная область позволяет найти интересующего нас пациента.
[2] - Справа выводится и редактируется общая информация о пациенте - ФИО, дата рождения, ДМС компания, и т.д.
[3] - Тулбар формы "Пациенты" позволяет производить различные операции с выбранным пациентом: печатать документы (договора, инф. согласия, и т.д.) для пациента, редактировать данные о пациенте и т.п. Также тут можно импортировать список пациентов из Excel файла.
[4] - В сабформах можно посмотреть относящиеся к пациенту документы, напоминания, услуги и т.п.
[5] - Уведомление о возможных повторах в списке пациентов

Форма используется для:
1. Просмотра информации о конкретном пациенте.
2. Поиска документов, напоминаний, услуг и других данных, связанных с конкретным пациентом.
3. Печати документов по пациенту.
4. Редактирования информации о пациенте.
5. Из формы "Пациенты" удобно создавать новые документы и напоминания (см. описание тулбара [3]).
6. С помощью тулбара формы [3] можно выполнять слияние пациентов, формирование выписного эпикриза, просматривать историю изменения данных пациента, переходить к форме "Курсы лечения" для просмотра сводной информации о визитах, услугах, оплатах и врачебных документах пациента, переходить к табличному представлению формы "Пациенты".

Поля редактирования, расположенные в правой части [2], могут быть настроены администратором. Для этого под пользователем SA доступно контекстное меню на каждом поле, которое содержит следующие параметры:

  • Обязательно для заполнения
  • Не обязательно
  • Обязательно при создании пациента
  • Только подсветить
  • Скрыть поле
  • Показать поле
  • Переименовать
  • Сбросить названия полей

При клике правой кнопкой мыши в части [4] отображаемые вкладки могут быть настроены администратором. Какие-то из них можно для пользователей при необходимости скрыть.

Некоторые константы влияют на работу формы "Пациенты":

  • "Пациенты - включить автоопределение пола на основании ФИО" - на основании заранее определенных правил программа определяет пол пациента на основании введенных фамилии, имени или отчества
  • "Пациенты - Выбирать рекламные каналы одним щелчком"
  • "Пациенты - Задержка в миллисекундах перед отправкой запроса на обновление списка пациентов (пусто=без задержки)" - задержка при обновлении навигационного списка в случае фильтра по ФИО пациента
  • "Пациенты - Нумерация договоров: 1=каждый год заново, 2=непрерывная"
  • "Пациенты - Раздельный учет фамилии имени отчества" - в форме "Пациенты" отображаются либо поля "ФИО" и "Телефон", либо поля "Фамилия", "Имя", "Отчество", "Телефон", "Телефон 2", "Телефон 3".
  • "Пациенты - Телефон должен соответствовать маске +*(***) ***-**-**" - телефон пациента должен соответствовать шаблону, например, +8(921)1234-56-78.


ПАЦИЕНТЫ

Навигация

Навигационная секция формы "Пациенты" используется для поиска пациентов. В простейшем случае пациент ищется путем просмотра списка пациентов [5]. Если пациентов много, можно воспользоваться полем поиска по ФИО [3]. При вводе в поле [3] любого текста, программа оставляет в списке [5] только тех пациентов, в ФИО либо в номере полиса которых содержатся введенные символы. Поле [3] можно также использовать для поиска по номеру медицинской карты. При этом, в отличие от поиска по ФИО, надо будет ввести номер медицинской карты полностью.

В области [1] программа выводит текстовое описание расширенного фильтра. На приведенном рисунке отфильтрованы пациенты, обслуживающиеся в ДМС компании "ООО "Страховая компания". Форма настройки расширенного фильтра открывается кнопкой [2]. Кнопка [4] сбрасывает все имеющиеся фильтры.

С помощью расширенного фильтра можно произвести отбор:

  • Пациентов, относящихся к определенной ДМС компании
  • Пациентов, пришедших в клинику благодаря выбранному рекламному каналу
  • Пациентов, записанных на прием, либо имеющих врачебные документы, либо впервые пришедшие за определенный период
  • Пациентов, относящихся к текущему пользователю. Пользователь идентифицируется по логину, введенному при запуске программы, привязка логина к фамилии врача в базе производится по колонке "Логин" справочника "Врачи". Отбираются все пациенты, у которых текущий пользователь является лечащим врачом. Кроме этого, если пользователь указал диапазон дат, то в список попадут все пациенты, которые были записаны на прием к текущему пользователю на указанный период, либо для которых у текущего пользователя существуют врачебные документы, относящиеся к указанному периоду.
  • Пациентов, с суммой услуг более указанной суммы
  • Пациентов, являющихся должниками
  • Пациентов, с указанным адресом электронной почты
  • Пациентов, у которых день рождения попадает в указанный период
  • Пациентов, с определенным статусом
  • Пациентов, с определенным номером телефона

А также по другим полям из карточки пациента.


ПАЦИЕНТЫ

Тулбар

Тулбар формы "Пациенты" состоит из тулбара редактирования, выпадающего списка "Напечатать" и нескольких кнопок.

Тулбар редактирования являются стандартным элементом, его использование описано в одноименном разделе справки.

В выпадающем списке "Напечатать" отображаются печатные формы, добавленные в систему в форме "Шаблоны печатных форм" (меню "Администрирование"). С помощью печатных форм производится печать договоров, информированных согласий, амбулаторных карт, и других документов. В выпадающий список "Напечатать" в тулбаре формы "Пациенты" попадают шаблоны печатных форм, у которых в поле "Вывод в форме" стоит значение "Пациенты" или "Пациенты - печать конвертов". Если для печатной формы указано название подменю, то шаблон будет расположен в этом подменю. Шаблоны со значением поля "Пациенты - печать конвертов" находятся в конце списка после разделительной строчки "ПЕЧАТЬ КОНВЕРТОВ". В зависимости от значения поля "Действие", а при его отсутствии в зависимости от константы пользователя "Пациенты - при нажатии на Печать: 1=Предпросмотр, 2=Печать, 3=Открыть в Ворде" (Справочники - Константы пользователя), при выборе печатной формы из выпадающего списка, она будет открыта для предпросмотра, сразу отправлена на печать, либо открыта в программе MS Word. Подробное описание работы с печатными формами приведено в разделе, описывающем шаблоны печатных форм.

Кнопка "Режим Госпитализации" переключает карточку пациента в данный режим и обратно к стандартному виду.

Кнопка "Создать документ из шаблона" используется для создания новых документов. После нажатия на кнопку, программа предложит пользователю выбрать один из имеющихся в системе шаблонов. На основании выбранного шаблона будет создан документ, после чего программа откроет форму "Документы" для редактирования созданного документа.

Кнопка "Добавить напоминание" выводит диалог создания напоминания для текущего пациента.

Кнопка "Слияние пациентов" позволяет объединить информацию двух пациентов. Часто в результате ошибок ввода один и тот же пациент оказывается введенным в программу несколько раз. В случае, если для разных копий одного и того же пациента введены врачебные документы, назначены напоминания, либо пациент записан на прием, возникает необходимость объединения этих данных в одном пациенте. Чтобы произвести слияние пациентов, выберите пациента, которого планируете оставить в базе. Далее нажмите на кнопку "Слияние пациентов", выберите пациента который будет удален, и подтвердите свой выбор. Программа переместит все документы, услуги и напоминания из удаляемого пациента в оставшегося, после чего удалит дубликат.

Кнопка "Выписной эпикриз" предназначена для формирования списка диагнозов, выставлявшихся пациенту в различных врачебных документах. После нажатия на кнопку, программа выведет диалоговое окно.

Заполнять поля диалогового окна не обязательно, если оставить их пустыми, программа составит список диагнозов по всем документам, относящимся к пациенту. Список документов, из которых извлекаются диагнозы, можно отфильтровать по дате, либо по врачу. Программа просматривает документы, и в каждом из них ищет абзац, начинающийся со слова "Диагноз:". Если в документе несколько абзацев, начинающихся со слова "Диагноз:", программа проигнорирует все диагнозы, кроме первого. Таким образом, программа формирует список документов, с указанием внутреннего номера, врача, даты, названия документа и диагноза. Если в документе нет слова "Диагноз:", документ все равно попадает в результирующий список. Если в диалоговом окне пользователь нажал кнопку "Просмотр", полученный список будет выведен для просмотра. Если в диалоговом окне пользователь нажал кнопку "Сформировать документ", программа создаст врачебный документ "Выписной эпикриз", и откроет его для редактирования.

Кнопка "Курсы лечения" предназначена для перехода к форме "Курсы лечения", в которой можно просмотреть итоговую информацию о курсах услуг, визитах, услугах, оплатах и врачебных документах пациента за весь период прохождения лечения в клинике. Подробное описание формы "Курсы услуг" находится в соответствующем разделе справки.

Кнопка "Опросы" предназначена для создания опроса пациента. Подробное описание действий по создании опросов находится в соответствующем разделе справки. Сразу после нажатия на кнопку откроется диалоговое окно создания нового опроса.

Кнопка "История изменения" предназначена для просмотра изменений данных пациента с момента его прихода в клинику. При нажатии на кнопку сформируется отчет:

Отчет "История изменения пациентов" доступен также из меню "Администрирование".

Заполнение Анкеты пациента.

Кнопка "Табличный вид" предназначена для просмотра данных пациентов в виде таблицы. При нажатии на кнопку откроется форма:

В целях безопасности, доступ к этой кнопке есть только у системного администратора (пользователь с логином sa), и членов специальной роли rl_patients_export.

Список пациентов в табличном виде соответствует списку пациентов, отфильтрованному в форме "Пациенты". После нажатия на кнопку "Печать", таблица будет распечатана в виде:

Импорт списка пациентов из файла Microsoft Excel. Для импорта можно указать только поля:

  • ФИО
  • Телефон
  • Адрес
  • Адрес регистрации
  • Дата рождения
  • Номер договора
  • Номер мед. карты
  • Примечание
  • Паспорт
  • Место работы
  • Профессия, должность
  • ДМС компания
  • Номер полиса ДМС
  • Действует ДМС с
  • Действует ДМС по
  • Номер полиса ОМС
  • Действует ОМС с
  • Действует ОМС по


ПАЦИЕНТЫ

Сабформы

В секции сабформ формы "Пациенты" можно посмотреть дополнительную информацию, связанную с выбранным в навигационном списке пациенте.

Сабформа "Визиты"

В сабформе выводится список всех визитов пациента с момента первого посещения клиники. Видимость сабформы зависит от константы "Пациенты - отображать закладку Визиты". Данные в сабформе не редактируются. Из контектного меню сабформы возможно распечатать документы, созданные на основе шаблонов печатных форм, у которых в поле "Открыть в форме" указано "Запись". Двойной щелчок на записи в сабформе открывает соответствующий визит.

Если для печатной формы указано название подменю, то печатная форма будет расположена в этом подменю. Подменю создается на том же уровне, что и пункт меню "Печать документов". Если название подменю начинается со "*", то в этом случае подменю создается внутри пункта "Печать документов".

Образец меню печати печатных форм:

Сабформа "Услуги"

В сабформе выводится список всех услуг, оказанных пациенту. Данные в сабформе не редактируются. Из контектного меню сабформы возможно распечатать документы, созданные на основе шаблонов печатных форм, у которых в поле "Открыть в форме" указано "Запись". Двойной щелчок на записи в сабформе открывает визит, в который входит выбранная услуга. При выборе пункта "Добавить" в контекстном меню программа пытается создать визит с сегодняшей датой, временем начала работы клиники, определяемым константами "Расписание врачей - Начало приема, часы" и "Расписание врачей - Начало приема, минуты", текущим пациентом и врачом. Если создание визита невозможно, например, в это время врач работает с другим пациентом, то создание визита следует провести в форме "Запись", изменив параметры визита. Пункт "Печать документов" формируется так же как и для сабформы "Визиты".

Сабформа "Документы"

В сабформе выводится список всех врачебных документов пациента. Данные в сабформе не редактируются. Двойной щелчок на записи в сабформе открывает форму "Документы" и переходит к выбранному документу. Из контекстного меню сабформы можно просмотреть выбранный документ с помощью пункта "Печать", а также просмотреть историю изменения документа с помощью соответствующего пункта.

Сабформа "Напоминания"

В сабформе выводится список всех напоминаний пациента. Данные в сабформе не редактируются. Из контекстного меню сабформы можно добавить или удалить напоминание, а также добавить звонок к выбранному напоминанию. Редактирование напоминания осуществляется двойным щелчком на записи. Работа с напоминаниями описана в соответствующем разделе справки.

Сабформа "Долги"

В сабформе выводится список визитов пациента со статусом "Пришел", "Сторно" или "Сторно, деньги возвращены", для которых сумма оказанных услуг не равна сумме оплат по визиту, т.е. визиты, за которые пациент не внес всю сумму оплаты либо, наоборот, переплатил. Данные в сабформе не редактируются. Двойной щелчок на записи в сабформе открывает соответствующий визит.

Сабформа "Файлы"

В сабформе выводится список файлов, прикрепленных к пациенту, и файлов, прикрепленных к врачебным документам пациента. В зависимости от констант "Файлы - хранить внутри базы (нет = во внешней папке)" и "Администрирование - Путь к сетевой папке для хранения файлов" файлы хранятся либо внутри базы либо на жестком диске. При двойном щелчке на выбранном файле он сохраняется из базы или копируется из сетевой папки в папку attachments, находящуюся на диске пользователя в папке, откуда запущена программа, а затем открывается в соответствующей расширению данного файла программе. Если прикрепленный файл является графическим и имеет расширение "png", "jpg", "bmp", то в правой части сабформы есть возможность просмотреть превью файла. Превью создается автоматически при прикреплении к документу графического файла. Его размеры зависят от констант "Файлы - Максимальный размер превью-файла по вертикали, в пикселях", "Файлы - Максимальный размер превью-файла по горизонтали, в пикселях", "Файлы - Качество preview файла (от 1=минимум до 5=максимум)". Если пользователь открыл прикрепленный файл дважды кликнув на записи, то с частотой определенной в константе "Документы - Если пользователь открыл из программы файл, проверять наличие изменений раз в Х секунд" программа будет сверять дату и размер файла в папке attachments с их старыми значениями. Если файл был изменен, то программа предложит сохранить изменения, т.е. сохранить файл в базе данных или скопировать его в сетевую папку для хранения файлов. Если файл был одновременно изменен и в папке attachments и в базе данных (или сетевой папке), например, в случае изменения файла другим пользователем или его изменения и сохранения в промежутке между срабатываниями таймера проверки изменений, то программа выдаст предупреждение и больше не будет следить за изменениями данного файла.

Сабформа "Оплаты"

В сабформе выводится список оплат услуг, оказанных пациенту. Видимость сабформы зависит от константы "Пациенты - отображать закладку Оплаты". Данные в сабформе не редактируются. При двойном щелчке на записи откроется визит, к которому привязана выбранная оплата. Работа с оплатами осуществляется в форме "Визит".

Сабформа "Переводы"

В сабформе выводится список переводов денег, поступивших на счет пациента, а также список переводов, сделанных пациентом на счета других пациентов. При двойном щелчке на поле "ФИО адресата" откроется форма выбора пациента, которому будут переведены деньги. Очистить уже заполненное поле "Фио адресата" можно только с помощью пункта "Очистить" контекстного меню. Константа "Пациенты - В переводах тип перевода по умолчанию" определяет тип перевода при создании новой записи в сабформе. В константе требуется указать числовое значение: 1 - Продажа сертификата, 2 - Использование сертификата, 3 - Списание долга, 4 - Внесение/возврат наличных, 5 - Перевод на другого пациента, 6 - Перевод от юрлица.

В зависимости от значения константы "Пациенты - Разносить платежные операции по вкладкам в соответствующим с типом операции" вместо вкладки "Переводы" может быть отображено 4 вкладки:

  • "Аванс" - тип перевода 4 - Внесение/возврат наличных
  • "ДМС" - тип перевода 6 - Перевод от юрлица (для юридических лиц, для которых указано "использовать предоплату")
  • "Безнал" - тип перевода 6 - Перевод от юрлица (для юридических лиц, для которых не указано "использовать предоплату")
  • "Разрешения" - оставшиеся типы переводов

Сабформа "Больничные"

В сабформе выводится список больничных листов, выданных разными врачами клиники пациенту.

Сабформа "Лист ожидания"

В сабформе выводится лист ожидания для пациента.

Сабформа "СМС"

В сабформе выводится список отправленных пациенту СМС и их статус на текущий момент. Зеленым фоном выделены входящие СМС, а желтым - исходящие. Также можно отправить из сабформы произвольное СМС сообщение по нажатию на плюс левой панели. В открытом после этого окне можно выбрать шаблон сообщения, ранее указанный в константах, подробнее в "Константы клиники".

Сабформа "Наряды"

В сабформе выводится список заказанных нарядов для пациента. Каждый наряд имеет следующие аттрибуты: номер наряда, дата, дата выполнения, статус, поставщик, прайс, описание и курс, в который наряд входит. В рамках одного наряда можно указывать любое количество услуг из общего прайс листа. Список всех нарядов с детализацией отображается в отчете "Наряды" из главного меню окна "Отчеты".

Сабформа "Фото"

В сабформе можно указать путь, где будут храниться графические файлы для пациента. Путь задается для каждого конкретного врача отдельно. Корневая папка для всех пациентов врача может быть задана в справочнике "Пользователи" в колонке "Путь к фото".

Сабформа "Звонки"

Для удобства Call-центра в закладке "Звонки" можно фиксировать обращения пациента по телефону.

Сабформа "Медкарты"

В сабформе выводится список медицинских карт пациента. Если у пациента не может быть более одной медицинской карты, то достаточно заполнять поле "Медицинская карта" в правой части формы "Пациенты". Видимость сабформы зависит от константы "Пациенты - Выводить закладку "Медкарты".

Сабформа "Анкеты"

В сабформе выводится список анкет пациента. Сабформа видна только в случае наличия в программе модуля "Анкеты". Данные в сабформе не редактируются. Работа с анкетами описана в соответствующем разделе справки.

Сабформа "Опросы"

В сабформе выводится список опросов пациента. Сабформа видна только в случае наличия в программе модуля "Опросы". Данные в сабформе не редактируются. Работа с опросами описана в соответствующем разделе справки.

Сабформа "Скидки"

В сабформе выводится список индивидуальных скидок пациента. Содержание сабформы аналогично справочнику скидок, описанному в разделе справки "Запись на прием - Скидки".

Сабформа "Квитанции"

В сабформе выводится список квитанций пациента, номера квитанций назначаются автоматически.

При первом открытии формы будет выбрана сабформа, определяемая константой пользователя "Пациенты - По умолчанию отображать закладку".


ПАЦИЕНТЫ

Печать конвертов

В программе реализована возможность одновременной печати нескольких документов на основании одного шаблона. В основном, этот способ применим для печати конвертов и типовых писем, отличающихся только индивидуальными данными пациентов, место которых в шаблоне занимают тэги.

В выпадающий список "Напечатать" в тулбаре формы "Пациенты" попадают шаблоны печатных форм, у которых в поле "Вывод в форме" стоит значение "Пациенты" или "Пациенты - печать конвертов". Шаблоны со значением поля "Пациенты - печать конвертов" находятся в конце списка после разделительной строчки "ПЕЧАТЬ КОНВЕРТОВ".

При выборе документа с данным типом шаблона открывается форма "Выбор пациентов для печати конвертов".

В левой части формы отображается список пациентов аналогичный содержанию навигационного списка формы "Пациенты". При этом навигационный список может быть предварительно отфильтрован по некоторым параметрам.

Для переноса пациентов в список печати, находящийся в правой части формы, и удаления из него используются кнопки "Переместить в список для печати", "Переместить в список "Отфильтрованные пациенты", "Переместить всех пациентов в список для печати", "Переместить всех пациентов в список "Отфильтрованные пациенты".

Для пациентов, находящихся в списке печати, после нажатия на кнопку "Печать" будет сформирован итоговый документ на основании выбранного шаблона печатной формы. Текст шаблона будет повторен несколько раз по числу выбранных пацинтов. В тэги шаблона будут подставлены данные каждого пациента.


ПАЦИЕНТЫ

Работа с электронными листками нетрудоспособности

ФСС РФ для работы с электронными листами нетрудоспособности (ЛН) требует использование программного обеспечения АРМ ЛПУ. Ссылка на дистрибутив АРМ ЛПУ: http://fss.ru/ru/fund/download/56223/index.shtml. Желательно установить и настроить последнюю версию.

После установки необходимо ввести в АРМ ЛПУ данные Вашей клиники в пункте меню АРМ ЛПУ «Сервис» -- «Настройки» -- «Данные ЛПУ».

В МИС «Учет пациентов» в форме «Пациенты» нажать в нижней части закладку «Больничные». Для добавления нового больничного нажать зеленый плюсик слева.

Появится бланк ЛН для ввода данных.
Когда Вы заполните все необходимые поля, то, при нажатии на кнопку сохранения, появится сообщение о том, что файл для загрузки ЛН в АРМ ЛПУ создан.

В АРМ ЛПУ Вы открываете меню «Учетная работа» -- «Учет ЛН» и выбираете пункт «Загрузка РЛН».

Выберите нужный файл.
ЛН импортирован в АРМ ЛПУ.


ДОКУМЕНТЫ

Автосохранение

Для защиты от потери данных в случае разрыва связи с сервером при редактировании документов добавлено автоматическое сохранение.

Периодичность автосохранения определяется константой 405 [Документы - Периодичность автосохранения, мин], и обычно составляет 2 минуты.

Незавершенные изменения сохраняются на сервере. Если по каким-либо причинам связь с сервером прерывается, то при следующем входе в программу, и открытии формы "Врачебные документы", программа откроет документ, редактирование которого не было завершено, и сообщит пользователю "Программа обнаружила, что во время предыдущего сеанса, Вы редактировали документ, но не сохранили его. Программа восстановила несохраненные изменения. Просьба завершить редактирование, либо сохранив данные, либо отменив изменения."

Внимание! Если у Вас установлена старая версия программы (последнее обновление до 31.12.2017), то у Вас действует старая схема, когда незавершенные документы сохраняются на диск. Старая схема описана ниже.

Текущий документ сохраняется в папку с программой с именем autosave.rtf, о чем будет выведено сообщение. Если записать в файл с данным именем невозможно (например, файл занят другим приложением или создана папка с этим именем), то к имени файла приписывается число начиная от 1 до 100 до первой удачной попытки записи на диск.

После перезапуска программы при переходе к Документам будет сделана разовая проверка наличия файла с автосохранением, который должен быть не старше 1 часа. Если такой файл найден, то будет предложено открыть его во внешнем редакторе для RTF файлов.


ДОКУМЕНТЫ

Выбор кода МКБ

Форма предназначена для выбора кодов МКБ.

Для работы со списками замен форма больше не используются, смотрите статью Списки замен

Форма вызывается:

  • Из меню "Администрирование" при выборе пункта "Словарь". В этом случае форма используется только для ввода и изменения данных словаря. Кнопки "Выбор" и "Отмена" отсутствуют.
  • Из формы "Документы" при выборе пункта "Словарь (МКБ)" из контекстного меню текущего документа или при двойном щелчке на слово #МКБ#, заключенное в ##
  • Из формы "Визит" при двойном щелчке в поле "МКБ" услуги
  • из формы "Пациенты" при щелчке на кнопку с треугольником справа от полей "Основной диагноз" "Дополнительный диагноз" "Сопутствующий диагноз". Открывается при условии, что в словаре пустой или отсутствует список диагнозов. Если в Словаре есть список диагнозов (папка "Диагноз" и добавленные к ней диагнозы), то вместо выбора МКБ предлагается выбрать один из введенных диагнозов.

Словарь организован в виде дерева. Каждый элемент в левой части формы является группой терминов (ветвь или узел дерева) и может содержать подгруппы (поддеревья). При навигации по дереву в правой части отображаются термины, входящие в данную ветвь дерева и его поддерево. Например, при выборе верхнего элемента дерева в правой части будут отображено все содержимое словаря (листья дерева). Одновременно отображается количество записей, заданное в константе "В словаре при выводе списка слов по умолчанию выводить только первые Х слов". При большем количестве записей в список терминов справа последней строчкой добавляется запись "ПОКАЗАТЬ ПОЛНЫЙ СПИСОК". При двойном щелчке на ней будут показаны все записи, входящие в текущее поддерево.

Правая часть формы состоит из текстового поля для фильтрации, кнопки Избранное, кнопки сброса фильтра и списка терминов словаря. При двойном щелчке на запись в правой части ее значение будет возвращено в вызывающую форму. При этом, возвращаемые данные зависят от формы, из которой был вызван словарь: для формы "Документы" будут возвращены данные в зависимости от константы "В словаре при вставке слова в Документ вставлять 1 = Код + Расшифровка (название), 2 = Только расшифровка", а для поля "МКБ" в форме "Визит" будет возвращен код МКБ.

Возможен множественный выбор из словаря при помощи клавиши CTRL. Для выхода из формы с передачей выбранных данных в вызывающую форму необходимо нажать кнопку "Выбрать". В случае, когда множественный выбор не производился, нажатие на кнопку аналогично выбору текущей записи при помощи двойного щелчка. Для сброса ранее выбранных слов достаточно выбрать любое слово без нажатой клавиши CTRL.

На поведение дерева влияют константы пользователя:

  • В словаре в дереве сохранять состояние между открытиями (Да=сохранять, Нет=сбрасывать)
  • В словаре в дереве автоматически сворачивать все ветки, кроме текущей

При щелчке правой клавишей на слово, заключенное в ##, в форме "Документы" вызывается видоизмененная форма словаря без дерева в правой части. При этом, предполагается, что слово, заключенное в ##, требуется заменить на один из предложенных вариантов.

Кнопка [image] позволяет отображать или скрывать дерево.

Управление избранным происходит с помощью контекстного меню у элементов дерева. При добавлении узла в избранное автоматически добавляются и все его родители для того, чтобы при переключении в режим показа только избранных записей было построено дерево. Удалить же из списка избранных узлы можно только находясь в этом режиме.

Форма "Словарь" позволяет также добавлять, изменять и удалять данные словаря. Эти действия выполняются при выборе соответствующих пунктов ("Добавить пункт", "Редактировать пункт", "Удалить пункт") из контекстного меню дерева или списка записей в правой части.

При добавлении записи в дерево открыватся форма "Добавить пункт в словарь".

Необходимо ввести поля "Название", "Код" и "Текст".

Запись может быть добавлена:

  • На тот же уровень дерева, что и текущая запись
  • В поддерево текущей записи

Добавленная запись будет являться листом дерева и отображаться только в правой части формы. Для преобразования записи из правой части в узел дерева необходимо добавить к нему данные, т.е. повторно вызвать форму "Добавить пункт в словарь".

При редактировании записи открыватся форма "Редактировать пункт в словаре".

Ее внешний вид и описание совпадает с формой "Добавить пункт в словарь".

Возможно добавление в дерево сразу нескольких листьев. Для этого из контекстного меню дерева или списка записей в правой части необходимо выбрать пункт "Добавить список". В открывшейся форме нужно перечислить названия добавляемых листьев, разделенные точкой с запятой или запятой, при условии, что значение константы "Словарь - при вводе списка пунктов запятую считать разделителем" равно "Да".

Если текстовое поле вверху формы оставить пустым, то новые узлы добавятся к текущему узлу дерева. В противном случае, сначала к текущему узлу дерева добавится узел с названием, взятым из текстового поля, новые листья добавятся непосредственно к созданному узлу.

Для первоначального заполнения словаря можно использовать следующий алгоритм:

1. В форме "Шаблоны" скопировать в буфер обмена текст, состоящий из названий листьев, разделенных запятой или точкой с запятой.
2. В форме "Шаблоны" произвести двойной щелчок на фразе, заключенной в "#".

Откроется форма "Словарь". Узел, выбранный при последнем закрытии формы, станет текущим. Откроется форма "Добавить список в словарь". Поле "Добавить подчиненный узел в узел" заполнится фразой, заключенной в "#", текст из буфера обмена вставится в поле "Добавить список".

3. Сохраняем данные
4. В форме "Словарь" выбираем пункт для добавления следующих значений, переходим в форму "Шаблоны" и повторяем действия.


ДОКУМЕНТЫ

Общее описание формы

Форма предназначена для редактирования врачебных документов.

Форма состоит из нескольких секций. Левая часть формы используется для навигации, т.е. выбора нужного документа. Правая часть формы используется для редактирования документа. Описание формы разбито на несколько статей:

  • Описание навигации
  • Описание заголовка и кнопок управления
  • Описание списка замен
  • Описание сабформ (списки напоминаний, услуг, лекарств и назначений внизу справа на форме)

Документы создаются на основе шаблонов врачебных документов - заранее подготовленных rtf файлов. Рекомендации по созданию шаблонов можно посмотреть в разделе справки "Администрирование - Подготовка шаблонов RTF документов". Дополнительное редактирование документа производится с помощью встроенного мини-редактора. Большая часть управляющих кнопок редактора очень сильно похожа на управляющие кнопки редактора MS Word, и в данной справке не описывается. Если в документ надо вставить табличку, рекомендуется сделать табличку в MS Word, скопировать ее, и вставить в документ. Работа с таблицами поддерживается редактором, но соответствующие кнопки не выведены на панели управления, чтобы не загромождать систему. Возможна вставка в документ рисунков, но делать это не рекомендуется. В программе используется бесплатная редакция MS SQL Server 2005 Express Edition, с ограничением размера базы в 4 ГБ. Это большой размер, но при интенсивной вставке рисунков в документы его можно исчерпать, и в этом случае необходимо будет переходить на достаточно дорогую платную версию сервера БД.

При редактировании текста документа можно пользоваться контекстным меню. В контекстном меню содержатся пункты:

  • Стандартные для текста "вырезать-копировать-вставить"
  • Создание и редактирование таблиц внутри документа
  • Перейти к документу. Курсор в тексте должен стоять на номере документа, заключенного в #
  • Добавить в услуги. Врач пишет список кодов в документе: 'Пр31; Пр52*3; Пр50*2'. Выделяет их текстовым выделением и щелкает правой клавишей для добавления. Программа расшифровывает коды на основании прейскуранта, и добавляет их в услуги.
  • Словарь (МКБ). Для вставки текста из словаря
  • Медстандарт. Поиск медстандарта по слову из под курсора.
  • Вставить список услуг. Позволяет добавить текстом или табличкой список оказанных услуг пациенту, услуги можно выбрать в отдельной форме.

У каждого документа есть внутренний номер. Он выводится в верхней правой части документа фиолетовым цветом. Если в тексте документа содержится номер другого документа, заключенный в символы решетки ("#147#"), то при щелчке на номере правой клавишей и выборе пункта контекстного меню "Перейти к документу" программа откроет документ с соответствующим номером.

Пункт контекстного меню "Добавить в услуги" может быть использован, если для даты и врача документа существует запись на прием (визит) пациента с аналогичными датой и врачом. Тогда пользователь может написать в документе через запятую коды услуг, выделить их, щелкнуть на них правой клавишей, и выбрать "Добавить в услуги". Если у пользователя есть соответствующий доступ, программа добавит услуги с введенными кодами к списку услуг найденного по дате и врачу визита. Данная опция используется в клиниках, для которых характерно большое количество услуг, и у врачей есть доступ к редактированию услуг.

При выборе из контекстного меню пункта "Словарь" или при двойном щелчке на слово, заключенное в ##, открывается форма "Словарь", предназначенная для выбора термина из словаря либо для замены слова одним из соответствующих ему вариантов. Подробное описание можно посмотреть в соответствующем разделе справки.

При открытии формы документы в главном меню программы появляется дополнительный пункт "Документы":

Для более удобного редактирования больших документов предназначена специальная форма доступная при выборе пункта меню "Полноэкранный режим" или при нажатии комбинации клавиш "Ctrl+F". При выборе оставшихся пунктов меню прячется или отображается соответствующая часть формы. То же самое можно сделать, задав константы пользователя: "Документы - отображать навигационную панель", "Документы - отображать панель прикрепления файлов", "Документы - отображать панель свойств текста", "Документы - отображать сабформы (услуги / напоминания)", "Документы - Отображать панель курсов лечения".


ДОКУМЕНТЫ

Заголовок и кнопки управления

  • Тублар редактирования [1] стандартный, его описание можно найти в одноименном разделе справки. К нему справа добавлена кнопка для снятия и установки флага "Подписано".
  • Кнопки [2] используются для перехода к предыдущему/последующему документу. Программа запоминает историю перемещения пользователя по документам, аналогично тому как это делается в браузерах.
  • Кнопки [3] позволяют добавить напоминание, добавить услугу, и посмотреть историю изменения документа, перейти к форме курсы услуг. Подробное описание приведено ниже.
  • Надпись [4] содержит ФИО пациента, к которому прикреплен документ, его дату рождения и возраст. Если щелкнуть на ФИО пациента правой кнопкой мыши, откроется контекстное меню с единственным пунктом "Перейти к пациенту".
  • Надпись [5] содержит внутренний номер документа. Если щелкнуть на номере правой кнопкой мыши, откроется контекстное меню, с помощью которого можно скопировать номер документа в клавиатурный буфер, либо скопировать в клавиатурный буфер полное название документа (Номер документа + ФИО пациента + Врач документа + Название документа). Если вставить в текст документа номер другого документа, заключенный в символы решетки (например: "Первичный осмотр #147#"), то в дальнейшем можно будет легко перейти к этому документу. Для этого следует щелкнуть на номере документа (т.е. в тексте "Первичный осмотр #147#" следует щелкнуть на цифре 147) правой клавишей, и в контекстном меню выбрать пункт "Перейти к документу".
  • Поля [6] - Название документа, Дата, Врач и Тип шаблона - предназначены для редактирования параметров документа.
  • Надпись [7] - содержит название курса лечения, в который входит врачебный документ. Если документ не входит ни в один курс лечения, то выводится надпись "Курс лечения не определен". Из контекстного меню надписи можно создать, удалить, переименовать существующий курс лечения, исключить документ из курса лечения, перенести документ в другой курс лечения, выбрав один из существующих для пациента курсов в нижней части контекстного меню. Двойной щелчок на надписи аналогичен щелчку на кнопке "Курсы лечения" в тулбаре.
  • Раздел [8] позволяет прикреплять к документу внешний файл (например рисунок). К документу можно прикрепить произвольный файл. Чаще всего эта возможность используется для прикрепления рисунков (кардиограммы, снимки зубов, данные анализов и т.п.). В зависимости от констант "Файлы - хранить внутри базы (нет = во внешней папке)" и "Администрирование - Путь к сетевой папке для хранения файлов" файлы хранятся либо внутри базы, либо на жестком диске. При двойном щелчке на названии прикрепленного файла он сохраняется из базы или копируется из сетевой папки в папку attachments, находящуюся на диске пользователя в папке, откуда запущена программа, а затем открывается в соответствующей расширению данного файла программе. Если прикрепленный файл является графическим и имеет расширение "png", "jpg", "bmp", то в нижней части панели навигации можно будет просмотреть превью файла. Превью создается автоматически при прикреплении к документу графического файла. Его размеры зависят от констант "Файлы - Максимальный размер превью-файла по вертикали, в пикселях", "Файлы - Максимальный размер превью-файла по горизонтали, в пикселях". Кнопка с изображением открытой папки добавляет файл к документу (выводится форма выбора файла). Кнопка с изображением дискеты сохраняет прикрепленный файл на диск. Кнопка с мусорной корзиной удаляет файл. Кнопка с листком с лупой действует аналогично двойному щелчку на названии файла. Если пользователь открыл файл, прикрепленный к документу, либо двойным щелчком на названии файла, либо с помощью кнопки "Просмотр", то с частотой определенной в константе "Документы - Если пользователь открыл из программы файл, проверять наличие изменений раз в Х секунд" программа будет сверять дату и размер файла в папке attachments с их старыми значениями. Если файл был изменен, то программа предложит сохранить изменения, т.е. сохранить файл в базе данных или скопировать его в сетевую папку для хранения файлов. Если файл был одновременно изменен и в папке attachments и в базе данных (или сетевой папке), например, в случае изменения файла другим пользователем или его изменения и сохранения в промежутке между срабатываниями таймера проверки изменений, то программа выдаст предупреждение и больше не будет следить за изменениями данного файла.
    При прикреплении файла в формате PDF документа, то данный документ будет отображаться вместо основного текста документа. Переключить на обычный вид и обратно можно с помощью кнопки "Показать документ" в данном тулбаре.

Описание кнопок [3] - Добавление напоминания.
При щелчке на кнопку с колокольчиком открывается форма добавления напоминания:

Подробное описание напоминаний можно прочитать в справке по форме Напоминаний. Внизу формы "Документы" есть ряд закладок. В том числе - закладка "Напоминания". В этой закладке отображаются все напоминания, назначенные из данного документа, либо созданные в день, совпадающий с днем документа.

Описание кнопок [3] - Добавление услуги.
При щелчке на кнопку с часами открывается форма выбора услуги. Форма выбора услуги полностью аналогична той форме, которая вызывается при редактировании Визита (см.справку по записи пациента на прием). Данная кнопка используется в стоматологических клиниках. Стоматологов отличает большое количество услуг, оказываемых пациенту за один визит. Иногда бывает удобно, чтобы список услуг редактировал не сотрудник ресепшена, как это делается в обычных клиниках, а непосредственно врач, одновременно с редактированием врачебного документа. Если для даты и врача документа программа находит запись на прием (визит) пациента с аналогичными датой и врачом, то к этому существующему визиту врач может добавлять услуги с помощью описываемой кнопки. Список услуг, дата которых совпадает с датой документа, отображается внизу формы "Документы".

Описание кнопок [3] - Просмотр истории изменений документа.
При щелчке на кнопку с перевернутой корзиной открывается форма просмотра истории изменения документа:

Система хранит определенное количество резервных копий каждого документа. Максимальное количество сохраняемых копий задается константой "Документы - Количество изменений документа, которые помнит система" (по умолчанию 5). В форме "История изменений документа" можно просмотреть предыдущии редакции документа. Красным цветом над текстом документа система выводит сообщение, какая именно информация была изменена в этой редакции документа.

Описание кнопок [3] - Курсы лечения.

Кнопка "Курсы лечения" предназначена для перехода к форме "Курсы лечения", в которой можно просмотреть итоговую информацию о курсах услуг, визитах, услугах, оплатах и врачебных документах пациента за весь период прохождения лечения в клинике. Подробное описание формы "Курсы услуг" находится в соответствующем разделе справки.

Описание кнопок [3] - Создать шаблон на основе документа.
При щелчке на данную кнопку потребуется ввести имя нового шаблона и документ будет скопирован в список шаблонов.

Описание кнопок [3] - Скопировать...
Позволяет скопировать данный документ для этого же или любого другого пациента.

Описание кнопок [3] - Печать нескольких документов.
При щелчке на кнопку с принтером открывается форма выбора документов для печати:

Первоначальный список документов в левой части совпадает со списком документов в навигационном списке формы "Документы". После перенесения документов в правую часть и задания порядка расположения документов с помощью кнопок,расположенных на форме, и нажатия на кнопку "Печать", выбранные документы будут объединены в один документ, который будет открыт для предварительного просмотра. При создании итогового документа учитываются выбранные на форме дополнительные параметры: "Печатать каждый документ с новой страницы" или "Печатать документы слитно", а также "добавлять шапку в начало документа".

Описание кнопок [3] - Печать консультативного заключения.
Печатается документ на основе Шапки консультативного заключения (шаблон печатных форм) и текста текущего документа, залюченного между словами указанными в константах:

  • 275 - Документы - "Печать консультативного заключения" печатать документ до абзаца, начинающегося на слово
  • 276 - Документы - "Печать консультативного заключения" печатать документ начиная со слова

Кнопка видима только при включенной константе 240 - Документы - Отображать кнопку "Печать консультативного заключения".


ДОКУМЕНТЫ

Навигация

Один из наиболее простых способов поиска документа - выбрать в форме Пациентов нужного пациента. В закладке "Документы" внизу формы можно будет увидеть все документы этого пациента. Дважды щелкнув на строчке, пользователь перейдет к редактированию соответствующего документа.

Левая часть формы "Документы" используется, если пользователь хочет посмотреть все документы за определенный период, или документы, сформированные определенным врачом, и т.п. В навигационной секции формы "Документы" имеются:

  • Область описания текущего фильтра [1]
  • Кнопка [image] вызова формы "Документы - расширенный фильтр"
  • Поле [2] фильтрации по названию документа
  • Кнопка [image] сброса фильтра
  • Галочка "Только документы пациента ***" - Если галочка включена, отображаются только документы соответствующего пациента (последний пациент, которого пользователь открывал в форме "Пациенты")
  • Галочка "Только мои документы" - Если галочка включена, отображаются только документы, принадлежащие текущему пользователю. Пользователь идентифицируется по логину, введенному при запуске программы, привязка логина к фамилии врача в базе производится по колонке "Логин" справочника "Врачи".
  • Навигационный список документов [3]. Поумолчанию отображается не более 50 документов, удовлетворяющих условиям текущего фильтра. При большем количестве документов последней строчкой добавляется запись "ОТОБРАЗИТЬ ВСЕ ДОКУМЕНТЫ". При двойном щелчке на ней будут показаны все документы, удовлетворяющие условиям фильтра.

Форма "Документы - расширенный фильтр":

С помощью расширенного фильтра можно отфильтровать документы по дате, по врачу, по наличию прикрепленного файла. После выбора фильтра, нажмите на кнопку "Сохранить", программа применит заданный фильтр, а описание фильтра будет выведено наверху навигационной секции формы "Документы". Кнопка "Отмена" закрывает форму без осуществления каких-либо действий.

Кнопка "Последние просмотренные" отображает в навигационном списке те документы, по которым пользователь перемещался (просматривал) в течение последнего времени. Кнопка "Последние редакт." отображает в навигационном списке документы, которые пользователь редактировал в течение последнего времени. Документы, которые просматривались/редактировались последними, отображаются наверху списка. Программа запоминает не более 50 документов, просмотренных либо исправленных во время текущего сеанса работы. Документ может отображаться в списке несколько раз, по числу просматров/редактирований.

Также есть фильтрация документов по типу шаблона из которого они были созданы.


ДОКУМЕНТЫ

Сабформы

В правой нижней части формы "Документы" расположена секция сабформ. Всего имеется 4 сабформы, "Услуги", "Напоминания", "Лекарства" и "Назначения". В заголовке сабформы, после названия, выводится через дробь два числа (для Лекарств одно). Второе число обозначает количество строчек в сабформе, первое - количество необработанных строчек. Т.е., "Напоминания 1/3" означает, что если пользователь откроет сабформу Напоминаний, то там будет 3 строчки, из них только одно Напоминание - со статусом "Не выполнено".

При работе с документом, пользователь может просматривать список услуг, на которые записан пациент. Программа выводит те услуги, дата которых совпадает с датой документа. Если у пользователя есть соответсвующий доступ, пользователь может редактировать артикул услуги, количество услуг, код МКБ и комментарий. Из контекстного меню сабформы доступны пункты "Добавить" и "Удалить". "Удалить" удаляет услугу, "Добавить" выводит диалог добавления услуги (при условии, что пациент уже записан на прием к этому врачу на этот день). Пункт контекстного меню "Добавить" аналогичен нажатию кнопки "Добавить услугу" наверху формы.

Вторая сабформа - "Напоминания". Пользователь программы может создать для пациента напоминание, например о том что пациент должен прийти на повторный осмотр. В сабформе выводится список всех напоминаний, дата создания которых совпадает с датой документа. Кроме того, выводятся все напоминания, созданные из текущего документа, независимо от даты их создания. Из контекстного меню сабформы доступны пункты "Добавить", "Удалить" и "Добавить звонок". Подробное описание напоминаний и работы с напоминаниями можно найти в справке по одноименной форме.

Третья сабформа - "Лекарства". Списание лекарств при работе с документом может использоваться для двух целей: во-первых, врач может пометить, какие лекарства были назначены пациенту, во-вторых, если в программе установлен модуль "ТМЦ" (товарно-материальные ценности), то при добавлении записи в сабформу Лекарств, соответствующее количество лекарства автоматически списывается со склада.

Последняя сабформа - "Назначения". В ходе визита пациенту врачом может быть запланировано оказание дополнительных услуг в будущем. Если текущий документ входит в курс лечения, то в саборме отображаются данные о всех сделанных назначениях и всех оказанных услугах, для выбранного пациента в течение данного курса лечения.


ДОКУМЕНТЫ

Отчет - Документы за день

Данный отчет позволяет получить информацию о добавленных документах за определенный период.

После выбора периода, врача и названия документа и нажатия на кнопку "Сформировать отчет" выводится отчет:

Обязательным для заполнения является только период.

отчет подключается по запросу клиента, в стандартной поставке его нет.


ДОКУМЕНТЫ

Создание документов

В статье описываются способы создания врачебных документов.

Документы создаются на основе шаблонов врачебных документов - заранее подготовленных rtf файлов. Рекомендации по созданию шаблонов можно посмотреть в разделе справки "Администрирование - Настройка печати - Подготовка шаблонов RTF документов".

Создать документ можно двумя способами:

  • из формы "Пациенты" с помощью кнопки [image] - "Создать документ из шаблона" или непосредственно из формы "Документы" с помощью кнопки [image] - "Добавить". Кнопки расположены в тулбарах форм.
  • из визита, с помощью иконки в колонке "Документ" сабформы Услуг

После нажатия на кнопку, программа откроет форму выбора шаблона, в которой можно выбрать один из имеющихся в системе шаблонов.

В левой части формы возможен поиск нужного шаблона в строке поиска по названию [1].

Также можно отфильтировать шаблоны по типу:

Часто используемые шаблоны можно добавить в избранное при помощи кнопки [image], в дальнейшем избранные шаблоны можно отфильтировать с помощью кнопки [image]. Для того чтобы удалить шаблон из списка из избранных, нужно отфильтировать шаблоны кнопкой [image], выделить нужный шаблон и нажать кнопку

На основании выбранного шаблона будет создан документ. Если документ создается из формы "Пациенты", то после создания программа откроет форму "Документы" для редактирования созданного документа. Документ будет привязан к выбранному пациенту. Если документ создается из формы "Документы", то он привязывается к последнему выбранному в форме "Пациенты" пациенту.

Программа формирует название созданного документа по имени шаблона, из которого документ создан. Если в названии шаблона присутствует символ "№" (например "Хирургическая операция №"), то программа ищет все документы, название которых начинается на "Хирургическая операция №", находит из них документ с максимальным номером. В этом случае название создаваемого документа будет сформировано из названия шаблона и максимального существующиего номера + 1.


ДОКУМЕНТЫ

Списки замен

В шаблонах документов можно создавать списки замен. Они создаются для упрощения работы с документами. Списки замен можно создавать как в документах, так и в шаблонах, но нужно учитывать, что список замен, созданный в документе, можно использовать только в том документе, в котором он был создан. Список замен, созданный в шаблонах документов работает во всех документах, созданных на основании этого шаблона.

Список замен находится в правой части формы шаблонов [1]:

Верхняя часть формы (заменяемое слово (термин)) предназначена для создания списка заменяемых слов (например жалобы, наследственность, состояние и.т.д.) В нижней части формы (Список) создается список замен для каждого из заменяемых слов. (например для слова жалобы – список заменяемых слов- головная боль, одышка и.т.д) Для того что бы добавить в шаблон заменяемое слово в верхней части формы нажимаем

Открывается форма

Куда вводится заменяемое слово. После ввода нажимаем кнопку сохранить, слово добавляется в верхнюю форму. Для того чтобы создать список замен, нажимаем в верхней части формы на заменяемое слово, для которого будем формировать список замен, и в нижней части формы нажимаем

Открывается форма для ввода списка замен:

куда вводятся все необходимые замены для выбранного заменяемого слова. Слова можно вводить через запятую, через точку с запятой, или делать перенос переводом строки. В форме это регулируется галочками [1] После введения всех слов нажимаем кнопку сохранить. Введенные заменяемые слова сохраняются в виде списка

Так как заменяемых слов в документе может быть много, и в большом списке неудобно искать заменяемое слово, то для каждого термина (заменяемого слова) можно прописать в шаблоне ссылку на него. Тогда, при работе с документом, сделанном на основании этого шаблона, при нажатии на ссылку сразу открывается нужный список замен.

Чтобы создать ссылку, в шаблоне в режиме редактирования встаем курсором на то место, где должна быть ссылка, после этого нажимаем в форме «Заменяемое слово (термин)» на нужный для ссылки термин два раза левой кнопкой мыши.

Термин отображается в шаблоне заключенным в решетку : #Жалобы#


ДОКУМЕНТЫ

Печать консультативного заключения

С помощью констант 275 (Документы - "Печать консультативного заключения" печатать документ до абзаца, начинающегося на слово) и 276 (Документы - "Печать консультативного заключения" печатать документ начиная со слова) любой врачебный документ делится на три части.

Для создания Консультативного заключения необходимы Часть 1 и Часть 3, а Часть 2 не нужна.

В приведенном ниже примере значение константы 275 «Жалобы:», а константы 276 «Диагноз:».

При нажатии на кнопку создания КЗ мы переходим в режим предпросмотра консультативного заключения, созданного программой.

В печатных формах можно создать шапку консультативного заключения – это обычная печатная форма для которой указан вывод в форме «Шапка консультативного заключения (форма Документы)». В примере это область выделенная красным контуром.


ДОКУМЕНТЫ

Прикрепление файлов

К медицинскому документу можно прикрепить файл. Для этого нужно воспользоваться панелью прикрепления файлов:

Панель прикрепления файлов видна, если пользовательская константа "Документы - Отображать панель прикрепления файлов" имеет значение "Да". Также сделать панель видимой можно, поставив галочку напротив соответствующего пункта в меню "Документы", появляющегося в главном меню программы при открытии формы "Документы".

Кнопка "Прикрепить файл" используется для прикрепления файлов. После нажатия на кнопку, откроется стандартный диалог открытия файла.

В зависимости от констант "Файлы - хранить внутри базы (нет = во внешней папке)" и "Администрирование - Путь к сетевой папке для хранения файлов" файлы хранятся либо внутри базы либо на жестком диске. При двойном щелчке на названии прикрепленного файла он сохраняется из базы или копируется из сетевой папки в папку attachments, находящуюся на диске пользователя в папке, откуда запущена программа, а затем открывается в соответствующей расширению данного файла программе.

Кнопка "Сохранить файл" позволяет сохранить файл на диск.

Кнопка "Удалить файл" удаляет прикрепленный к документу файл с диска или базы данных.

Кнопка "Просмотреть файл" позволяет просмотреть файл. При нажатии на кнопку файл сохраняется в папку attachments, находящуюся на диске пользователя в папке, откуда запущена программа. Далее открывается редактор, который определяется по расширению файла, как если бы файл был открыт в проводнике. Для графических файлов можно изменить редактор по умолчанию. Для этого надо задать константу пользователя "Файлы - Графические файлы открывать с помощью программы", где указать путь до графического редактора.

Кнопка "Отправить по почте" позволяет через настроенный аккунт в программах Microsoft Outlook или TheBat отправить текущий документ с вложением в виде прикрепленного файла по электронной почте. Кнопка видна только системному администратору, администраторам клиники и врачам с правом rl_email.

Кнопка "Показать документ" позволяет переключиться обратно к показу текста документа с отображения PDF.

Если прикрепленный файл является графическим и имеет расширение "png", "jpg", "bmp", то в нижней части навигационной панели есть возможность просмотреть превью файла. Превью создается автоматически при прикреплении к документу графического файла. Его размеры зависят от констант "Файлы - Максимальный размер превью-файла по вертикали, в пикселях", "Файлы - Максимальный размер превью-файла по горизонтали, в пикселях", "Файлы - Качество preview файла (от 1=минимум до 5=максимум)". Превью-файл всегда сохраняется в базе данных.
Если прикрепленный файл имеет формат PDF, то он прикрепится к документу и будет отображаться по умолчанию вместо него. Для переключения к обычному текстовому виду документа необходимо нажать "Показать документ". Для показа PDF файлов на компьютере должен быть установлен бесплатный Adobe Acrobat Reader.

Если файл был открыт в редакторе нажатием на кнопку предварительного просмотра, программа с частотой определенной в константе 174 [Документы - Если пользователь открыл файл из программы, проверять наличие изменений раз в Х секунд (0 - не проверять)] будет сверять дату и размер файла в папке attachments с их старыми значениями. Если файл был изменен, то программа предложит сохранить изменения, т.е. сохранить файл в базе данных или скопировать его в сетевую папку для хранения файлов. Если файл был одновременно изменен и в папке attachments и в базе данных (или сетевой папке), например, в случае изменения файла другим пользователем или его изменения и сохранения в промежутке между срабатываниями таймера проверки изменений, то программа выдаст предупреждение и больше не будет следить за изменениями данного файла.

Если константа 173 [Документы - Если к документу прикреплен графический файл, печатать прикрепленный рисунок при печати документа] равна "Да", то при предварительном просмотре или печати документа в конец будет добавлен прикрепленный графический файл.

Напрямую к медицинскому документу пациента можно прикрепить только один файл. При необходимости к пациенту можно прикреплять большее количество файлов. Для этого следут воспользоваться сабформой "Файлы" в форме "Пациенты", описанной в разделе справки "Пациенты - сабформы".

Общие рекомендации по подготовке графических файлов

  • используйте разрешение разрешение 150 dpi, меньшее разрешение недостаточно для качественной печати, большее - дает незначительный прирост в качестве при существенном увеличении размера файла
  • желательно, чтобы размер рисунка в документе совпадал с размером рисунка в файле
  • сохраняйте рисунок в формате jpeg

Таким образом, если вы хотите прикрепить к документу логотип шириной 10 см и высотой 3 см, то подготовьте в программе работы с изображениями рисунок jpeg с разрешением 150 dpi и требуемыми размерами. При разрешении 150 dp, ширине 10 см и высоте 3 см размер рисунка должен быть 591 на 118 пикселей.


ОСНОВНЫЕ ФОРМЫ

Шаблоны

Шаблоны являются заготовками, из которых создаются врачебные документы. Форма шаблонов открывается с помощью кнопки [image] в тулбаре приложения. Каждый врач может создавать для себя произвольное количество шаблонов, либо главный врач может задать правила, как должны выглядеть документы, и какие шаблоны в каких случаях использовать.

Форма шаблонов состоит из двух частей. Левая часть используется для навигации, т.е. выбора нужного пользователю шаблона. В правая части пользователь просматривает текст шаблона, и при необходимости исправляет его.

Навигационная часть состоит из:

  • Навигационного списка [1]. В списке перечислены названия шаблонов. Когда пользователь щелкает мышкой на одной из строчек, программа открывает соответствующий шаблон в правой части формы.
  • Поле [2] для быстрого отбора шаблонов по названию. Когда пользователь вводит в данное поле часть названия шаблона, в списке [1] остаются только те шаблоны, в названии которых есть введенное пользователем слово.
  • Кнопка [3] служит для сброса фильтра, и отображения полного списка всех имеющихся в системе шаблонов.
  • Кнопка [4] переключает список между режимом отображения всех имеющихся шаблонов, и шаблонов, относящихся к текущему пользователю. Поскольку каждый врач может создавать "под себя" произвольное количество шаблонов, то в какой-то момент шаблонов становится очень много, и появляется проблема поиска нужных. Пользователь может пометить некоторый набор шаблонов как "избранные", и нажатием на кнопку [4] отбирать из общего списка только те шаблоны, с которыми работает чаще всего. В режиме отображения избранного списка шаблонов, вокруг кнопки [4] появляется желтая окантовка.
  • Кнопка [5] "Добавить в избранное" позволяет добавлять шаблоны в список избранных, либо, когда в навигационном списке [1] отображаются только избранные шаблоны, подпись на кнопке меняется на "Исключить из избранного".

Правая часть формы состоит из:

  • Тулбара редактирования [6].
  • Поле [7] "Название шаблона" - в этом поле отбражается название редактируемого или просматриваемого шаблона.
  • Область редактирования [8] служит для отображения и редактирования текста шаблона.
  • Тулбар изменения свойст текста [9] позволяет изменять размер, цвет и начертание текста в шаблоне, изменять выравнивание, печатать шаблон.

Форму "Шаблоны" можно использовать для работы со Списками замен.

Импорт и экспорт шаблонов описан в разделе справки Описание импорта и экспорта шаблонов печатных форм можно посмотреть в разделе справки "Экспорт/импорт шаблонов и печатных форм"


ЗАПИСЬ

Запись на прием

Форма предназначена для записи пациентов на прием.

Слева сверху расположены поле выбора даты [1], кнопки перехода к следующей / предыдущей дате [2]. Расписание представлено в виде таблицы, время оказания услуги развернуто по вертикали. На рисунке, для удобства просмотра, приведен урезанный вариант, обычно в Записи на прием больше колонок (не меньше 7), и больше строчек.

В Записи на прием возможно переключение между несколькими режимами просмотра. Для выбора режима используются переключатели [5].

  • запись к одному врачу на несколько дней (левый нижний переключатель)
  • запись к нескольким врачам на один день (левый верхний переключатель)
  • запись в один кабинет на несколько дней (правый нижний переключатель)
  • запись в несколько кабинетов на один день (правый верхний переключатель)

Например, если Вы хотите посмотреть запись к врачу Докторову Д.Д., нажмите левый нижний переключатель [5] и после этого выберите врача Докторова из выпадающего списка Врач [4].

Врачей в клинике может быть много, и если при просмотре записи на день программа будет выводить каждого врача в отдельной колонке, колонок может не хватить. Поэтому в форме "Пользователи" (Справочники - Пользователи) для каждого врача указывается так называемая "Закладка". Часто названия закладок совпадают со специальностями, но не всегда. Например, если в клинике много терапевтов, они могут быть поделены по закладкам "Терапевты 1", "Терапевты 2" и т.д. Если, наоборот, в клинике единственный уролог и 2 гинеколога, их можно сгруппировать на закладке "Урологи+гинекологи". Для врача может быть задано несколько закладок, разделенных точкой с запятой, например, "Терапия;Физеотерапия". В таком случае врач будет отображен при выборе любой из этих закладок.

Для просмотра расписания на день, нажмите левый верхний переключатель [5] и после этого выберите нужный набор врачей из выпадающего списка Закладка [3].

Аналогично происходит переключение для двух оставшихся режимов.

Для того чтобы посмотреть запись в кабинет 20, необходимо нажать правый нижний переключатель и выбрать кабинет из выпадающего списка [4].

Для того чтобы посмотреть запись в несколько кабинетов на день, нужно нажать правый верхний переключатель и выбрать нужную закладку из выпадающего списка [3]. Закладка для кабинета задается в справочнике Кабинеты.

При двойном щелчке на заголовке колонки происходит автоматическое переключение между режимами. Поведение программы зависит от текущего режима:

Режим "Запись к одному врачу на несколько дней" меняется на режим "Запись к нескольким врачам на один день". При этом дата [1] меняется на дату колонки и из выпадающего списка "Закладка" [3] выбирается закладка, заданная для текущего врача.

Режим "Запись к нескольким врачам на один день" меняется на режим "Запись к одному врачу на несколько дней". При этом, дата [1] меняется в зависимости константы "Запись на прием - в первой колонке отображать: Да=понедельник, Нет=текущую дату". Из выпадающего списка "Врач" [4] выбирается врач, чье расписание отображается в выбранной колонке.

Режим "Запись в один кабинет на несколько дней" меняется на режим "Запись в несколько кабинетов на один день". При этом дата [1] меняется на дату колонки и из выпадающего списка "Закладка" [3] выбирается закладка, заданная для текущего кабинета.

Режим "Запись в несколько кабинетов на один день" меняется на режим "Запись в один кабинет на несколько дней". При этом, дата [1] меняется в зависимости константы "Запись на прием - в первой колонке отображать: Да=понедельник, Нет=текущую дату". Из выпадающего списка "Кабинет" [4] выбирается кабинет, чье расписание отображается в выбранной колонке.

Максимальное количество колонок в форме запись определяется константой пользователя "Запись на прием - Количество колонок (дней) при показе одного доктора". Одновременно может быть отображено не больше 14 колонок. В случае превышения данного числа пользователь получит предупреждение при открытии формы "Запись".

При первом открытии формы "Запись" в режиме отображения врачей программа рассчитывает число врачей для всех заданных в справочнике "Пользователи" закладок. Если количество врачей на каких-либо закладках превышает количество колонок, заданное константой, пользователь получит предупреждение.

При первом открытии формы "Запись" в режиме отображения кабинетов программа рассчитывает число кабинетов для всех заданных в справочнике "Кабинеты" закладок. Если количество кабинетов на каких-либо закладках превышает количество колонок, заданное константой, пользователь также получит предупреждение.

При нажатии на кнопку [9] в режимах "Запись к нескольким врачам на один день" или "Запись в несколько кабинетов на один день" программа определит первые несколько врачей или кабинетов (не более 14), для которых на выбранный день есть наибольшее количество визитов, и выведет колонки только для этих врачей/кабинетов.

При нажатии на кнопку [10] применяется фильтр на период отображаемых часов: утренняя смена, вечерняя смена, весь день или ночная смена.

При нажатии на кнопку [11] выполняется сохранение текущего окна Записи в таблицу MS Excel, в последствии которую можно распечатать.

В левой части клеток расписания находится набор иконок, позволяющих определить некоторые параметры визита, например:

- у данного пациента заключен договор со страховой компанией

- пациент впервые записан на прием к выбранному врачу

- VIP пациент

- доктор не извещен о визите

Если константа "Запись - Выводить маркеры в 2 колонки" равна "Да", то левая часть клетки будет состоять из двух колонок. Во второй колонке выводится дополнительная информация:

- у пациента есть долги по врачам, либо общая задолженность по лечению

- у пациента внесен аванс по лечению

Красный фон в левой части клетки означает, что по данному визиту есть долг.

Красный квадратик в белой рамке в правом верхнем углу ячейки с визитом означает наличие комментария.

Выбранная ячейка выделяется черной рамкой. При этом, в левой части формы в столбце времени подсвечивается соответствующий ячейке интервал.

Стандартно, программа подсвечивает различными цветами различные статусы Визитов. В программе определены следующие статусы: Предварительная запись, Подтвержденная запись, Пришел, Не пришел, Сторно, Сторно деньги возвращены. Пользователь может выбрать другой вариант расцветки, воспользовавшись выпадающим списком [7] "Подсвечивать". Варианты выбора различаются для разных клиник, например, можно выбрать подсветку VIP-статуса пациента, либо подсветку различным цветом различных страховых компаний.

В клетке, где отображается информация о Визите (о записи пациента на прием), может не хватить места для вывода всей информации. В этом случае в зависимости от константы "Запись - детализацию визита в шапке отображать: 1=наведении мышки, 2=при щелчке", можно подвести к клетке мышку или щелкнуть на клетку, и полный текст отобразится наверху формы [6]. Для каждого визита отображается ФИО пациента, и его телефон(ы).

В форме "Пользователи" для врача можно поставить пометку, что врач может одновременно принимать нескольких пациентов (например, врач работает в процедурном кабинете, либо врач является тренером по лечебной физкультуре). В этом случае, в одной клетке может отображаться запись на прием сразу нескольких пациентов, и выводятся только ФИО пациентов через запятую, без телефонов.

Для редактирования существующего визита, дважды щелкните мышкой на любую из клеток, «занятую» визитом. Откроется форма редактирования / добавления визита. Если для врача или кабинета разрешен множественный прием пациентов, то программа предложит выбрать один из имеющихся визитов или создать новый визит.

Для создания нового визита, выберите незанятое время, и дважды щелкните мышкой по соответствующей клетке. Откроется форма редактирования / добавления визита. Дата, время, врач или кабинет в новом визите будут заполнены в соответствии с выбранной клеткой. При этом, если время клетки частично пересекается с временем приема врачом другого пациента и выбранный врач не может принимать одновременно нескольких пациентов (или в кабинете не разрешен одновременный прием нескольких пациентов), то время приема и длительность приема по умолчанию могут измениться.

При нажатии на кнопку печати [8] будет выведен отчет о расписании работы врачей на текущий день.

При выборе пункта "Печать расписания врача на день" из контекстного меню, доступного при щелчке правой кнопкой мыши на заголовке колонки, будет выведен отчет расписании работы одного врача на день.

При щелчке правой кнопкой мыши на левой части клетки визита откроется контекстное меню:

Возможно поменять статус визита, сделать пометку о том, что врач извещен о визите, или о том, что пациенту требуется парковка.

Если щелкнуть правой кнопкой мыши на правой части клетки с визитом, то откроется контекстное меню:

С помощью меню можно перейти к пациенту визита, просмотреть информацию о истории изменения визита, перейти к форме "Курсы лечения", сбросить присвоенный визиту номер договора, напечатать один из зарегистрированных в системе документов (талон на прием, договор с перечислением списка услуг и т.п.) либо напечатать отчеты "Реестр услуг" для текущего визита или "План лечения" и "Предписано в рамках курса лечения" для пациента текущего визита. Возможно также скопировать или перенести выбранный визит в другую клетку. При копировании создается новый визит. Дата, время, врач и кабинет для созданного или перемещенного визита будут определяться данными ячейки, куда будет вставлен визит. В зависимости от константы "Запись - При копировании визитов копировать список услуг визита" будет скопирован только визит или визит вместе с услугами.

Меню "Печать документов" и "Печать документов для формы Пациенты" автоматически формируется на основании справочника "Шаблоны печатных форм". Для таких документов в форме "Шаблоны печатных форм" в поле "Тип шаблона" должно стоять, соответственно, "Запись" или "Пациенты".

При печати документов для выбранного визита программа автоматически присваивает визиту номер договора. При этом, если у пациента в выбранный день были визиты к нескольким врачам пользователю будет предложено выбрать визиты для включения в договор.

В записи на прием используется два основных фоновых цвета: белый для незанятых часов, серый обозначает нерабочее время врача. В зависимости от константы "Запись (оформление) - Цвета врачей брать из таблицы врачей (Нет=генерировать автоматически)" и "Запись на прием - свободное время закрашивать белым (нет=закрашивать цветом врача по умолчанию)" цвет незанятой ячейки или фоновый цвет визита может взят из справочника "Пользователи".


ЗАПИСЬ

Печать из формы "Запись"

В разделе рассказывается о печати документов и отчетов из формы "Запись".

При нажатии на кнопку "Сформировать отчет Расписание записи на прием" из формы "Запись" будет выведен отчет о расписании работы врачей на текущий день.

При выборе пункта "Печать расписания врача на день" из контекстного меню, доступного при щелчке правой кнопкой мыши на заголовке колонки, будет выведен отчет расписании работы одного врача на день.

С помощью контекстного меню, открывающегося при щелчке правой кнопкой мыши на правой части клетки с визитом, можно напечатать один из зарегистрированных в системе документов (талон на прием, договор с перечислением списка услуг и т.п.) либо напечать отчеты "Реестр услуг" для текущего визита или "План лечения" и "Предписано в рамках курса лечения" для пациента текущего визита.

Меню "Печать документов" и "Печать документов для формы Пациенты" автоматически формируется на основании справочника "Шаблоны печатных форм". Для таких документов в форме "Шаблоны печатных форм" в поле "Тип шаблона" должно стоять, соответственно, "Запись" или "Пациенты". Тэги, используемые документах подробно описаны в соответсвующем разделе справки.

Если для печатной формы указано название подменю, то печатная форма будет расположена в этом подменю. Подменю создается на том же уровне, что и пункт меню "Печать документов" и "Печать документов для формы Пациенты". Если название подменю начинается со "*", то в этом случае подменю создается внутри пунктов "Печать документов" или "Печать документов для формы пациенты".

Образец меню печати печатных форм:

В отчет "Реестр услуг" попадают данные об услугах, оказанных пациенту в выбранном визите.

В отчет "План лечения" попадает информация об услугах, которые планируется оказать пациенту в дальнейшем, т.е. данные о визитах со статусом "Предварительная запись" и "Подтвержденная запись".

В отчет "Предписано в рамках курса лечения" попадает информация об уже оказанных пациенту услугах, а также об услугах, которые планируется оказать пациенту в рамках текущего курса лечения. Цены указаны с учетом выбранного в визите прайса.


ЗАПИСЬ

Визуальное редактирование расписания врачей

В статье описывается возможность редактирования расписания врачей из формы "Запись".

Форма "Запись" помимо записи пациентов на прием, позволяет визуально редактировать расписание работы врачей.

Расписание выводится в виде таблицы, состоящей из колонок - дней недели. По вертикали расположены часы приема. Интервал между приемом пациентов может быть настроен для каждого врача и составляет от 15 до 60 минут.

Редактирование расписания возможно как для выбранного врача за период, так и для выбранного кабинета за период. Ниже будет описано редактирование расписания для выбранного врача. Расписание для выбранного кабинета редактируется аналогично.

Установите переключатель режима просмотра [1] в левое нижнее положение для отображения расписания работы врача за период, либо в правое нижнее положение для отображения расписания работы кабинета за период. В том случае, когда у вас отключена работа с кабинетами, у переключателя [1] будет только 2 возможных положения, и выбрать необходимо нижнее.

В выпадающем списке "Врач" [2] выберите нужного врача.

Белые клетки показывают дни и часы, когда врач работает, если клетки серые - в это время врач не принимает.

Для каждого врача может быть задано несколько правил, например:
1. Врач работает по понедельникам и средам с 11:00 до 14:00.
2. Врач не работает 7 июля.

Выбор периода редактирования

Слева вверху находится поле выбора даты. По умолчанию расписание открывается, начиная с текущей даты. Первый отображаемый день можно изменить либо в выпадающем меню-календаре, либо стрелками: на неделю вперед или назад.

Создание нового правила

Для создания правила нажмите клавишу "Shift" и левую кнопку мыши. Тяните мышку, выделяя нужные клетки. Завершив выделение, отпустите кнопки. Появится форма "Редактировать расписание врачей":

Можно задать номер кабинета, где принимает врач, в выпадающем списке "Кабинет". Период, на который распространяется правило, задается с помощью выпадающих меню-календарей "Начало периода" и "Конец периода". Справа от них находятся кнопки Н, В, М, О, с помощью которых можно быстро задать стандартный период.
Н - устанавливает период равным отображенному на экране в форме "Запись"
В - период равен выбранному дню, указанному мышкой;
М - период равен текущему месяцу, с 1 числа и до последнего дня месяца;
О - устанавливает неограниченный период действия правила.

Время приема устанавливается с помощью выпадающих списков "Время с" и "Время по".

Из выпадающего списка "Тип правила" можно выбрать разные типы правил:

"Раб. четные" - правило применяется в заданном периоде к четным числам рабочих дней (с понедельника по пятницу).
"Раб. нечетные" - правило применяется в заданном периоде к нечетным числам рабочих дней.
"Работает" - врач работает в указанное время во все дни недели заданного периода.
"Не работает" - врач не работает в указанное время во все дни недели заданого периода.
"Выбранные дни" - правило применяется в заданном периоде к выбранным дням недели. Чтобы выбрать дни недели, установите галочки в соответствующих квадратиках формы.
"Четные выбр. дни" - правило применяется в заданном периоде к выбранным дням недели по четным числам.
"Нечетные выбр. дни" - правило применяется в заданном периоде к выбранным дням недели по нечетным числам.

Отмеченные галочками выбранные дни учитываются только в правилах "Выбранные дни", "Четные выбр. дни", "Нечетные выбр. дни"" В остальных правилах выбранные дни игнорируются.

Стрелки внизу формы позволяют переходить от одного правила к другому, не закрывая форму. Справа от стрелок указывается количество правил, заданных для выбранного периода.

Правило можно "Сохранить" или "Удалить" при помощи соответсвующих кнопок внизу формы. Отменить редактирование можно кнопкой "Отменить" или нажатием Esc на клавиатуре.

Чтобы форма редактирования расписания при этом не закрылась, в контекстном меню кнопок "Сохранить", "Удалить" или "Отменить" выберите соответствующие пункты "Сохранить не закрывая", "Удалить не закрывая" или "Отменить не закрывая".

Редактирование правил

Чтобы изменить существующее правило, нажмите клавишу "Shift" и дважды щелкните левой кнопкой мыши на белой клетке. Откроется форма "Редактировать расписание врачей", где можно поменять любые значения, как было описано выше, а затем сохранить правило.

Время и дни, на которые распространияется правило, визуально выделяются в форме "Запись" красной рамкой.

Правило "Не работает" всегда имеет приоритет перед остальными правилами. То есть, если врач работает по понедельникам и средам (правило № 1) и не работает 7 июля (правило № 2), то в среду 7 июля будет применяться правило "Не работает 7 июля".


ЗАПИСЬ

Визит

Форма предназначена для редактирования одного визита пациента в клинику (редактирование списка услуг и прочих параметров визита).

Форма "Визит" состоит из основной информации о пациенте [1] [2], элементами управления текущим визитом [3] [4], области [5] для указания основных параметров визита, области [6] с информацией о визите, кнопками [7] для управления вкладками [8] и информации о текущей записи на вкладке [9].

Наверху формы выводится информация о пациенте: ФИО, дата рождения, возраст, телефоны, страховая компания, номер и дата окончания действия полиса. Выбор пациента производится нажатием на кнопку [1]. Смена страховой компании только для данного визита производится при помощи клика по информации [2].

Кнопки [3]: удаление визита, переход к предыдущему визиту пациента, переход к следующему визиту пациента, отменить последние изменения, сохранить и закрыть визит. Перед удалением пользователь получает предупреждение.

Кнопка [4] позволяет создать напоминание о текущем визите.

Область [5] служит для указания параметров визита. У каждого выбора врача есть контекстное меню для отправки ему уведомления. Статус этого уведомления обозначен чертой разного цвета под выбором. Точно такое же меню есть у пациента в области [2]. Цвета статуса:

  • Синий - отправка сообщения внутри программы
  • Зеленый - СМС сообщение доставлено
  • Оранжевый - СМС сообщение создано, но не доставлено
  • Красный - СМС сообщение не удалось доставить

Информация в блоке [6] отображает основную информацию о текущем визите: впервые ли пациент пришел, впервые у врача данной специальности, номер договора, общий долг пациента, стоимость услуг текущего визита, количество услуг, дата и время создания и последнего изменения информации [5].

Программа позволяет объединить визиты пациента в курсы лечения. Надпись под [3] содержит название курса лечения, в который входит визит. С помощью контекстного меню надписи можно создать перименовать или удалить курс лечения, исключить визит из курса лечения, перейти к форме "Курсы лечения".

В конце контекстного меню перечислены шесть последних курсов лечения для выбранного пациента. Выбор пункта меняет курс лечения текущего визита.

Двойной щелчок на надписи аналогичен выбору пункта меню "Просмотр списка курсов/визитов". Дополнительная информация содержится в разделе справки "Курсы лечения".

Кнопки [7] управляют данными в текущей выбранной вкладке [8]: печать, добавить строку, удалить строку, сохранить изменения во вкладке. Кнопка "Печать" выполняет разные действия в зависимости от текущей вкладки. На некоторых вкладках имеются дополнительные функции: например автозаполнение ТМЦ, создание оплаты.

Информация [9] зависит от выбранной вкладки и отображает дату и время создания и последнего изменения текущей строки в ней.

Возможно множественное добавление услуг, если в форме "Выбор услуги" выбрать несколько записей. Дополнительную информацию о добавлении услуг можно посмотреть в разделе справки "Выбор услуги".

Если для врача в справочнике "Пользователи" указаны услуги по умолчанию при первичном и повторном визитах, то при создании нового визита соответствующая услуга будет добавлена в визит автоматически.

Двойной щелчок в поле "МКБ" открывает форму "Словарь" для выбора кода болезни из списка.

Если в программу включен модуль "Визиты - оплата", то в форму "Визит" добавляется дополнительная сабформа "Оплата".

В группу кнопок [7] добавляется кнопка [image] - "Автоматическая оплата". Кнопка видна, если сабформа "ТМЦ" выбрана и только при наличии подключенного кассового аппарата. При нажатии на кнопку будет распечатан чек для услуг, входящих в визит.

При нажатии на кнопку "Добавить" [image] [7] будет открыта форма, в которой можно выбрать оплачиваемые услуги. При нажатии на кнопку "Сторнировать" [image] [7] будет будет открыта форма для выбора услуг для сторнирования. Более подробная информация содержится в статье справки "Визит - оплата".

Информация об оплате может быть также добавлена, удалена и изменена непосредственно в сабформе. При добавлении новой записи в поле "Дата" автоматически подставляется текущая дата, в поле вид оплаты - "ДМС", если у пациента указана страховая компания, или "Наличные".

Если закладка "Оплата" пустая, то программа по умолчанию считает, что пациент заплатил ровно столько денег, на какую сумму ему были оказаны услуги. Таким образом, когда сумма оплаты равна стоимости оказанных услуг, достаточно поставить правильный статус визита (например, "пришел"). Если пациент производит предоплату, либо у пациента не хватает денег, сотрудник ресепшена указывает фактически полученную сумму в закладке "Оплата". Можно внести несколько оплат с разными датами.

Рассмотрим несколько примеров:

Стоимость услуг 100 рублей, статус визита - "Пришел", оплачено 200 рублей = предоплата 100 рублей.
Стоимость услуг 100 рублей, статус визита - "Предварительная запись", оплачено 200 рублей = предоплата 200 рублей.
Стоимость услуг 100 рублей, статус визита - "Пришел", оплачено 0 рублей (т.е. в закладке оплат внесена оплата с суммой полученных денег, равной нулю) = долг 100 рублей.

Общая сумма задолженности/предоплаты пациента вычисляется суммированием задолженности/предоплаты по всем визитам и отображается в [6]. Дополнительно выводится информация об изменении задолженности на дату текущего визита, и задолженность по курсу услуг.

В форме "Курсы лечения", описанной в соответствующем разделе справки, можно посмотреть информацию о стоимости услуг и полученных оплатах, представленную в виде дерева с разбивкой по визитам. Сводную информацию о долгах пациентов можно посмотреть в отчете "Долги".

Если значение константы "Визит - Отображать сабформу списания ТМЦ" равно "Да", то в форме "Визит" становится видна сабформа "ТМЦ".

В группу кнопок [7] добавляется кнопка [image] - "Заполнить ТМЦ". Кнопка видна, если сабформа "ТМЦ" выбрана.

Сабформа предназначена для просмотра и редактирования материалов, использованных в текущем визите. Информация может быть добавлена и удалена из сабформы с помощью кнопок [7] и изменена непосредственно в сабформе. При добавлении новой записи в поле "Склад" автоматически подставляется используемый по умолчанию склад из справочника "Список складов ТМЦ".

Кнопка "Заполнить ТМЦ" автоматически заполняет список значениями из справочника "Автоматическое списание ТМЦ" на основе услуг текущего визита. Введенные вручную данные при этом удаляются. Автоматическое заполнение ТМЦ для всех визитов за определенный период можно выполнить в форме "Заполнить автоматическое списание" в меню "ТМЦ".

Если в программу включен модуль "Назначения", то в форму "Визит" добавляется сабформа "Назначения".

В группу кнопок [7] добавляется кнопка [image] - "Печать отчета Назначения". Кнопка видна, если выбрана сабформа "Назначения". При нажатии на кнопку будет распечатан отчет "Назначения" или отчет, созданный на основе шаблона печатной формы, указанной в константе "Визит - при нажатии на кнопку с принтером в списке услуг печатать Печатную форму".

Если текущий визит входит в курс лечения, то в саборме отображаются данные о всех сделанных назначениях и всех оказанных услугах, для выбранного пациента в течение данного курса лечения.

Информация может быть добавлена и удалена из сабформы с помощью кнопок [7] и изменена непосредственно в сабформе. При этом добавить можно только услугу еще не находящуюся в списке. Для имеющейся услуги необходимо исправить поле "Назначено". Удалить можно только записи об услугах не входящих ни в один визит данного курса лечения.

В сабформе отображается информация об назначенных, запланированных (услуги из визитов со статусами "Предварительная запись" и "Подтвержденная запись") и оказанных услугах (услуги из физитов со статусами "Пришел", "Сторно", "Сторно, деньги возвращены"). Редактировать можно только информацию о назначенных услугах.

Для визита можно указать дополнительно начисленные премиальные вознаграждения для врачей. На выбор дается 5 вариантов типов начислений:

  • % от полученных денег
  • % от оказанных услуг
  • к выплате, руб
  • начислять процент на сумму, руб
  • начислять стандартные проценты

В визите продублирована закладка переводов пациента. Функционал идентичен вкладке формы Пациенты.

Некоторые услуги сопровождаются взятием анализов, отправка которых возможна в лабораторию Хеликса. Для этого должна быть заполнена константа [222 - Хеликс - Идентификатор МИС].


ЗАПИСЬ

Визит - оплата

В разделе дается описание возможности получения денег от пациента в клиниках, где рабочее место сотрудника ресепшена и рабочее место кассира совмещены.

В некоторых клиниках рабочее место сотрудника ресепшена и рабочее место кассира совмещены, то есть оформление документов и получение денег производится одним и тем же сотрудником. Обычно так работают в клиниках с небольшим потоком пациентов. В этом случае сотрудник ресепшена вносит информацию о получении денег (изменяет статус на "Пришел") непосредственно в карточке визита.

Для внесения денег служит сабформа "Оплата" в форме "Визит".

Информация об оплате может быть добавлена и удалена из саформы с помощью соответствующих кнопок формы "Визит" или изменена непосредственно в сабформе.

Если закладка "Оплата" пустая, то программа по умолчанию считает, что пациент заплатил ровно столько денег, на какую сумму ему были оказаны услуги. Таким образом, когда сумма оплаты равна стоимости оказанных услуг, достаточно поставить правильный статус визита (например, "пришел"). Если пациент производит предоплату, либо у пациента не хватает денег, сотрудник ресепшена указывает фактически полученную сумму в закладке "Оплата". Можно внести несколько оплат с разными датами.

При нажатии на кнопку "Добавить" [image] [10] будет открыта форма, в которой можно выбрать оплачиваемые услуги:

С помощью переключателей вверху формы можно выбрать для отображения только услуги визита или все услуги оказанные пациенту. Кнопка "Оплатить все" формирует список услуг для оплаты на основании всех показанных услуг, а кнопка "Оплатить выбранное" - на основании выбранных услуг. Выбор осуществляется с помощью клавиш "Shift" и "Ctrl".

При подключенном модуле "Касса" программа пытается распечатать чек продажи на контрольно-кассовом аппарате. Печать доступна только пользователям с правами кассира и администратора и только в случае, если у них задан пароль кассира. Количество напечатанных чеков соответствует количеству показанных визитов. Если в ходе печати прозошел сбой, например, при выключенном или неработающем кассовом аппарате, пользователю будет предложено сформировать реестр без печати чека. Если после сбоя программа не смогла выполнить операцию отмены чека, то текущий визит будет заблокирован, и дальнейшие действия по нему станут невозможны. Пользователь получит соответствующее предупреждение.

При нажатии на кнопку "Сторнировать" [image] [10] будет открыта форма для выбора услуг для сторнирования:

При подключенном модуле "Касса" программа пытается распечатать на контрольно-кассовом аппарате чек возврата или чек аннулирования. Тип чека определяется датой печати чека продажи. Если дата совпадает с текущей, то будет напечатан чек аннулирования, иначе - чек возврата. Печать доступна только пользователям с правами кассира и администратора и только в случае, если у них задан пароль кассира.

Для визита определены следующие статусы:

  • предварительная запись
  • подтвержденная запись
  • пришел
  • не пришел
  • сторно (используются только при выделенном рабочем месте кассира)
  • сторно, деньги возвращены

При вычислении суммы оплаченных услуг учитываются данные внесенные в сабформе "Оплата" и вычитаются суммы возвращенных пациенту денег по визитам со статусом "Сторно, деньги возвращены".

Сумма всех оказанных пациенту услуг равна сумме всех оказанных услуг для визитов со статусами "Пришел", "Сторно", "Сторно, деньги возвращены".

Данные берутся по всем визитам пациента с момента начала прохождения лечения в клинике.

Вычисляется разница между суммой оплаченных и оказанных услуг. Если полученное число положительное - это значит у пациента сделана предоплата, если отрицательное - у пациента существует задолженность.

В форме "Курсы лечения", описанной в соответствующем разделе справки, можно посмотреть информацию о стоимости услуг и полученных оплатах, представленную в виде дерева с разбивкой по визитам. Данные выводятся для каждого визита и курса лечения. Сумма оказанных услуг, оплат, а также задолженность для курса лечения вычисляется суммированием соответствующих данных для всех визитов, входящих в курс лечения.

Кроме того, итоговая информация о задолженности/предоплате выбранного пациента выводится в справочной информации в шапке формы "Визит", в правой части формы "Пациенты", а также в сабформе "Долги" формы "Пациенты".

Отчет "Должники/предоплата", доступный из меню "Отчеты" позволяет получить список пациентов, имеющих задолженность или предоплату и узнать общую сумму задолженности/предоплаты. В отчете "Задолженность пациента" показывается общая сумма задолженности/предоплаты пациента за период с разбивкой по врачам, оказывавшим услуги. Описание отчетов можно посмотреть в соответствующих разделах справки.


ЗАПИСЬ

Визит - таблица с итоговыми суммами

В разделе дается описание табличной формы визита по итоговым суммам с возможностью настройки

В визите в середине формы находится таблица с информацией по итоговым суммам.

Отображаемые в таблице данные можно настраивать. Настройка производится только под sa.

Для выбора отображаемых данных в таблице нужно кликнуть правой клавишей по нужному столбцу, появится контекстное меню:

С помощью него можно редактировать заголовок (задавать свое название) [1], выделять текст ячейки жирным шрифтом [2], писать текст подсказки для ячейки [3], выбирать цвет текста и цвет фона ячейки [4] [5], растянуть таблицу [6], удалить не нужную ячейку [7].

Первый пункт контекстного меню "Формула" позволяет настроить отображаемые в каждой ячейке данные:

Данные по визиту:

Данные по пациенту за день:

Данные по пациенту:

Данные по назначенному курсу лечения:

Данные задаются для каждой ячейки отдельно.


ЗАПИСЬ

Выбор пациента

Форма предназначена для выбора пациента.

Внешний вид формы выбора пациента напоминает основную форму "Пациенты". Форма предназначена для выбора пациента, которого пользователь записывает на прием, здесь же можно исправить данные пациента, либо создать нового пациента. Эта же форма используется при выборе пациента при слиянии пациентов (см. описание формы "Пациенты").

Слева находятся поле фильтрации по фамилии [1] и список пациентов [2]. Данные о выбранном пациенте можно увидеть в правой части формы [3]. Создание нового пациента происходит с помощью кнопки с плюсиком наверху формы. Пользователь подтверждает либо отменяет выбор пациента нажатием на одну из кнопок [4]. Выбрать пациента возможно также двойным щелчком на записи из списка [2].


ЗАПИСЬ

Выбор услуги

Форма предназначена для выбора услуги.

Список выводимых в форме услуг [7] можно уменьшить с помощью фильтра по группе [1], с помощью фильтра по названию/коду услуги [3] или поставив галочки "выводить только услуги, которые доктор ... оказывал в последние ... дней" [5] и "отображать только услуги, назначенные врачами, но не оказанные пациенту" [6]. Количество дней определено в константе "Выбор услуги - при быстром выборе показывать список услуг врача за последние Х дней".

При нажатии на кнопку [2] откроется форма выбора группы услуг.

Если в программу добавлен модуль "Назначения", то в форму добавляется галочка "отображать только услуги, назначенные врачами, но не оказанные пациенту" [6]. Галочка доступна, только если визит или документ, из которого вызвана форма "Выбор услуги", входит в курс лечения.

Если для врача в справочнике "Пользователи" указаны услуги по умолчанию при первичном и повторном визитах, то именно эти услуги будут выведены первыми в списке услуг.

Кнопка [4] служит для сброса фильтра. Выбрав услугу, необходимо подтвердить выбор кнопкой [8] "Выбрать" или закрыть форму кнопкой "Отмена". Двойной щелчок на строчке с услугой эквивалентен выбору услуги в списке, и последующему нажатию кнопки [8] "Выбрать".

С помощью кнопок "Shift" и "Ctrl" можно одновременно выбрать несколько услуг. Если выбираются услуги из списка назначенных, но не оказанных пациенту (галочка [6] включена), то программа расчитывает количество добавляемых услуг, как разницу между всеми назначенными и оказанными услугами в течение данного курса лечения.


ЗАПИСЬ

Визит - скидки

В разделе дается описание системы скидок на услуги.

В програме реализована гибкая система скидок, зависящая от даты услуги, врача, общей суммы суммы услуг, оказанных пациенту, оказываемой услуги и т.д.

Добавление и редактирование скидок ведется в справочнике "Услуги - скидки".

Скидки могут быть в процентах и в рублях. Из двух полей "Скидка по умолчанию в процентах" и "Скидка в рублях" должно быть заполнено только одно нужное поле.

Двойной щелчок в поле "Группы прейскуранта"открывает форму, в которой можно выбрать одну или несколько групп или очистить предыдущий выбор.

В форме "Визит" возможно указывать как общую скидку на визит, так и скидку на каждую услугу в отдельности. Общая скидка на визит отображается в шапке визита и влияет только на заполнение скидок для услуг. На расчет стоимости услуги она не влияет.

При добавлении нового визита или услуг в визит, если константа "Визит - При добавлении визита/услуг автоматически ставить максимальную возможную скидку да/нет/да+без ред." равна "да" или "да+без ред.", программа составляет список скидок на основе справочника скидок, удовлетворяющих параметрам визита - дате, времени, врачу, выбранной услуге и т.п. и среди них ищет скидку с максимальной суммой. При этом в зависимости от стоимости добавленной услуги максимальной может быть, например, как разовая рублевая скидка за посещение, так и процентная скидка от стоимости услуги.

Редактирование скидок визита осуществляется в специальной форме, открывающейся при нажатии на кнопку рядом с полем услуги в шапке формы:

Кнопка недоступна если константа "Визит - При добавлении визита/услуг автоматически ставить максимальную возможную скидку да/нет/да+без ред." равна "да+без ред.". При нажатии на кнопку открывается форма:

В форме отображаются все возможные для данного визита скидки. Можно выбрать нужную скидку, отредактировать значение выбранной скидки или очистить выбор, отменяя тем самым скидку на визит.

Дальнейшие действия программы зависят от константы "Визит - При изменении скидки визита обновлять скидки всех услуг (нет - только для новых услуг)". Если значение константы равно "Да", программа попытается обновить скидки имеющихся в визите услуг. При этом может возникнуть ситуация, когда выбранная скидка визита не применима к конкретной услуге. В этом случае скидка данной услуги будет сброшена, а пользователь получит предупреждение.

Скидка для услуги редактируется при двойном щелчке на поля "Скидка" и "Стоимость" [1] в сабформах услуг.


ЗАПИСЬ

Cкидки - описание бизнес процессов

В системе имеются следующие типы скидок:

  • Вручную
  • Накопительная
  • Автоматическая (ранее называлась "Простая", переименовываем)
  • Разовая от суммы оплаты
  • Сотрудникам/Специальная

За некоторыми исключениями, можно поделить скидки на две группы. К первой группе относятся скидки, которые пользователи выбирают вручную. К первой группе относятся типы скидок "Вручную" и "Сотрудникам/специальная". Вторая группа - это скидки, которые автоматически ставит программа. В эту группу входят типы скидок "Накопительная", "Автоматическая", "Разовая от суммы оплаты".

================

В форме "Пациенты" имеется поле "Скидка по умолчанию". Пользователь может выбрать скидку по умолчанию из активных скидок с типами "Вручную", "Накопительная", "Сотрудникам". Из ограничений при этом учитывается только ограничение по полу пациента.

Хотя Накопительная скидка стандартно ставится программой, в данном случае, пользователь может выбрать любую из действующих накопительных скидок. Это сделано для случаев, например, когда программой пользуются недавно, и в программе не учтены старые оплаты пациента. Проверка накопленной суммы оплат при этом не выполняется. Если накопительная скидка указана в качестве скидки пациента по умолчанию, то в дальнейшем, в новых визитах и услугах, эта скидка может "наследоваться" из пациентов, даже если накопленная пациентом сумма оплат недостаточна.

================

В форме "Пациенты" имеется табличка "Скидки". Эта табличка используется для учета индивидуальных скидок пациента, которые действуют с некоторым ограничением, и которые неправильно писать в поле "Скидка пациента по умолчанию". Пример использования: "Флаер 5% на процедуры LPG до конца 20** года". Или "Распоряжение главврача скидка 100% на протезирование".

Индивидуальные скидки, добавленные в табличку, относятся к типу "Автоматические", и автоматом применяются программой для всех последующих визитов и услуг пациента, согласно ограничивающим условиям.

Индивидуальные скидки можно вносить вручную, кнопкой с зеленым плюсиком. Или можно выбирать из списка активных скидок с типом "Сотрудникам/Специальная", нажатием на кнопку с голубым плюсиком. При нажатии на голубой плюсик, выбранная скидка с типом "Сотрудникам/Специальная" используется в качестве шаблона, из нее создается "Автоматическая" индивидуальная скидка пациента. Созданную индивидуальную скидку можно произвольным образом менять, на Специальную скидку, выступавшую в качестве шаблона, это не влияет.

================

При создании нового визита пользователем, программа выбирает максимальную скидку из 1) Скидки пациента по умолчанию 2) Скидки главы семьи пациента по умолчанию 3) Личных скидок пациента 4) Скидок с типом "Автоматическая", "Накопительная", "Разовая от суммы оплаты".

Выбор производится с учетом ограничений, указанных у скидки. То есть, если у пациента выбрана скидка по умолчанию с типом "Вручную", для этой скидки помечено, что она не действует по понедельникам, то в понедельничных визитах скидка использоваться не будет. Исключением, как упоминалось выше, являются накопительные скидки, выбранные в поле "Скидка по умолчанию" пациента - для таких скидок не выполняется проверка по накопленной сумме платежей.

Дополнительное ограничение - при выборе скидки для шапки визита не учитываются скидки, у которых установлено ограничение "только для услуги ХХХ", или "только для группы услуг ХХХ". Это сделано, чтобы адресно используемые скидки не мешали работе других отделений.

Из всех допустимых скидок, перечисленных выше, программа выбирает максимальную скидку. При выборе максимальной скидки, учитываются в первую очередь % скидки. Абсолютные скидки ("-100 руб. предъявителю купона") учитываются во вторую очередь.

В существующем визите (или в только что созданном визите), пользователь может выбрать в шапке визита скидку, отличную от предложенной программой. При ручном выборе, предлагаемый пользователю для выбора список скидок формируется по принципу, отличающемуся от автоматического выбора максимальной скидки программой. При ручном выборе, в список попадают скидки: 1) с типами "Вручную", "Сотрудникам/Специальная", 2) с типом "Накопительная", если она унаследована из поля "Скидка по умолчанию" пациента, или главы семьи пациента 3) максимальная из автоматических скидок, как если бы программа выбирала максимальную скидку для нового визита. Пункт 3) нужен на случай, если пользователь случайно сотрет автоматически поставленную программой скидку, и захочет ее восстановить. Естественно, при формировании списка выполняется проверка всех ограничений, указанных для скидок.

При копировании визита, программа проверяет: если в исходном визите в шапке выбрана скидка с типом "Вручную", или "Сотрудникам/специальная", то программа пытается скопировать эту скидку в новый визит. При этом копируется также значение скидки. Если в новом визите копируемая скидка оказалась неприменима (например, для скидки было указано ограничение по врачу, а в новом визите врач отличается), или если в шапке исходного визита стояла скидка с другим типом, то в создаваемом визите программа расчитывает максимально возможную скидку, как если бы это был новый визит.

При изменении скидки в шапке визита, программа пересчитывает скидки в услугах визита, если включена константа 139 [Визит - При изменении скидки Визита обновлять скидки всех услуг (Нет=только новых услуг)]

================

При добавлении новой услуги, или при перерасчете существующей услуги, программа автоматически выбирает максимальную скидку из следующего перечня: 1) Скидки пациента/главы семьи пациента по умолчанию 2) Личных скидок пациента 3) Скидок с типом "Автоматическая", "Накопительная", "Разовая от суммы оплаты" 4) Скидка, указанная в шапке визита, независимо от ее типа. При этом если в шапке визита был скорректирован % скидки, то для скидки берется % из шапки, а не из таблицы скидок.

Для существующей услуги, пользователь может выбрать скидку, отличную от предложенной программой. При ручном выборе, предлагаемый пользователю для выбора список скидок формируется по принципу, отличающемуся от автоматического выбора максимальной скидки программой. При ручном выборе, в список попадают скидки: 1) с типами "Вручную", "Сотрудникам/Специальная", 2) с типом "Накопительная", если она унаследована из поля "Скидка по умолчанию" пациента, или главы семьи пациента 3) максимальная из автоматических скидок, как если бы программа выбирала максимальную скидку для новой услуги.

При копировании услуги из назначений, если у назначения указана скидка, в услугу копируется скидка назначения. Название скидки в услуге при этом не указывается. Если в назначении скидка не указана, то программа производит расчет максимальной скидки, как если бы это была новая услуга.

================

На ближайшее время запланированы следующие изменения:
1. Скидка "Сотрудникам/Специальная" сейчас выполняет две функции: она может использоваться как аналог скидок с типом "Вручную", и может использоваться в качестве шаблона при создании индивидуальных скидок пациентов. Планируется переименовать тип скидки в "Шаблон индивидуальной скидки", и такие скидки будут использоваться только как шаблоны.
2. "Разовая от суммы оплаты" сейчас никем не используется. Предполагается заблокировать использование этого типа скидки, и через некоторое время удалить этот тип скидок.


ЗАПИСЬ

"Курсы лечения"

Форма предназначена просмотра итоговой информации о курсах услуг, визитах, услугах, оплатах и врачебных документах пациента за весь период прохождения лечения в клинике.

Форма "Просмотр списка курсов/визитов" вызывается:

  • при нажатии на кнопку "Курсы услуг" [image] в форме "Пациенты"
  • при нажатии на кнопку "Курсы услуг" [image] в форме "Документы"
  • из контекстного меню ячейки в форме "Запись"
  • из контекстного меню надписи "Курс лечения" в форме "Визит"

Список выводимых курсов лечения можно отфильтровать с помощью полей [1] наверху формы: "Период с", "по". Кнопка [2] служит для сброса фильтра. При открытии формы отображаются данные только за несколько последних месяцев, заданных константой "Курсы лечения - При открытии выводить информацию с даты визита минус Х месяцев (пусто=без фильтра)".

Кнопка [3] автоматически сворачивает все ветки дерева, отображаются только курсы услуг и визиты, не входящие в курсы. Кнопка [4] - разворачивает дерево до второго уровня, при этом отображаются все курсы услуг и визиты. Кнопка [5] - полностью разворачивает дерево, отображается информация о всех курсах, визитах, услугах и оплатах. [6] - надпись с итоговой информацией о предоплате или задолженности пациента. [7] - переключают режимы отображения записей. Возможно показать в дереве только информацию о визитах, услугах и оплатах или только о врачебных документах.

Список курсов/визитов [8] организован в виде дерева. В списке отображаются:

- курсы услуг

- визиты

- услуги

- оплаты

- врачебные документы

Визиты и врачебные документы, не входящие в курсы услуг показываются отдельными записями в списке. Записи отсортированы по дате создания. Датой начала курса считается дата создания первого входящего в него врачебного документа или визита.

В случае открытия формы из формы "Запись" или "Визит" информация о текущем визите и курсе, в который входит данный визит, выводится жирным шрифтом.

Если сумма оплат по визиту или курсу больше чем сумма оказанных услуг, информация отображается зеленым цветом, если меньше - коричневым цветом, если совпадает - черным.

В контекстном меню дерева доступны следующие пункты:

  • Создать новый курс лечения
  • Переименовать курс лечения
  • Удалить курс лечения
  • Исключить из курса лечения - исключение из курса выбранного визита или врачебного документа

При удалении курса лечения все входящие в курс визиты и врачебные документы будут сохранены. Будут удалены название курса и ссылки на курс.

Визиты и врачебные документы в списке можно премещать между курсами с помощью мышки.

При двойном щелчке на визите в дереве откроется форма "Визит" для выбранного визита.

При двойном щелчке на врачебном документе в дереве откроется форма "Документы" для выбранного документа.


ЗАПИСЬ

ЛИСТ ОЖИДАНИЯ

"Лист ожидания" предназначен для отслеживания пациентов, которым необходимо попасть к конкретному врачу или к врачу конкретной специальности, но в записи нет свободного времени для их приема. Пациенты готовы ждать и просят сообщить им о любой возможности попасть к нужному специалисту, например, если кто-то из записанных отказался от приема или врач дал для записи дополнительное время.

Пациент заносится в Лист и, при возникновении возможности записать его, программа автоматически напоминает об этом работникам ресепшн.

С листом ожидания можно работать в трех формах:

  • В специальной форме "Формы"-"Лист ожидания", где можно посмотреть все имеющиеся в листе ожидания записи
  • В Записи в заголовках колонок со врачами наличие ожидающих записи пациентов отмечается иконкой с песочными часами
  • В форме "Пациенты" есть специальная закладка "Лист ожидания", где можно посмотреть все записи из листа ожидания конкретного пациента

Подробное описание каждого из способов ниже.

Как просмотреть Лист ожидания.

В выпадающем меню пункта "Формы" верхнего тулбара есть "Лист ожидания".

Форма выглядит следующим образом:

Сверху фильтры для просмотра списка Листа ожидания. Автоматически открывается список ожидающих на текущую дату. Столбцы "Актуально с" и "Актуально по" показывают период ожидания, который устраивает пациента. Из столбцов "К врачу" и "К специалисту" должен быть заполнен только один, т.е. или пациент хочет к конкретному врачу или к врачу конкретной специальности. Столбец "Рекомендовавший" - это ФИО сотрудника, по рекомендации которого пациент занесен в Лист ожидания. Данный столбец не обязателен для заполнения. Столбец "Визит" заполняется автоматически при создании визита.

Как записать пациента в Лист ожидания.

Новая запись в Лист добавляется нажатием зеленого плюсика над столбцом "Актуально с". При этом появляется новая строка с периодом, равным текущей дате. Пациент выбирается из общего списка пациентов, для этого выполняем двойной щелчок в поле для столбца "Пациент". "Телефон" заполняется автоматически после выбора пациента. Остальные поля (кроме "Визит") редактируются сотрудником клиники. После заполнения данных щелкаем на любую другую строку и закрываем форму. Пациент внесен в Лист ожидания.

Как увидеть, что к врачу есть пациент в Листе ожидания.

Программа показывает, что к врачу есть желающие в Листе ожидания в форме "Запись" и ТОЛЬКО в режимах "Врачи за день" и "Врач за период".

В заголовке столбца рядом с ФИО врача появляется значок "песочные часы".

Если просто нажать на часики, то программа покажет записи к этому врачу в Листе ожидания.

Если перед нажатием на часики выбрать время для создания визита, то в открывшемся окне появится возможность создать визит из Листа ожидания. Тогда запись в Листе ожидания автоматически пропадет. В противном случае запись не пропадает.


ЗАПИСЬ

ОМС/ДМС визиты

Выбор между ДМС и ОМС компанией в визитах

Для того, чтобы включить в программе работу с ОМС, следует изменить константу 359 [Визит - 1=по умолч.оплата ОМС, 2=ОМС включены, но по умолч. оплата ДМС, любое др. значение=ОМС выкл.]. Работа с ОМС включена, если константа 359 равна 1 или 2.

Далее, следует зайти в программу под логином sa, и в форме "Пациенты" настроить видимость полей: "ДМС компания", "Лимит оплаты", "Номер полиса", "Полис действует с/по", "ОМС компания", "Лимит оплаты ОМС", "Номер полиса ОМС", "Полис ОМС действует с/по". Настройка видимости полей происходит в режиме редактирования, с помощью контекстного меню. Скрытие полей производится щелчком правой кнопкой мыши на поле, и выбором команды "Скрыть поле ИМЯ". Отображение полей производится щелчком правой кнопкой мыши на поле, и выбором команды "Показать поле...", с дальнейшим выбором поля.

Значение константы 359 определяет, ДМС или ОМС компания используется в Визитах по умолчанию. Название страховой, номер и срок действия полиса можно увидеть в форме "Визит" в левом верхнем углу, под фио пациента. Красный цвет надписи означает, что полис просрочен на момент визита, коричневый цвет надписи означает ДМС компанию, зеленый цвет надписи означает ОМС компанию. По умолчанию, данные о компании, номер и срок действия полиса берутся из данных о пациенте. Однако, пользователь может отредактировать данные о полисе, использованном в текущем визите. Для этого следует кликнуть мышкой по названию страховой компании вверху под именем пациента.

В данной форме можно переключить тип визита, ДМС на ОМС и обратно, если в константе 359 включены ОМС визиты. Также можно отредактировать данные полиса, если они отличаются от указанных в карточке пациента. Если пользователь не редактировал для ДМС/ОМС визита данные о полисе, то программа автоматически скопирует в визит данные о полисе из данных о пациенте, после оказания услуг по визиту.


ЗАПИСЬ

Константы, влияющие на форму "Запись"

В данном разделе справки перечислены константы и параметры, влияющие на работу формы "Запись".

В форме "Пользователи" для врача можно поставить пометку, что врач может одновременно принимать нескольких пациентов (например, врач работает в процедурном кабинете, либо врач является тренером по лечебной физкультуре). В этом случае, в одной клетке может отображаться запись на прием сразу нескольких пациентов, и выводятся только ФИО пациентов через запятую, без телефонов.

Там же старший администратор клиники задает права доступа для врачей и сотрудников клиники. Доступ к редактированию визита есть только у администраторов, врачам разрешен только просмотр.

Если задана константа "Запись на прием - При выборе врача скрывать не работающих врачей", то на поведение программы влияет наличие галочек "Работает" напротив фамилий врачей, подробное описание можно прочитать ниже, в описании константы.

Справочник "Константы":

  • "Запись - Выводить маркеры в 2 колонки" - отображение маркеров дополнительной информации о визите в две колонки
  • "Запись - Высота заголовка колонок (в пикселях, пусто=по умолчанию)"
  • "Запись - детализацию визита в шапке отображать: 1=наведении мышки, 2=при щелчке"
  • "Запись - запрет на нерабочее время 1=запрет,2=предупр.при создан,3=разреш.,4=пред.каждое откр./сохр." - влияет на поведение программы при редактировании визитов пациентов.
  • "Запись - количество столбцов" - количество столбцов, отображаемых в форме "Запись". Минимальное количество столбцов - 7, максимальное - 14.
  • "Запись - Количество колонок равно кол-ву врачей (кабинетов) в закладке" - количество отображаемых в форме "Запись" столбцов будет равно количеству врачей/кабинетов в выбранной закладке, но не больше 14.
  • "Запись - Между утренней и вечерней сменой доп.зазор Х пикселей" - расстояние между ячейками формы "Запись", относящимися к разным сменам
  • "Запись - Отображать визиты со статусом "Не пришел"
  • Запись - Панель редактирования пациента (1=авт.сохранение 2=спрашивать 3=удалять изменения)" - влияет на поведение программы при изменении данных в панели редактирования пациента формы "Запись".
  • "Запись - Период автообновления (сек)" - период обновления формы "Запись"
  • "Запись - по умолчанию открывать режим (1=Врачи день, 2=Кабинеты день, 3=Врач неделя, 4=Каб.неделя)" - выбор режима при первом открытии формы "Запись".
  • "Запись - Подпись к триединой анкете (только Меди Эстетик)"
  • "Запись - Подсветка по умолчанию: Авто=в зависимости от режима, Статус, Врач" - выбор варианта подсветки при первом открытии формы "Запись".
  • "Запись - пользователь может печатать документы которые обычно печатаются из формы Пациенты" - в форме "Запись" пользователь может дополнительно печатать документы на основе шаблонов из справочника "Шаблоны печатных форм", у которых в поле "Тип шаблона" стоит значение "Пациенты".
  • "Запись - При копировании визитов копировать список услуг визита" - при копировании визита через контекстное меню копировать или нет информацию об услугах визита
  • "Запись - при печати расписания врача выводить: 1=коды оказанных услуг, 2=названия, 3=ничего" - дополнительная информация, выводимая при печати расписания врача в форме "Запись".
  • "Запись - при печати расписания врача выводить даты полисов пациентов"
  • "Запись - при печати расписания врача выводить название ДМС компаний пациентов"
  • "Запись - при печати расписания врача выводить телефоны пациентов"
  • "Запись - при печати расписания врача выводить номер медицинской карты перед ФИО"
  • "Запись - при сохранении визита ДМС пациента с незаполненным диспетчером выдавать предупреждение" - если для пациента, заключившего договор со страховой компанией, в форме "Визит" не указан диспетчер, то при выходе из формы пользователь получит предупреждение.
  • "Запись - В контекстном меню блокировать выбор статуса "Пришел" (только через форму)" - запрет на изменение статуса визита на "Пришел" через контекстное меню в форме "Запись".
  • "Запись (оформл.) - выводить строки, не помещающиеся по высоте (1=Да 2=Нет 3=Если видно более 50% по высоте)" - задает режим отображения текста в ячейках формы "Запись". Одна строчка (или ее часть) будет отображена в любом случае.
  • "Запись (оформл.) - Жирность шрифта (0=стандартный, 1=жирный)" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - размер шрифта" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - цвет шрифта" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - цвет шрифта для врача по умолчанию" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - Цвета врачей брать из таблицы врачей (Нет=генерировать автоматически)" - в случае выбора варианта подсветки "Врач" цвет ячейки будет браться из таблицы "Пользователи" или генерироваться автоматически.
  • "Запись (оформл.) - ширина пиктограмм (в пикселях)" - ширина рисунков в левой части ячеек формы "Запись".
  • "Запись (оформл.) - ширина рамки в пикселях" - толщина рамки при выделении ячейки в форме "Запись".
  • "Запись (текст) - выводить N медкарты перед ФИО пациента"
  • "Запись (текст) - Выводить время в пустых клетках записи на прием" - отображать время в пустых клетках в форме "Запись".
  • "Запись (текст) - выводить время перед ФИО пациента"
  • "Запись (текст) - Выводить номер телефона пациента"
  • "Запись (текст) - при выводе ФИО пациента сокращать имя-отчество (Иванов И.И. вместо Иванов Иван Иванович)"
  • "Запись (текст) - расписание по кабинетам, белые клетки: 1=выводить спец.врача, 2=сокращенно, 3=не выводить"
  • "Запись (текст) - расписание по кабинетам, цветные клетки - выводить ФИО врача"
  • "Запись (текст) - Расписание по кабинетам, цветные клетки: 1=выводить спец. врача, 2=сокращенно, 3=не выводить"
  • "Запись на прием - Визуализировать запрещающие правила (нерабочее время) в виде квадратиков (только Меди Эстетик)"
  • "Запись на прием - свободное время закрашивать белым (нет=закрашивать цветом врача по умолчанию)" - в режиме "Кабинеты на день" или "Кабинеты на неделю" ячейка закрашивается белым цветом или цветом врача, определенным в форме "Пользователи".

Справочник "Константы пользователя":

  • "Визит - При создании нового визита автоматически открывать форму выбора пациента" - если при вызове формы пациент не определен, будет открыта форма выбора пациента.
  • "Визит - услуги показывать по умолчанию в виде таблички" - в форме редактирования визита услуги можно отображать либо в виде таблички, либо выводить подробную информацию о каждой оказанной пациенту услуге. Константа определяет, какой вид формы "Визит" отображается по умолчанию.
  • "Запись на прием - в первой колонке отображать: Да=понедельник, Нет=текущую дату" - в зависимости от константы в режиме выбора врача первая колонка будет соответствовать понедельнику текущей недели или текущей дате.
  • "Запись на прием - максимальная ширина колонки"
  • "Запись на прием - отображаемая по умолчанию закладка по врачам"
  • "Запись на прием - отображаемая по умолчанию закладка по кабинетам"
  • "Запись на прием - по умолчанию подсвечивать 1=VIP, 2=Врача, 3=Форму оплаты, 4=Специальность, 5=Статус, 6=ДМС компанию" - выбор значения по умолчанию для выпадающего списка "Подсвечивать" для отображения различными цветами ячеек.
  • "Запись на прием - В выборе врача выводить специальность (Сокращенная специальность: ФИО врача)" - отображать специальность в выпадающем списке выбора врача.
  • "Запись на прием - Возможность выбора врача для каждой колонки" - возможность в режиме просмотра расписания на день выбирать врача для каждой колонки по отдельности.
  • "Запись на прием - Высота одной строки в пикселах. 0 означает автонастройку." - если константа равна 0, то программа автоматически подстроит высоту клетки, так чтобы на по вертикали клетки расписания занимали все имеющееся на экране место.
  • "Запись на прием - Количество колонок (дней) при показе одного доктора" - при начальной установке программы количество колонок задается равным 7 (по количеству дней недели). Изменение этой константы имеет смысл, если в пользователя широкий монитор.
  • "Запись на прием - Открывать карточку визита в режиме редактирования" - если значение константы равно "Нет", то после открытия карточки Визита администратору нужно нажать кнопку перехода в режим редактирования, чтобы получить возможность вносить изменения.
  • "Запись на прием - При выборе врача скрывать не работающих врачей" - в системе нельзя удалять уволившихся врачей, если на них есть ссылки, например есть документы, принадлежащие этому врачу, либо есть услуги, оказанные врачом. Кроме того, часть зарегистрированных в системе пользователей (администраторы) не занимаются приемом пациентов. Поэтому со временем список врачей становится довольно большим. Чтобы облегчить работу администраторов, можно задать значение константы равным "Да". В этом случае при выборе врача в форме "Запись" в списке будут отображаться только те пользователи системы, для которых в форме "Врачи" (Справочники - Врачи) поставлена галочка "Работает".
  • "Запись на прием - при нажатии на "Печать": 1=Предпросмотр, 2=Печать, 3=Открыть в Ворде" - задает режим просмотра или печати документов из формы.
  • "Запись на прием - При создании визита выбирать по умолчанию последнего пациента с которым работали" - по умолчанию константа равна "Нет". Если изменить значение на "Да", то при создании нового визита программа будет подставлять последнего пациента, с которым пользователь работал в форме Пациентов.
  • "Запись на прием - Ширина одной колонки в пикселах. 0 означает автонастройку." - если константа равна 0, то программа автоматически подстроит ширину клетки, так чтобы на по горизонтали клетки расписания занимали все имеющееся на экране место.
  • "Запись на прием - Ширина подписи Времени приема в пикселах" - задает ширину подписей времени (9:00, 9:30 и т.д.), расположенных слева от клеток записи на прием.


ОПЛАТА

Общее описание

В разделе дается общее описание рабочего места кассира.

Существуют два варианта получения денег от пациентов: В первом случае рабочее место сотрудника ресепшена и рабочее место кассира совмещены. То есть оформление документов и получение денег производится одним и тем же сотрудником. Обычно так работают в клиниках с небольшим потоком пациентов. В этом случае сотрудник ресепшена вносит информацию о получении денег (изменяет статус на "Пришел") непосредственно в карточке визита, из формы Записи на прием. Данный случай в настоящем разделе справки не рассматривается. Во втором случае существует выделенное рабочее место кассира. Кассир не занимается оформлением документов, единственная обязанность кассира – получить деньги по уже оформленным документам, и пометить в базе, что деньги за визит получены. Данная секция справки посвящена описанию работы кассира.

Если рабочее место кассира отделено от рабочего места администратора ресепшена, для услуг, оказываемых за наличный расчет, имеются следующие статусы:

  • "Предварительная запись", "Подтвержденная запись", "Не пришел". Услуги с данными статусами могут редактироваться произвольным образом любыми сотрудниками ресепшена и администрацией.
  • "Пришел". Присвоить услуге статус "Пришел" может только кассир или администратор. Редактирование услуг со статусом "Пришел" запрещено, но администратор может изменить статус услуги с "Пришел" на "Сторно"
  • "Сторно". Статус "Сторно" может быть присвоен услуге только администратором, и только для услуг со статусом "Пришел". Редактирование услуг со статусом "Сторно" запрещено, но кассир может изменить статус услуги со "Сторно" на "Сторно, деньги возвращены".
  • "Пришел". Присвоить услуге статус "Пришел" может только кассир или администратор. Редактирование услуг со статусом "Пришел" запрещено, но администратор может изменить статус услуги с "Пришел" на "Сторно"
  • "Сторно, деньги возвращены". Статус может быть присвоен услуге только кассиром или администратором, и только для услуг со статусом "Сторно". Редактирование услуг со статусом "Сторно, деньги возвращены" запрещено всем пользователям. Услуги с данным статусом не отображаются в расписании "Запись пациентов на прием", но могут быть просмотрены в карточке пациента и из интерфейса кассира.

Если к компьютеру кассира подключен фискальный регистратор, то программа автоматически печатает чеки продажи, возврата и аннулирования, одновременно с изменением статуса визита в базе данных.

Для рабочего места кассира определены следующие константы:

  • "Оплата (касса) - Частота обновления списка пациентов" - определяет частоту обновления списка оказанных услуг.
  • "Оплата (касса) - выводить "Всего получено наличных за день" - в форме выводится дополнительная информация: "Всего получено наличных за день" - сумма услуг за сегодняшний день с учетом сторнированных услуг.
  • "Оплата (касса) - При печати нескольких чеков сразу, останавливаться после каждого чека" - в случае печати нескольких чеков, после завершения печати каждого чека печать будет остановлена и продолжена только после нажатия кнопки OK.
  • "Оплата (касса) - При печати нескольких дубликатов чеков, останавливаться после каждого дубликата" - в случае печати нескольких дубликатов чека, после завершения печати каждого дубликата печать будет остановлена и продолжена только после нажатия кнопки OK.

При печати документов возврата (см. раздел справки "Возврат денег") используются следующие тэги:

  • MoneyBackSumN - сумма всех услуг, по которым деньги будут возвращены
  • MoneyBackSumS - сумма прописью всех услуг, по которым деньги будут возвращены
  • MoneyBackDate - дата возврата денег
  • MoneyBackCheckN - номер ранее пробитого чека продажи


ОПЛАТА

Оплата

Форма дает возможность кассиру помечать в базе данных, за какие услуги, предоставляемые за наличный расчет, были получены деньги. Форма "Оплата" и форма "Кассовый отчет", а также дополнительные статусы "Сторно" и "Сторно, деньги возвращены" используются в клиниках, где рабочее место кассира отделено от рабочего места администратора ресепшена. В небольших клиниках без выделенной кассы, эти формы не включаются в систему.

Форма "Оплата" вызывается при нажатии на кнопку [image] в основном тулбаре или при выборе соответствующего пункта в меню "Формы".

Работа кассира начинается с поиска пациента в базе данных. Поиск производится с помощью списка пациентов [4]. В списке пациентов 2 колонки, в первой отображается ФИО пациента, во второй колонке - дата рождения. Список отсортирован по ФИО.

Галочка [3] "только пациенты, назначенные на сегодня" позволяет ограничить список пациентов [4] только теми пациентами, у которых есть записи на прием на сегодня, помеченные как оплачиваемые за наличный расчет.

Поле [1] предназначено для поиска пациента по ФИО. При вводе текста в поле программа будет оставлять в списке [4] только пациентов, в ФИО которых имеется введенное сочетание букв. Кнопка [2] очищает поле [1] и снимает галочку [3], тем самым сбрасывая фильтр.

Для выбранного пациента на форме выводится дополнительная информация [6]:

  • "Пациентом сегодня оплачено" - сумма оплаченных выбранным пациентов услуг за текущую дату
  • "Сумма последнего договора" - сумма услуг по последнему сформированному реестру
  • "Всего получено наличных за день" - сумма услуг за сегодняшний день с учетом сторнированных услуг. Надпись отображается в зввисимости от константы: "Оплата (касса) - выводить Всего получено наличных за день".

Найдя нужного пациента, кассир просматривает информацию в группе полей [5] (дата рождения, возраст), чтобы убедиться, что найден правильный пациент.

Далее кассир проверяет в таблице [13], когда и какие услуги предоставлялись пациенту. В таблице [13] отображаются:

  • Все реестры услуг оказанных пациенту за последние 2 месяца (выделяются красным фоном). При поставленной галочке [3] отображаются только реестры услуг за текущую дату.
  • Все сторнированные реестры (выделяются голубым фоном) и сторнированные реестры, по которым пациенту были возвращены деньги (выделяются фиолетовым фоном). При поставленной галочке [3] отображаются только сторнированные реестры за текущую дату, иначе сторнированные реестры выводятся все, независимо от срока давности.
  • Визиты на сегодня со статусом "Предварительная запись" и "Подтвержденная запись", помеченные как оказываемые за наличный расчет (белый фон).

Следует иметь в виду, что кассиру не видны:

  • Услуги, оказываемые пациенту за безналичный расчет (независимо от статуса).
  • Оплаченные услуги, оказанные пациенту более 2 месяцев назад.
  • Все услуги со статусом "Не пришел".
  • Неоплаченные услуги за наличный расчет, дата которых отличается от текущей.

Строчки в таблице [13] отсортированы по дате по убыванию.

Если в таблице имеется белая строчка, соответствующая услугам, за которые пациент хочет расплатиться, кассир нажимает кнопку [7] "Сформировать новый реестр", и попадает в форму предварительного просмотра реестра.

Форма предназначена для предварительного просмотра реестра, по которому кассир собирается получать деньги. В формируемый реестр попадают все операции за сегодняшний день, относящиеся к выбранному визиту или всем визитам с одинаковым номером договора, оказываемые выбранному пациенту за наличный расчет, имеющие статус "Предварительная запись" либо "Подтвержденная запись". Услуги, относящиеся к разным визитам, отделяются друг от друга, также выводится дополнительная информация о сумме услуг визита.

На форме имеется 2 кнопки:

Кнопка "Услуги оплачены" производит следующие действия: формирует реестр, присваивает реестру номер и меняет статус всех услуг, входящих в реестр, на "Пришел".

При подключенном модуле "Касса" программа пытается распечатать чек продажи на контрольно-кассовом аппарате. Печать доступна только пользователям с правами кассира и администратора и только в случае, если у них задан пароль кассира. Количество напечатанных чеков соответствует количеству показанных визитов. Если в ходе печати прозошел сбой, например, при выключенном или неработающем кассовом аппарате, пользователю будет предложено сформировать реестр без печати чека. Если после сбоя программа не смогла выполнить операцию отмены чека, то текущий визит будет заблокирован, и дальнейшие действия по нему станут невозможны. Пользователь получит соответствующее предупреждение.

При открытии формы программа вычисляет сумму оказанных услуг и формирует надпись "Итого". Перед началом формированияя реестра программа проверяет не изменилась ли сумма оказанных услуг и в случае изменения выдает предупреждение: "Сумма услуг в выбранных визитах изменилась!!! Для обновления данных необходимо заново открыть форму." После печати чека также сравниваются сумма в чеке и сумма оказанных услуг. В случае несоответствия пользователю рекомендуется проверить стоимость, количество и скидку и другие данные для всех услуг в выбранных визитах.

Кнопка «Отмена» предназначена для закрытия формы без произведения каких-либо действий.

На форме также имеется поле для ввода полученной от клиента суммы. В случае подключенного модуля "Касса", а также если в форму попали услуги только для одного визита, в чеке продажи дополнительно сформируются строки "Получено" и "Сдача".

Кнопка [8] "Напечатать существующий реестр" предназначена для печати существующих реестров. Чтобы напечатать реестр, кассиру следует найти пациента, щелкнуть мышкой в таблице [13] на нужном реестре, и нажать кнопку [8]. С помощью кнопки "Напечатать существующий реестр" нельзя напечатать реестр по услугам, за которые еще не получены деньги (белая строчка в таблице [10] без номера реестра).

Кнопка [9] "Напечатать дубликат чека" позволяет распечатать копию уже сформированного чека. Чтобы напечатать копию чека, кассиру следует щелкнуть мышкой в таблице [13] на нужном реестре, и нажать кнопку [9]. Действие доступно для пользователей с правами администратора, кассира и сторно.

Кнопка [10] "Сторнировать (отменить) реестр" предназначена для изменения статуса существующего реестра со статуса "Пришел" на статус "Сторно". Дополнительную информацию можно посмотреть в разделе справки "Возврат товара".

Кнопка [11] "Печать документов о возврате товара" позволяет распечатать документ, созданный на основе шаблона печатной формы. Дополнительную информацию можно посмотреть в разделе справки "Возврат товара".

Кнопка [12] "Возвращены деньги по сторнированному реестру" предназначена для изменения статуса существующего реестра со статуса «Сторно» на статус "Сторно, деньги возвращены". Дополнительную информацию можно посмотреть в разделе справки "Возврат товара".

При подключенном модуле "Касса" программа пытается распечатать на контрольно-кассовом аппарате чек возврата или чек аннулирования. Тип чека определяется датой печати чека продажи. Если дата совпадает с текущей, то будет напечатан чек аннулирования, иначе - чек возврата. Печать доступна только пользователям с правами кассира и администратора и только в случае, если у них задан пароль кассира.


ОПЛАТА

Возврат денег

В разделе описываются действия сотрудника в случае необходимости произвести возврат денег за оказанные услуги.

Кнопка "Сторнировать (отменить) реестр" в форме "Оплата" предназначена для изменения статуса существующего реестра со статуса "Пришел" на статус "Сторно". Для изменения статуса реестра следует в навигационной панели формы "Оплата" выбрать пациента, найти в сабформе нужный реестр и нажать кнопку "Сторнировать (отменить) реестр". Программа предупредит начальника ресепшена, что операция необратимая, и попросит подтвердить изменение статуса реестра. Действие доступно только пользователям с правами администратора и сторно.

Если рабочее место кассира и ресепшн разделены, то возврат денег выполняется в два этапа. Сначала начальник ресепшена (любой сотрудник, у которого включен доступ "Сторно") помечает, что по по выбранному реестру можно вернуть деньги пациенту. Далее кассир производит возврат денег.

В программе предусмотрена возможность сторнировать услуги, входящие в визит по отдельности. Если визит состоит из нескольких услуг, то перед сторнированием откроется форма выбора услуг, входящих в визит.

Выбор осуществляется с помощью клавиш Shift и Ctrl.

Кнопка "Возвращены деньги по сторнированному реестру" в форме "Оплата" предназначена для изменения статуса существующего реестра со статуса «Сторно» на статус "Сторно, деньги возвращены". Для изменения статуса сторнированного реестра следует найти пациента, найти в сабформе формы "Оплата" сторнированный реестр, и нажать кнопку "Возвращены деньги по сторнированному реестру". Программа предупредит кассира, что операция необратимая, и попросит подтвердить изменение статуса реестра.

При подключенном модуле "Касса" программа пытается распечатать на контрольно-кассовом аппарате чек возврата или чек аннулирования. Тип чека определяется датой печати чека продажи. Если дата совпадает с текущей, то будет напечатан чек аннулирования, иначе - чек возврата. Печать доступна только пользователям с правами кассира и администратора и только в случае, если у них задан пароль кассира.

Кнопка "Печать документов о возврате товара" в форме "Оплата" позволяет распечатать документ, созданный на основе шаблона печатной формы. Для таких документов в форме "Шаблоны печатных форм" в поле "Тип шаблона" должно стоять "Возврат товара". Если имеется несколько документов в данным типом шаблона, то при нажатии на кнопку программа предложит пользователю выбрать нужный документ.


ОПЛАТА

Касса

В разделе описываются дополнительные функции, доступные пользователям с правами кассира или администратора в случае подключенного к программе модуля "Касса".

В случае подключенного к программе модуля "Касса" для пользователей с правами кассира и администратора становится доступно меню "Касса", состоящее из следующих пунктов:

  • "Напечатать X - отчет"
  • "Напечатать Z - отчет"
  • "Снятие денег из кассы"
  • "Внесение денег в кассу"
  • "Задать пароль кассира"

При выборе пунктов меню "Снятие денег из кассы" или "Внесение денег в кассу" соответственно откроются формы:

или

В форме показана справочная информация об остатке денег в кассе по данным кассы, а также о внесенных в кассу деньгах за текущую смену. После нажатия на кнопку "Выполнить" значение введенное в поле "Сумма" будет снято или внесено в память кассового аппарата.

При выборе последнего пункта откроется форма "Изменение пароля кассира", где можно задать или изменить пароль кассира для текущего пользователя.

Пользователь с правами администратора также может изменить пароль касира в форме "Создание и модификация прав пользователей".


Оплата

Счета пациентов и начисление премиальных процентов

В статье описывается термины и соглашения, используемые при работе со счетом пациента и начислении премиальных процентов врачам

Работа со счетом.

Чаще всего, пациент производит оплату одновременно с получением услуг. В этом случае оплата фиксируется в закладке "Оплата" формы "Визит". Но есть ряд операций (вносятся в закладке "Переводы" формы Пациентов), когда денежные операции не привязаны к визиту. Это следующие операции (в скобках - влияние на кассовый отчет и баланс пациента):

  • Продажа сертификата (+ -)
  • Использование сертификата (- +)
  • Списание долга (- +)
  • Внесение/возврат наличных (+ +)
  • Перевод на другого пациента (- +)
  • Перевод от юрлица (- +)
  • Перевод от физлица (- +)

Все операции, кроме продажи сертификата, влияют на баланс пациента. На кассовый отчет влияют продажа сертификата, и внесение/возврат наличных. Ни одна из перечисленных операций не влияет на "Отчет по продажам".

Деньги, внесенные в закладке "Переводы" формы Пациентов (например, внесение наличных), поступают на "счет" пациента. "Счет" пациета - это деньги, которые пациент заплатил клинике, и которые еще не были привязаны к лечению. Использование денег со счета производится путем указания вида оплаты "Списание со счета" в закладке оплат в форме Визит. Операции со счетом могут использоваться в случае курсового лечения, если лечение единственное, и ведется без создания курса услуг (актуально для общепрофильной клиники). Поскольку для некурсовых услуг премиальные врачу начисляются от суммы полученных денег, то стандартное правило "пишем в закладке оплат ровно ту сумму которую получили" может привести к дисбалансам по премиальным врачей, если пациент оплачивает визиты неравномерно (есть предоплаты либо постоплаты). Чтобы избежать дисбалансов по премиальным, можно внести деньги на счет пациента, оформив "внесение/возврат наличных", и потом указывать программе, что деньги на оплату визита взяты со счета пациента. При правильной работе, сумма на счете пациента всегда должна быть положительной.

Долги.

В программе возможен учет долгов по курсам, по врачам, и без деления. В настоящий момент в общепрофильной клинике включен учет долгов по курсам услуг. То есть для пациента отдельно подсчитывается баланс для каждого из получаемых им курсов услуг, и отдельно подсчитывается баланс для некурсовых услуг плюс сумма на счете пациента. Пациент считается должником, если у него есть долг хотя бы по одному курсу, за исключением случаев, когда сумма на счете пациента достаточна, чтобы погасить все долги.

В стоматологиях включен учет долгов с разбивкой по врачам. То есть для пациента отдельно подсчитывается баланс по каждому из лечивших пациента врачей, и отдельно подсчитывается сумма на счете пациента. Пациент считается должником, если у него есть долг хотя бы по одному врачу, за исключением случаев, когда сумма на счете пациента достаточна, чтобы погасить все долги.

Начисление премиальных.

Премиальные врачам для некурсовых визитов считаются по сумме полученных денег. То есть премиальные начисляются на сумму в закладке "Оплата" формы "Визит", либо на сумму услуг визита, если услуги оказаны /статус визита="Пациент пришел"/ и закладка "Оплата" пустая.

Премиальные для курсовых визитов начисляются на сумму оказанных врачами услуг. Начисление произодится после завершения курса, то есть после того как пользователь поставил галочку "Курс лечения завершен" в форме "Визит" рядом с названием курса. После завершения курса, программа запрещает редактирование входящих в курс визитов. Премиальные врачам начисляются на дату закрытия курса, то есть пока курс не завершен, премиальные не начисляются.

Пользователь может указать в закладке "Премиальные" формы "Визит" точную сумму премиальных, которая должна быть начислена за визит. В этом случае программа производит начисление премиальных за визит в соответствии с указаниями в закладке "Премиальные", все другие правила при этом игнорируются. Следует иметь в виду, что при закрытии визита, если сотрудник (врач) уже получал выплаты за визиты курса (согласно указаниям закладки "Премиальные"), итоговые премиальные расчитываются таким образом, чтобы общая сумма выплат соответствовала общей расчетной сумме процентов на все услуги визитов курса. То есть промежуточные премиальные вплаты будут вычтены из итоговых выплат. В настоящий момент в закладке "Премиальные" протестирован только оговоренный со стоматологиями вид премиальных "Начислять % на сумму".


ОСНОВНЫЕ ФОРМЫ

Прейскурант

Форма предназначена для редактирования списка услуг и для редактирования цен на услуги (артикула).

Верхняя строчка [1] ("Код", "Группа", "Название услуги", "Клиника") предназначена для фильтрации списка услуг. Кнопка "Клиника" видна только при установленном модуле "Клиники". Кнопка [2] сбрасывает фильтр.

Кнопка [3] скрывает/показывает панель навигации по группам [8].

Кнопка [4] выводит список услуг прейскурант на печать. Выводятся только отфильтрованные услуги.

Кнопка [5] позволяет импортировать данные об услугах из Excel. При нажатии на кнопку откроется форма "Импорт прейскурантов". Дополнительную информацию можно посмотреть в разделе справки "Прейскуранты - импорт".

Кнопки [6] добавления новой услуги, удаления услуги и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех справочниках.

Программа поддерживает неограниченное количество Прейскурантов и Поставщиков. В качестве примера прейскурантов можно привести чаще всего встречающиеся "Прейскурант за наличный расчет" и "Прейскурант - безнал". Поставщиками чаще всего являются лаборатории, в которые мы отправляем анализы, и которым за выполнение работы платим деньги. Редактирование списка названий прейскурантов производится в справочнике "Прайсы", списка названий поставщиков - в справочнике "Прайсы-Поставщики". В справочнике "Прайсы" есть галочка "Прейскурант по умолчанию". Эта галочка должна быть установлена у единственного прейскуранта.

Для удобства использования, программа позволяет одновременно просматривать и редактировать до 3 прейскурантов. Выбор редактируемых прейскурантов производится с помощью выпадающих списков [7]. Когда пользователь выбирает прейскурант, либо прейскурант себестоимости (поставщика) в выпадающих списках [7], то на экране меняется название соответствующей колонки в списке услуг [9]. На приведенном на рисунке примере в списке [9] выводится прейскурант "Осн. (нал.)" в 4 колонке и прейскурант "Осн. (безнал.)" в 5 колонке. Редактирование прейскурантов производится в списке [9], в этом же списке редактируются данные об услуге (название, группа, код).

При вводе информации об оказанных пациенту услугах, программа определяет стоимость следующим образом:
1. Если пациент обслуживается в ДМС компании, то программа по умолчанию использует прейскурант, определенный для данной ДМС компании в форме "Юридические лица".
2. Если пациент обслуживается за наличный расчет (ДМС компания не указана), либо в ДМС компании не выбран прейскурант, программа использует общий прайс по умолчанию, определенный галочкой в справочнике "Прайсы".
3. Пользователь может указать вручную прейскурант, используемый при вычислении стоимостей услуг в Визите.
4. Пользователь может вручную скорректировать цену услуги, исправив цену услуги, которую подставила программа.

В списке [9] есть колонка "Поставщик по умолчанию", которая видна, если хотя бы в одном из выпадающих списков [7] выбран прайс себестоимости. В этой колонке пользователь может указать для услуги один из прейскурантов себестоимости. Допустим, что у нас есть постащик "122 МСЧ", и этот поставщик указан в графе "Поставщик по умолчанию" для услуги "Анализ крови на гормон ХХ". Тогда при записи пациента на прием, если администратор укажет, что пациент получил у нас услугу "Анализ крови на гормон ХХ", программа автоматически пометит, что данный анализ был отправлен на обработку в лабораторию "122 МСЧ", и подставит в графу "Себестоимость" соответствующее значение из прейскуранта себестоимости "122 МСЧ".

Панель навигации по группам [8] организована в виде дерева и позволяет фильтровать список услуг по выбранной группе. Группы в панели навигации можно перетаскивать с помощью мышки в другие группы, тем самым создавая вложенную структуру групп. Для изменения группы услуги из списка услуг [9] можно выбрать нужное название группы в выпадающем списке поля "Группы услуг" или перетащить услугу в определенную группу в панели навигации [8].

Каждой группе услуг в справочнике "Прейскуранты - группы" можно задать определенную пиктограмму. Услуги, входящие в эту группу, будут помечены соответствующим значком при отображении в форме "Визит".

Порядок вывода групп прайсов в [8] определяется значениями в поле "Порядковый номер" в справочнике "Прейскуранты - группы", а при отсутствии заданного значения - алфавитным порядком (в пределах одного уровня дерева групп).

Оказание одной услуги может включать в себя оказание нескольких дополнительных услуг. Для таких услуг можно определить дочерние услуги. После этого при выборе в форме "Визит" этой услуги одновременно будет добавлены и все дочерние услуги. Для выбора дочерних услуг необходимо из контекстного меню списка услуг [9] выбрать пункт "Редактировать набор услуг".

В открывшейся форме можно добавлят, изменять и удалять набор дочерних услуг.

Услуги, имеющие дочерние услуги в списке помечены значком [image].

В услуге может быть добавлен комментарий. Комментарий добавляется с помощью соответствующего пункта контекстного меню услуги. Услуга, имеющая комментарий, отобращается в списке [9] с красным квадратиком в правом верхнем углу поля "Наименование услуги".

В справочнике "Прейскуранты названия" можно выбрать один из статусов прейскуранта: "готовится", "утвержден", "устарел". Если в выпадающем списке "Прайс 2" выбран прейскурант со статусом "готовится", но на форме становятся видны 2 кнопки [10] - "проверить" и "утвердить". При нажатии на кнопку "проверить" фильтрация прейскурантов будет сброшена, и будут отображаться только артикулы, для которых стоимость в прейскурантах "Прайс 1" и "Прайс 2" не указна или отличается не более чем в два раза. Нажатие на кнопку "утвердить" приводит к соответствующей смене статуса выбранного в выпадающем списке "Прайс 2" прейскуранта.

При открытии формы "Прейскуранты" в главное меню программы добавляется пункт меню "Прейскуранты".

C помощью пункта меню "Сравнение цен" можно дополнительно отфильтровать список услуг по определенным критериям.

C помощью пункта меню "Вывести повторяющиеся коды" можно отфильтровать имеющиеся в базе услуги с повторяющимися кодами. Устаревшие услуги при этом не учитываются.

C помощью пункта меню "Вывести повторяющиеся названия" можно отфильтровать имеющиеся в базе услуги с повторяющимися названиями. Устаревшие услуги при этом не учитываются.

При выборе пункта меню "Копирование цен" откроется форма "Копирование прейскурантов".

Выбрав прейскуранты, откуда и куда будет произведено копирование стоимостей, и задав дополнительные параметры, можно перенести данные о ценах.

Определения:
1. Артикулом называется имеющееся в системе описание услуги. Артикул характиризуется шифром, названием, группой (например, шифр (код) "М01.02", название "Массаж спины", группа "Массаж").
2. Услугой называется факт оказания услуги пациенту.
3. Прейскурантом называется список цен для артикулов. В прейскуранте цены могут быть указаны только для части артикулов, имеющихся в системе.
4. Визитом называется список услуг с одинаковыми временем, датой, пациентом и врачом.

Частые ошибки при работе с прейскурантами:
1. При внесении изменений в прейскурант, следует иметь в виду, что не допускается удаление из системы Артикулов, по которым пациентам уже оказывались Услуги.
2. Наиболее частая ошибка, которую делают пользователи при составлении нового прейскуранта - произвольная перенумерация шифров Артикулов в новом прейскуранте. То есть если в сущестующем прейскуранте был Артикул с кодом (шифром) "М01.02", называвшийся "Массаж спины", а в новом прейскуранте существует артикул "М01.02", называющийся "УЗИ надпочечников", то у сотрудника, отвечающего за ввод в систему нового прейскуранта, будут большие проблемы. Поскольку система не допускает существование арикулов с одинаковым кодом, то при вводе нового прайса для старых артикулов придется менять Код.
3. Вторая по частоте ошибка - переименование существующих в системе артикулов. Пользователю следует иметь в виду, что при изменении названия артикула, изменения производятся в том числе для всех услуг, ранее оказанных пациентам.

При вводе нового прейскуранта следует:
1. Добавить название нового прейскуранта в список прейскурантов (меню Справочники -> Прайсы). Допустим, что новый прейскурант называется "Прайс 2008-12-01".
2. Открыть форму "Прайс". В форме допускается просмотр до 3 прейскуратнов одновременно. Следует выбрать в одном из выпадающих списков "Прайс 1", "Прайс 2", "Прайс 3" тот прейскурант, который мы хотим редактировать (в нашем случае "Прайс 2008-12-01"). После этого одна из колонок таблицы с ценами изменит название на "Прайс 2008-12-01", и в ней отобразятся цены соответствующего прейскуранта.
3. Для тех артикулов, которые уже существуют в системе, следует указать новую цену (в колонке "Прайс 2008-12-01").
4. Следует ввести в систему те артикула, которые в новом прейскуранте появились впервые, и указать их цену по созданному прейскуранту.
5. Не следует пытаться удалить из системы те артикула, которых нет в новом прейскуранте. При добавлении артикулов в список услуг, оказанных пациенту, система предлагает пользователю на выбор только те артикула, для которых в текущем прейскуранте указана цена. То есть если для какого-либо старого артикула вы не укажете новую цену, то этот артикул не будет вам мешать, он не будет виден в списке при выборе.
6. В день, когда новый прейскурант вводится в действие, следует открыть таблицу прейскурантов (меню Справочники -> Прайсы) и указать новый прейскурант в качестве прейскуранта по умолчанию (с помощью галочки в колонке "Прайс по умолчанию"). Если клиника работает с ДМС компаниями, желательно просмотреть в форме "Юридические лица" информацию о прейскурантах, использующихся по умолчанию для конкретных ДМС компаний.


ПРЕЙСКУРАНТ

Импорт прейскурантов

Форма предназначена для импорта цен и услуг в базу данных из файлов Excel.

Форма вызывается из формы прейскуранты при нажатии на кнопку "Импорт прейскурантов" [image].

Импорт осуществляется из файла, выбранного с помощью кнопки [3]. При первом открытии формы для выбора файла будет открыт каталог программы.

Импорт может осуществляться из следующих версий MS Office: MS Office 2000, MS Office XP, MS Office 2003. С активной страницы импортируется 3 столбца данных: код услуги, название услуги, стоимость. Признаком конца обработки служат три подряд идущие строки с незаполненными первыми двумя столбцами.

При импорте происходит обновление цен в прейскуранте, выбранном в выпадающем списке [1]. При первом открытии формы прейскурант берется из первого выпадающего списка выбора прейскурантов в форме "Прейскурант". Обновляются артикула, находящиеся в группе, выбранной в выпадающем списке [2] и всех ее подгруппах. При открытии формы группа прейскуранта совпадает с группой, выбранной в навигационном списке групп формы "Прейскурант".

В зависимости от настроек [4] при импорте может произойти либо обновление цен, либо обновление цен и добавление новых артикулов.

В зависимости от настроек [5] сопоставление артикулов происходит либо только по коду либо по коду, а в случае невозможности сопоставления, по названию.

При импорте программа пытается найти уже имеющийся артикул в выбранном прейскуранте.

Сначала происходит сопоставление артикулов по коду. Программа ищет в группах, не являющихся подгруппами выбранной для импорта группы, артикула с совпадающим кодом. Если такие артикула найдены, то при заданном в настройках импорта поиске по коду и названию, будут искаться артикула с совпадающим названием уже в пределах выбранной для импорта группы. Если таких артикулов не найдено или, наоборот, найдено более одного артикула, импорт артикула осуществляться не будет и результатом обработки строки импортируемого файла станет сообщение "Запись не обработана!!! В существующем в программе прейскуранте найден артикул с совпадающим кодом за пределами обрабатываемой группы." Такой же результат обработки строки будет, если за пределами группы найдены артикула с совпадающим кодом, а сопоставление происходит только по коду.

Если в группах, не являющихся подгруппами выбранной для импорта группы для импорта, отсутствуют артикула с совпадающим кодом, такие артикула будут искаться в пределах выбранной для импорта группы. Если таких артикулов найдено несколько и поиск по названию (если в настройках разрешено сопоставлять артикула по названию) не дал результатов, т.е. было найдено несколько артикулов с совпадающим назвнием или ни одного артикула не найдено, импорт артикула осуществляться не будет и результатом обработки строки импортируемого файла станет сообщение "Запись не обработана!!! В существующем в программе прейскуранте найдено несколько артикулов с совпадающим кодом в пределах обрабатываемой группы." Такой же результат обработки строки будет, если в пределах группы найдены несколько артикулов с совпадающим кодом, а сопоставление происходит только по коду.

Вышеприведенные ситуации, когда в базе данных имеются несколько артикулов с совпадающим кодом, а сопоставление по названию артикула, если оно разрешено в настройках импорта, не дает однозначного результата, являются ошибочными. Обработка строки файла импорта не производится.

Если поиск по коду не дал результатов, т.е. в пределах обрабатываемой группы нет артикула с совпадающим кодом, то при разрешенном в настройке импорта сопоставлении артикулов по названию, в пределах выбранной для импорта группы будут искаться артикула с совпадающим названием. Если таких артикулов найдено несколько, импорт артикула осуществляться не будет и результатом обработки строки импортируемого файла станет сообщение "Запись не обработана!!! В существующем в программе прейскуранте найдено несколько артикулов с совпадающим названием в пределами обрабатываемой группы." Эта ситуация также является ошибочной.

Если поиск не привел к однозначному сопоставлению артикула и в настройках импорта не разрешено вставлять новые артукула, то импорт артикула осуществляться не будет и результатом обработки строки импортируемого файла станет сообщение "Запись не обработана!!!В существующем в программе прейскуранте не найдено ни одного артикула с совпадающим кодом или названием. В настройках импорта не разрешен импорт новых артикулов." Если импорт новых артикулов разрешен, то артикул будет добавлен в выбранную для импорта группу прейскуранта.

Далее программа обновит стоимость для найденного (или вставленного) артикула и выбранного прейскуранта.

Результат импорта отображается в таблице [7]. Разные результаты обработки выделяются разными цветами. При наведении мыши на поле "Результат" отобразится полное сообщение о результате обработки строки.

При нажатии на галочку [6] "показать услуги из выбранной группы прейскуранта, не найденные в импортируемом прайсе", в таблице будут отображаться соответствующие артикула.

Импорт осуществляется при нажатию на кнопку "Импортировать" [8].

При импорте происходит запись результатов обработки в файл import.txt, находящийся в каталоге программы.


ПРЕЙСКУРАНТ

Прейскурант - составные услуги

В разделе описывается работа с составными услугами.

В программе имеется возможность вводить составные услуги. Выбор такой услуги врачом приведет к добавлению в программу комплекса дочерних услуг, определенного в форме "Дочерние услуги", вызываемой из контекстного меню услуги формы "Прейскурант".

При нажатии в прейскуранте на пункт контекстного меню "Редактировать составные услуги" откроется форма

В основном такая возможность используется при создании курсов лечения для более быстрого назначения пациенту стандартного набора услуг. У пользователя есть два типичных варианта задания стоимости составной услуги.
1. Можно задать стоимость составной услуги, равную нулю. В этом случае сумма выставляемого пациенту счета будет определяться стоимостью дочерних услуг, входящих в составную услугу.
2. Либо можно задать стоимость составной услуги, а для дочерних услуг поставить скидку 100%.

Обращаем Ваше внимание, что в форме редактирования дочерных услуг, если ввести в колонку "Скидка" число больше 1, то программа будет рассматривать введенное число как сумму скидки в рублях. Если ввести в колонку "Скидка" 1 или меньшее число, то программа будет считать, что скидка указана в процентах.

В форме редактирования дочерних услуг возможно добавить и удалить услугу. При добавлении откроется стандартная форма для выбора услуги.

В форме "Прейскуранты", сабформе "Услуги" формы "Визит" и в форме "Выбор услуги" составные услуги помечаются специальным значком [image].

В зависимости от значения константы 261 [Прейскурант - При добавлении составной услуги в Визит дочерние услуги добавлять: Да=в Назначения, Нет=в оказанные услуги], при добавлении составной услуги в визит дочерние услуги будут добавлены либо сразу в список оказанных услуг, либо в список услуг, назначенных согласно курсу лечения. Если при попытке добавить список услуг в курс лечения программа обнаружит, что курса лечения не существует, пользователю будет предложено создать курс лечения.


ГОСПИТАЛИЗАЦИЯ

Закладка "Госпитализация" в форме пациенты

В форме "Пациенты" госпитализации видны только при нажатой кнопке "госпитализация".

У одного пациента можно быть несколько госпитализаций, переключаться между ними можно, нажимая на закладку с датой начала госпитализации [9].

Программа дает возможность выбрать тип койки [11] - дневной или круглосуточный, № госпитализации задается автоматически [10], при нажатии восклицательного знака. Дата - автоматически ставится текущая дата. Дату и номер госпитализации можно редактировать вручную. Список полей, которые будут являться обязательными, можно отредактировать с помощью контекстного меню, открыв форму Пациентов под логином администратора sa. Дата выбытия задается вручную, при этом в верхнем поле [11] появляется количество дней госпитализации, которое программа просчитывает автоматически. Если не задавать время выбытия, то по умолчанию создается двухдневная госпитализация. Остальные поля заполняются по аналогии с формой "Пациенты". При нажатии

происходит сохранение внесенных изменений. В закладках [14] сохраняются все госпитализации, которые были у пациента. При нажатии кнопки с синей стрелкой вправо [15] осуществляется переход в форму госпитализации.


ГОСПИТАЛИЗАЦИЯ

Форма "Госпитализация"

Форма "Госпитализация" предназначена для ведения учета госпитализации пациентов.

Форма вызывается из меню, "Формы"-"Госпитализации". Форма доступна, только если включена константа 244 [Пациенты - Отображать закладку госпитализаций]. Перед началом работы с формой, в справочнике "Кабинеты" следует заполнить колонку "Число коек". В форме госпитализаций кабинеты с не указанным количеством коек не отображаются.

Форма представлена в виде таблицы. Первая колонка табличной формы [6] - название кабинета, вторая колонка [7] - номер койки. Каждая строчка соответствует одному койко-месту. Строки упорядочены по кабинетам, и по номерам коек. Строчки отображаются, даже если койка в течение периода не была никем занята. Каждая колонка табличной формы равна одному календарному дню. Не занятые клетки - пустые, белый фон. Наверху формы [1] - выбор даты. Если дата - первое число месяца, то в форме отображается месяц целиком. Если дата отлична от первого числа, то отображается 30 дней, начиная с выбранной даты включительно. [4] - кнопка обновления данных. Мужчины выделяются голубым фоном, женщины розовым. Начало и конец госпитализации выделяются вертикальными полосками чуть более темного фона. Если длительность госпитализации один день, то в клетке отображается полностью ФИО пациента. Если госпитализация занимает 2 дня, то в первой клетке отображается фамилия, во второй имя и отчество. Если госпитализация занимает 3 или более дней, то в первой клетке отображается фамилия, во второй имя, в третьей отчество, в последующих клетках - "====".

Программа позволяет занимать одну койку двумя пациентами, при условии, что у одного пациента госпитализация заканчивается, а у другого начинается. При этом их данные пишутся в клетке через слеш - сначала выбывающий, потом поступающий. Занятие койки тремя и более пациентами в течение дня программой запрещено. При двойном щелчке на пустые клетки поля [8] программа предлагает выбрать пациента, после чего создает госпитализацию длительностью в два дня, и открывает эту госпитализацию. Срок госпитализации можно редактировать в самой форме, встав курсором на нужную госпитализацию и изменив дату начала и дату окончания госпитализации в шапке формы. [5]

При щелчке правой кнопкой по госпитализации появляется контекстное меню из 5 пунктов:

  • Перейти к пациенту
  • Запись (программа переходит в форму "Запись", в режим кабинеты за день, к выбранной дате)
  • Визиты (показываются все визиты, которые были у пациента во время госпитализации, клик по визиту приводит к его открытию)
  • Документы (программа показывает список врачебных документов, которые у пациента были в течение госпитализации, клик по госпитализации приводит к ее открытию)
  • Удалить (программа предлагает удалить госпитализацию)

Все визиты и документы упорядочены по дате и времени создания. При отсутствии документов или визитов контекстное меню не активно. При наличии у пациента во время госпитализации визитов или документов, на том дне, в который был визит, в правом верхнем углу появляется иконка:

Цвет иконки информативен:

  • Зеленый квадрат - был визит
  • Синий квадрат - был документ
  • Красный квадрат – был и визит и документ

Программа предлагает возможность показывать или скрывать иконки документов и визитов при помощи проставления галочки [2] около надписи "Показывать иконки документов и визитов". Наверху формы [3] - кнопка печати. Печать формы выполняется в виде таблицы, без выделения клеток фоном. Над таблицей указывается период.


ГОСПИТАЛИЗАЦИЯ

Справочники

"Госпитализация - отделения"

Вызывается из меню "Справочники" – "Госпитализация - отделения". В справочник отделений заносятся все отделения, на которые возможна госпитализация, число коек на отделении, сколько из них круглосуточных, сколько на ремонте, какой план койко-дней. Все кнопки в тулбаре стандартные, как во всей программе.

Учет отделений делался для одной из государственных клиник, с большим количеством отделений, и учетом перемещений между отделениями. В коммерческих клиниках справочник не используется.

Справочник "Кабинеты"

Количество коек в палатах настраивается из справочника "кабинеты".

каждому кабинету присваивается число коек, на которое возможна госпитализация. Все кнопки в тулбаре стандартные, как во всей программе.

Справочник "Госпитализация - настройка отчетов"

Отчеты формируются по формам, утвержденным приказом Минздрава России. Самостоятельно редактировать справочник "Госпитализация - настройка отчетов" не рекомендуется.


ГОСПИТАЛИЗАЦИЯ

Отчеты по госпитализации

Отчеты по госпитализации можно открыть из меню "Отчеты", вложенное меню "Госпитализации". Отчеты формируются по формам, утвержденным приказом Минздрава России. Отчеты делались для одной из государственных клиник, в коммерческих клиниках не используются.

В отчетах есть возможность выбрать отделение, задать дату или период.


ОСНОВНЫЕ ФОРМЫ

Расписание работы врачей

Форма предназначена для ввода расписания работы врачей.

Для одного врача может быть создано произвольное количество правил. Если для врача не создано ни одного правила, то считается, что он не работает. На рисунке видно, что для врача Аллергологова задано 3 правила, он работает ежедневно с 9:00 до 18:30, по субботам с 11:00 до 15:00, и в сентябре 2010 г. у него отпуск. В форме записи пациентов на прием рабочее время врача отображается белым цветом, нерабочее - серым.

По умолчанию, если администратор пытается записать пациента на время, когда у врача нет приема, программа выдает предупреждение, но разрешает произвести запись. Поведение программы можно изменить, исправив константу "Запись - запрет на запись в нерабочее время, 1=запрет, 2=предупреждение, 3=разрешить" (меню "Справочники" - "Константы").

Наверху формы расположены поля фильтрации [1]. С помощью выпадающего списка врачей можно ограничить просмотр одним врачом, поля фильтрации по периоду позволяют ограничить просмотр только теми правилами, которые действуют в течении интересующего пользователя периода. Фильтр можно сбросить кнопкой [3]. Если в программе разрешена работа с клиниками, то при выборе клиники из выпадающего списка [2] будут показаны только правила врачей, работающих в этой клиники. При этом остальные фильтры будут сброшены.
Также наверху формы расположены стандартные кнопки [4] добавления записи, удаления записи, и переключения режима запрета изменений.

Правило "Не работает" имеет приоритет над остальными правилами. Например, можно указать для сотрудника, что он всегда работает по понедельникам и вторникам с 9:00 до 15:00, и что он НЕ работает 20 февраля.

Если не заполнены колонки [Правило действует с] и [Правило действует по], то правило действует всегда. Поля [Правило действует с] и [Правило действует по] можно заполнять или не заполнять в любом сочетании.

Поля [Начало часы], [Начало минуты], [Окончание часы], [Окончание минуты] указывают время начала предоставления услуги. Т.е. если пациенты записываются с интервалом в полчаса, и врач работает с 9:00 до 16:00, время окончания будет равно 15:30.

Галочки [Пн], [Вт], [Ср], [Чт], [Пт], [Сб], [Вс] имеют значение, только если в [Вид работы] стоит "Выбранные дни".

Поле [Вид работы] может принимать следующие значения: "Рабочие четные", "Рабочие нечетные", "Работает", "Не работает", "Выбранные дни", "Четные выбранные дни", "Нечетные выбранные дни", "2 через 2".

При нажатии на кнопку печати [5] выводится отчет о расписании работы врачей на день, указанный в поле "Начало периода". В зависимости от констант "Печать расписания врачей - относить записи ко 2 колонке (часы)", "Печать расписания врачей - относить записи ко 2 колонке (минуты)", задающих время разделения на утро/вечер, при печати расписания данные попадут в первую или вторую колонку. Данные в отчете сгруппированы по профессии врача. В конце отчета выводится подпись, заданныя в константе "Расписание врачей (печать) - подпись".


ОСНОВНЫЕ ФОРМЫ

Юридические лица (ДМС/ОМС)

Форма предназначена для редактирования страховых фирм, заключивших с пациентами договора на обслуживание.

Общее описание формы

Форма "Юридические лица" вызывается при нажатии на кнопку [image] в основном тулбаре или при выборе соответствующего пункта в меню "Формы". Форма состоит из нескольких секций:

Левая часть формы [1] используется для навигации, т.е. выбора нужной страховой фирмы.

Тублар редактирования [2] стандартный, его описание можно найти в соответствующем разделе справки. Справа от стандартного тулбара расположены кнопки "Печать списка пациентов", и кнопка "Слияние юридических лиц".

Правая часть [3] используется для редактирования данных о страховой фирме - наименование, номер договора, период действия договора и т.д. Если договор с фирмой просрочен или дата окончания не определена (поле "Действует по" пустое или введенная дата меньше сегодняшней), то введенный в поле текст будет выделен красным цветом. При навигации по списку страховых фирм в режиме запрета редактирования в случае просроченного договора красным будет выделена надпись "Действует по". В поле "Лимит оплаты" можно задать максимальную сумму стоимости услуг для пациента, заключившего договор, в случае превышения которой в форме "Пациенты" надпись, информирующая о стоимости услуг, будет выделена красным цветом. Поле "Лимит оплаты" существует не во всех версиях программы.

В правой нижней части формы "Юридические лица" расположена секция сабформ [4]. В сабформе "Пациенты" можно найти информацию о пациентах, приписанных к данной страховой компании. Данные заполняются автоматически, на основании информации, указанной в карточках пациентов. В сабформе "Документы" - данные о документообороте со страховой - акты, письма, договора, реестры, счета. Сабформа "Оплаты" предназначена для ввода информации о платежах, поступавших от страховой компании. В сабформе "Переводы" отображаются адресные перечисления со счета страховой на счета пациентов. Данные берутся из сабформы "Переводы" формы "Пациенты", с учетом страховой компании, указанной в колонке "Юр.лицо" перевода. Адресные переводы используются в основном даже не страховыми, а юр.лицами, которые платят за своих сотрудников. Видимость сабформ "Оплата" и "Документы" зависит от константы 136 [ДМС - Отображать информацию о взаиморасчетах с ДМС компаниями].

Навигация

Навигационная секция формы "Юридические лица" используется для поиска нужной страховой фирмы. В простейшем случае фирма ищется путем просмотра списка [3]. Если страховых фирм много, можно воспользоваться полем фильтрации по названию. При вводе в поле [1] любого текста, программа оставляет в списке только те страховые фирмы, в названии которых содержатся введенные символы. Кнопка [2] очищает строку [1], тем самым сбрасывая фильтр.

Сабформа "Пациенты"

В сабформе "Пациенты" отображается информация о пациентах, заключивших со страховой фирмой договора на обслуживание. Возможности редактирования данных пациента не предусмотрено. По двойному щелчку на записи открывается форма "Пациенты" и осуществляется переход к выбранному пациенту.

При нажатии на кнопку с изображением принтера в тулбаре формы будет напечатана информация, содержащаяся в сабформе "Пациенты".

Если значение константы 7 [ДМС (Юридические лица) - Выводить суммы услуг по пациентам] в справочнике "Константы" равно "Да", то в сабформе отображаются колонки "Все услуги" - сумма стоимостей всех услуг, оказанных пациенту или на которые пациент записан, и "Оказанные услуги" - сумма стоимостей всех услуг оказанных пациенту (т.е. услуг со статусом "Пришел"), c формой оплаты "ДМС". Для больших клиник с существенными оборотами, включение константы 7 может замедлить работу.

Сабформа "Документы"

В сабформе "Документы" возможно прикреплять к страховой компании файлы, содержащие счета, акты и т.п. В зависимости от константы "Файлы - хранить внутри базы (нет = во внешней папке)" файлы сохраняются в базе данных или на жестком диске в папке, указанной в константе 135 [Администрирование - Путь к сетевой папке для хранения ДМС документов].

Из контекстного меню сабформы можно распечатать документ, созданный на основе шаблона печатной формы. Для таких документов в форме "Шаблоны печатных форм" в поле "Тип шаблона" должно стоять "ДМС". Дополнительная информацию содержится в разделе справки "ДМС - печать счетов и актов".

Также в контекстном меню доступен пункт "Присвоить номер текущему документу" - присваивается следующий номер для данного типа документа, с учетом года. Пункт контекстного меню "Заполнить сумму оказанных услуг для выбранного периода" выполняет указанное в названии действие.

Сабформа "Оплата"

В сабформе "Оплата" отображается информация об оплатах, произведенных страховой фирмой. Возможно добавлять, изменять и удалять данные.


ОСНОВНЫЕ ФОРМЫ

Себестоимость

Форма предназначена для просмотра списка услуг, отдаваемых на субподряд.

Достаточно часто клиника часть оказываемых услуг отдает на выполнение субподрядчику. Субподрядчиком может выступать лаборатория, выполняющая анализы, зубопротезная лаборатория, занимающаяся изготовлением протезов, и т.п. Список субподрядчиков редактируется в справочнике "Прайсы - Поставщики". Стоимость услуг субподрядчиков редактируется в форме "Прайс". Себестоимость и поставщик для конкретной услуги могут быть изменены при записи пациента на прием, в форме "Визит".

Форма "Себестоимость" предназначена для просмотра услуг, отдаваемых на субподряд. То есть в данную форму попадают все услуги, введенные в форме "Визит", для которых указан либо поставщик, либо ненулевая себестоимость. В форме доступны для редактирования всего 2 колонки, "Поставщик" и "Себестоимость".

Список выводимых услуг можно ограничить (отфильтровать) с помощью полей наверху формы [1]: "Начало периода", "Конец периода", "Поставщик". Кнопка с воронкой и крестиком служит для сброса фильтра. При первом открытии формы отображаются только услуги, оказанные пациентам в течении текущего месяца.

Кнопка "Запретить/разрешить редактирование" [2] является стандартной, и переводит форму в режим разрешения редактирования и обратно.


ОСНОВНЫЕ ФОРМЫ

Напоминания

Напоминания предназначены для записи событий, о которых надо напоминать пациентам.

Довольно часто требуется напомнить клиенту, что он должен прийти на повторный осмотр, или что он обещал оплатить долг, возможны и другие поводы. Для открытия формы нажмите кнопку [image] в основном тулбаре.

Поля наверху формы [1] нужны для фильтрации напоминаний. Напоминаний может быть много, с помощью фильтров можно отобрать напоминания по дате ожидаемого события, по пациенту, по врачу (сотруднику) создавшему напоминание, по фамилии пациента, и по дате создания напоминания.

Кнопка [2] [image] служит для сбоса фильтра в исходное состояние. По умолчанию на экран выводятся все невыполненные напоминания, для которых дата ожидаемого события наступит в течении ближайшей недели.

Для того чтобы просмотреть только невыполненные напоминания, служит галочка [1] "Только невыполненные". Выпадающий список "Когда" нужен, чтобы можно было легко выбрать интересующий пользователя период, когда надо сделать напоминание. По умолчанию выводятся только "невыполненные" напоминания, по которым надо прозвониться в течении ближайшей недели. Определение "выполненного" и "невыполненного" напоминания можно найти ниже, в описании кнопок [7] и [8], и поля [9].

Кнопка [3] [image] служит для создания нового напоминания. При нажатии выводится окно "Добавить напоминание".

Напоминание можно так же создать из формы "Пациенты" и из формы редактирования документа. Напоминание создается для последнего пациента, которого пользователь просматривал в форме "Пациенты". Программа расчитана на значительное количество пациентов, поэтому выбор пациента из выпадающего списка не предусмотрен. При создании напоминания из формы "Документы", напоминание создается для того же пациента, к которому относится документ. Предполагается, что в основном форма "Напоминания" предназначена для просмотра напоминаний, по которым надо позвонить, а добавление напоминаний в основном производится из форм "Пациенты" либо "Документы"

Кнопка [4] [image] используется для удаления напоминания. Чтобы удалеть напоминание, щелкните мышкой на то напоминание, которое Вы хотите удалить. Программа обведет выбранное напоминание пунктиром (на рисунке обведено напоминание Петрову Петру Петровичу). После нажатия на кнопку программа просит подтвердить удаление напоминания, и производит удаление.

В описании напоминания [5] программа пишет, какой врач назначил напоминание, ФИО и телефон пациента, дату когда пациенту надо перезвонить, и собственно текст напоминания. Обработанные напоминания (по которым мы уже позвонили пациенту и сделали напоминание) выводятся зеленым цветом, необработанные - коричневым.

Кнопка [6] [image] открывает напоминание для редактирования. Окно редактирования существующего напоминания внешне идентично окну создания нового напоминания.

В правой части каждого напоминания отображаются данные [9] о двух последних звонках (дата, кто звонил и результат). После звонка пациенту, пользователь добавляет запись о звонке кнопкой [8] [image]. При нажатии на кнопку в центре экрана выводится формочка ввода.

В этой формочке пользователь должен указать кто звонил (по умолчанию текущий пользователь), был ли звонок успешным (галочка "Выполнено"), и выбирает из выпадающего списка результат звонка. Напоминание считается выполненным, если по нему был хотя бы один "выполненный" звонок. В выпадающем списке приведены только наиболее часто встречающиеся результаты. В случае необходимости, вы можете набрать описание результатов звонка с клавиатуры.

Кнопка [7] [image] выводит на экран форму, в которой можно просмотреть полный список звонков пациенту по выбранному напоминанию.

Для администраторов, программа при запуске проверяет наличие невыполненных напоминаний на ближайшие несколько дней, либо просроченных напоминаний. Если в системе есть такие напоминания, администратору выводится их список. Количество дней, которые просматривает программа, задается в константах.


ОСНОВНЫЕ ФОРМЫ

Премиальные проценты врачей (простое начисление)

В статье описывается возможность начисления сотрудникам премиальных процентов, в случае когда врач получает фиксированный процент от суммы оказанных услуг.

В программе реализованы две возможности начисления премиальных процентов:

В первом случае, врач получает фиксированный процент от суммы оказанных услуг.

Во втором случае, премиальный процент может меняться в зависимости от группы услуги, от того, за наличный или безналичный расчет осуществляется услуга. Также по втором случае может быть несколько вариантов начисления премиальных процентов.

Описание второго способа можно посмотреть в разделе справки "Премиальные проценты врачей (сложное начисление)".

В случае выбора простого начисления премиальных процентов (первый способ) требутся заполнить справочник "Врачи - премиальный процент".

С помощью полей [1] возможно отфильтровать список врачей. [2] - кнопка сброса фильтра. Кнопка переключения режима запрета/разрешения редактирования [3] является стандартной, и работает одинаково во всех формах.

В случае простого начисления процентов в форме настройки отчета по продажам становятся доступны галочки "% врача" и "% врача от продаж" для отображения в отчете соответствующих колонок.


ОСНОВНЫЕ ФОРМЫ

Премиальные проценты врачей (сложное начисление)

В статье описывается возможность начисления сотрудникам премиальных процентов за оказанные пациентам услуги в случае, когда премиальный процент зависит от нескольких параметров.

В программе реализованы две возможности начисления премиальных процентов:

В первом случае, врач получает фиксированный процент от суммы оказанных услуг. Описание этого способа приведено в статье справки "Премиальные проценты врачей (простое начисление)".

Во втором случае, премиальный процент может меняться в зависимости от группы услуги, от того, за наличный или безналичный расчет осуществляется услуга. Также по втором случае может быть несколько вариантов начисления премиальных процентов.

Сложное начисление процентов происходит в форме "Премиальные проценты врачей, которая вызывается при выборе соответствующего пункта в меню "Формы".

С помощью полей [1] определяется список врачей, для которых будет выводится информация. С помощью переключателей выбираются все врачи, рабаотающие врачи, врачи, у которых были услуги за период, заданный интервалом дат, или врачи, у которых указан процент за услуги хотя бы для одной группы прайса.

Количество врачей, которые могут одновременно отображаться на экране задается константой "Премиальные проценты врачей (сложное начисление) - количество колонок в форме". Максимальное количество колонок равно 50. Если константа не определена, отображается первые 20 врачей, удовлетворяющих условиям фильтра. С помощью кнопок [7] осуществляется отображение следующей или предыдущей группы врачей.

Редактирование осуществляется в списке [9]. Каждая запись в списке соответствует одной из групп прейскуранта, для услуг из которой врачу начисляется премиальный процент. Перед началом редактирования трубуется выбрать версию (один из вариантов начисления процентов) и подверсию (один из прейскурантов) из выпадающих списков [2]. Для версий и подверсий не предусмотрены отдельные справочники. Добавление, редактирование и удаление записей осуществляется с помощью кнопок [3].

При нажатии на кнопку добавления версии откроется форма:

Редактирование версии происходит в форме:

Аналогично, подверсии добавляется в форме:

а редактирование происходит в форме:

При редактировании подверсии кроме выбора прейскуранта требуется задать для наличных и/или безналичных услуг будет происходить начисление процентов.

Кнопка [4] очищает поля фильтрации. Устанавливается диапазон дат равный текущему месяцу, переключатель врачей ставится в положение "все врачи".

Кнопка [6] переключения режима запрета/разрешения редактирования, является стандартной и работает одинаково во всех формах.

При нажатии на кнопку [5] выводится отчет на основе данных, отображаемых в форме в данный момент. Из-за ограничения размера бумаги одновременно может быть выведено не более 8 врачей, даже если на экране отображается большее количество врачей.

При нажатии на кнопку "Отчет" [8] откроется форма настройки отчета "Премиальные проценты врачей":

Версия начисления процентов берется из формы начисления процентов.

В зависимости от значений выбранных в выпадающих списках "Группировать по" и "Затем по", может быть получено несколько вариантов отчета:

или


ОСНОВНЫЕ ФОРМЫ

Врачи - табель рабочего времени

В статье описывается возможность редактирования табеля работы сотрудников.

С помощью формы "Врачи - табель" сотрудники администрации клиники могут просматривать и редактировать время работы врачей за период.

С помощью полей [1] определяется список врачей, для которых будет выводится информация. После изменения полей [1] для изменения фильтра обязательно нужно нажать кнопку "Обновить данные". Поля [2] задают интервал, за который отображается информация. Количество отображаемых столбцов можно ограничить с помощью галочек "с 1 по 15", "с 16 по конец месяца". Переключатели [3] показают полный список врачей или только врачей, для которых вводились записи в табель в выбранном месяце. Кнопка [4] позволяет переходить в режим редактирования/запрета редактирования.

Редактирование осуществляется в списке [8]. Каждому врачу соответствует 2 строчки. В столбцах дней первая строчка соответствует времени начала работы врача, вторая - времени окончания работы. Двойной щелчок на ячейке записывает в ячейку текущее время. Для заполнения времени окончания работы требуется обязательное заполнение времени начала работы.

В итоговой строчке отображается суммарное время работы врача. При этом, если у врача в справочнике "Пользователи" заполнено поле "Ставка за час", то в итоговой строке будет показана сумма к выплате.

При нажатии на кнопку [5] будет сформирован отчет на основании данных, отображаемых на форме:

Название фирмы в заголовке отчета берется из константы 11 - Отчет ДМС - Название клиники.

При нажатии на кнопку [6] будет сформирован отчет для выделенного в таблице врача:

Кнопка [7] открывет форму "История изменения табеля" с фильтрацией по диапазону дат. К этой же форме можно перейти с помощью контекстного меню грида. В этом случае ставится фильтр по диапазону дат и врачу текущей строчки табеля. Форма "история изменения табеля" описана в соответствующем разделе справки.


ОСНОВНЫЕ ФОРМЫ

Медстандарты

Форма предназначена для ввода документов с медицинскими стандартами для кодов МКБ.

Каждый стандарт может содержать информацию о нескольких кодах МКБ, которые можно указать нажав на многоточие в колонке для открытия справочника МКБ или вручную. После указания всех необходимых медстандартов в каждой форме, где есть колонка МКБ, появится пункт в контекстном меню "Просмотр медстандарта". При выборе этого пункта будет произведен поиск соответствующего кода МКБ в таблице с кодом МКБ в форме медстандартов. Если найдено несколько подходящих документов, то пользователю будет предложен множественный выбор того, который следует открыть. Также данный пункт меню доступен в любом врачебном документе, достаточно встать на нужный код мышью и вызвать контекстное меню.

Соответствие определяется по полному совпадению кода МКБ или по разделу. Например, для кода МКБ R10.2 будет предложен документ с кодом R10.


ОБЩАЯ ИНФОРМАЦИЯ

Основной тулбар программы

Основной тулбар программы расположен под строкой меню, и доступен пользователю из любого места программы. С помощью тулбара пользователь может переключаться между наиболее важными и часто доступными формами.

Открывает форму "Расписание работы врачей". Форма предназначена для редактирования расписания, кто из докторов когда ведет прием.

Открывает форму "Пациенты". Форма предназначена для просмотра и редактирования информации о пациентах.

Открывает форму "Юридические лица". Форма предназначена для просмотра и редактирования информации о ДМС компаниях.

Открывает форму "Прейскурант"

Открывает форму "Запись на прием". Форма предназначена для записи пациентов на прием, и просмотра расписания приема пациентов в разрезе по пациентам и по закладкам.

Открывает форму "Себестоимость". Форма предназначена для просмотра данных об услугах, выполнение которых мы отдаем на субподряд (например, анализы, либо изготовление протезов). В форме можно указывать, услугами какого поставщика мы воспользовались для того, чтобы оказать услугу конкретному пациенту, и сколько мы должны поставщику за эту услугу.

Открывает форму "Напоминания". Форма предназначена для просмотра списка напоминаний, и ввода информации о звонках по напоминаниям. Типичное напоминание, например "Пациент Иванов И.И. должен прийти на повторный осмотр в январе".

Открывает форму "Шаблоны". Шаблоны являются заготовками для врачебных документов.

Открывает форму "Документы". В Документах хранится врачебная информация об осмотрах и лечении пациентов.


ОБЩАЯ ИНФОРМАЦИЯ

Тулбар редактирования

Тулбар редактирования используется во всех местах, где пользователь работает с данными.

Кнопка "Разрешить редактирование" предназначена для перехода в режим редактирования и обратно. В режиме редактирования пользователь может изменять данные, в режиме запрета редактирования - не может. В таблицах режим редактирования обычно отображается желтым фоном, режим запрета редактирования - светло-светло-красным. Если пользователь начал редактировать данные, кнопка становится недоступной, до тех пор пока пользователь не сохранит, либо не отменит изменения.

Кнопка "Добавить новую запись" производит вставку новой записи (документа, пациента, врача, константы и т.п.) При редактировании таблицы новую запись можно также вставить, нажав клавишу "Insert". Если пользователь начал редактировать данные, кнопка становится недоступной, до тех пор пока пользователь не сохранит, либо не отменит изменения.

Кнопка "Удалить запись" удаляет текущую запись (документа, пациента, врача, константы и т.п.) Перед удалением программа выводит предупреждение, и запись удаляется только после подтверждения пользователя. Следует иметь в виду, что нельзя удалить запись, если на нее есть ссылки. Напримет, если пользователь пытается удалить врача, и при этом в программе есть услуги, которые ссылаются на этого врача, то программа выведет сообщение об ошибке, и не будет удалять запись. Кнопка удаления доступна в режиме редактирования.

Кнопка "Сохранить изменения" становится доступной, когда пользователь вносит какие-либо изменения в текущую запись. При нажатии на кнопку программа сохраняет внесенные изменения.

Кнопка "Отменить изменения" становится доступной, когда пользователь вносит какие-либо изменения в текущую запись. При нажатии на кнопку программа отменяет внесенные изменения.


ОТЧЕТЫ

ДМС - Реестр операций

Отчет предназначен для формирования реестра операций для отсылки в страховые компании.

В форме настройки пользователь задает период, страховую (ДМС) компанию и выбирает вариант отчета. После нажатия кнопки "Сформировать отчет" программа формирует реестр операций. В реестр попадают только услуги со статусом "Пришел" и типом оплаты "ДМС".

При формировании отчета используются константы из справочника "Константы":

  • Отчет ДМС - Название клиники (используется во всех вариантах отчета)
  • Отчет ДМС - Подпись внизу отчета (используется во всех вариантах отчета)
  • Отчет ДМС - Телефон фирмы (используется в варианте отчета 2)
  • Отчет ДМС - Шапка для отчета v3 (используется в варианте отчета 3)

Данные, взятые из этих констант, могут быть выведены в шапке или в конце отчета, в зависимости от выбранного отчета.

Информация "№ счета" и "Дата счета" также будет выведена в заголовке отчета (варианты 2-5). Кроме того, заполнение этих данных явялется обязательным условием при формировании счетов и актов.

Дата и номер счета будут автоматически подставлены в соответствующие поля формы при выборе страховой компании или периода, если для выбранной страховой компании в указанном периоде уже был сформирован счет.

Кнопка "Печать счетов и актов" позволяет распечатать документ, созданный на основе шаблона печатной формы. Для таких документов в форме "Шаблоны печатных форм" в поле "Тип шаблона" должно стоять "ДМС". Если имеется несколько документов с данным типом шаблона, то при нажатии на кнопку программа предложит пользователю выбрать нужный документ. Более полная информация содержится в разделе справки "ДМС - Печать счетов и актов".

При нажатии на кнопку "Сформировать отчет" или "Печать счетов и актов" в случае заполненных "№ счета" и "Дата счета" информация о счете будет занесена в базу данных и в дальнейшем станет отображаться в сабформе "Счета" формы "Юридические лица".

В программе реализованы несколько вариантов отчета ДМС, отличающихся друг от друга, отображаемыми данными, порядком вывода информации и подсчетом промежуточных итогов.

Вариант 1 - группировка данных по дате услуги

Вариант 2 - группировка данных по пациенту

Вариант 3 - группировка данных по пациенту

Вариант 4 - группировка данных по номеру страхового полиса

Вариант 5 - группировка данных по номеру страхового полиса

Программа умеет экспортировать полученный документ в Excel, для этого надо воспользоваться кнопкой "Экспорт":


ОТЧЕТЫ

ДМС - Печать счетов и актов

В разделе описываются особенности печати документов, предоставляемых в страховые компании.

Кнопка "Печать счетов и актов" в форме "Настройка отчета Страховые компании" позволяет распечатать документ, созданный на основе шаблона печатной формы. Для таких документов в форме "Шаблоны печатных форм" в поле "Тип шаблона" должно стоять "ДМС". Если имеется несколько документов с данным типом шаблона, то при нажатии на кнопку программа предложит пользователю выбрать нужный документ.

Кнопка "Печать счетов и актов" доступна только в случае, если константа "Отчет ДМС - Показывать поля ввода N и даты счета в форме настроек" имеет значение "Да".

В форме "Настройка отчета Страховые компании" выбирается страховая компания, период (месяц), за который предоставляется счет, задаются номер и дата счета. В сформированный документ попадает информация об услугах, оказанных пациентам, заключивших договор со страховой компанией, за указанный период, имеющих статус "Пришел" и тип оплаты "ДМС".

В шаблонах печатных форм для печати документов для страховых компаний возможно использовать тэги из следующих групп: "ДМС", "Общие тэги", "Константы", "Услуги - таблица".

Тэги группы "Услуги - таблица" должны находиться в ячейках таблицы в шаблоне документа. В этом случае при наличии нескольких оказанных услуг в таблицу будет добавлено соответствующее количество строчек с данными о каждой услуге. Такие тэги должны начинаться с символов "Srv".

Дополнительную информацию о тэгах можно посмотреть в разделе справка "Администрирование" - "Настройка печати" - "Список тэгов".

Далее приведен пример одного из возможных вариантов шаблона документа для страховой компании:

После подстановки тэгов, пользователь увидит следующий документ:


ОТЧЕТЫ

Взаиморасчеты с ДМС компаниями

Данный отчет позволяет получить информацию о взаиморасчетах со страховыми компаниями.

Если галочка "выводить разбивку по месяцам" не поставлена, то выводится итоговая информация по страховой компании:

Если галочка "выводить разбивку по месяцам" поставлена, то информация для каждой страховой компании будет дополнительно разбита по месяцам:


ОТЧЕТЫ

Отчет по продажам

Данный отчет является основным инструментом для анализа продаж в различных разрезах.

Формирование отчета по продажам начинается с выбора диапазона дат, и задания прочих фильтров (секция [1] формы настройки отчета). По умолчанию отчет строится по услугам, оказанным в течение текущего месяца, и только по визитам со статусом "Пришел". Пользователь может также фильтровать данные по виду оплаты и по врачу. Фильтрация по Статусу и по Специальности врача допускает множественный выбор. Чтобы выбрать несколько специальностей, либо несколько статусов, нажмите кнопку с биноклем справа от поля, и произведите выбор в открывшейся форме. Кнопки с изображением мусорной корзины сбрасывают выбор.

Выпадающие списки [2] "Группировать по" позволяют выводить информацию в различных разрезах:

  • vip - по VIP-статусу пациента
  • Адм. зарегистрировал - по сотруднику, создавшему запись
  • Адм. последний редактировал - по сотруднику, который последний изменял запись
  • Вид оплаты - по виду оплаты (чаще всего нал/безнал)
  • Возраст - по возрасту пациента
  • Врач - по ФИО врача
  • Врач 2 - по ФИО врача-асистента
  • Время - по времени оказания услуги
  • Группа услуг - по группе услуг
  • Дата - по дате
  • Дата+Время - по дате и времени
  • Дата+Время+Врач+Пациент
  • Кабинет - по кабинету
  • Курс - по курсу
  • Лечащий врач - по лечащему врачу
  • Месяц - по году и месяцу
  • МКБ - по коду МКБ (указывается в услугах)
  • Пациент - по ФИО пациента
  • Первичный/повторный - по первичным/повторным визитам
  • Первичный/повторный в названии услуги
  • Первый визит в клинику Х месяцев назад
  • Первый визит к этому врачу Х месяцев назад
  • Пол - по полу пациента
  • Поставщик - по поставщику (субподрядчику услуги)
  • Рекламный канал - по рекламному каналу пациента
  • Скидка/Наценка - по скидке, указанной в услуге
  • Специальность - по специальности пациента
  • Статус - по статусу услуги
  • Услуга - по названию услуги
  • Юр.лицо - по названию ДМС компании
  • Юр.лицо - номер списка

Помимо значения параметра, по которому производится группировка, программа выводит в отчете колонки с количествами и стоимостями. Пользователь может выбрать желаемые колонки в секции [3] формы настройки:

  • количество услуг - сумма поля "Количество" по всем услугам, оказанным пользователю
  • количество визитов - сумма количества визитов. Под визитом программа понимает приход ко врачу в определенный день в определенное время, т.е. если пациент Иванов в какой-либо день запишется на прием к врачу Докторову на 10:00, а к врачу Лекареву на 12:00, то программа посчитает это за 2 визита.
  • количество пациентов - общее число пациентов, которым оазывали услуги
  • % врача - подсчет премиального процента врача. В справочнике "Врачи" есть колонка "Премиальный %". Программа умножает % врача на стоимость услуги с учетом скидки, и получает искомую сумму. То есть, если премиальный процент врача составляет 10%, стоимость услуги составляет 100р., и пациенту была предоставлена скидка 20%, то получится сумма (100р.-20% * 10%) = 8р.
  • поставщики (себестоимость) - суммируется поле "Себестоимость", описание работы с себестомостью можно прочитать в справке по формам "Прейскурант" и "Себестоимость"
  • за вычетом себестоимости - разница между стоимостью оказанной услуги и ее себестоимостью
  • без учета скидок - Полная стоимость оказанных услуг
  • сумма скидок - сумма предоставленных пациенту скидок
  • с учетом скидок - сумма денег, которые должен уплатить пациент (полная стоимость услуг за минусом предоставленных скидок)
  • получено денег - сумма полученных денег
  • % врача от оплат
  • со счета - сумма оплат с типом оплаты "Списано со счета пациента"
  • наличные - сумма оплат с типом оплаты "Наличные"
  • ДМС - сумма оплат с типом оплаты "ДМС"
  • юридическое лицо - сумма оплат с типом оплаты "Юридическое лицо"
  • терминал - сумма оплат с типом оплаты "Терминал"

Галочки "% врача" и "% врача от оплат" становятся доступны только если установлено простое начисление премиальных процентов. Для дополнительной информации можно посмотреть статью справки "Начисление премиальных процентов".

Кнопка [4] используется для сброса настроек отчета в начальное состояние.

Задав все параметры, пользователь нажимает на кнопку "Сформировать отчет", и получает отчет:


ОТЧЕТЫ

Должники / предоплата

Данный отчет позволяет получить список должников, и узнать общую сумму задолженности/предоплаты.

Если галочка "группировать по курсам услуг" не поставлена, то выводится итоговая информация о задолженности/предоплате для каждого пациента:

Задолженность можно просматривать с разбивкой по курсам услуг. Например, пациент внес предоплату на изготовление зубного протеза. Чтобы случайно не израсходовать эту предоплату на лечение аллергии, возможен раздельный учет долгов, с разбивкой по курсам.

Если галочка "группировать по курсам услуг" поставлена, то информация о задолженности/предоплате для каждого пациента будет дополнительно разбита по курсам услуг:


ОТЧЕТЫ

Рабочее вермя

Данный отчет позволяет получить информацию об общем времени работы врачей за период и о времени работы врачей с клиентами.

Если галочка "группировать по професии врача" не поставлена, то выводится информация по каждому врачу:

Если галочка "группировать по професии врача" поставлена, то информация выводится с группировкой по профессии:


ОТЧЕТЫ

Окупаемость оборудования

Данный отчет позволяет получить информацию об амортизации оборудования при оказании услуг.

Для формирования отчета необходимо предварительно заполнить справочник "Прейскуранты - оборудование", указав стоимость оборудования и амортизацию за визит и минуту, а также привязать оборудование в конкретной услуге в форме "Прейскуранты". Видимость поля "Оборудование" в фоме "Прейскуранты" зависит от константы "Прейскурант - отображать используемое оборудование".

Выпадающие списки "Группировать по" позволяют выводить информацию в различных разрезах:

  • Группа прейскуранта - по группе прайса
  • Месяц - по месяцу
  • Название услуги - по услуге
  • Оборудование - по оборудованию
  • Отделение - по отделению, в котором используется оборудование
  • Отделение+Оборудование

При нажатии на кнопку "Сформировать отчет" выводится отчет:


ОТЧЕТЫ

Кассовый отчет

Данный отчет позволяет в зввисимости от версии отчета получить список сформированных за день реестров или информацию о денежных средствах, проходящих через кассу, за период.

В зависимости от константы "Отчеты - Используемая версия кассового отчета", которая может принимать значени 1 или 2, возможны две версии кассового отчета:

Кассовый отчет (версия 1)

Позволяет получить список сформированных за день реестров.

Выбрав день, пользователь нажимает на кнопку "Сформировать отчет" и получает отчет:

Если по всем услугам реестра был осуществлен возврат денег, то значения в колонках "Количество" и "Сумма" для такого реестра будет нулевыми. Если на день формирования отчета производился только возврат денег, а сами услуги были оплачены ранее, то количество и сумма будут отрицательными.

Оранжевым цветом в отчете выделены реестры со статусами "Сторно" и "Сторно, деньги возвращены".

Кассовый отчет (версия 2)

Позволяет получить информацию о денежных средствах, проходящих через кассу, за период.

Выбрав период и тип операции, пользователь нажимает на кнопку "Сформировать отчет"

В зависимости от галочки "выводить разбивку по операциям" отчет выводится в следующих вариантах:


ОТЧЕТЫ

Рекламные каналы

Данный отчет позволяет получить информацию суммах полученных от пациентов, привлеченных благодаря различным видам рекламы.

После выбора параметров фильтрации и нажатия на кнопку "Сформировать отчет" выводится отчет:


ОТЧЕТЫ

Сводный отчет

Данный отчет позволяет получить информацию о движении денежных средств за определенный период.

После выбора периода и нажатия на кнопку "Сформировать отчет" выводится отчет:


ОТЧЕТЫ

Продажи врачей с разбивкой по дням

Данный отчет позволяет получить информацию о суммах, полученных при оказании услуг, за определенный месяц.

Выпадающий список "Версия отчета" позволяет получать информацию для разных вариантов денежных операций:

  • Поступления денег
  • Поступления+Возврат
  • Возврат денег
  • Поступления денег (только фискальный регистратор)
  • Поступления+Возврат (только фискальный регистратор)
  • Возврат денег (только фискальный регистратор)
  • Выработка

После выбора определенного месяца и года и нажатия на кнопку "Сформировать отчет" выводится отчет:


ОТЧЕТЫ

Дни рождения пациентов

Данный отчет позволяет получить список пациентов, которых желательно поздравить с днем рождения

Задав период и дополнительные параметры, пользователь нажимает на кнопку "Сформировать отчет", и получает отчет:

Столбец с адресами пациентов виден, если значение константы "Отчет "Дни рождения" - Выводить с адресом" равно "Да". Столбец "Сумма" - только если в форме настройки задано значение в поле "Только клиенты с суммой услуг более".


ОТЧЕТЫ

Реестр услуг

Данный отчет позволяет получить список услуг пациента за период.

Формирование отчета начинается с выбора диапазона дат и статуса услуг. По умолчанию отчет строится по услугам, оказанным в течение текущего месяца, и только по визитам со статусом "Предварительная запись" и "Подтвержденная запись". Фильтрация по Статусу допускает множественный выбор. Чтобы выбрать несколько статусов, необходимо нажать кнопку с биноклем справа от поля, и произвести выбор в открывшейся форме. Кнопка с изображением мусорной корзины сбрасывает выбор.

Задав все параметры, пользователь нажимает на кнопку "Сформировать отчет", и получает отчет:

В случае, если текущий пациент не определен, отчет не будет сформирован, а пользователь получит предупреждающую надпись.

Отчет без формы предварительной настройки доступен из формы "Запись" при выборе соответствующего пункта из контекстного меню ячейки.


ОТЧЕТЫ

Задолженность пациента

Данный отчет позволяет получить общую сумму задолженности/предоплаты пациента за период с разбивкой по врачам, оказывавшим услуги.

По умолчанию при первом открытии формы задается период равный четырем последним месяцм, включая текущий.

Выбрав период, пользователь нажимает на кнопку "Сформировать отчет".

В зависимости от галочки "выводить список услуг" отчет выводится в следующих вариантах:


ОТЧЕТЫ

Экспорт в Excel

Для каждого отчета в форму настройки его параметров добавлена кнопка выгрузки результата в таблицу Excel.

Шаблоны выгрузки можно загрузить под пользователем SA, к части основных отчетов уже прикреплен шаблон по умолчанию от разработчиков. Данный отчет удалить нельзя, но всегда можно заменить его на свой. Для этого кликаем по кнопке под пользователем SA и выбираем пункт меню "Добавить новый шаблон". Шаблонам можно задавать удобное имя, а также отметить один из них как шаблон по умолчанию. Если есть такой шаблон, то при клике по кнопке под любым пользователем будет открыт именно он, а не предложен выбор из всех имеющихся.

Формат шаблона - это Excel файл, сохраненный как "Таблица XML 2003". В котором соблюдены следующие условности:

Строки именуются (Формулы - Присвоить имя) как:

  • RowColor0 - строка с данными. Если такой нет, то берется первая сверху RowColorX строка
  • RowColor1 - строка с выделенными данными. Используется для строк c полем "row_color" = Истина
  • RowColorX - строка с выделенными данными. Используется для строк c полем "row_color" как число, именно значение поля определяет X. Если такой строки нет, то берется первая сверху RowColorX строка
  • Footer - строка с подсуммой, первое указанное поле в строке - поле для группировки. В остальных полях могут быть стандартные формулы.

Ячейки в строке настраиваются как:

  • Имя поля из результата запроса 1 в 1
  • Зарезервированы имена CurTemplateN и DocN для печати номера документа
  • В Footer нельзя указывать имена полей, должны быть только сами формулы в ячейке
  • Тип данных в ячейке выставляется соответственно полю в таблице, если тип ячейки не был указан в шаблоне

Смотрите также статью Отправка отчетов по продаже на почту


КАК СДЕЛАТЬ ...

Создать документ и добавить услугу в сущестующий визит


КАК СДЕЛАТЬ ...

Как научить врача пользоваться системой

Врач должен уметь:

  • Создавать документ из шаблона (справка "КАК СДЕЛАТЬ ..." - "Создать документ и добавить услугу в сущестующий визит"). Подробнее с работой с врачебными документами можно ознакомиться в разделе справки "Документы".
  • Добавлять напомнинания для пользователей (кнопка [image] в формах "Документы" и "Пациенты")

Не обязательные умения:

  • Врачебные документы в системе создаются из шаблонов. Политику клиники определяет главный врач: либо список шаблонов жестко задан, либо каждый врач может произвольным образом добавлять удобные для себя шаблоны. Если рядовые врачи могут редактировать шаблоны документов, перед началом работы врачу рекомендуется прочитать справку "Основные формы - Шаблоны".
  • Поиск пациентов (разделы справки "Пациенты" - "Пациенты" и "Пациенты" - "Навигация").
  • Раздел справки "Тулбары" - "Тулбар редактирования" дает общее представление о работе системы.
  • "Администрирование" - "Просмотр удаленных документов" может потребоваться, если пользователь нечаяно сотрет какой-либо из своих документов (врачи могут редактировать и удалять только свои документы). Работа с резерными копиями документа описана в "Документы" - "Заголовок и кнопки управления".
  • С пациентами, записанными на прием к врачу, врач может ознакомиться в форме "Запись". Для ознакомления можно прочитать раздел справки "Запись" - "Запись на прием"

Подсказка: чтобы не вводить логин при каждом входе в систему, его можно указать в .ini файле. При задании паролей, сочетания из цифр и специальных символов разработчики стараются задавать таким образом, чтобы их было удобно набирать на дополнительной цифровой клавиатуре.


КАК СДЕЛАТЬ ...

Как записать пациента на прием


КАК СДЕЛАТЬ ...

Как исправить печатную форму


АДМИНИСТРИРОВАНИЕ

Создание резервных копий

Программа может создавать архивные копии базы данных в автоматическом и ручном режимах.

Если в настроечном файле med.ini значение параметра auto-backup равно "on", то при первом в течении дня запуске программы происходит автоматическое создание резервной копии.

В первую очередь проверяется наличие успешно созданных резервных копий за последние 3 дня. В случае их отсутствия программа выдает предупреждение: "ВНИМАНИЕ!!! Обнаружено отсутствие резервных копий за последние 3 дня. Это может быть связано либо с длительным простоем системы (праздники и т.п.) либо со сбоем автоматического резервного копирования. Если это сообщение будет повторяться, пожалуйста, обратитесь в службу технической поддержки!!!"

В случае, если на сегодняшний день резервное копирование еще не проводилось, программа начинает создавать резервную копию. Для средней по размеру базы данных этот процесс занимает несколько секунд и практически не заметен пользователю. После окончания копирования выдается сообщение "Резервная копия создана успешно!" или, в случае неудачи, "Резервная копия не создана!!!"

Программа может создавать полную или дифференциальную резервную копию. Полная копия в автоматическом режиме создается один раз в начале каждого месяца. В дальнейшем при запуске программы, если в базе данных хранится информация о успешном создании полной резервной копии, создаются дифференциальные копии, где хранится информация только о измененных данных. Для восстановления из резервной копии необходимо наличие как полной, так и дифференциальной копий.

После создания резервной копии она архивируется в формате zip и помещается в папку на сервере. В названии резервной копии и заархивированного файла есть информация о дате и времени создания резервной копии. Для предотвращения несанкционированного доступа к данным архивный файл защищен паролем.

Следует помнить, что даже в случае успешного создания резервной копии, файл резервной копии может быть вручную удален пользователем либо перемещен в другое место.

При создании резервных копий используются константы:

  • Путь к папке с архивными копиями на сервере (например, d:\back\)
  • Путь к программе архиватору (например, d:\back\7za.exe)

При указании путей наличие конечного "\" обязательно.

Для просмотра списка созданных резервных копий, а также для их создания в ручном режиме служит форма "Просмотр списка резервных копий", вызываемая из меню "Администрирование".

В верхней части формы находится полный список созданных резервных копий с информацией о дате и времени создании копии, успешности создания и т.п. При перемещении по списку в окне "Дополнительная информация" отображается информация об этапах создания резервной копии (создание копии, архивирование, копирование в папку на сервере).

При нажатии на соответствующую кнопку возможно ручное создание полной или дифференциальной резервной копии.


АДМИНИСТРИРОВАНИЕ

Отправка и получение почты

Программа может использоваться в сети из нескольких клиник. При этом ввод первичных данных, и их обработка может производиться в разных местах. Например, данных могут потребоваться бухгалтеру, руководству, сотруднику, отвечающему за взаиморасчеты с ДМС компаниями, и т.п. Для подобных случаев в программе предусмотрена возможность пересылки информации между системами, установленными на разных площадках.

Для отправки резервной копии служит форма "Отправка архива по почте", вызываемая из меню "Администрирование".

Возможна отправка полной или дифференциальной резервной копии [1].

Полное резервное копирование – создает полную резервную копию базы данных. При восстановлении базы данных, используя полную резервную копию, потребуется только самый последний созданный экземпляр.

Дифференциальное резервное копирование – создает резервную копию только тех данных, которые были изменены с момента последнего полного копирования. При восстановлении базы данных, используя дифференциальную резервную копию, потребуется последняя полная резервная копия и последняя созданная дифференциальная резервная копия.

При необходимости к письму добавляется текстовое описание, находящееся в секции [2].

При нажатии на кнопку [3] программа вытается найти в папке, заданной в константе "Путь к папке с архивными копиями на сервере" файл с последней созданной резервной копией. В случае нахождения файла он отправляется, в противной случае выдается предупреждение.

[4] – индикатор хода выполнения приема сообщения. [5] – строка статуса для информирования о текущих операциях и их завершении.

Для правильной отсылки и приема сообщений необходимо задать несколько констант:

  • Порт pop3 для приема сообщений – порт pop3 на почтовом сервере для входящей почты
  • Порт smtp для отправки сообщений – порт smtp на почтовом сервере для исходящей почты
  • Почтовый сервер входящей почты (pop3) – адрес сервера для входящей почты (например, pop.crm-soft.ru)
  • Почтовый сервер исходящей почты (smtp) – адрес сервера для исходящей почты (например, smtp.crm-soft.ru)
  • Логин для сервера входящей почты
  • Пароль для сервера входящей почты
  • E-mail, с которого будет отправляться сообщение
  • E-mail, на который будет отправляться сообщение
  • Логин для сервера исходящей почты
  • Пароль для сервера исходящей почты

Для приема почты служит форма "Прием почты".

Форма вызывается при запуске программы, если в настроечном файле med.ini значение параметра checkmail равно "on".

ВНИМАНИЕ ! для успешного восстановления данных из полученной резервной копии, надо чтобы программа была закрыта на всех компьютерах (в случае, если на площадке, где производится прием данных, работа с базой возможна с нескольких компьютеров).

Форма состоит из нескольких секций:

[1] – тулбар [image].

Описание кнопок (слева направо):

  • Проверить почту – устанавливает соединение с сервером, получает заголовки сообщений. Сами сообщения, включая прикрепленные файлы, не передаются.
  • Получить письмо без восстановления – получает выбранное сообщение. Прикрепленные файлы сохраняются в папку, заданную в константе "Сетевой путь к папке с архивными копиями на сервере".
  • Удалить письмо – удаляет сообщение с почтового сервера.
  • Получить письмо и восстановить из резервной копии – получает выбранное сообщение. Если полученное сообщение содержит резервную копию базы данных, выполняется восстановление из резервной копии. Восстановление возможно только при наличии полной или полной и дифференциальной резервной копии.

Кнопки доступны только в режиме "Принять почту".

  • Восстановить из резервной копии – выполняет восстановление из резервной копии.

Кнопка доступна только в режиме "Восстановить из резервной копии".

[2] – переключатель между режимами "Принять почту" и "Восстановить из резервной копии".

[3] – список принятых сообщений. При выборе сообщения из списка в секции [4] отображается текстовая часть сообщения, в секции [5] – информация о прикрепленных файлах.

[6] – индикатор хода выполнения приема сообщения.

[7] – строка статуса для информирования о текущих операциях и их завершении.

В режиме "Востановить из резервной копии" форма принимает вид:

В списке перечислены все архивные копии, находящиеся в папке, заданной в константе "Сетевой путь к папке с архивными копиями на сервере". Возможен выбор нескольких элементов списка. При этом программа предложит восстановить данные только из последнего выбранного файла с полной резервной копией и последнего выбранного файла с дифференциальной резервной копией. Восстановление возможно только при наличии полной или полной и дифференциальной резервной копии.

При восстановлении из резервной копии используются константы:

  • Путь к папке с архивными копиями на сервере (например, d:\back\)
  • Путь к программе архиватору (например, d:\back\7za.exe)
  • Путь к общей папке на сервере (например, d:\common\)
  • Cетевой путь к общей папке на сервере (например, \\server\back\)

При указании путей наличие конечного "\" обязательно.


АДМИНИСТРИРОВАНИЕ

Шаблоны печатных форм

Данная форма вызывается из меню "Администрирование" и используется для редактирования списка используемых в системе .rtf шаблонов. Помимо печати врачебных документов (форма "Документы"), в клиниках сущестует большой набор стандартных документов. В их число входят информированные согласия, договора, медкарты, талоны на лечение и т.п. В различных клиниках отличается формат этих документов, их количество, способы оформления. Для придания системе универсальности, пользователям дана возможность произвольным образом настраивать такие документы (печатные формы). Чтобы добавить в систему печатную форму, надо выполнить следующую последовательность шагов:
1. Создать необходимый Вам документ в программе MS Word. Документ может быть произвольным образом отформатирован, может содержать рисунки и т.д.
2. В созданном документе, в местах где Вы хотите видеть данные о пациенте, список оказанных пациенту услуг и т.п., подставить специальные ключевые слова. Далее в справке такие слова будут называться Тэгами. То есть если вы хотите, чтобы при печати договора программа в определенном месте вставляла фамилию пациента, в шаблоне в этом месте следует написать "PatFIO", "PatFullYears" программа будет заменять на полный возраст пациента, и т.д. Полный список тэгов приведен в отдельном разделе.
3. Сохранить созданный документ в формате .rtf (В MS Word выбрать меню Файл - Сохранить как, и в диалоге сохранения внизу выбрать из выпадающего списка "Тип файлов" значение "Текст в формате .rtf (*.rtf)".
4. Закрыть MS Word, в программе открыть справочник "Шаблоны печатных форм" (меню Администрирование - Шаблоны печатных форм).
5. Нажать на кнопку [image], и выбрать сохраненный файл.
6. Если надо, перейти в режим редактирования кнопкой [image], исправить название документа (по умолчанию название документа совпадает с исходным названием файла), заполнить поле "Тип шаблона". При необходимости поставить галочку "Заменять пустые поля подчеркиваниями", указать число экземпляров по умолчанию и действие при открытии документа.

Описание импорта и экспорта шаблонов печатных форм можно посмотреть в разделе справки "Экспорт/импорт шаблонов и печатных форм"

Описание кнопок тулбара:

Кнопка "Редактировать" переводит справочник в режим редактирования (разрешены исправления, желтый фон таблицы) и обратно в режим запрета редактирования (исправления запрещены, фон таблицы светло-светло-красный).

Кнопка "Удалить шаблон печатной формы" удаляет текущий шаблон из системы.

Кнопка "Добавить новый шаблон" открывает диалог выбора .rtf файла, используемого для создания нового шаблона.

Кнопка "Сохранить" открывает диалог сохранения на диск текущего шаблона в виде .rtf файла.

Кнопка "Открыть в Ворде" сохраняет текущий шаблон на диск в папку attachments, и открывает его в программе MS Word.

Для печатной формы необходимо указать тип шаблона. Тип шаблона определяет из каких форм может быть напечатан документ и какие тэги в нем можно использовать.

Имеются следующие типы шаблона:

  • Пациенты
  • Запись
  • ДМС
  • Возврат товара
  • Шапка документа
  • Пациенты - печать конвертов

Тип шаблона печатной формы "Пациенты"

Документы с данным типом шаблона можно напечатать из формы "Пациенты", "Запись" (если константа "Запись - пользователь может печатать документы которые обычно печатаются из формы Пациенты" из справочника "Константы" имеет значение "Да") и меню "Отчеты" - "Печать документов". В шаблонах могут быть использованы тэги из групп "Общие тэги", "Пациенты" и "Константы".

Тип шаблона печатной формы "Запись"

Документы с данным типом шаблона можно напечатать из формы "Запись" и "Пациенты". В шаблонах могут быть использованы тэги из групп "Общие тэги","Пациенты", "Константы", "Услуги", "Услуги - таблица".

Тип шаблона печатной формы "ДМС"

Документы с данным типом шаблона можно напечатать из формы "Юридические лица". В шаблонах могут быть использованы тэги из групп "Общие тэги", "ДМС", "Услуги - таблица".

Тип шаблона печатной формы "Возврат товара"

Документы с данным типом шаблона можно напечатать из формы "Оплата". В шаблонах могут быть использованы тэги из групп "Общие тэги", "Пациенты", "Константы", "Возврат товара".

Тип шаблона печатной формы "Шапка документа"

Документы с данным типом шаблона можно напечатать из формы "Документы". Обычно в шапке содержится логотип клиники, название клиники и описание текущего документа. При выводе на печать любого врачебного документа программа "сшивает" печатную форму "Шапка", и содержание текущего документа. В шаблонах могут быть использованы тэги из группы "Общие тэги", "Пациенты", "Врачебные документы".

Тип шаблона печатной формы "Пациенты - печать конвертов"

Документы с данным типом шаблона можно напечатать из формы "Пациенты". В шаблонах могут быть использованы тэги из групп "Общие тэги", "Пациенты" и "Константы". Программа предложит выбрать пациентов, для которых будет сформирован итоговый документ, созданный на основании шаблона. Действие аналогично "слиянию" данных в MS Office.

Имеющиеся тэги подробно описаны в разделе справки "Администрирование" - "Печать документов" - "Список тэгов".

Если в тексте шаблона имеется тэг, а соответствующее ему значение из базы данных не заполнено, то:

Если для шаблона поставлена галочка в поле "Заменять пустые поля подчеркиваниями", то вместо тэга в сформированный документ подставится "______". В противном случае, последовательность символов тэга просто не будет отображаться в документе.

Значение в поле "Число экземпляров по умолчанию" определяет количество копий по умолчанию при печати документа, созданного на основе шаблона.

При создании документа на основе шаблона печатной формы в зависимости от значения в поле "Действие" документ может быть открыт для предварительного просмотра, направлен на печать или открыт в Ворде. Если оставить поле пустым, то действие будет определяться константой пользователя "Пациенты - При нажатии на "Печать": 1=Предпросмотр, 2=Печать, 3=Открыть в Ворде".


АДМИНИСТРИРОВАНИЕ

Список тэгов, используемых при печати

В данном разделе справки перечислены тэги (последовательности символов), которые можно использовать в шаблонах документов.

При формировании документа на основе шаблона тэги в документе заменяются на текст полученный на основе значений в базе данных. Например, PatFIO будет заменено на ФИО текущего пациента. В большинстве случаев, если тэг найден, а значение для него не определено, он будет заменен на строку "________". При печати документа, созданного на основе шаблона печатной формы, замена зависит от поля "Заменять пустые поля подчеркиваниями" для текущей печатной формы.

Показать все Скрыть все

Группа тэгов "Общие тэги"

Используется при печати любых документов из форм "Пациенты", "Запись", "ДМС", "Оплата" и врачебных документов из формы "Документы". Для документов, созданных на основе шаблона печатных форм, может быть задан любой тип шаблона.

Показать Скрыть

  • CurDateLong - текстовое описание даты (1 января 2008 г.)
  • CurDateShort - дата в формате день/месяц/год (01.01.2008)
  • CurDocumentTitle - Заголовок документа на основании которого создается консультативное заключение
  • CurTemplateN - Номер последнего напечатанного документа. При каждом выводе на печать/предпросмотр увеличивается на 1.
  • CurTime - текущее время
  • CurUserDoverennost - Доверенность текущего пользователя
  • CurUserFIO - Фамилия, имя, отчество текущего пользователя
  • CurUserFullFIO - Полное ФИО текущего пользователя
  • CurUserLogin - логин текущего пользователя
  • CurYear - текущий год

Группа тэгов "Константы"

Используется при печати любых документов из форм "Пациенты", "Запись", "ДМС", "Настройка отчета Страховые компании", "Оплата" и врачебных документов из формы "Документы". Для документов, созданных на основе шаблона печатных форм, может быть задан любой тип шаблона.

В справочнике "Константы" пользователь может добавить константы с номерами от 501 до 600. При формировании документа в тексте шаблона ищется последовательность символов, с которой начинается название константы (до первого пробела). При нахождении она заменяется на строку из колонки "Значение" или на "________" в зависимости от значения поля "Заменять пустые поля подчеркиваниями" выбранного шаблона. Название тэга не должно быть составной частью другого тэга. В противном случае возможна неправильная замена в тексте документа. Более полную информацию можно посмотреть в разделе справки "Константы клиники".

Показать Скрыть

В текущей версии программы определены следующие тэги этой группы:

  • ConstBank - банк
  • ConstBFIO - Фамилия, имя, отчество главного бухгалтера / второго сотрудника, подписывающее договоры
  • ConstBIK - БИК
  • ConstCity - город
  • ConstDFIO - Фамилия, имя, отчество сотрудника, подписывающее договоры
  • ConstDPosition - должность сотрудника, подписывающего договоры
  • ConstEmail - Email
  • ConstFaktAdr - фактический адрес
  • ConstFirmPhones - телефоны фирмы
  • ConstFullName - полное название фирмы
  • ConstINN - ИНН
  • ConstJurAdr - юридический адрес
  • ConstKPP - КПП
  • ConstKS - корр. счет
  • ConstLic - номер лицензии
  • ConstLiDate - дата лицензии
  • ConstLiDateTill - дата окончания лицензии
  • ConstName - название фирмы
  • ConstOGRN - ОГРН
  • ConstOKPO - ОКПО
  • ConstPict1 - используется для вставки рисунка в документ (указывается путь к графическому файлу)
  • ConstPict2 - используется для вставки рисунка в документ (указывается путь к графическому файлу)
  • ConstPict3 - используется для вставки рисунка в документ (указывается путь к графическому файлу)
  • ConstRodDFIO - Фамилия, имя, отчество сотрудника, подписывающее договоры в родительном падеже
  • ConstRodDPosition - должность сотрудника, подписывающего договоры в родительном падеже
  • ConstRS - расчетный счет
  • ConstSecondLic - номер второй лицензии

Пользователю разрешено изменять названия, добавлять и удалять тэги этой группы, при редактировании справочника "Константы".

Группа тэгов "Пациенты"

Используется при печати документов, созданных на основе шаблонов печатных форм, из форм "Пациенты", "Запись", "Оплата" и врачебных документов из формы "Документы". Для документов, созданных на основе шаблона печатных форм, должен быть задан тип шаблона "Пациенты", "Запись", "Возврат товара" или "Шапка документа".

Показать Скрыть

  • PatAddr - адресные данные пациента
  • PatAddrIndex - индекс адреса текущего пациента
  • PatAddrDom - номер дома текущего пациента
  • PatAddrKwart - номер квартиры текущего пациента
  • PatFIASRegion - регион текущего пациента
  • PatFIASCity - город текущего пациента
  • PatFIASStreet - улица текущего пациента
  • PatAdvert - рекламный канал
  • PatAllergy – информация об аллергиях пациента
  • PatAllServicesSumN - сумма всех услуг, оказанных пациенту
  • PatAllServicesSumS - сумма прописью всех услуг, оказанных пациенту
  • PatBirthday - дата рождения пациента
  • PatBirthPlace - место рождения пациента
  • PatBirthTime - время рождения пациента
  • PatFullYears - число полных лет пациента
  • PatYM - выводит кол-во полных лет, а для пациентов до года - кол-во месяцев, с округлением. Возраст до Х полных месяцев + 15 дней отображается как "Х мес.", начиная с Х полных месяцев + 16 дней отображается как "Х+1 мес."
  • PatCardD - дата медицинской карты пациента
  • PatCardN - номер медицинской карты пациента
  • PatCardD2 - дата медицинской карты ОМС пациента
  • PatCardN2 - номер медицинской карты ОМС пациента
  • PatCardDSN - номер медицинской карты диспансеризации пациента
  • PatCardDSD - дата медицинской карты диспансеризации пациента
  • PatComments - комментарий в карточке пациента
  • PatCustomerAddress - адрес заказчика
  • PatCustomerName - заказчик
  • PatCustomerPassport - паспорт заказчика
  • PatCustomerPhone - телефон заказчика
  • PatDat - Фамилия, имя, отчество текущего пациента в дательном падеже
  • PatDebet - дебетовая сумма по клиенту
  • PatDebetToWords - дебетовая сумма по клиенту прописью
  • PatDebetToWordsUA - дебетовая сумма по клиенту прописью на укр.
  • PatDiagnoz - информация о диагнозе пациента
  • PatExtraDiagnoz - информация о дополнительном диагнозе пациента
  • PatAssocDiagnoz - информация о сопутствующем диагнозе пациента
  • PatDiscCardN - номер дисконтной карты
  • PatDiscCardSum - скидка по дисконтной карте
  • PatDisease – информация о заболеваниях пациента
  • PatDMS - страховая фирма пациента
  • PatDoctorFIO - Фамилия, имя, отчество лечащего врача пациента
  • PatDogD - дата договора пациента
  • PatDogI - часть номера договора пациента (без учета года)
  • PatDogN - номер договора пациента
  • PatEmail - e-mail пациента
  • PatExtVIP - статус vip-клиента (используется если VIP-статус имеет градации)
  • PatFam - фамилия пациента
  • PatFamIO - фамилия, имя отчество пациента (сокращенное написание)
  • PatFIO - Фамилия, имя, отчество текущего пациента
  • PatFirstServiceDate - дата первой услуги, оказанной пациенту
  • PatGrKrovi - группа крови пациента
  • PatI - имя пациента
  • PatID - идентификационный номер пациента
  • PatInn - ИНН пациента
  • PatLastServiceDate - дата последней услуги, оказанной пациенту
  • PatLechenie - выполненное лечение
  • PatLegalFIO - Фамилия, имя, отчество родителя пациента, а при его отсутствии ФИО пациента
  • PatLimit - лимит оплаты пациента в страховой компании
  • PatO - отчество пациента
  • PatOMS - страховая фирма пациента
  • PatOMSLimit - лимит оплаты пациента в страховой компании
  • PatOMSPoliceDOne - дата начала действия полиса пациента
  • PatOMSPoliceDTwo - дата окончания действия полиса пациента
  • PatOMSPoliceN - номер полиса пациента
  • PatParFIO - Фамилия, имя, отчество родителя пациента
  • PatPassport - паспортные данные пациента
  • PatPassportChild - паспорт ребенка
  • PatPasspVidan - место и дата выдачи паспорта пациента
  • PatPeriodBegin - дата начала периода оказания услуг
  • PatPeriodEnd - дата окончания периода оказания услуг
  • PatPeriodEnd - дата окончания периода оказания услуг
  • PatPh1 - дополнительный телефон пациента
  • PatPh2 - дополнительный телефон пациента
  • PatPh3 - дополнительный телефон пациента
  • PatPhone - телефон пациента
  • PatPol - пол пациента ("М"/"Ж")
  • PatPoliceDOne - дата начала действия полиса пациента
  • PatPoliceDTwo - дата окончания действия полиса пациента
  • PatPoliceN - номер полиса пациента
  • PatProfession - профессия пациента
  • PatRegion - регион пациента
  • PatRegistrAddr - адрес регистрации пациента
  • PatRegistrRegion - регион регистрации пациента
  • PatRod - Фамилия, имя, отчество текущего пациента в родительном падеже
  • PatServicesSumInPeriodN - сумма всех услуг, оказанных пациенту за период
  • PatServicesSumInPeriodS - сумма прописью всех услуг, оказанных пациенту за период
  • PatSNILS - СНИЛС пациента
  • PatVIP - является ли пациент vip-клиентом ("VIP" или не указывается)
  • PatWorkAt - место работы пациента
  • PatFld1Id - идентификатор первого дополнительного свойства (выпадающий список). Всего свойств 5
  • PatFld1Name - текстовое значение первого дополнительного свойства (выпадающий список). Всего свойств 5
  • PatFld6 - текстовое значение шестого дополнительного свойства (простое тектовое поле). Всего свойств от 6 до 10
  • PatFld1Caption - название любого дополнительного свойства. Всего свойств 10
  • PatNum1 - дополнительный номер в карточке пациента. Всего свойств 3
  • PatNum1Caption - название дополнительного номера. Всего свойств 3

Тэги "PatPeriodBegin","PatPeriodEnd","PatServicesSumInPeriodN","PatServicesSumInPeriodS" используются только для шаблонов печатных форм, название которых содержит фразу "Справка для налоговой". Для таких шаблонов программа запрашивает у пользователя период, и при наличии в печатной форме соответствующих тэгов производит подстановку значений за выбранный пользователем период. В других печатных формах перечисленные тэги не используются.

Если для текущего пациента заполнено поле "Плательщик", то становятся доступны следующие тэги:

Показать Скрыть

  • PatPlatAddr - адресные данные плательщика
  • PatPlatAddrIndex - индекс адреса плательщика
  • PatPlatAddrDom - номер дома плательщика
  • PatPlatAddrKwart - номер квартиры плательщика
  • PatPlatFIASRegion - регион текущего плательщика
  • PatPlatFIASCity - город текущего плательщика
  • PatPlatFIASStreet - улица текущего плательщика
  • PatPlatAdvert - рекламный канал
  • PatPlatAllergy – информация об аллергиях плательщика
  • PatPlatAllServicesSumN - сумма всех услуг, оказанных плательщику
  • PatPlatAllServicesSumS - сумма прописью всех услуг, оказанных плательщику
  • PatPlatBirthday - дата рождения плательщика
  • PatPlatBirthPlace - место рождения плательщика
  • PatPlatBirthTime - время рождения плательщика
  • PatPlatCardD - дата медицинской карты плательщика
  • PatPlatCardN - номер медицинской карты плательщика
  • PatPlatCardDSN - номер медицинской карты диспансеризации плательщика
  • PatPlatCardDSD - дата медицинской карты диспансеризации плательщика
  • PatPlatComments - комментарий в карточке плательщика
  • PatPlatCustomerAddress - адрес заказчика плательщика
  • PatPlatCustomerName - заказчик плательщика
  • PatPlatCustomerPassport - паспорт заказчика плательщика
  • PatPlatCustomerPhone - телефон заказчика плательщика
  • PatPlatDat - Фамилия, имя, отчество плательщика в дательном падеже
  • PatPlatDebet - дебетовая сумма плательщика
  • PatPlatDebetToWords - дебетовая сумма плательщика прописью
  • PatPlatDebetToWordsUA - дебетовая сумма плательщика прописью на укр.
  • PatPlatDiagnoz - информация о диагнозе плательщика
  • PatExtraDiagnoz - информация о дополнительном диагнозе плательщика
  • PatAssocDiagnoz - информация о сопутствующем диагнозе плательщика
  • PatPlatDiscCardN - номер дисконтной карты
  • PatPlatDisease – информация о заболеваниях плательщика
  • PatPlatDMS - страховая фирма плательщика
  • PatPlatDoctorFIO - Фамилия, имя, отчество лечащего врача плательщика
  • PatPlatDogD - дата договора плательщика
  • PatPlatDogI - часть номера договора плательщика (без учета года)
  • PatPlatDogN - номер договора плательщика
  • PatPlatEmail - e-mail плательщика
  • PatPlatExtVIP - статус vip-клиента для плательщика (используется если VIP-статус имеет градации)
  • PatPlatFam - фамилия плательщика
  • PatPlatFamIO - фамилия, имя отчество пациента (сокращенное написание)
  • PatPlatFIO - Фамилия, имя, отчество плательщика
  • PatPlatFirstServiceDate - дата первой услуги, оказанной плательщику
  • PatPlatFullYears - число полных лет плательщика
  • PatPlatGrKrovi - группа крови плательщика
  • PatPlatI - имя плательщика
  • PatPlatID - идентификационный номер плательщика
  • PatPlatInn - ИНН плательщика
  • PatPlatLastServiceDate - дата последней услуги, оказанной плательщику
  • PatPlatLechenie - выполненное лечение
  • PatPlatLegalFIO - Фамилия, имя, отчество родителя плательщика, а при его отсутствии ФИО пациента
  • PatPlatLimit - лимит оплаты плательщика в страховой компании
  • PatPlatO - отчество плательщика
  • PatPlatOMS - страховая фирма плательщика
  • PatPlatOMSLimit - лимит оплаты плательщика в страховой компании
  • PatPlatOMSPoliceDOne - дата начала действия полиса плательщика
  • PatPlatOMSPoliceDTwo - дата окончания действия полиса плательщика
  • PatPlatOMSPoliceN - номер полиса плательщика
  • PatPlatParFIO - Фамилия, имя, отчество родителя плательщика
  • PatPlatPassport - паспортные данные плательщика
  • PatPlatPassportChild - паспорт ребенка плательщика
  • PatPlatPasspVidan - место и дата выдачи паспорта плательщика
  • PatPlatPeriodBegin - дата начала периода оказания услуг
  • PatPlatPeriodEnd - дата окончания периода оказания услуг
  • PatPlatPeriodEnd - дата окончания периода оказания услуг
  • PatPlatPh1 - дополнительный телефон плательщика
  • PatPlatPh2 - дополнительный телефон плательщика
  • PatPlatPh3 - дополнительный телефон плательщика
  • PatPlatPhone - телефон плательщика
  • PatPlatPol - пол плательщика ("М"/"Ж")
  • PatPlatPoliceDOne - дата начала действия полиса плательщика
  • PatPlatPoliceDTwo - дата окончания действия полиса плательщика
  • PatPlatPoliceN - номер полиса плательщика
  • PatPlatProfession - профессия плательщика
  • PatPlatRegion - регион плательщика
  • PatPlatRegistrAddr - адрес регистрации плательщика
  • PatPlatRegistrRegion - регион регистрации плательщика
  • PatPlatRod - Фамилия, имя, отчество плательщика в родительном падеже
  • PatPlatServicesSumInPeriodN - сумма всех услуг, оказанных плательщику за период
  • PatPlatServicesSumInPeriodS - сумма прописью всех услуг, оказанных плательщику за период
  • PatPlatSNILS - СНИЛС плательщика
  • PatPlatVIP - является ли плательщик vip-клиентом ("VIP" или не указывается)
  • PatPlatWorkAt - место работы плательщика
  • PatPlatFld1Id - идентификатор первого дополнительного свойства (выпадающий список) плательщика. Всего свойств 5
  • PatPlatFld1Name - текстовое значение первого дополнительного свойства (выпадающий список) плательщика. Всего свойств 5
  • PatPlatFld6 - текстовое значение шестого дополнительного свойства (простое тектовое поле) плательщика. Всего свойств от 6 до 10
  • PatPlatNum1 - дополнительный номер в карточке плательщика. Всего свойств 3

Если для текущего пациента заполнено поле "Глава семьи", то становятся доступны следующие тэги:

Показать Скрыть

  • PatParentAddr - адресные данные главы семьи
  • PatParentAddrIndex - индекс адреса главы семьи
  • PatParentAddrDom - номер дома главы семьи
  • PatParentAddrKwart - номер квартиры главы семьи
  • PatParentFIASRegion - регион текущего главы семьи
  • PatParentFIASCity - город текущего главы семьи
  • PatParentFIASStreet - улица текущего главы семьи
  • PatParentAdvert - рекламный канал
  • PatParentAllergy – информация об аллергиях главы семьи
  • PatParentAllServicesSumN - сумма всех услуг, оказанных плательщику
  • PatParentAllServicesSumS - сумма прописью всех услуг, оказанных плательщику
  • PatParentBirthday - дата рождения главы семьи
  • PatParentBirthPlace - место рождения главы семьи
  • PatParentBirthTime - время рождения главы семьи
  • PatParentCardD - дата медицинской карты главы семьи
  • PatParentCardN - номер медицинской карты главы семьи
  • PatParentCardDSN - номер медицинской карты диспансеризации главы семьи
  • PatParentCardDSD - дата медицинской карты диспансеризации главы семьи
  • PatParentComments - комментарий в карточке главы семьи
  • PatParentCustomerAddress - адрес заказчика у главы семьи
  • PatParentCustomerName - заказчик у главы семьи
  • PatParentCustomerPassport - паспорт заказчика у главы семьи
  • PatParentCustomerPhone - телефон заказчика у главы семьи
  • PatParentDat - Фамилия, имя, отчество главы семьи в дательном падеже
  • PatParentDebet - дебетовая сумма главы семьи
  • PatParentDebetToWords - дебетовая сумма главы семьи прописью
  • PatParentDebetToWordsUA - дебетовая сумма главы семьи прописью на укр.
  • PatParentDiagnoz - информация о диагнозе главы семьи
  • PatExtraDiagnoz - информация о дополнительном диагнозе главы семьи
  • PatAssocDiagnoz - информация о сопутствующем диагнозе главы семьи
  • PatParentDiscCardN - номер дисконтной карты
  • PatParentDisease – информация о заболеваниях главы семьи
  • PatParentDMS - страховая фирма главы семьи
  • PatParentDoctorFIO - Фамилия, имя, отчество лечащего врача главы семьи
  • PatParentDogD - дата договора главы семьи
  • PatParentDogI - часть номера договора главы семьи (без учета года)
  • PatParentDogN - номер договора главы семьи
  • PatParentEmail - e-mail главы семьи
  • PatParentExtVIP - статус vip-клиента для главы семьи (используется если VIP-статус имеет градации)
  • PatParentFam - фамилия главы семьи
  • PatParentFamIO - фамилия, имя отчество пациента (сокращенное написание)
  • PatParentFIO - Фамилия, имя, отчество главы семьи
  • PatParentFirstServiceDate - дата первой услуги, оказанной плательщику
  • PatParentFullYears - число полных лет главы семьи
  • PatParentGrKrovi - группа крови главы семьи
  • PatParentI - имя главы семьи
  • PatParentID - идентификационный номер главы семьи
  • PatParentInn - ИНН главы семьи
  • PatParentLastServiceDate - дата последней услуги, оказанной плательщику
  • PatParentLechenie - выполненное лечение
  • PatParentLegalFIO - Фамилия, имя, отчество родителя главы семьи, а при его отсутствии ФИО пациента
  • PatParentLimit - лимит оплаты главы семьи в страховой компании
  • PatParentO - отчество главы семьи
  • PatParentOMS - страховая фирма главы семьи
  • PatParentOMSLimit - лимит оплаты главы семьи в страховой компании
  • PatParentOMSPoliceDOne - дата начала действия полиса главы семьи
  • PatParentOMSPoliceDTwo - дата окончания действия полиса главы семьи
  • PatParentOMSPoliceN - номер полиса главы семьи
  • PatParentParFIO - Фамилия, имя, отчество родителя главы семьи
  • PatParentPassport - паспортные данные главы семьи
  • PatParentPassportChild - паспорт ребенка главы семьи
  • PatParentPasspVidan - место и дата выдачи паспорта главы семьи
  • PatParentPeriodBegin - дата начала периода оказания услуг
  • PatParentPeriodEnd - дата окончания периода оказания услуг
  • PatParentPeriodEnd - дата окончания периода оказания услуг
  • PatParentPh1 - дополнительный телефон главы семьи
  • PatParentPh2 - дополнительный телефон главы семьи
  • PatParentPh3 - дополнительный телефон главы семьи
  • PatParentPhone - телефон главы семьи
  • PatParentPol - пол главы семьи ("М"/"Ж")
  • PatParentPoliceDOne - дата начала действия полиса главы семьи
  • PatParentPoliceDTwo - дата окончания действия полиса главы семьи
  • PatParentPoliceN - номер полиса главы семьи
  • PatParentProfession - профессия главы семьи
  • PatParentRegion - регион главы семьи
  • PatParentRegistrAddr - адрес регистрации главы семьи
  • PatParentRegistrRegion - регион регистрации главы семьи
  • PatParentRod - Фамилия, имя, отчество главы семьи в родительном падеже
  • PatParentServicesSumInPeriodN - сумма всех услуг, оказанных плательщику за период
  • PatParentServicesSumInPeriodS - сумма прописью всех услуг, оказанных плательщику за период
  • PatParentSNILS - СНИЛС главы семьи
  • PatParentVIP - является ли глава семьи vip-клиентом ("VIP" или не указывается)
  • PatParentWorkAt - место работы главы семьи
  • PatParentFld1Id - идентификатор первого дополнительного свойства (выпадающий список) главы семьи. Всего свойств 5
  • PatParentFld1Name - текстовое значение первого дополнительного свойства (выпадающий список) главы семьи. Всего свойств 5
  • PatParentFld6 - текстовое значение шестого дополнительного свойства (простое тектовое поле) главы семьи. Всего свойств от 6 до 10
  • PatParentNum1 - дополнительный номер в карточке главы семьи. Всего свойств 3

Таким образом, для пациента в название тэга подставляется префикс 'Pat', для плательщика - 'PatPlat', для главы семьи - 'PatParent'.

Группа тэгов "Госпитализация"

Используется при печати документов, созданных на основе шаблонов печатных форм, из формы "Пациенты". Для документов, созданных на основе шаблона печатных форм, должен быть задан тип шаблона "Пациенты". При выборе документа из выпадающего списка печати в форме "Пациенты" нижеперечисленные тэги заменятся на данные текущей госпитализации.

Показать Скрыть

  • HospAdmit - решение по госпитализации
  • HospArchivDate - дата сдачи в архив
  • HospCanwork - трудоспособность
  • HospChamberNum - палата
  • HospCommDate - дата комиссии
  • HospCommNum - номер комиссии
  • HospDenialDescr - причина отказа
  • HospDep - отделение
  • HospDms - страховая компания
  • HospDoctor - лечащий врач текущей госпитализации
  • HospEffect - эффективность лечения
  • HospFinalMkb - диагноз при выписке (код и расшифровка)
  • HospFinalMkbCode - диагноз при выписке (код)
  • HospFinalMkbName - диагноз при выписке (расшифровка)
  • HospFirstDenial - первичный или повторный отказ
  • HospIncDate - фактическая дата
  • HospIncHour - фактическое время (часы)
  • HospIncMin - фактическое время (минуты)
  • HospIncMkb - диагноз при поступлении (код и расшифровка)
  • HospIncMkbCode - диагноз при поступлении (код)
  • HospIncMkbName - диагноз при поступлении (расшифровка)
  • HospIncTime - фактическое время
  • HospInvalidSom - инвалидность сом.
  • HospLeave - вид выбытия
  • HospLeaveDate - дата выбытия
  • HospLeaveDescr - описание выбытия
  • HospNum - номер госпитализации
  • HospOrderDate - дата направления
  • HospOrderNum - номер направления
  • HospPayType - вид оплаты
  • HospPlanDate - плановая дата
  • HospPoliceDate - полис (дата)
  • HospPoliceNum - полис (номер)
  • HospPoliceSer - полис (серия)
  • HospRecomendation - рекомендации
  • HospReferer - кем направлен
  • HospRepeat - повторность
  • HospType - тип койки

Группа тэгов "Визит"

Используется при печати документов, созданных на основе шаблонов печатных форм, из форм "Пациенты" (сабформы "Визиты" и "Услуги") и "Запись". Для таких документов должен быть задан тип шаблона "Запись".

В зависимости от константы 126 "Визит - Нумерация договоров: Да=при печати, Нет=номер договора совпадает с номером медкарты" список услуг (ServiceList) формируется как список услуг визитов, входящих в договор (все визиты пациента на выбранную дату с типом оплаты "Наличные" или как список услуг текущего визита.

При печати из сабформы "Услуги" формы "Пациенты" услуга, для которой применяются тэги, определена, в других случаях услуга определяется как первая услуга из списка ServiceList.

Визит определяется как визит этой услуги. Исключения составляют тэги "VisitSumN", "VisitSumS", "VisitList", "VisitListNoSum", "VisitListWithCode", "VisitListWithCodeNoSum", "VisitListOnlyCode", "VisitListOnlyCodeNoSum" применяемые для выбранного визита (или визита выбранной услуги), независимо от списка ServiceList.

Показать Скрыть

  • PayDaySumN - сумма всех оплат за день
  • PayDaySumS - сумма всех оплат за день прописью
  • ServiceArticleCode - код артикула услуги
  • ServiceArticleGroup - группа прайса артикула услуги
  • ServiceArticleName - название артикула услуги
  • ServiceArticleNameShort - краткое название артикула услуги
  • ServiceArticleExecDuration - срок исполнения услуги
  • ServiceAssistant - ассистент
  • ServiceChangeDoctor - последний сотрудник, изменявший запись об услуге
  • ServiceChangeTime - время последнего изменения записи об услуге
  • ServiceComments - коменнтарий к услуге
  • ServiceCost - стоимость одной единицы услуги
  • ServiceCreateDoctor - сотрудник создавший запись об услуге
  • ServiceCreateTime - время создания записи об услуге
  • ServiceCWD - сумма услуги (с учетом скидки)
  • ServiceDate - дата визита
  • ServiceDaySumN - сумма всех услуг за день
  • ServiceDaySumS - сумма всех услуг за день прописью
  • ServiceDebtInfo - Долг/Предоплата у пациента. Результатом работы является строка: - Услуг к оплате: *** руб., оплачено: ** руб., общий долг (или общая предоплата) по пациенту: * руб. -
  • ServiceDiscountN - скидка услуги в процентах или рублях (автоматический выбор)
  • ServiceDiscountName - название скидки услуги
  • ServiceDiscountProcent - скидка услуги в процентах
  • ServiceDiscountRub - скидка услуги в рублях
  • ServiceDiscountS - скидка услуги в процентах или рублях (автоматический выбор), дополнительно указывается единица (% или руб.)
  • ServiceDispetcher - диспетчер
  • ServiceDoctor - врач, оказывающий услугу
  • ServiceDoctorCategory - категория врача, оказывающего услугу
  • ServiceDoctor2 - врач 2, оказывающий услугу
  • ServiceDoctor3 - врач 3, оказывающий услугу
  • ServiceDogovorN - номер договора (документа) визита
  • ServiceDuration - длительность визита
  • ServiceFirstTime - является ли визит первичным или повторным ("Первичный визит"/"Повторный визит")
  • ServiceHome - оказывается ли услуга на дому ("да"/"нет")
  • ServiceHour - час визита (определяется временем визита)
  • ServiceKassaCheckN - номер кассового чека (в случае, если при формировании реестра в форме "Оплата" для визита был напечатан чек)
  • ServiceKassaDocN - номер кассового документа (в случае, если при формировании реестра в форме "Оплата" для визита был напечатан чек)
  • ServiceList - список услуг, оказанных пациенту, разделенных переводом строки, в формате "Название услуги, стоимость с учетом скидки"
  • ServiceListNoSum - список услуг, оказанных пациенту, разделенных запятой
  • ServiceListOnlyCode - список услуг, оказанных пациенту, разделенных переводом строки, в формате "Код услуги, стоимость с учетом скидки"
  • ServiceListOnlyCodeNoSum - список кодов услуг, оказанных пациенту, разделенных запятой
  • ServiceListWithCode - список услуг, оказанных пациенту, разделенных переводом строки, в формате "Код услуги, название услуги, стоимость с учетом скидки"
  • ServiceListWithCodeNoSum - список услуг, оказанных пациенту, разделенных запятой, в формате "Код услуги, название услуги"
  • ServiceMBD - дата возврата денег (в случае, если услуги визита были сторнированы в форме "Оплата")
  • ServiceMins - минуты визита (определяются временем визита)
  • ServiceMkbCode - код болезни из справочника МКБ
  • ServiceMkbName - название болезни из справочника МКБ
  • ServiceNumber - количество услуг, входящих в список ServiceList
  • ServicePayType - тип оплаты для услуг визита
  • ServicePriceName - прайс для услуг визита
  • ServicePrimeCost - себестоимость услуги
  • ServiceQuantity - количество оказанных единиц услуги
  • ServiceRoomFloor - этаж на котором находится кабинет врача
  • ServiceRoomN - кабинет, в котором принимает врач
  • ServiceStatus - статус визита
  • ServiceSumN - сумма всех услуг из списка ServiceList
  • ServiceSumS - сумма прописью всех услуг из списка ServiceList
  • ServiceSupplier - поставщик
  • ServiceTime - время визита (время оказания услуги)
  • ServiceTooth - номер зуба (только для стоматологических клиник)
  • ServiceTreatmentD1 - дата начала курса лечения, в который входит услуга
  • ServiceTreatmentD2 - дата окончания курса лечения, в который входит услуга
  • ServiceTreatmentName - курс лечения, в который входит услуга
  • SrvAssist - ассистент
  • SrvDate - дата визита
  • SrvDateTime - дата и время визита (01.01.2009 12:00)
  • SrvDisp - диспетчер
  • SrvDoctor - врач, оказывающий услугу
  • SrvDoctorCategory - категория врача, оказывающего услугу
  • SrvDoctorProf - специализация врача, оказывающего услугу
  • SrvDoctor2 - врач 2, оказывающий услугу
  • SrvDoctor3 - врач 3, оказывающий услугу
  • SrvDogN - номер договора (документа) визита
  • SrvDur - длительность визита
  • SrvHome - оказывается ли услуга на дому
  • SrvHour - час визита (определяется временем визита)
  • SrvMins - минуты визита (определяются временем визита)
  • SrvPayType - тип оплаты для услуг визита
  • SrvPriceName - прайс для услуг визита
  • SrvRoomFloor - этаж на котором находится кабинет врача
  • SrvRoomN - кабинет, в котором принимает врач
  • SrvStatus - статус визита
  • VisitChangeDoctor - последний сотрудник, изменявший запись о визите
  • VisitChangeTime - время последнего изменения записи о визите
  • VisitCostN - сумма всех услуг визита без учета скидки
  • VisitCreateDoctor - сотрудник создавший запись о визите
  • VisitCreateTime - время создания записи о визите
  • VisitCWD - общая сумма услуг по визиту (с учетом скидки)
  • VisitDiagnos - Если в системе есть врачебный документ(документы), день которого совпадает с датой визита, врач совпадает с врачом визита, и в этом документе указан диагноз (абзац начинающийся со слова "Диагноз:"), то для вывода на печать этого диагноза (диагнозов) можно использовать тэг VisitDiagnos
  • VisitDiscountN - скидка визита в процентах или рублях (автоматический выбор)
  • VisitDiscountName - название скидки текущего визита
  • VisitDiscountProcent - скидка визита в процентах
  • VisitDiscountRub - скидка визита в рублях
  • VisitDiscountS - скидка визита в процентах или рублях (автоматический выбор), дополнительно указывается единица (% или руб.)
  • VisitDiscountValN - сумма скидки визита
  • VisitDiscountValS - сумма прописью скидки визита
  • VisitDMS - страховая фирма, указанная в визите
  • VisitLastEditedBy - последний сотрудник, создавший или изменявший запись о визите
  • VisitList - список услуг визита, разделенных переводом строки, в формате "Название услуги, стоимость с учетом скидки"
  • VisitListNoSum - список услуг визита, разделенных зяпятой
  • VisitListOnlyCode - список услуг визита, разделенных переводом строки, в формате "Код услуги, стоимость с учетом скидки"
  • VisitListOnlyCodeNoSum - список кодов услуг визита, разделенных запятой
  • VisitListWithCode - список услуг визита, разделенных переводом строки, в формате "Код услуги, название услуги, стоимость с учетом скидки"
  • VisitListWithCodeNoSum - список услуг визита, разделенных запятой, в формате "Код услуги, название услуги"
  • VisitN - идентификационный номер визита
  • VisitNumber - количество услуг из списка ServiceList, относящихся к текущему визиту
  • VisitOrdNum - номер визита
  • VisitPoliceDOne - дата начала действия полиса страховой фирмы, указанной в визите
  • VisitPoliceDTwo - дата окончания действия полиса страховой фирмы, указанной в визите
  • VisitPoliceN - номер полиса страховой фирмы, указанной в визите
  • VisitSumN - сумма всех услуг визита (отличается от VisitCWD способом определения визита)
  • VisitSumPaymN - сумма платежей клиента по визиту за вычетом оплат с типом "списано со счета" (для новой налоговой справки)
  • VisitSumPaymS - сумма прописью платежей клиента по визиту за вычетом оплат с типом "списано со счета" (для новой налоговой справки)
  • VisitSumS - сумма прописью всех услуг визита
  • VisitSumS - сумма прописью всех услуг визита без учета скидки
  • VisitSumWithoutPBN - сумма (за вычетом сторно) всех услуг визита (отличается от VisitCWD способом определения визита)
  • VisitSumWithoutPBS - сумма (за вычетом сторно) прописью всех услуг визита

Группа тэгов "Услуги - таблица"

Используется при печати документов, созданных на основе шаблонов печатных форм, из форм "Пациенты" (сабформы "Визиты" и "Услуги"), "Запись", "ДМС", "Настройка отчета Страховые компании". Для таких документов должен быть задан тип шаблона "Запись" или "ДМС".

Следующие тэги должны находиться в ячейках таблицы в шаблоне документа. В этом случае при наличии нескольких оказанных услуг в таблицу будет добавлено соответствующее количество строчек с данными о каждой услуге.

Показать Скрыть

  • SrvArticle - название артикула услуги (*)
  • SrvArticleShort - краткое название артикула услуги (*)
  • SrvArticleComment - комментарий к услуге
  • SrvArticleExecDuration - срок исполнения услуги
  • SrvCode - код артикула услуги (*)
  • SrvComments - комментарий к услуге (*)
  • SrvCost - стоимость одной единицы услуги
  • SrvCQ - сумма услуги (без учета скидки, SrvQ * SrvCost) (*)
  • SrvCWD - стоимость одной единицы услуги с учетом скидки (*)
  • SrvDiscN - скидка услуги в процентах или рублях (автоматический выбор) (*)
  • SrvDiscName - название скидки для услуги
  • SrvDiscProcent - скидка услуги в процентах (*)
  • SrvDiscRub - скидка услуги в рублях (*)
  • SrvDiscInRub - скидка услуги, пересчитанная в рублевом выражении (*)
  • SrvDiscS - скидка услуги в процентах или рублях (автоматический выбор), дополнительно указывается единица (% или руб.) (*)
  • SrvCmpVal - коэффициент сложности
  • SrvCmpName - название коэффициента сложности
  • SrvGroup - группа прайса артикула услуги
  • SrvLineN - номер услуги по порядку (*)
  • SrvMkbCode - код болезни из справочника МКБ (*)
  • SrvMkbName - название болезни из справочника МКБ (*)
  • SrvPrimeCost - себестоимость услуги
  • SrvQ - количество оказанных единиц услуги (*)
  • SrvSum и SrvPrice - сумма услуги (с учетом скидки) (*)
  • SrvSumL - сумма оставшихся в назначении услуг с учетом скидки (только для назначений)
  • SrvSuppl - поставщик
  • SrvTime - время визита (время оказания услуги)
  • SrvTooth - номер зуба (только для стоматологических клиник) (*)

Тэги, этой группы, помеченные "*", можно использовать при печати шаблона печатной формы из сабформы "Назначения" формы "Визит".

Кроме того, допускается использование большинства тэгов группы "Переводы", за исключением тэгов "TransferSumInS", "TransferSumOutS", "ServiceTransferSumN", "ServiceTransferSumS", "ServiceTransferList", "ServiceTransferListNoSum", "ServiceTransferListWithCode", "ServiceTransferListWithCodeNoSum", "ServiceTransferListOnlyCode", "ServiceTransferListOnlyCodeNoSum" и тэгов SrvPrescrQWill, SrvPrescrQHas группы "Предписания".

Группа тэгов "ДМС"

Используется при печати документов, созданных на основе шаблонов печатных форм, из форм "ДМС", "Настройка отчета Страховые компании" и "Визит - Переводы". Для таких документов должен быть задан тип шаблона "ДМС".

Показать Скрыть

  • DmsAddr - адрес
  • DmsAgrFio - Фамилия, имя, отчество представителя страховой компании
  • DmsBank - банк
  • DmsBik - БИК
  • DmsCanceled - приостановлен или действует договор со страховой компанией
  • DmsDogDate1 - дата начала действия договора
  • DmsDogDate2 - дата окончания действия договора
  • DmsDogN - номер договора
  • DmsInn - ИНН
  • DmsJurName - юридическое название страховой компании
  • DmsKpp - КПП
  • DmsKs - коррсчет
  • DmsLicence - номер лицензии
  • DmsLimit - лимит оплаты для пациентов страховой компании
  • DmsName - название страховой компании
  • DmsOgrn - ОГРН
  • DmsOkpo - ОКПО
  • DmsPhone - телефон
  • DmsPriceName - название прайса
  • DmsRepr - подпись "В лице" (для договоров)
  • DmsRs - расчетный счет
  • SchetDate - дата счета
  • SchetDateFirst - первый день выбранного периода
  • SchetDateLast - последний день выбранного периода
  • SchetMonth - месяц, за который выставлен счет
  • SchetMonthName - название месяца, за который выставлен счет
  • SchetN - номер счета
  • SchetNumber - количество посещений (визитов) пациентов данной страховой компании в выбранном периоде
  • SchetSumN - сумма всех оказанных по счету услуг
  • SchetSumS - сумма прописью всех оказанных по счету услуг
  • SchetYear - год, за который выставлен счет

Группа тэгов "Возврат товара"

Используется при печати документов, созданных на основе шаблонов печатных форм, из формы "Оплата". Для таких документов должен быть задан тип шаблона "Возврат товара".

Показать Скрыть

  • MoneyBackCheckN - номер ранее пробитого чека продажи
  • MoneyBackDate - дата возврата денег
  • MoneyBackSumN - сумма всех услуг, по которым деньги будут возвращены
  • MoneyBackSumS - сумма прописью всех услуг, по которым деньги будут возвращены

Группа тэгов "Врачебные документы"

Используется при печати врачебных документов из формы "Документы". Также в шаблонах врачебных документов можно использовать тэги из разделов "Пациенты", "Общие тэги", "Константы".

Показать Скрыть

  • DocDate - дата документа
  • DocDoctorFIO - ФИО врача документа
  • DocDoctorFullFIO - полное ФИО врача документа. Если полное ФИО у врача не указано, берется краткое
  • DocDoctorProf - профессия врача документа
  • DocName - название документа
  • DocTypeName - тип документа
  • document_descr - описание документа: название документа + дата + ФИО врача + ФИО пациента
  • QR1, QR2, QR3 - при создании документа, в документ вставляется картинка с QR кодом 1/2/3 пользователя, создавшего документ !!! Планируется удаление тэга, использование не рекомендуется !!!
  • QRV1, QRV2, QRV3 - при создании документа, в документ вставляется картинка с QR кодом 1/2/3 врача визита, для услуги которого создается документ !!! Планируется удаление тэга, использование не рекомендуется !!!
  • QRD1, QRD2, QRD3 - при _печати_ документа, тэг заменяется на картинку с QR кодом 1/2/3 врача документа. Рекомендуется использовать именно этот тэг, так как он самый надежный - корректно работает при смене врача документа, и не расходует место на хранение картинок

Группа тэгов "Переводы"

Используется при печати документов из сабформы "Переводы" формы "Пациенты" и "Визит".

Показать Скрыть

  • ServiceTransferList - список услуг, оказанных пациенту, разделенных переводом строки, в формате "Название услуги, стоимость с учетом скидки"
  • ServiceTransferListNoSum - список услуг, оказанных пациенту, разделенных запятой
  • ServiceTransferListOnlyCode - список услуг, оказанных пациенту, разделенных переводом строки, в формате "Код услуги, стоимость с учетом скидки"
  • ServiceTransferListOnlyCodeNoSum - список кодов услуг, оказанных пациенту, разделенных запятой
  • ServiceTransferListWithCode - список услуг, оказанных пациенту, разделенных переводом строки, в формате "Код услуги, название услуги, стоимость с учетом скидки"
  • ServiceTransferListWithCodeNoSum - список услуг, оказанных пациенту, разделенных запятой, в формате "Код услуги, название услуги"
  • ServiceTransferSumN - сумма всех услуг из перевода
  • ServiceTransferSumS - сумма прописью всех услуг из перевода
  • TransferArticleName - услуга перевода
  • TransferArticleNameShort - краткое название услуги перевода
  • TransferComments - комментарий перевода
  • TransferCreateDoctor - ФИО врача, создавшего перевод
  • TransferCreateTime - время создания перевода
  • TransferDate - дата перевода
  • TransferDiscountName - скидка перевода
  • TransferDiscountProc - скидка перевода в процентах
  • TransferDiscountRub - скидка перевода в рублях
  • TransferDms - страховая компания перевода
  • TransferDtDms - дата оплаты страховой компании перевода
  • TransferEyeN - перевод за лечение глаз (левый, правый, оба)
  • TransferMonth - месяц перевода
  • TransferPatientFioIn - ФИО адресата перевода
  • TransferPatientFioOut - ФИО отправителя перевода
  • TransferPayTypeName - тип оплаты перевода
  • TransferSchetN - номер счета (договора) перевода
  • TransferSumInN - сумма перевода, поступившая на счет в рублях
  • TransferSumInS - сумма перевода, поступившая на счет прописью
  • TransferSumOutN - сумма посланного перевода в рублях
  • TransferSumOutS - сумма посланного перевода прописью
  • TransferTypeName - тип перевода
  • TransferUAEyeN - перевод за лечение глаз (лiвому оцi, правому оцi, обох очах) на украинском
  • TransferVisitTime - дата и время визита, для которого был создан перевод
  • TransferYear - год перевода

Группа тэгов "ТМЦ - Приход"

Используется при печати документов из формы "Приход".

Показать Скрыть

  • IncomeAvCost - средняя стоимость материалов
  • IncomeChangeDoctor - последний сотрудник, изменявший запись о приходе
  • IncomeChangeTime - время последнего изменения записи о приходе
  • IncomeCreateDoctor - сотрудник создавший запись о приходе
  • IncomeCreateTime - время создания записи о приходе
  • IncomeDate - дата прихода
  • IncomeDepot - склад ТМЦ
  • IncomeExpDate - срок годности материала
  • IncomeLastEditedBy - последний сотрудник, создавший или изменявший запись о приходе
  • IncomeMatCode - код материала
  • IncomeMaterial - название материала
  • IncomeMatGroup - группа материала
  • IncomePacks - количество упаковок
  • IncomeQInPack - количество материала в упаковке
  • IncomeQuantity - итоговое количество материала
  • IncomeSupplier - поставщик ТМЦ
  • IncomeTotalCost - общая стоимость материалов

Группа тэгов "Назначения"

Используется при печати шаблона печатной формы из сабформы "Назначения" формы "Визит". Название шаблона должно быть указано в константе "Визит - при нажатии на кнопку с принтером в списке назначений печатать Печатную форму". В шаблоне назначений можно использовать тэги группы "Услуги - таблица", помеченные звездочкой.

Показать Скрыть

  • PrescrCostN - сумма всех назначенных услуг без учета скидки
  • PrescrCostS - сумма прописью всех назначенных услуг без учета скидки
  • PrescrDiscountValN - сумма скидки по всем назначенным услугам
  • PrescrDiscountValS - сумма прописью скидки по всем назначенным услугам
  • PrescrSumLN - сумма оставшихся в назначении услуг с учетом скидки
  • PrescrSumLS- сумма прописьюоставшихся в назначении услуг с учетом скидки
  • PrescrSumN - сумма всех назначенных услуг
  • PrescrSumS - сумма прописью всех назначенных услуг
  • PrescrTreatmentName - курс услуг назначений
  • SrvPrescrQHas - количество оказанных услуг (используется в таблице)
  • SrvPrescrQWill - количество назначенных услуг (используется в таблице)

Группа тэгов "Справка для налоговой"

Используется дополнительно при печати только справки пациенту для налоговой за период.

Показать Скрыть

  • NalogCodes - cписок кодов окзанных услуг за период, учитываются только визиты со статусом "пришел"
  • NalogPaymD - cписок дат оплат услуг за период, учитываются только оплаты визитов со статусом "пришел"

Группа тэгов "Квитанции"

Используется при печати шаблона печатной формы из сабформы "Квитанции" формы "Пациент" и из справочника квитанций.

Показать Скрыть

  • KvitDate - дата квитанции
  • KvitNum - номер квитанции
  • KvitSum - сумма числом
  • KvitSumToWords - сумма прописью
  • KvitSumToWordsUA - сумма прописью на укр. языке

Группа тэгов "Пациент - Наряды"

Используется при печати документов из формы "Пациент " закладки "Наряды".

Показать Скрыть

  • OrderComments - описание наряда
  • OrderCurs - курс, в который входит наряд
  • OrderDate - дата наряда
  • OrderDateDone - дата выполнения наряда
  • OrderNumber - номер наряда
  • OrderPrice - прайс наряда
  • OrderStatus - статус наряда
  • OrderSumN - сумма всех услуг
  • OrderSumPrimeN - себестоимость всех услуг
  • OrderSumPrimeToWords - себестоимость прописью всех услуг
  • OrderSumPrimeToWordsUA - себестоимость прописью всех услуг на укр.
  • OrderSumToWords - сумма прописью всех услуг
  • OrderSumToWordsUa - сумма прописью всех услуг на укр.
  • OrderSupplier - поставщик наряда

Для табличных данных списка услуг наряда

Показать Скрыть

  • OrdsArticle - услуга
  • OrdsArticleShort - краткое название услуги
  • OrdsCode - код услуги
  • OrdsCost - стоимость
  • OrdsLineN - номер строки
  • OrdsPrimeCost - себестоимость
  • OrdsQ - количество
  • OrdsSum - сумма
  • OrdsSumPrime - сумма себестоимости
  • OrdsTooth - зубы

Группа тэгов "Профосмотры"

Используется для печати данных о профосмотрах

Показать Скрыть

  • ProfDate - дата осмотра
  • DoctorFIO - врач
  • DoctorFIOFull - полное ФИО врача
  • ProfSum - общая стоимость осмотра
  • ProfSumToWords - общая стоимость осмотра прописью
  • ProfArticles - список пунктов приказа 302
  • ProfType - тип осмотра
  • ProfPatientsCount - количество пациентов
  • ProfPatientsMaleCount - количество мужчин
  • ProfPatientsFemaleCount - количество женщин
  • ProfPatientsChildCount - количество пациентов до 18 лет
  • ProfStatusProfpat - нуждается в обследовании в центре профпаталогии
  • ProfStatusAmb - нуждается в амбулаторном обследовании и лечении
  • ProfStatusStats - нуждается в стационарном обследовании и лечении
  • ProfStatusDisp - нуждается в диспансерном наблюдении
  • ProfStatusFinish - завершил осмотр
  • ProfNotComeName - почему не пришел
  • ProfSanKur - сан. курортное лечение
  • pr_list_of_articles_xls - список вредностей при импорте
  • pr_list_of_articles - список вредностей
  • pr_list_of_services - список услуг, входят как анализы, так и врачи
  • pr_list_of_services_doc - список врачей
  • pr_list_of_services_an - список анализов

При одном выбранном пациенте:

  • PatientAddress - адрес пациента
  • PatientBirthday - дата рождения пациента
  • PatientDepartment - отдел фирмы пациента
  • PatientFIO - ФИО пациента
  • PatientPhone - телефон пациента
  • PatientProf - профессия пациента
  • PatientSex - пол пациента
  • PatientSnils - СНИЛС пациента
  • PatientYears - возраст пациента на текущую дату
  • PatientFirm - фирма пациента
  • PatientFirmShort - фирма пациента (краткое название)
  • PatientFirmPeople - кол-во сотрудников в фирме пациента
  • PatientFirmPeopleWomen - кол-во женщин в фирме пациента
  • PatientFirmPeopleBelow18 - кол-во сотрудников до 18 лет в фирме пациента
  • PatientFirmDog - номер договора с фирмой пациента
  • PatientFirmDog1 - дата начала договора с фирмой пациента
  • PatientFirmDog2 - дата окончания договора с фирмой пациента
  • PatientFirmComments - комментарий у фирмы пациента

Табличные данные. Заполнение таблиц начинается с первого найденного тега с префиксом Srv:

  • SrvPatientFIO - ФИО пациента
  • SrvPatientSex - пол пациента
  • SrvPatientAddress - адрес пациента
  • SrvPatientProf - профессия пациента
  • SrvPatientDepartment - отдел фирмы пациента
  • SrvPatientBirthday - дата рождения пациента
  • SrvPatientYears - возраст пациента
  • SrvPatientPhone - телефон пациента
  • SrvPatientFirm - фирма пациента
  • SrvPatientFirmPeople - кол-во сотрудников в фирме пациента
  • SrvPatientFirmPeopleWomen - кол-во женщин в фирме пациента
  • SrvPatientFirmPeopleBelow18 - кол-во сотрудников до 18 лет в фирме пациента
  • SrvPatientFirmDog - номер договора с фирмой пациента
  • SrvPatientFirmDog1 - дата начала договора с фирмой пациента
  • SrvPatientFirmDog2 - дата окончания договора с фирмой пациента
  • SrvPatientFirmComments - комментарий у фирмы пациента

При формировании табличных данных можно использовать в первой строке с данными тег SrvDynCol, данная колонка будет размножена для указания в шапке названия оказанной улуги (исследования или анализа), а в строке с данными ее результат. При этом если результат отрицательный (значение "-"), то ячейка с данными окрасится в красный цвет.

Для Украины. Использование и значение тегов соответствует такому же тегу, но без суффикса UA.

Показать Скрыть

  • CurUADateLong
  • DebetToWordsUA
  • KvitSumToWordsUA
  • MoneyBackUASumS
  • PatDebetToWordsUA
  • PatServicesUASumInPeriodS
  • PrescrUACostS
  • PrescrUADiscountValS
  • PrescrUASumS
  • SchetUASumS
  • ServiceUAArticleName
  • ServiceUATransferSumS
  • SrvUAArticle
  • SrvUAServiceName
  • SumPrimeToWordsUA
  • SumToWordsUA
  • TransferUAArticleName
  • TransferUAEyeN
  • TransferUALongDate
  • TransferUASumInS
  • TransferUASumOutS
  • UAAllServicesSumS
  • UAFIO
  • VisitUACostS
  • VisitUADiscountValS
  • VisitUASumS

При необходимости использования в программе дополнительных тэгов следует обратиться к разработчику.


АДМИНИСТРИРОВАНИЕ

Подготовка шаблона RTF документа

В данном разделе справки даются общие рекомендации по подготовке RTF документов для их дальнейшего использования в качестве шаблона печатной формы или шаблона врачебного документа.

Общие рекомендации по вставке рисунков в RTF файл

  • используйте разрешение разрешение 150 dpi, меньшее разрешение недостаточно для качественной печати, большее - дает незначительный прирост в качестве при существенном увеличении размера файла
  • желательно, чтобы размер рисунка в документе совпадал с размером рисунка в файле
  • сохраняйте рисунок в формате jpeg или png
  • для вставки в документ используйте стандартные средства в меню Вставка - Рисунок. Не использзуйте копи-паст.

Таким образом, если вы хотите вставить в документ логотип шириной 10 см и высотой 3 см, то подготовьте в программе работы с изображениями рисунок jpeg с разрешением 150 dpi и требуемыми размерами. При разрешении 150 dp, ширине 10 см и высоте 3 см размер рисунка должен быть 591 на 118 пикселей.

Стандартные проблемы

При переводе документов в rtf, самая большая проблема - это сохранение размера ячеек таблиц, чтобы они не поползли. Следующая по значимости проблема - подчеркивания, особенно если их несколько и надо чтобы они были одинаково выровнены - для того чтобы документ смотрелся аккуратно, обычно приходится использовать таблички из 1-2 ячеек, в которых нарисована только одна грань.

Рекомендации по сохранению размера таблиц при создании документов rtf

  • Делить работу на части. Например, если есть необходимость нарисовать на альбомно расположенном листе 2 страницы, рекомендуется сначала сделать бесцветную таблицу из 3 ячеек (левая страница, правая страница, разделительный промежуток), а потом по отдельности рисовать левую и правую страницы внутри соответствующих ячеек большой таблицы.
  • Стараться не использовать сильно сложные таблицы с объединением ячеек. Например, если есть возможность разделить страницу на секции по вертикали, то использовать несколько простых таблиц вместо одной сложной.
  • Word "оптимизирует" ширину колонок и ширину таблицы, на этот алгоритм лучше не полагаться, поскольку он отличается во вьюере и в ворде. Если в ворде зайти в свойства ячейки, или в свойства таблицы, то отображаемая там ширина элемента может не соответствовать тому что Вы видите на экране. Рекомендуется сначала делать табличку, потом заполнять ее текстом, потом вручную указывать ширину таблицы и ширину каждой ячейки.

В сложных случаях - перешлите документ/форму на почту разработчику.


АДМИНИСТРИРОВАНИЕ

Добавление сложных таблиц в печатные формы

В данном разделе справки даются общие рекомендации по созданию сложных таблиц внутри печатных форм.

В печатных формах ранее можно было выводить таблички только со списком оказанных услуг. Изменение сортировки, добавление промежуточных итогов, другие сложные операции были невозможны. Теперь добавилась возможность не изменяя ехе, создать хранимку на сервере, и вывести ее результаты в печатной форме один к одному. Дальнейшая информация - для сотрудников техподдержки, и программистов клиентов. Появился новый тег для табличных данных, который позволяет выполнить любой запрос для формирования данных в таблице. Теги в столбцах данной таблицы указывать не нужно, вывод будет сделан 1 к 1 как в выборке. Также как и в пользовательских отчетах есть специальная колонка is_bold, которая отвечает за жирность всей строки.

Использовать новый функционал можно так (указывается в первой ячейке): {{Srv_exec_print_form_get_data @patient_id,@service_id,@param3=100}}. Где print_form_get_data - это имя хранимой процедуры для получения данных, @param3 - параметр со значением типа константа, два остальных параметра получат своё значение в зависимости от текущего контекста, распознаются следующие параметры:

Запись

  • @patient_id
  • @service_id
  • @service_visit_id
  • @service_ids

Пациент

  • @patient_id
  • @hosp_id
  • @limit_period_d1 (для ПФ для формы 'Пациенты - запрос периода')
  • @limit_period_d2 (для ПФ для формы 'Пациенты - запрос периода')

ДМС

  • @dms_id
  • @dms_document_id
  • @dms_d1
  • @dms_d2

Назначения

  • @service_visit_id


АДМИНИСТРИРОВАНИЕ

Список тэгов, используемых для печати записи на прием

В данном разделе справки перечислены тэги (последовательности символов), которые можно использовать в шаблонах при печати расписания работы врача на день, кабинета или записи на прием в Записи.

Данные теги должны быть обрамлены символом процента, чтобы получилось например %fio%. Используются теги в константах:

  • 380 - Запись - Печать расписания врача на день. Шаблон для 1-ой колонки ("ФИО пациента")
  • 381 - Запись - Печать расписания кабинета на день. Шаблон для 1-ой колонки ("ФИО пациента")
  • 382 - Запись - Печать расписания врача/кабинета на день. Шаблон для 2-ой колонки ("Явка на прием")
  • 383 - Запись - Шаблон печати "Расписания записи на прием" (кнопка с принтером в шапке формы)

Для ячейки/визита существуют следующие теги:

  • room_info - информация о кабинете
  • doctor_fio - информация о враче
  • fio - ФИО пациента
  • full_years - количество полных лет пациента
  • phone - телефон пациента
  • card_n - номер мед. карты
  • dent_num - номер стоматологической карты
  • advert_name - рекламный канал
  • treatment_name - курс лечения
  • parent_fio - ФИО родителя пациента
  • dispetcher - диспетчер
  • comments - комментарий к визиту
  • debt_sum - сумма предоплаты или задолженности пациента
  • debt_info - сумма предоплаты или задолженности пациента с текстом описанием
  • police_n - номер полиса
  • police_d1 - дата полиса С
  • police_d2 - дата полиса ПО
  • dms_name - ДМС компания
  • dms_phone - телефон ДМС компании

Для услуг существуют следующие теги:

  • article_code - код услуги
  • article_name - название услуги
  • a_comments - комментарий к услуге в визите
  • article_code_name - код услуги, при его отсуствии название услуги
  • article_code_and_name - код услуги и название услуги через пробел


АДМИНИСТРИРОВАНИЕ

Список тэгов, используемых для шаблона ячеек в записи и в шапке визита

В данном разделе справки перечислены тэги (последовательности символов), которые можно использовать в шаблонах для ячеек в записи и в шапке визита.

Ячейки в Записи

При формировании документа на основе шаблона тэги в заменяются на текст, полученный на основе значений в базе данных. Для ячеек с несколькими визитами данные в тегах заполняются через запятую.

  • %h% - час начала визита
  • %mins% - минуты начала визита
  • %time% - время визита в формате ЧЧ:ММ
  • %duration_mins% - длительность визита в минутах
  • %visit_period% - период визита с длительностью
  • %u_fio% - ФИО пациента полностью
  • %u_short_fio% - ФИО пациента с инициалами
  • %u_phone% - телефон пациента
  • %full_years% - количество полных лет пациента
  • %card_n% - номер мед карты пациента
  • %dogovor_n% - номер мед договора пациента
  • %parent_fio% - ролители пациента
  • %parent_str% - строка с родителями пациента и префиксом "род.:", если они указаны
  • %dms_name% - ДМС
  • %disc_card_n% - номер дисконтной карты
  • %debt_str% - сумма долга в скобочках, только если не равна 0
  • %doctor_fio% - ФИО врача
  • %doctor_profession% - специальность врача
  • %comments% - комментарий
  • %visit_comments% - комментарий к визиту
  • %line% - признак начала новой строки

При необходимости использования в программе дополнительных тэгов следует обратиться к разработчику.

Тэги используются при формировании констант:

Номер константы | Название константы | Пример значения константы
324 | Запись (текст) - Формат вывода текста в клетках | %time% %card_n%, %u_short_fio% %u_phone% %doctor_profession%:%doctor_fio%
326 | Запись (текст) - Формат вывода текста в клетках, если на одно время записано более одного пациента | %time% %card_n%, %u_short_fio%
331 | Запись (текст) - Формат вывода текста в Excel | %time% %card_n%, %u_short_fio% %u_phone% %debt_str%%line%%comments%
332 | Запись (текст) - Формат вывода текста в Excel, если на одно время записано более одного пациента | %time% %card_n%, %u_short_fio% %u_phone% %debt_str%%line%%comments%
325 | Запись - При наведении мышки на клетку, отображать подсказку в строке наверху формы в следующем формате | %time% %card_n%, %u_short_fio% %u_phone% %u_phone% %doctor_fio%, %parent_str% %comments%
327 | Запись - При наведении мышки на клетку с неск.пациентами,отображать подсказку в строке наверху формы в следующем формате | %time% %card_n%, %u_short_fio% %u_phone% %u_phone% %comments%

Шапка визита (информация о пациенте)

Шаблонный текст указывается в константе 347 [Визит - Формат вывода текста в информации о пациенте].

Список поддерживаемых тегов:

  • %u_fio% - ФИО пациента полностью
  • %u_short_fio% - ФИО пациента с инициалами
  • %u_phone% - телефон пациента
  • %card_n% - номер мед карты пациента
  • %dogovor_n% - номер мед договора пациента
  • %parent_fio% - ролители пациента
  • %parent_str% - строка с родителями пациента и префиксом "род.:", если они указаны
  • %disc_card_n% - номер дисконтной карты
  • %birthday% - дата рождения
  • %full_years% - количество полных лет

Пример:

Номер константы | Название константы | Пример значения константы | Пример итогового текста
347 | Визит - Формат вывода информации о пациенте | %time%, %card_n%, %u_short_fio% %u_phone% | 11:45, 1/12, Павлов В. В. +9 (111) 112-23-56


АДМИНИСТРИРОВАНИЕ

Пользовательские отчеты

В статье описывается возможность создания пользовательских отчетов.

В программе реализовано несколько десятков различных отчетов. В большинстве случаев этого достаточно для получения требуемой информации. Кроме того, пользователь имеет возможность разрабатывать собственные отчеты.

Разработка отчета состоит из нескольких этапов:

  • подготовка отчета в дизайнере
  • добавление отчета в справочник "Пользовательские отчеты"
  • заполнение справочника "Настройка форм пользовательских отчетов"

Для создания отчета используется программа Fast Report (www.fast-report.com). Отчет может быть подготовлен во внешнем редакторе или вызван с помощью кнопки [image] из формы "Пользовательские отчеты".

При добавлении отчета в справочник "Пользовательские отчеты" необходимо задать название отчета, имя файла и выражение SQL для формирования отчета. Файлы отчетов должны находиться в папке на сервере, заданной константой "Пользовательские отчеты - Путь к файлам *.fr3". Для папки должен быть открыт общий доступ.

При заполнении справочника "Настройка форм пользовательских отчетов" необходимо указать текстовое название параметра, название параметра в выражении SQL, задать тип параметра, обязательное или нет поле к заполнению. При необходимости можно указать значение по умолчанию. Некоторые параметры отчета предполагают выбор значения из выпадающего списка, для них необходимо указать выражение SQL для формирования списка. Также в SQL можно использовать переменную @current_patient_ID, указывающую на текущего пользователя, выбранного последним в форме Пациентов. Если не было выбранного пациента, то будет передан 0.

Если в выражении SQL для отчета нет параметров, то заполнять справочник "Настройка форм пользовательских отчетов" не нужно.

[1] - фильтр справочника по названию отчета. [2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающем списке. Кнопки [3] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

Запуск созданных пользовательских отчетов возможен из меню "Отчеты - Пользовательские отчеты". Если параметры отчета не заданы, то отчет сразу выводится на экран. В противном случае, на основании данных справочника "Настройка форм пользовательских отчетов" формируется форма настройки параметров отчета.

Поля "Название параметра" из справочника "Настройка форм пользовательских отчетов" задают надписи на форме.

Поле "Тип параметра" определяет вид элемента для выбора параметра:

  • Целое - текстовое поле, с возможностью вводить только цифры. Если параметр имеет тип "целое" и для него указано выражение SQL для формирования списка, то этот параметр будет представлен выпадающим списком, заполненным на основе выражения SQL.
  • Дата - поле выбора даты.
  • Строка - текстовое поле.
  • Логическое - чекбокс.
  • Множественный выбор из списка - обязательно нужно указывать выражение SQL для формирования данного списка, где первое поле - это идентификатор элемента, а второе его текстовое название. Этому типу соотвествует текстовое поле, справа от которого расположены кнопки для показа формы со списком элементов и для очистки введенных ранее данных. В форме настроек пользователь видит перечисленные через запятую текстовые названия, а в sql подставляются перечисленные через запятую идентификаторы.

Если в справочнике "Настройка форм пользовательских отчетов" для параметра задано значение по умолчанию, оно будет автоматически выбрано в соответствующем элементе формы. Для параметров типа "дата" значения вводятся в формате "yy-mm-dd" ("2009-06-30"), также можно указать значение "date" - текущая дата или другие из списка:

  • MONTH_BEGIN - первое число текущего месяца
  • DATE_PREV - предыдущий день
  • DATE - текущий день
  • DATE_TOMORROW - следующий день
  • TODAY_PLUS_MONTH - прибавляет один месяц к текущей дате
  • MONTH_END - последний день текущего месяца
  • PREV_MONTH_BEGIN - первый день предыдущего месяца
  • PREV_MONTH_END - последний день предыдущего месяца
  • MONTH_6_BEGIN - первый день 6 месяцев назад
  • MONTH_6_END - последний день 6 месяцев назад

При нажатии на кнопку "Сформировать отчет" значения, заданные в форме подставятся в выражение SQL, определенное в справочнике "Пользовательские отчеты" и на его основе будет сформирован отчет. Если для параметра указано, что он обязателен к заполнению, пользователь получит предупреждение в случае незаданного параметра.

Пользователь отвечает за правильное создание формы отчета, определение выражения SQL для отчета и задание параметров отчета.

Пример формирования отчета можно посмотреть в соответсвующем разделе справки.


АДМИНИСТРИРОВАНИЕ

Пример создания пользовательского отчета

В статье описывается последовательность действий для создания пользовательских отчетов.

Предположим мы хотим получить список услуг выбранного врача за указанный период.

В дизайнере Fast Report создаем форму отчета и сохраняем ее под именем "services_list.fr3" в папке, заданной константой "Пользовательские отчеты - Путь к файлам *.fr3".

В справочнике "Пользовательские отчеты" задаем название отчета - "Список оказанных услуг (без параметров)", имя файла - "services_list.fr3" и выражение SQL для формирования отчета:

select d.fio as doctor_fio,pa.article_name,vs.cost_with_discount
from dbo.visits v
left join dbo.visits_services vs on v.visit_id=vs.visit_id
left join dbo.doctors d on v.doctor_id=d.doctor_id
left join dbo.prices_articles pa on vs.price_article_id=pa.price_article_id
where v.doctor_id=@doctor_id and (v.dd>=@d1 or @d1 is null) and (v.dd<=@d2 or @d2 is null)

Таким образом, в выражении SQL заданы три параметра "doctor_id", "d1" и "d2".

Далее заполняем справочник "Настройка форм пользовательских отчетов". Добавляем параметр "doctor_id" типа "целое". Так как мы хотим, чтобы ФИО врача выбиралось из выпадающего списка, указываем выражение SQL для формирования списка врачей:

select doctor_id,fio from dbo.doctors order by fio

Добавляем два параметра типа "дата" - "d1" и "d2".

Указываем, что "ФИО врача" обязательно к заполнению, а "Дата с" и "Дата по" нет.

Отчет готов.

Запускаем созданный отчет из меню "Отчеты - Пользовательские отчеты". На основании данных справочника "Настройка форм пользовательских отчетов" формируется форма настройки параметров отчета.

При нажатии на кнопку "Сформировать отчет" получаем:


АДМИНИСТРИРОВАНИЕ

Автоматическая генерация отчетов

В статье описывается последовательность действий для создания пользовательских отчетов в автоматическом режиме, без участия пользователя.

В программе имеется возможность создавать отчеты в автоматическом режиме и с заполненными заранее параметрами. Для этого необходимо запустить программу под пользователем SA, выбрать необходимый пользовательский отчет, заполнить необходимые параметры в появившейся форме и нажать на кнопку слева - "Скопировать в буфер обмена параметры запуска отчета".

Затем создать ярлык Windows или командный файл .BAT, в котором в качестве параметра вставить из буфера значение.

В med.ini обязательно должен быть указан пароль доступа к базе данных. Желательно запускать программу в автоматическом режиме на компьютере, который не используется сотрудниками, т.к. запуск второй копии программы запрещен.

Возможные форматы экспорта (зависят от указанного расширения):

  • xls - Формат файла Microsoft Excel 2003
  • pdf - Формат файла Adobe Acrobat Reader

Даты в параметрах отчетов указываются в формате ГГГГ-ММ-ДД, например: /print "export.xls" 1 "2015-09-14". Или в текущем формате компьютера, где будет запускаться.


АДМИНИСТРИРОВАНИЕ

Справочник "Пользователи"

Форма предназначена для добавления, удаления и изменения данных сотрудников фирмы

Форма открывается из меню "Справочники".

Следует различать термины "Сотрудник" и "Пользователь". Сотрудник - работник фирмы (врач, менеджер, кладовщик, уволенный врач и т.п.). Сотрудник может и не работать с программой. Пользователь отличается от сотрудника наличием логина и пароля. Программа идентифицирует пользователя по логину, который он указал перед запуском программы. Логин, пароль, а также имя sql-сервера и базы данных берутся из файла med.ini, находящегося в каталоге программы. Если невозможно соединиться с сервером, используя указанные логин и пароль, программа предоставит возможность задать их повторно. Таким образом, например, для предотвращения несанкционированного доступа к программе возможно не указывать логин и пароль (или только пароль) в файле med.ini. В базе данных всегда существует учетная запись пользователя "sa" с паролем, установленным администратором базы данных. Ее можно использовать для задания логина и пароля других пользователей. При создании пользователя его логин и пароль задаются в форме "Создание и модификация пользователей". Форма открывается из справочника "Пользователи" при двойном щелчке на любую из колонок "Логин", "Врачебный доступ", "Полный доступ". Дополнительную информацию смотрите в соответствующем разделе справки. При удалении сотрудника происходит удаление соответствующего пользователя из базы данных. Если у сотрудника при этом есть прикрепленные услуги, документы, либо другая информация, удалить запись из справочника нельзя.

Для каждого врача указывается так называемая "Закладка" - группа врачей, выбранная по определенному признаку. При выборе названия закладки из выпадающего списка в форме "Запись" на экране будут отображаться данные о расписании врачей, относящихся к указанной закладке. Часто названия закладок совпадают со специальностями, но не всегда. Например, если в клинике много терапевтов, они могут быть поделены по закладкам "Терапевты 1", "Терапевты 2" и т.д. Если, наоборот, в клинике единственный уролог и 2 гинеколога, их можно сгруппировать на закладке "Урологи+гинекологи".

Для врача можно поставить пометку, что врач может одновременно принимать нескольких пациентов (например, врач работает в процедурном кабинете, либо врач является тренером по лечебной физкультуре). В этом случае, в форме "Запись" в одной клетке может отображаться информация сразу о нескольких пациентах.

Колонка "Премиальный процент" видна только сотрудникам, входящим в группу "Администраторы".

Значение в колонке "Цвет" влияет на цвета ячеек в форме "Запись" при задании соответствующих значений в константах "Запись (оформление) - Цвета врачей брать из таблицы врачей (Нет=генерировать автоматически)" и "Запись на прием - свободное время закрашивать белым (нет=закрашивать цветом врача по умолчанию)".

Если в программу включен модуль "Извещения", то можно пометить компьютер как рабочее место врача. В этом случае извещение, посланное врачу, будет отображаться только на этом компьютере. Для того чтобы пометить компьютер как рабочее место врача, нужно из контекстного меню ячейки нужно выбрать соответствующий пункт:

С помощью переключателей "Все колонки", "Услуги по умолчанию", "Доступы", "Личные данные" можно выбрать один из заданных вариантов настройки колонок для отображения необходимых столбцов.


АДМИНИСТРИРОВАНИЕ

Создание и модификация прав пользователей

Форма предназначена для добавления, удаления и изменения прав пользователей, имеющих доступ к программе

Форма открывается из справочника "Пользователи" при двойном щелчке колонку "Логин" или любую другую колонку, относящуюся к доступам. Такие колоки в справочнике "Пользователи" не подлежат редактированию и выделены розовым цветом в режиме редактирования. Обычно они находятся в одной группе и отображаются при выборе переключателя "доступы".

Сотрудник должен быть добавлен в базу заранее. Т.е. сначала создается запись сотрудника в справочнике "пользователи", сохраняется запись (например, в момент перехода к предыдущей либо последующей строчке), и только потом возможно задание мозданному пользователю логина, пароля и прав доступа.

В программе может быть определено несколько групп пользователей. Пользователи, входящие в группу "Администраторы" обладают полным доступом к функциям программы. Для остальных существуют некоторые ограничения. Возможно добавить пользователя в одну из групп или в несколько групп сразу.

Группы пользователя создаются разработчиком или администратором базы данных согласно определенным правилам, изложенным в статье справки "Создание новой роли доступа". Надписи в форме "Создание и модификация прав пользователя" генерируются автоматически на основе созданных групп пользователей.

При создании нового пользователя или изменения его логина необходимо указать пароль. Windows накладывает ограничения на длину пароля и символы, из которых он может состоять. Допустимы буквы латинского алфавита и цифры. Длина пароля не должна быть меньше четырех символов. Дополнительную информацию можно получить в справке Windows. Пример пароля: Test-123. Для того, чтобы удалить существующего пользователя нужно оставить пустым поле "Логин" и снять все галочки доступа. При этом запись сотрудника останется в базе, хотя он и не сможет запустить программу под своим именем. Нельзя редактировать доступ для пользователя с логином "sa", являющегося главным администратором.

Внимание! Изменять логины и пароли пользователей, а также исправлять группы доступа может только системный администратор (пользователь с логином sa), либо пользователь с аналогичными правами. Для большинства пользователей редактирование доступов запрещено.


АДМИНИСТРИРОВАНИЕ

Создание новой роли доступа

ВНИМАНИЕ!!! ДАННЫЙ РАЗДЕЛ ПРЕДНАЗНАЧЕН ТОЛЬКО ДЛЯ ПОЛЬЗОВАТЕЛЕЙ, ОБЛАДАЮЩИХ НЕОБХОДИМОЙ КВАЛИФИКАЦИЕЙ (СИСТЕМНЫХ АДМИНИСТРАТОРОВ И ПРОГРАММИСТОВ)

Порядок добавления новой роли в программу

1. Придумать название для роли. Название может включать в себя строчные (маленькие) латинские буквы и подчеркивания. Например, "osn_doktor", "laborant". Допустим, мы хотим добавить в программу группу доступа для лаборантов, называться она будет "laborant".

2. Добавить в таблицу dbo.doctors новое поле. В случае, если новая роль доступа описывает какой-либо тип сотрудников (например лаборанты, кассиры, врачи, гл.бухгалтера), то поле следует назвать is_laborant. Если роль доступа дает какую-либо дополнительную возможность (например, доступ к редактированию прейскуранта, или разрешение на слияние пациентов), то поле следует назвать rl_laborant. Использование префиксов "is_" либо "rl_" обязательно. Не забудьте указать для поля значение по умолчанию. Если создавать поле скриптом, то скрипт выглядит так:

ALTER TABLE dbo.patients ADD is_laborant bit NOT NULL Default 0;

GO

3. Открыть в базе "Безопасность" - "Роли" - "Роли базы данных" и создать там новую роль. Если название поля начиналось на is_***, то роль должна начинаться на my_***. Если название поля начиналось на rl_***, то название роли совпадает с названием поля.

В нашем примере, мы должны добавить роль my_laborant. Пример скрипта:

CREATE ROLE my_laborant

GO

4. При необходимости, можете включить созданную роль в другие роли доступа. Например, если у лаборантов есть полный доступ на чтение всей информации в базе, можно включить созданную роль my_laborant в стандартную роль db_datareader. Доступ к служебным и справочным таблицам прописан в стандартной роли my_public, поэтому использовать роль db_datareader скорее всего не потребуется (и не рекомендуется), она приведена для примера.

Любой создаваемый в базе пользователь всегда включается в роли my_public и db_backupoperator. В остальном принадлежность пользователя к различным группам определяется проставляемыми администратором в справочнике пользователей галочками.

5. Запускаем программу под пользователем sa, открываем справочник пользователей, режим просмотра доступов. Щелкаем на гриде правой клавишей, выбираем "Настроить колонки" из контекстного меню. Перемещаем новое поле налево, в список отображаемых полей, и вводим название для нового поля. В нашем случае название будет "Лаборант".

Список отображаемых полей и ширина полей для каждого пользователя индивидуальны. Чтобы изменения в списке отображаемых галочек доступа стали видны другому пользователю, следует выполнить "Сброс настроек текущего пользователя" в пункте главного меню, название которого совпадает с ФИО текущего пользователя. Сброс настроек для всех пользователей можно выполнить командой

exec dbo.reset_users_constants Null, 'hard'; -- Обновить константы пользователя и ширину колонок для всех пользователей, на основании данных sa

GO

6. В дальнейшем при открытии модальной формы редактирования доступов, в ней добавится галочка "Лаборант". Установка этой галочки добавляет соответствующего пользователя в группу my_laborant. Модальная форма редактирования доступов вызывается в справочнике пользователей, в режиме просмотра доступов, после перехода в режим редактирования, двойным кликом на логине либо на любой из галочек доступов. В модальной форме отображаются галочками все доступы, для которых в настройке колонок было задано название и указана видимость.

7. Разрешения для группы доступа my_laborant проставляются в management studio стандартным образом. При необходимости более точной настройки, возможно создание проверочных триггеров. В случае создания проверочных триггеров, их название должно начинаться с латинского названия клиента (т.е. в большинстве случаев начало названия проверочного триггера должно совпадать с названием базы, например nordclinic_no_pay_edits_after_1_day). При обновлении версии, производится перезапись всех объектов, отличающихся от аналогичных объектов в мастер-версии базы, и добавление всех объектов которые есть в мастер-версии и нет в клиентской. Таким образом, если в клиентской версии есть какие-либо дополнительные триггера, то при обновлении программы и базы, эти триггера не затрагиваются.


АДМИНИСТРИРОВАНИЕ

Служебные роли доступа

ВНИМАНИЕ!!! ДАННЫЙ РАЗДЕЛ ПРЕДНАЗНАЧЕН ТОЛЬКО ДЛЯ ПОЛЬЗОВАТЕЛЕЙ, ОБЛАДАЮЩИХ НЕОБХОДИМОЙ КВАЛИФИКАЦИЕЙ (СИСТЕМНЫХ АДМИНИСТРАТОРОВ И ПРОГРАММИСТОВ)

Помимо стандартных ролей (db_doctor, my_public, my_admin и т.д.), определяющих типовые права доступа, в базе существуют так называемые "служебные" роли, позволяющие указать некоторые специфические права.

В настоящее время определены следующие служебные роли:

  • rl_can_view_payments_future - члены роли могут просматривать и редактировать оплаты за будущие даты
  • rl_can_view_payments_past - члены роли могут просматривать и редактировать оплаты за прошедшие даты
  • rl_cant_view_prime_cost - члены роли могут просматривать и редактировать форму Себестоимость
  • rl_doctor_no_edit_def_color - членам роли запрещено редактирование цветов по умолчанию в таблице врачей
  • rl_doctors_premium - члены роли могут работать с формами премиальных процентов врачей
  • rl_documents_no_edit_past_time - членам роли запрещено редактирование документов за прошедшие даты
  • rl_helix - членам роли разрешана работа с Хеликсом: обновление справочников, отправка и получение результатов анализов
  • rl_no_report - членам роли запрещен просмотр встроенных отчетов и пользовательских отчетов
  • rl_only_own_documents - члены роли могут просматривать и редактировать только собственные документы
  • rl_patients_card_n__no_edit - членам роли запрещено редактирование номеров медицинской карты
  • rl_patients_limited - членам роли не видны личные данные пациента
  • rl_report_no_print - членам роли запрещена печать и экспорт отчетов
  • rl_visit_no_edit_done - членам роли запрещено редактирование визитов со статусом Пришел за прошедшие даты
  • rl_visit_no_edit_past_time - членам роли запрещено редактирование визитов за прошедшие даты

Если требуется дать членам одной из стандартных ролей дополнительные права/ограничения, соответствующие одной из служебных ролей, следует:

1. Открыть "Пуск" - "Все программы" - "Microsoft SQL Server 2005" - "Среда SQL Management Studio Express" (название программы зависит от установленной версии SQL Server) 2. Выбрать базу данных. Открыть "Безопасность" - "Роли" - "Роли базы данных" и выбрать требуемую служебную роль, например rl_report_no_printr.

3. Дважды щелкнуть на роли, откроется окно "Свойства роли базы данных". В нижней части окна нажать кнопку "Добавить".

4. Ввести название стандартной роли, которую нужно добавить в служебную. Ввести можно полное название, либо нажать кнопку "Обзор" и выбрать роль из списка, либо начать вводить название роли и нажать на кнопку "Проверить имена" для получение отфильтрованного списка ролей. Закрыть окно "Выбор пользователя или роли базы данных", нажав кнопку "ОК". Закрыть окно "Свойства роли базы данных".


АДМИНИСТРИРОВАНИЕ

Доступы по группам

Форма предназначена для настройки доступа групп пользователей.

Форма вызывается при выборе соответствующего пункта в меню "Администрирование" и состоит из нескольких секций:

Верхняя часть формы служит для фильтрации выводимых данных. В секции [1] необходимо выбрать группы пользователей, для которых будет производиться редактирование доступов. В секции [2] осуществляется фильтрация объектов по уже выделенным правам (пример фильтра указан ниже), а в [3] по важности объекта. После изменения фильтра необходимо обновить данные нажатием на кнопку "Обновить данные".

В нижней части выводятся сами права на выбранные объекты с условными обозначениями операций над ними в колонках:

  • В - вставка (для таблиц)
  • И - изменение (для таблиц)
  • У - удаление (для таблиц)
  • З - запуск (для функций и хранимых процедур)
  • Ч - чтение (для таблиц)

Значение доступа может быть следующих типов:
- доступ не задан
- доступ запрещен
- доступ разрешен
- сложный доступ, когда доступ разрешен на часть объекта

Кнопка "Печать" позволяет распечатать матрицу доступа на принтере.

Редактирование

Редактировать данные можно после нажатия на кнопку "Разрешить редактирование", при этом появляется также возможность отредактировать помимо доступов и русское название объекта, а также его примечание - через контекстное меню "Редактировать примечание". Данное поле исключительно информационное и служит для написания клиентом заметки по объекту базы данных. При этом в таблице такие объекты помечаются красным квадратом в правом верхнем углу колонки с русским названием.

Задать права можно набрав с клавиатуры "+", "-" или пробел, для снятия прав, или двойным кликом мышкой по ячейке. Эти действия также доступны из контекстного меню ячейки.

С помощью контекстного меню "Копировать" можно полностью скопировать права одной группы в другую, следует учесть, что при этом сложные доступы не переносятся. При копировании прав есть возможность выбрать объекты для копирования: все или только отфильтрованные.

При обновлении версии программы, русские названия объектов и уровни важности перезаписываются данными из мастер-базы. Комментарии же сохраняются.

Комментарии

Вызов формы для ввода комментария к праву вызывается через контекстное меню правой кнопкой мыши в любом столбце - "Редактировать примечание". Данный комментарий вводится исключительно в информационных для пользователя целях и нигде более в программе не отображается. После ввода комментария в колонке "Объект (рус.)" справа вверху появляется небольшой красный квадрат.


АДМИНИСТРИРОВАНИЕ

История изменения услуг

Форма предназначена для просмотра истории изменения услуг.

Форма вызывается при выборе соответствующего пункта в меню "Администрирование".

В зависимости от константы "Сохранять историю изменений услуг: 2=ВСЕ, 1=только статус "Пришел", 0="Пришел" за прошедшие даты" в базе данных сохраняется информация о добавленных, удаленных и измененных услугах:

  • При значении константы 0 - сохраняются изменения услуг с датой визита меньше текущей и статусом "Пришел"
  • При значении константы 1 - сохраняются изменения услуг со статусом "Пришел"
  • При значении константы 2 - сохраняются все изменения услуг

В дальнейшем информация отображается в форме "История изменения услуг".

Имеющейся список [4] можно дополнительно отфильтровать по диапазону дат и пациенту [1].

Поставленная галочка [2] "только услуги, приведшие к изменению стоимости" определяет, что список будет содержать только услуги, приведшие к изменению стоимости всех услуг за день.

[3] - кнопка сброса фильтра. Сбрасывает выбранный интервал дат и галочку "только услуги, приведшие к изменению стоимости".

Список услуг доступен только для просмотра.


АДМИНИСТРИРОВАНИЕ

История изменения прейскуранта

Форма предназначена для просмотра истории изменения прейскурантов.

Форма вызывается при выборе соответствующего пункта в меню "Администрирование", отображаемом в случае, если значение константы "Администрирование - Вести историю изменения прейскуранта" равно "Да".

Имеющейся список [4] можно дополнительно отфильтровать по диапазону дат, группе услуг, услуге, прейскуранту [1]. С помощью выпадающего списка "Отслеживать изменения" можно дополнительно отфильтровать список по изменениям в названии прейскуранта, артикуле и цене. С помощью выпадающего списка "Отслеживать действия" отбираются только вставленные, измененные или удаленные записи, а также прейскуранты, для которых произошло изменение клиники. Данные будут обновлены при нажатии на кнопку [2]. О том, что фильтр был изменен после последнего обновления данных сигнализирует серый фон таблицы. [3] - кнопка сброса фильтра.

Список изменений доступен только для просмотра.


АДМИНИСТРИРОВАНИЕ

История изменения пациента

Форма предназначена для вывода отчета об истории изменения данных пациентов.

Форма вызывается при выборе соответствующего пункта в меню "Администрирование".

Можно выбрать пациента и задать диапазон дат отчета. С помощью выпадающего списка "Тип события" отбираются только определенные изменения данных пациента: создание записи, изменение ФИО, изменение страховой компании, слияние данных.

При нажатии на кнопку "Сформировать отчет" выводится отчет:


АДМИНИСТРИРОВАНИЕ

История изменения табеля

Форма предназначена для просмотра истории изменения табеля работы врачей.

Форма вызывается при выборе соответствующего пункта в меню "Администрирование" и непосредственно из формы "Врачи - табель".

Имеющейся список [4] можно дополнительно отфильтровать по диапазону дат и врачу [1]. Данные будут обновлены при нажатии на кнопку [2]. О том, что фильтр был изменен после последнего обновления данных сигнализирует серый фон таблицы. [3] - кнопка сброса фильтра.

Список изменений доступен только для просмотра.


АДМИНИСТРИРОВАНИЕ

Просмотр удаленных врачебных документов

Форма предназначена для просмотра удаленных врачебных документов.

Форма вызывается при выборе соответствующего пункта в меню "Администрирование". Форма состоит из нескольких секций:

Левая часть формы [1] используется для навигации, т.е. выбора нужного документа. При вводе в поле фильтрации любого текста, программа оставляет в списке только те удаленные документы, в названии документа, ФИО пациента либо ФИО врача которых содержатся введенные символы. Фильтр будет применен только после выхода из поля фильтрации или нажатия на "Enter".

Тублар редактирования [2] позволяет сохранить документ в формате RTF на диск, открыть окно предварительного просмотра документа, отправить документ на печать и скопировать выделенный в документе текст в буфер обмена.

Правая часть [3] используется для просмотра удаленного документа. Редактирование запрещено.


АДМИНИСТРИРОВАНИЕ

Настройка почты

В программе существует возможность отправить документы и отчеты с помощью установленного на компьютере почтового клиента. Для отправки используется кнопка со значком

Отправка может быть осуществлена из следующих мест:

  • Пациенты. Вкладка "Документы".
  • Пациенты. Вкладка "Файлы".
  • Форма "Документы". Если к документу прикреплен файл, то он также добавится и к письму.
  • Предпросмотр любого документа.
  • Предпросмотр любой печатной формы.

При этом открывается форма выбора кому отправить данный документ:

А затем и сам почтовый клиент с отправляемым письмом.

Настройка почтового клиента

Отправка письма происходит по технологии MAPI, соответственно подходит любой почтовый клиент, поддерживающий данную технологию.

Например:

  • Microsoft Outlook
  • Microsoft Outlook Express
  • Microsoft MAPI Controls
  • TheBat! с установленным плагином tbmapi.dll (как замена mapi32.dll в system)
  • Mozilla Thunderbird (последние версии)

Сама же настройка почтового аккаунта никак не отличается от стандартной процедуры в данном почтовом клиенте.


АДМИНИСТРИРОВАНИЕ

Отправка отчетов по продаже на почту

В программе существует возможность отправить некоторые отчеты (в частности отчет по продажам) на электронную почту. Для отправки используется кнопка со значком [image], которая делает выгрузку в отчета в Excel шаблон. При этом проверяется значение пользовательской константы 67 [Администрирование - Путь по умолчанию для сохранения XML отчетов] и если там указан адрес электронной почты, то отправка осуществляется на него, вместо стандартного сохранения файла на диск.

Настройка:

  • Необходимо для пользователя, который будет отправлять отчеты заполнить значение пользовательской константы 67 [Администрирование - Путь по умолчанию для сохранения XML отчетов] адресом эл. почты
  • Вторым шагом необходимо настроить почтовый аккаунт с помощью 410 константы [Администрирование - почтовый сервер для отправки отчетов (smtp хост, порт, логин, пароль, имя, ssl метод, тип ssl)].
    • ssl метод может принимать значения: SSL2, SSL23, SSL3, TLSv1, TLS11, TLSv12, -
    • тип ssl метод может принимать значения: ITLS, RTLS, -
    • Если ssl отключен, в последних двух параметрах ставите знак "-"
    • Параметры перечисляются через запятую без пробелов
  • Компьютер, где будете получать письма с отчетами, желательно настроить так, чтобы xml-файлы по умолчанию открывался в MS Excel

Для почтового аккаунта Google параметры SLL для константы 410 будут иметь следующий вид: smtp.gmail.com,465,login@google.com,pass,Отправитель,TLS12,ITLS

Для почтового аккаунта Яндекс параметры SLL для константы 410 будут иметь следующий вид: smtp.yandex.ru,25,login@yandex.ru,pass,Отправитель,TLS12,RTLS

Смотрите также статью Отчеты - Экспорт в Excel


АДМИНИСТРИРОВАНИЕ

Настройка службы отправки СМС

В данном разделе справки указаны шаги по настройке службы СМС рассылки.

Служба проверяет наличие новых смс в таблице dbo.sms, перед этим вызвав процедуру dbo.sms_preparation. Если в таблице dbo.sms появились новые смс, то служба пытается их отправить через указанного в INI провайдера смс рассылок. Также, периодически проверяет наличие новых входящих смс, данная услуга предоставляется провайдером с ограничением - зарегистрированный номер отправки СМС в сервисе должен быть цифровой, а не буквенный. Если такие смс есть, то получает их с интернет-сервера и сохраняет в таблице dbo.sms_inbox. Частота попыток отправки и приема смс указана в INI файле.
Сообщения, написанные пользователями программы напрямую клиентам, будут отправлены незамедлительно, поэтому нужно внимательно следить за текущим временем. Рассылки же отправляются в заданное в константах (ниже описаны) время, интервал, в который будет сделана рассылка определяется параметром INI файла - mailing_period.
Рассылки формируются хранимками dbo.sms_****. Например, хранимка dbo.sms_accepting используется службой для формирования списка смс, напоминающих пациенту о визите в клинику. Служба проверяет, с учетом констант, можно ли выполнять рассылку. Если можно, то вызывается хранимая процедура (например dbo.sms_accepting), возвращающая список подлежащих отправке смс. Список сохраняется в таблице dbo.sms. Далее выполняется хранимка dbo.sms_preparation. После чего служба пытается отправить новые смс, из таблицы dbo.sms. Индивидуальные смс, которые сотрудники могут отправлять пациентам из сабформы "смс" формы "Пациенты", сразу попадают в таблицу dbo.sms.
Смс не отправляются пациентам, у которых стоит галочка "Не посылать смс".
При отсылке смс "подтверждения прихода в клинику", служба помечает визиты, по которым смс уже отправлены, невидимой для пользователя отметкой.

Ini-файл:
Файл настроек может быть расположен на любом диске, в фиксированной папке "crm-soft", расположенной в корне диска. Проверка идет по алфавиту и начинается с буквы C. Путь для поиска: X:\crm-soft\SMSSender.ini. Описание каждого параметра описаны в самом INI-файле:

  • [sms]
  • ;провайдер (MF - Мегафон, EP - ePochta)
    provider=MF
  • ;логин
    login=sms_sender
  • ;пароль
    password=gfhjkm
  • ;база данных
    database=g82
  • ;сервер
    server=DEVELOPERVM\SQLEXPRESS
  • ;частота отправки смс, сек
    delay=2
  • ;частота получения смс, сек
    delay_recv=60
  • ;частота проверки рассылок смс, сек
    delay_mailing=300
  • ;вилка для рассылки начиная с константы, указанной как начало рассылки, мин
    mailing_period=60
  • ;имя отправителя смс
    sender_name=clinic
  • ;ключи
    ;публичный/логин
    PublicSMSKey=(111)111-11-11
  • ;приватный/пароль
    PrivateSMSKey=11116
  • ;=1 - не отсылать реально смс (только для ePochta)
    test=1
  • ;белый список префиксов
    whitelist=
  • ;в трее
    2tray=0
  • ;время попытки соединиться с базой после ошибки, мин
    error_delay=5
  • ;количество попыток отправки сообщения
    sms_try_count=3
  • ;пауза между попытками отправки сообщения, сек
    sms_try_delay=300

Список используемых констант:

  • [92] - Пациенты - Отображать поле "Рассылка смс разрешена"
  • [299] - СМС - Черный список телефонных префиксов (через запятую)
  • [300] - Отправка СМС сообщений из программы
  • [901] - Отправлять смс с подтверждением прихода пациента
  • [902] - Отправлять смс с подтверждением прихода пациента в XX:YY (часов:минут)
  • [903] - Отправлять смс с подтверждением прихода пациента на послезавтра, если не найдено визитов на завтра
  • [904] - Шаблон смс сообщения для подтверждения одного визита (жен)
  • [905] - Шаблон смс сообщения для подтверждения одного визита (муж)
  • [906] - Шаблон смс сообщения для подтверждения двух визитов (жен)
  • [907] - Шаблон смс сообщения для подтверждения двух визитов (муж)
  • [908] - Отправлять смс с рекламной акцией
  • [909] - Отправлять смс с рекламной акцией в XX:YY (часов:минут)
  • [910] - Шаблон смс сообщения для рекламных акций (жен)
  • [911] - Шаблон смс сообщения для рекламных акций (муж)
  • [912] - Отправлять смс с поздравлением на день рождения
  • [913] - Отправлять смс с поздравлением на день рождения в XX:YY (часов:минут)
  • [914] - Шаблон смс сообщения для поздравления на день рождения (жен)
  • [915] - Шаблон смс сообщения для поздравления на день рождения (муж)
  • [916] - Отправлять смс с приветствием нового пациента
  • [917] - Отправлять смс с приветствием нового пациента в XX:YY (часов:минут)
  • [918] - Шаблон смс сообщения для приветствия нового пациента (жен)
  • [919] - Шаблон смс сообщения для приветствия нового пациента (муж)
  • [920] - Шаблон смс с контролем качества услуг (жен)
  • [921] - Шаблон смс с контролем качества услуг (муж)

Если оставить пустыми константы 906 и 907, то для каждого визита будет отправлена отдельная СМС.

После настройки Ini-файла и констант необходимо зарегистрировать службу в Windows, для этого необходимо выполнить команду SMSSender.exe /install в командной строке, запущенной под администратором. Далее открываем Службы в панели управления и настраиваем автоматический запуск при старте системы и запускаем службу. Контролировать ошибки работы сервиса можно через "Просмотр событий" Windows в меню Пуск - Панель управления - Администрирование.

Хранимые процедуры для разных типов рассылки, вызываются для получения списка СМС для отправки:

  • sms_birthdays - для рассылки с поздравлением о дне рождения. Константы: 912, 913, 914, 915.
  • sms_advert - для рассылки с рекламным объявлением. Константы: 908, 909, 910, 911.
  • sms_welcome - для рассылки с приветственным сообщением при первом посещении клиники. Константы: 916, 917, 918, 919.
  • sms_accepting - для рассылки с просьбой подтвердить запись на прием (за день или за два дня, в зависимости от констант). Константы: 901, 902, 903, 904, 905, 906, 907.

Перед отправкой сообщений каждый раз выполняется процедура sms_preparation, на данный момент пустая.

Возможные теги для констант при указании текста сообщения:

  • %dd% - дата
  • %dd2% - дата без года
  • %h% - час визита
  • %mins% - минуты визита
  • %dfio% - ФИО врача визита / лечащего врача, если смс не привязана к визиту
  • %fio% - ФИО пациента
  • %f% - фамилия пациента
  • %i% - имя пациента
  • %o% - отчество пациента
  • %birthday% - дата рождения
  • %dskype% - Скайп врача, используется в информации о визите

Данные теги можно использовать везде, кроме отправки одиночных СМС из визита и пациентов, а в шаблонах рекламного объявления, приветствия и дня рождения еще и остальные поля из таблицы пациентов (patients), указав их так - %ПОЛЕ%.

Константы 906 и 907 - шаблон сообщения для подтверждения сразу нескольких визитов - должны оформляться по следующим правилам:
1. начало СМС берется до двоеточия
2. середина между двоеточием и точкой копируется по количеству визитов
3. конец смс всё, что после точки
Пример: "Вы записаны на прием: %dfio% в %h%:%mins% . Невский пр., д.1 (812)777-77-77". Для двух (например) визитов центральная часть будет скопирована, и получится: "Вы записаны на прием: Докторов Д.Д. в 10:00 и Лекарев Л.Л. в 10:30 . Невский пр., д.1 (812)777-77-77".

Право, дающее возможность отправлять врачу СМС из программы: rl_send_sms

Для разработчика:
create login sms_sender with password='ПАРОЛЬ'
go
create user sms_sender for login sms_sender
go
exec sp_addrolemember 'rl_sms_service', 'sms_sender'
go
-- Если login и user уже существуют (create user sms_sender for login sms_sender выдало ошибку), и надо их сопоставить
-- EXEC sp_change_users_login 'Update_One', 'sms_sender', 'sms_sender';


АДМИНИСТРИРОВАНИЕ

Возможности программы по отправке смс

Для отправки СМС из программы необходимо выполнить следующие шаги:

  1. Определиться, требуется ли получение ответов от пациентов. Пациенты могут присылать смс, например, для подтверждения визита, или для оценки качества обслуживания в клинике. Все провайдеры поддерживают отправку смс, но не все провайдеры поддерживают получение смс. Также, если необходимо получать ответы от пациентов, то номер клиники должен быть только цифровым, на буквенные имена ответ приходить не будет.
  2. Выбрать провайдера СМС. На данный момент (01.02.2017) доступны следующие провайдеры: SMS4B (доступен приём смс), Мегафон (доступен приём смс), ePochta и prostor. Зарегистрироваться, выбрать номер или имя, дождаться его подтверждения в личном кабинете. Оплатить услуги провайдера.
  3. Оплатить модуль СМС рассылки, при необходимости обновить программу на актуальную версию. Если выбранный смс провайдер не входит в приведенный выше список, необходимо согласовать стоимость и срок доработки модуля смс-рассылки, для возможности работать с выбранным провайдером.
  4. Настроить службу и константы согласно статье справки. Обычно установкой службы и начальными настройками занимается наш сотрудник, текстовые шаблоны и время отправки смс - настраивает Заказчик. Для настройки нужен доступ к личному кабинету, а также к серверу. Доступ к серверу для установки службы обработки СМС нужен с правами администратора (включая управление Локальными службами).

Все смс, когда-либо отправленные пациенту, или полученные от пациента, отображаются в сабформе "СМС" формы Пациентов. Отправленные смс отличаются от полученных цветом фона. Здесь же можно отправить пациенту индивидуальную смс, и посмотреть статус отправленных сообщений. На скриншоте ниже светло-желтым фоном выделены исходящие смс, светло-зеленым - входящие. Во входящих смс до символов "///" приводится текст смс пациента, после "///" описывается реакция системы (в данном случае - отметка визитов как (не)подтвержденных.

Все СМС делятся на три типа:

  • Сформированные вручную для пациентов. Такие СМС можно создавать: из формы Пациентов (вкладка СМС, зеленый плюсик слева), из формы Табличное представление пациентов (кнопкой в тулбаре) [image], из Записи (контекстное меню на визите), из Визита (контекстное меню на фио пациента). В Табличном представлении, смс можно послать как текущему пациенту (кнопка с зеленой иконкой в тулбаре), так и всем пациентам из выбранного списка (кнопка с красным телефоном в тулбаре).
    В форме Пациентов статус отправленного смс можно увидеть непосредственно в табличке смс. В Визите статус последнего отправленного смс отображается линией рядом с ФИО, зеленая линия означает успешную доставку, красная - ошибка, рыжая - смс отправлено, но еще не получено. В Записи и в Табличном представлении статус отправленного смс увидеть нельзя.
    При этом доступны шаблоны СМС, созданные для часто повторяющихся сообщений. Создать такие шаблоны можно добавив пользовательскую константу (от 500 до 600) с именем "ConstSmsText - Шаблон отправки смс №*" и значением, например, "Уважаемый(ая) %fio% Клиника "Доктор" напоминает о визите. Ждем Вас по адресу: ул.Здоровья, д.1". При отправке сообщения %fio% будет заменено на ФИО пациента.
    Пример: отправка смс из Визита:

  • Сформированные вручную для врачей. Можно создать из справочника Пользователи (из контекстного меню), из Визита (контекстное меню у выпадающего списка врачей). В визите статус отправки сообщения обозначается линией у соответствующего списка: красная - ошибка, зеленая - получено, рыжая - отправлено. Список этих сообщений доступен в форме "Сообщения". Естественно, смс можно отправить только тем врачам, у которых в справочнике пользователей указан телефон.
    При отправке смс и сообщений сотрудникам, форма отправки смс объединена с формой отправки сообщения.

    Пользователь вводит текст сообщения, и далее, с помощью галочек, указывает желательные способы доставки: в виде сообщения, отображаемого в запущенной программе адресата, или сообщение+смс.
  • Сформированные автоматически. Существуют следующие рассылки: подтверждение визита, рекламные акции, поздравления с днем рождения, приветствие нового пациента, оценка качества услуг. Все они управляются константами с номерами 900+, в которых можно включить рассылку, указать шаблон сообщения и время его отправки. Такие СМС отправляются ежедневно в диапазоне, настроенном в INI файле службы.

Существует два пользовательских отчета, предназначенных для анализа смс рассылки, "Смс рассылка - детализация" и "Смс рассылка - статистика".
Пример отчета "Смс рассылка - детализация":

Пример отчета "Смс рассылка - статистика":


АДМИНИСТРИРОВАНИЕ

Настройка службы планировщика задач

В данном разделе справки указаны шаги по настройке службы "CRM-Soft Планировщик задач".

Служба создана для того, чтобы по расписанию выполнять определенные действия с базой с возможностью выгружать результат в файл на диске или на FTP. Выполняется задача раз в заданный интервал времени, это может быть раз в X:

  • second - секунд
  • minute - минут
  • hour - часов
  • day - дней
  • week - недель
  • month - месяцев
  • year - лет

На данный момент реализованы следующие форматы данных (dbo.www_transfers.data_type):

  • xml - XML документ в первом поле результата, который берется как строка. Sql код берется из dbo.www_jobs.sql, допустимо использование параметров @d, @month_begin, @month_end в формате 'yyyy-mm-dd'.

На данный момент реализованы следующие протоколы (dbo.www_transfers.protocol):

  • file - сохраняет данные на диск по указанному в host пути и имени, если файл существует, то перезаписывает
  • ftp - сохраняет данные на FTP-сервере в корневой папке пользователя под именем, указанным в params (можно указать относительный путь)
  • napopravku - ведет обмен данными с веб-сервисом записи пациентов на прием НаПоправку

Служба "CRM-Soft Планировщик задач" проверяет изменение списка задач в таблице dbo.www_jobs каждые 10 минут, а необходимость запуска каждой из них раз в 10 секунд. Если при этом выполнение задач заняло много времени, то 10 секунд отсчитываются с момента окончания последней.
При возникновении ошибки в одной из задач служба записывает соответствующее событие в Журнал cобытий Windows и продолжает работу.
При добавлении задач в планировщик необходимо учесть, что на все объекты SQL-запроса у роли rl_www должны быть права. А значит лучше для каждой задачи создавать отдельную хранимую процедуру и выделять право на ее запуск.

Обработка ошибок

При возникновении ошибки выполнения задачи или её не запуске в положенное время создается сообщение, которое отправляется разработчику ПО, а также отвественному за задачу пользователю. Ответственного можно указать в соответствующем поле списка задач, если у него будет указан номер телефона и к системе подключен модуль отправки СМС, то дополнительно к сообщению в программе он получит короткое СМС уведомление. Если ответственный не указан, то всем онлайн пользователям будет выслано сообщение (без СМС), а также пользователям, которые запустят программу в день ошибки.

В списке задач также можно задать список электронных адресов для получения уведомлений об ошибке. Перечислять получателей необходимо через запятую. Сообщение отправляется один раз в день при появлении самой первой ошибки у задачи.

Как настроить обмен данными о визитах с сервисом НаПоправку:

  • Протокол указываем "НаПоправку-Визиты"
  • Сервер "api.napopravku.ru"
  • Порт "443"
  • Имя пользователя указываем присланное из сервиса, обычно это число до 1000
  • Пароль указываем присланный из сервиса, обычно это GUID
  • Частота обмена даннми 1 раз в минуту

Как настроить обмен данными о врачах с сервисом НаПоправку:

  • Протокол указываем "НаПоправку-Врачи"
  • Сервер "api.napopravku.ru"
  • Порт "443"
  • Имя пользователя указываем присланное из сервиса, обычно это число до 1000
  • Пароль указываем присланный из сервиса, обычно это GUID
  • Частота обмена даннми 1 раз в неделю

Ini-файл:
Файл настроек может быть расположен на любом диске, в фиксированной папке "crm-soft", расположенной в корне диска. Проверка идет по алфавиту и начинается с буквы C. Путь для поиска: X:\crm-soft\Tasks.ini. Описание каждого параметра описаны в самом INI-файле:

  • [db]
  • ;логин
    login=www_tasks
  • ;пароль
    password=123456
  • ;база данных
    database=g82
  • ;сервер
    server=DEVELOPERVM\SQLEXPRESS
  • ;убирает из строки коннекта опцию trusted connection, некоторые сервера с ней соединение не открывают
    no_trusted_connection=0
  • ;провайдер для связи с базой, значения как в осн. программе. max - выбор максимально доступного в системе
    provider=max

Для установки службы надо выполнить Tasks.ехе /install, для удаления Tasks.ехе /uninstall


АДМИНИСТРИРОВАНИЕ

Требования к компьютерам

(Для системных администраторов)

Программа состоит из базы данных MS SQL Server, и Windows-клиента.

Требования к серверу - любой новый компьютер с количеством ядер не менее 2-ух. Количество памяти не менее 3 Гб, и не менее (объем нужный операционной системе + 1.5 Гб). Мы обычно ставим MS SQL Express 2005 или 2008, в зависимости от операционной системы. MS SQL Express в любом случае использует не более 1 ядра, и не более 1 Гб памяти, поэтому усердствовать с увеличением количества ядер и с объемом памяти смысла нет. Подходят любые винды, начиная с XP. Рэйд не обязателен, но обязательно наличие как минимум двух отдельных дисков, так чтобы на одном из дисков работала система и хранилась рабочая версия данных, а на втором хранились бэкапы. Если есть рэйд, наличие отдельного диска под бэкапы все равно желательно. Желательно, чтобы сервер не использовался в качестве рабочей станции. Если сервер будет использоваться для каких-либо прочих нужд - желательно обсудить этот вопрос по телефону.

Установкой/настройкой SQL Server обычно занимается наш сотрудник.

К серверу нужен удаленный доступ (RDP, можно teamviewer или radmin). Желательно, чтобы у сервера был статический ip.

На втором (не системном) диске сервера нужны папки *:\CRM-Soft\ и *:\CRM-Soft\CRM-Soft-public. Папка *:\CRM-Soft\CRM-Soft-public должна быть расшарена, и доступна на чтение с любого из компьютеров сети.

Все компьютеры, на которые будет установлена программа, должны быть подключены к сети. Если в сети используется WiFi, надо предупредить об этом разработчика.

По объему - объем базы измеряется в единицах гигабайт. Каждое первое число месяца, и иногда вручную, снимаются полные резервные копии, объем которых равен текущему объему базы. Каждый день утром снимается дифференциальная копия, объем которой (грубо говоря) примерно 10% от текущего объема данных. Соответственно, нужно место под хранение резервных копий, на втором (не системном) диске.

При настройке системы, можно выбрать хранение объемных рисунков, и других "внешних" документов (если они будут нужны клиенту) внутри базы, либо во внешней папке на сервере. Если клиент выберет сохранять рисунки и объемные документы во внешнюю папку, то нужно будет организовать эту внешнюю папку, и доступ к ней из сети. К этой папке нужен будет доступ из сети на чтение/запись. Вынесение объемных рисунков во внешнюю папку практикуется, если есть риск не уложиться в стандартное ограничение бесплатной версии MS SQL Express по объему (4-10 Гб данных на диске, в зависимости от редакции). При начальной установке, такая папка обычно не делается.

Требования к клиентским компьютерам:

  • Не менее 2 ГБ оперативной памяти (4 ГБ предпочтительнее)
  • Видеокарта и монитор, поддерживающие режим не менее чем 1280*1024
  • Процессор не менее чем двухядерный с частотой не менее 2,5 ГГц

Требования к серверу:

  • 4 Гб или более оперативной памяти. Требуемуое количество памяти = количество памяти для оперативной системы + 2 Гб, например для Windows Vista минимум 4 Гб оперативной памяти.
  • Процессор не менее чем двухядерный пентиум с частотой не менее 2,5 ГГц
  • Желательно отдельный жесткий диск для хранения бэкапов.

При наличии установленного антивируса, файервола, Mail.Guard или подобных программ, необходим более быстрый процессор и больший объем оперативной памяти.

Практика показывает, что бесплатной версии MS SQL Server Express Edition обычно хватает примерно для систем с количеством рабочих мест примерно до 20. От 20 рабочих мест может потребоваться покупка полнофункционального MS SQL Server.

В случае использования MS SQL Server Express Edition с системой до 15 рабочих мест, характиристики сервера не принципиальны. В случае 15-25 рабочих мест, рекомендуется брать сервер с максимально производительными ядрами и тактовой частотой. Кол-во ядер в случае использования Express Edition не важно.

Если в системе до 10 рабочих мест, возможно совмещение сервера и клиентского рабочего места.

Для терминального сервера, требования к серверу определяются системным администратором, так как обычно программа является не самым "тяжелым" приложением, из тех с которыми работают пользователи. Собственно программа потребляет обычно порядка 50 Мб оперативной памяти, и назначительный процент от мощности процессора.


АДМИНИСТРИРОВАНИЕ

Автоматическое обновление программы

Для настройки автоматического обновления приложения необходимо скопировать в любую папку на диске два файла: CRM-Soft-upd.exe и updater.ini. Копирование CRM-Soft-upd.exe между компьютерами лучше производить в архиве, т.к. Windows помечают поступившие извне ехе файлы как чужеродные, и потом постоянно предупреждают пользователя об опасности. После копирования следует отредактировать ini-файл, указав следующие общие параметры:

  • copy_to_path - путь к локальной папке с установленной программой, должен заканчиваться на слеш. Если не указан, то апдейтер сохраняет файлы в текущую папку.
  • WriteToLog - записывать действия в лог-файл, возможные значения 1 и 0
  • WriteToDlg - выводить диалоговые окна при действиях, возможные значения 1 и 0
  • Autostart - запускать основное приложение после проверки обновления, возможные значения 1 и 0
  • TestAlwaysCopy - обновлять приложение даже если оно не изменилось, возможные значения 1 и 0
  • UseDbConnect - использовать базу данных для поиска обновлений, возможные значения 1 и 0

Желательно, чтобы был включен хотя бы один из флагов WriteToLog или WriteToDlg

При UseDbConnect = 0, апдейтер берет новую версию основной программы из сетевой папки. При UseDbConnect=0 мы часто сталкивались с недоступностью сетевой папки, и прочими проблемами доступа. Поэтому UseDbConnect=0 считается устаревшей опцией, и использовать опцию не рекомендуется. При обновлении из сетевого пути, должны быть заданы следующие параметры:

  • copy_from_path - путь с именем файла откуда брать новую версию
  • copy_all_files_in_folder - копировать все файлы из папки, возможные значения 1 и 0
  • net_login - логин сетевого пользователя для доступа к папке из copy_from_path, если необходим
  • net_pass - пароль сетевого пользователя для доступа к папке из copy_from_path, если необходим

При UseDbConnect = 1, апдейтер подключается к базе данных, и получает новую версию основной программы из SQL Server. При этом должны быть заданы следующие параметры:

  • DbServer - имя сервера откуда брать новую версию
  • DbName - имя базы данных
  • DbLogin - логин к базе данных
  • DbPass - пароль к базе данных

И по желанию заполнена секция [files] списком файлов для обновления. Если секцию оставить пустой, то при обновлении возьмутся все файлы из базы.

Если при запуске автоматического обновления не будет найдено конфигурационного файла updater.ini, то будет произведена попытка обновления с использованием файла med.ini, если он будет найден в текущей папке.

Пример конфигурационного файла:

[updater]
;куда копировать, не заполнено=использовать текущую папку
copy_to_path=
;писать ошибки в лог
WriteToLog=1
;выводить ошибки на экран
WriteToDlg=1
; запускать после работы основной файл
autostart=1
;копировать всегда (0 - работать в штатном режиме)
TestAlwaysCopy=0

;откуда копировать
copy_from_path=c:\crm-soft\update\crm_soft_norv.exe
;копировать все файлы в папке и её подпапках
copy_all_files_in_folder=1
;сетевой логин, если нужен
net_login=
;сетевой пароль, если нужен
net_pass=

[db]
UseDbConnect=1
DbServer=DEVELOPERVM\SQLEXPRESS
DbName=g89
DbLogin=sa
DbPass=123456

; Список файлов для обновления из базы, первым ОБЯЗАТЕЛЬНО указывать EXE
[files]
1=crm_soft_norv.exe
2=crm-soft-med.chm
3=med.ini

При настройке обновления на сервере, создаем в SQL Server скриптом отдельного пользователя, который будет иметь права только на то, чтобы загрузить из SQL Server новую версию основной программы. То есть доступ на чтение к таблицам exe_file и constants. Его и указываем в ini как логин/пароль обновления. Делать разные пароли для разных клиентов - желательно, но не обязательно.

Скрипт для создания такого пользователя представлен ниже (выполнить в Sql Management Studio) однократно.

create login updater with password='5(65FfGq)O-a', CHECK_POLICY = OFF, CHECK_EXPIRATION = OFF
go
use имя_базы_клиента
go
create user updater for login updater
go
grant select on dbo.exe_file to updater
grant select on dbo.constants to updater
go

Таким образом, на сервере:
  1. Выполняем скрипт, создающий пользователя crm_soft_updater.
  2. При каждом обновлении ехе, запускаем новую версию ехе под sa, и нажимаем “Администрирование - Обновить размер и дату исполняемого модуля”. При этом в базе сохраняется текущий ехе (т.е. та версия программы, которую мы сейчас запустили).
На клиенте:
  3. На каждого клиента однократно копируем Updater.exe, и настроенный updater.ini. Желательно класть Updater.exe в ту же папку, где лежит программа, чтобы избежать возможной ситуации, когда Updater.exe не сможет создать лог-файл из-за отсутствия соотв. доступа.
  4. На каждом клиенте вместо файла crm_soft_***.ехе запускаем Updater.exe (параметр autostart должен быть равным 1). И ярлык запуска программы на рабочем столе делаем для Updater.exe.
Тестирование на сервере:
  5. При желании, можно скопировать Updater.exe в какую-либо тестовую папку на сервере, и настроить updater.ini, чтобы новая версия ехе копировалась в эту тестовую папку. В этом случае, после нажатия “Администрирование - Обновить размер и дату исполняемого модуля”, можно вручную запустить Updater.exe в тестовой папке, и убедиться что ехе действительно обновляется.

При обновлении версии, обязателен только п.2. Пункт 5 - по желанию. Пункты 1,3,4 - только при начальной настройке.


АДМИНИСТРИРОВАНИЕ

Установка программы на новый компьютер

Статья предназначена для системных администраторов.

Обычно на начальном этапе внедрения системы файлы программы размещаются в общедоступной папке. В автозагрузку пользователя вставляется командный файл, копирующий на компьютер пользователя новую версию программы и справки при каждом запуске системы.

Для правильного функционирования программы достаточно трех файлов:

  • crm-soft.exe - исполняемый файл программы
  • med.ini - файл настроек для доступа к базе данных. В файле указываются четыре основных параметра, требуемых для установления связи с sql-сервером: имя сервера, название базы данных, логин и пароль пользователя. Если имя сервера или название базы данных в med.ini указаны неверно, следует выйти из программы и задать правильные значения. Если невозможно соединиться с сервером, используя указанные логин и пароль, программа предоставит возможность задать их повторно. Таким образом, например, для предотвращения несанкционированного доступа к программе возможно не указывать логин и пароль (или только пароль) в файле med.ini. В базе данных всегда существует учетная запись пользователя "sa" с паролем, установленным администратором базы данных. Ее можно использовать для задания логина и пароля других пользователей. Дополнительную информацию можно посмотреть в разделе справки Справочник "Пользователи".
  • crm-soft-med.chm - файл справки. Файл справки, единственный из всех, может не находится непосредственно в каталоге программы. Путь к нему можно задать, изменив константу "Путь к файлу справки" в справочнике "Константы". Путь может быть абсолютным и относительным. Например, d:\help\crm-soft-med.chm или \help\crm-soft-med.chm. При указании относительного пути первый "\" обязателен, т.к. программа будет искать файл справки, начиная с текущего каталога: "d:\med" + "\help\crm-soft-med.chm" - "d:\med\help\crm-soft-med.chm".

Крайне рекомендуется проверить версию драйверов доступа к серверу базы данных, как это сделать Вы можете прочитать в статье "Обновление драйверов, используемых программой для связи с сервером"


АДМИНИСТРИРОВАНИЕ

Обновление драйверов, используемых программой для связи с сервером

(Для системных администраторов)

Для связи с сервером, программа по умолчанию использует стандартные драйвера, поставляемые с Windows. Иногда бывает, что стандартные виндовые dll работают с ошибками. Чаще всего это проявляется в проблемах с печатью. Если при попытке отправить отчет, или печатную форму на печать, компьютер зависает, следует выполнить описанные далее действия.

В первую очередь, на проблемном компьютере в файле настроек med.ini добавляем строчку "provider=max". Эта строчка скажет программе использовать самую современную версию из имеющихся в системе драйверов.

Открыть в программе пункт меню "Помощь" - "О программе". Если в строке "Провайдер" написано "OLE DB", то это означает что драйвера старые, и их надо обновить.

Далее, надо загрузить с сайта Майкрософта пакет (заплатку) "SQL Server Native Client". Файл обычно называется "sqlncli.msi". Есть много версий sqlncli.msi: от 2005 SQL Serer, от 2008, от 2008 R2, от 2012. Различаются версии для 64 разрядной системы, и для 32 разрядной. Пытаться установить можно любой из пакетов, начиная с 2005 и более поздние. При попытке установить несовместимый с компьютером пакет, Вы получите сообщение типа "данная ОС несовместима ...", или "процессор этого компьютера несовместим...", и установка выполнена не будет. Если установка завершилась успешно, то в программе в меню "Помощь" - "О программе" должно измениться содержание строки "Провайдер".


АДМИНИСТРИРОВАНИЕ

Справочник "Константы"

В данном разделе справки перечислены константы и параметры, влияющие на работу программы, одинаковые для всех пользователей или для всех пользователей выбранной клиники.

Если к программе подключен дополнительный модуль "Клиники", то на форме становится доступен выпадающий список "Редактировать константы для клиники". В конце списка перечислены все клиники, зарегистрированные в базе данных. Выбрав клинику, можно переопределить для нее значения констант. При добавлении константы для конкретной клиники досточно заполнить поле с номером константы. При этом название константы подставится автоматически.

Первые два значения в выпадающем списке выбора констант для клиники фиксированы. "По умолчанию" - позволяет редактировать список констант, одинаковых для всех пользователей всех клиник, если их значения не переопределены для конкретной клиники. "Все, кроме констант по умолчанию" - позволяет редактировать переопределенные для клиник константы. В этом случае становится виден столбец с названием клиники.

Если в программе не разрешена работа с клиниками, то на форме отображаются все константы, значения которых будут одинаковыми для всех пользователей программы.

Если значение поля "Служебное" равно "Да", то видимость такой записи определяется константой 259 - "Администрирование - Отображать служебные константы".

Далее приведен полный список названий констант:

  • "Администрирование - www техподдержки" - используется в меню "Помощь", для перехода к сайту учета обращений в техподдержку
  • "Администрирование - В заголовке программы выводить название" - название, которое будет выведено в заголовке программы. Название по умолчанию - "Учет пациентов".
  • "Администрирование - Вести историю изменения прейскуранта" - сохранять информацию об изменении прейскурантов. Просмотр изменений доступен из меню "Администрирование".
  • "Администрирование - Включена работа с кабинетами (константу разрешено менять только разработчику)" - используется только разработчиком в хранимых вычислениях.
  • "Администрирование - Включена работа с несколькими клиниками (константу разрешено менять только разработчику)" - используется только разработчиком в хранимых вычислениях.
  • "Администрирование - Пользовательские отчеты - Путь к файлам *.fr3" - путь к папке с файлами пользовательских отчетов.
  • "Администрирование - прикрепленные файлы хранить внутри базы (нет = во внешней папке)" - задает способ хранения файлов, прикрепленных к пациентам, врачебным документам и страховым компаниям.
  • "Администрирование - Путь к сетевой папке для хранения ДМС документов" - путь к папке с файлами документов страховых компаний.
  • "Администрирование - Путь к сетевой папке для хранения файлов" - путь к папке с файлами, прикрепленными к пациентам и врачебным документам.
  • "Администрирование - путь к файлу справки" - абсолютный - начинающийся с названия компьютера или логического диска (например, d:\help\crm-soft-med.chm) или относительный - заданный относительно каталога, в котором находится программа (например, \help\crm-soft-med.chm) путь к файлу справки.
  • "Администрирование - Телефоны техподдержки (отображаются в меню "Помощь - О программе")" - телефоны техподдержки.
  • "Администрирование - Цвет фона справочника в режиме запрета редактирования" - цвет фона таблицы с данными в различных формах в режиме запрета редактирования. По умолчанию - розовый.
  • "Администрирование - Цвет фона справочника в режиме редактирования" - цвет фона таблицы с данными в различных формах в режиме редактирования. По умолчанию - желтый.
  • "Администрирование - Экспорт ТМЦ в 1С - Выгрузку сохранять в директории" - папка для сохранения данных для 1С. Выгружаемые данные формируются индивидуально для каждого клиента при наличии подключенного модуля "Выгрузка в 1С".
  • "Администрирование - Включена работа с неск.клиниками (константу разрешено менять только разработчику)" - используется внутри программы и в хранимых процедурах. Изменение константы запрещено.
  • "Администрирование - Включена работа с кабинетами (константу разрешено менять только разработчику)" - используется внутри рограммы и в хранимых процедурах. Изменение константы запрещено.
  • "Администрирование - Протоколировать SQL выражения запускаемых отчетов (отладка)" - используется в хранимых процедурах. Изменение константы запрещено.
  • "Администрирование - Спрашивать у пользователя подтверждение при закрытии программы"
  • "Администрирование - Вести отдельный лог ошибок для каждого пользователя (актуально для терминальных клиентов)" - лог ошибок программы формируется в отдельном файле для каждого пользователя
  • "Администрирование - Отображать служебные константы" - влияет на отображение списка констант в зависимости от значения поля "Служебное". Если значение константы равно "Нет", то увидеть данную константу в списке и изменить ее значение может только пользователь "sa".
  • "Администрирование - Скрывать информацию о ДМС"
  • "Визит - Выводить в шапке 2-ого врача (ассистента)" - отображение дополнительного выпадающего списка для выбора врача/ассистента
  • "Визит - В графе "Врач 2" отображать всех пользователей (Нет = только работающих врачей)"
  • "Визит - Выводить фактическое время начала/окончания приема" - отображение информации о фактическом времени начала/окончания приема
  • "Визит - Если размер экрана позволяет, растягивать форму Визит по горизонтали" - автоматическое растягивание формы по горизонтали
  • "Визит - Извещать врачей о приходе пациента за Х дней (пусто=не извещать)" - отображение информации извещен ли врач о приходе пациента в форме "Запись" и "Визит".
  • "Визит - Нумерация договоров: Да=нумеруются при печати, Нет=номер договора совпадает с номером медкарты" - Если константа равна "Да" - все услуги визитов пациента за день с типом оплаты "Наличные" попадают в один договор. Документ формируется на основании услуг договора. В противном случае, в документ попадают только услуги выбранного визита.
  • "Визит - Отображать поле "Является курсом" - отображение информации о типе курса лечения для визита
  • "Визит - Отображать сабформу списания ТМЦ" - показывать/скрывать сабформу "ТМЦ" в форме "Визит".
  • "Визит - Пользователям разрешается вручную изменять процент скидки"
  • "Визит - Пользователям разрешается редактировать цены (Нет=цены строго из прейскуранта)"
  • "Визит - При добавлении визита/услуг автоматически ставить максимальную возможную скидку"
  • "Визит - При изменении скидки Визита обновлять скидки всех услуг (Нет=только новых услуг)"
  • "Визит - При нажатии на кнопку с принтером в списке назначений печатать Печатную форму" - название шаблона печатной формы, который будет напечатан при нажатии на кнопку
  • "Визит - При нажатии на кнопку с принтером в списке услуг печатать Печатную форму" - название шаблона печатной формы, который будет напечатан при нажатии на кнопку
  • "Визит - При сохранении Визита с пустым списком услуг предлагать удалить визит"
  • "Визиты - Назначения: в списке услуг отображать только назначенные, без фактически оказанных"
  • "Визиты - Запрещать оплату визитов со статусом "Предварительная запись"
  • "Визит - В графе "Врач 2" отображать всех пользователей (Нет = только работающих врачей)"
  • "Визит - Отображать колонку "Коэффициент сложности" (наценку)" - отображение дополнительного поля в гриде "Услуги" формы "Визит"
  • "Визиты - По умолчанию считать оказанные услуги оплаченными (кроме ДМС)"
  • "Визит - Отображать неделю беременности, и стадию менструального цикла" - отображение дополнительных полей в шапке формы "Визит"
  • "Визит - Отображать закладку "Переводы" - показывать/скрывать сабформу "Переводы" в форме "Визит"
  • "Визит - Выводить поле "Примечание" - показывать/скрывать поле в сабформе "Услуги" формы "Визит"
  • "Визит - Отображать в списке услуг номер зуба, отображать ассистента, отображать зуб и МКБ в назначениях" - отображение дополнительных полей в шапке и сабформе "Услуги" формы "Визит"
  • "Визит - Выводить в шапке 3-его врача (ассистента)"
  • "Визит - Запрещать одновременную запись пациента к нескольким врачам"
  • "Визиты - Отображать закладку со списком услуг в ленточной форме"
  • "Время изменения записи выводить: Да=черным стандартным шрифтом, Нет=мелким коричневым" - цвет и размер информационных надписей в форме "Визит".
  • "Выбор услуги - при быстром выборе показывать список услуг врача за последние Х дней" - в форме выбора услуги показывать услуги, оказанные текущим врачом за последние Х дней.
  • "Выбор услуги - При щелчке на услугу выводить внизу формы цену согласно текущему прайсу"
  • "Выбор услуги - При щелчке на услугу выводить полное название услуги внизу формы"
  • "Генеральный директор" - ФИО руководителя
  • "Главный бухгалтер" - ФИО главного бухгалтера
  • "ДМС - Отображать информацию о взаиморасчетах с ДМС компаниями" - отображение сабформ "Документы" и "Оплаты" в форме "Страховые компании".
  • "ДМС - Делить юридические лица по виду оплаты (постоплата / предоплата)"
  • "Документы - Если к документу прикреплен графический файл, печатать прикрепленный рисунок при печати документа"
  • "Документы - Если пользователь открыл из программы рисунок, проверять наличие изменений раз в Х секунд" - интервал времени для отслеживания изменений при редактировании файлов, прикрепленных к врачебных документам или пациенту
  • "Документы - При вставке из словаря, вставлять 1=Код+Расшифровка (название), 2=Только расшифровка"
  • "Документы - Сотрудники видят только документы из запроса" - название таблицы или представления, из которого берутся данные для отображения в форме документы
  • "Документы - Цвет строчки 1 в навигационном списке документов" - цвет нечетной записи в навигационном списке документов в форме "Документы"
  • "Документы - Цвет строчки 2 в навигационном списке документов" - цвет четной записи в навигационном списке документов в форме "Документы"
  • "Документы - Цвет выделения для списков замены (слов в ## для вызова словаря)"
  • "Документы - Вызов списков замены во врачебных документах - по одинарному щелчку на слово в ## (Нет=двойной щелчок)"
  • "Документы - Отображать кнопку "Печать консультативного заключения" - печать части врачебного документа, начиная со слов «Диагноз:» и до конца документа, с добавлением шапки из шаблона печатной формы со специальным режимом печати "Консультативное заключение"
  • "Документы - "Печать консультативного заключения" печатать документ до абзаца, начинающегося на слово" - вместе со следующей константой задает часть текста документа, который будет выведен при печати консультативного заключения
  • "Документы - "Печать консультативного заключения" печатать документ начиная со слова" - вместе со предыдущей константой задает часть текста документа, который будет выведен при печати консультативного заключения
  • "Документы - Включать проверку орфографии (0=отключить полностью, 1=ручная, 2=автоматически)" - задает режимы проверки орфографии при просмотре шаблонов и врачебных документов
  • "Документы - При щелчке на список замен, текст текущего пункта должен отображаться под списком"
  • "Долги - Группировать долги: В=по врачам,К=по курсам,Б=без группировки (константу разрешено менять только разработчику)" - используется только разработчиком в хранимых вычислениях
  • "Доступ - Врачи могут редактировать Визиты в течение Х дней (Пусто=без ограничений)" - количество дней после которых врачи не смогут редактировать визиты.
  • "Доступ - Запретить всем (кроме сотрудников с полным доступом) возможность экспорта печатных форм" - запрет экспорта отчетов сотруднкиам, не обладающим необходимыми правами
  • "Запись - Выводить маркеры в 2 колонки" - отображение маркеров дополнительной информации о визите в две колонки
  • "Запись - Высота заголовка колонок (в пикселях, пусто=по умолчанию)"
  • "Запись - детализацию визита в шапке отображать: 1=наведении мышки, 2=при щелчке"
  • "Запись - запрет на нерабочее время 1=запрет,2=предупр.при создан,3=разреш.,4=пред.каждое откр./сохр." - влияет на поведение программы при редактировании визитов пациентов.
  • "Запись - количество столбцов" - количество столбцов, отображаемых в форме "Запись". Минимальное количество столбцов - 7, максимальное - 14.
  • "Запись - Количество колонок равно кол-ву врачей (кабинетов) в закладке" - количество отображаемых в форме "Запись" столбцов будет равно количеству врачей/кабинетов в выбранной закладке, но не больше 14.
  • "Запись - Между утренней и вечерней сменой доп.зазор Х пикселей" - расстояние между ячейками формы "Запись", относящимися к разным сменам
  • "Запись - Отображать визиты со статусом "Не пришел"
  • Запись - Панель редактирования пациента (1=авт.сохранение 2=спрашивать 3=удалять изменения)" - влияет на поведение программы при изменении данных в панели редактирования пациента формы "Запись".
  • "Запись - Период автообновления (сек)" - период обновления формы "Запись"
  • "Запись - по умолчанию открывать режим (1=Врачи день, 2=Кабинеты день, 3=Врач неделя, 4=Каб.неделя)" - выбор режима при первом открытии формы "Запись".
  • "Запись - Подпись к триединой анкете (только Меди Эстетик)"
  • "Запись - Подсветка по умолчанию: Авто=в зависимости от режима, Статус, Врач" - выбор варианта подсветки при первом открытии формы "Запись".
  • "Запись - пользователь может печатать документы которые обычно печатаются из формы Пациенты" - в форме "Запись" пользователь может дополнительно печатать документы на основе шаблонов из справочника "Шаблоны печатных форм", у которых в поле "Тип шаблона" стоит значение "Пациенты".
  • "Запись - При копировании визитов копировать список услуг визита" - при копировании визита через контекстное меню копировать или нет информацию об услугах визита
  • "Запись - при печати расписания врача выводить: 1=коды оказанных услуг, 2=названия, 3=ничего" - дополнительная информация, выводимая при печати расписания врача в форме "Запись".
  • "Запись - при печати расписания врача выводить даты полисов пациентов"
  • "Запись - при печати расписания врача выводить название ДМС компаний пациентов"
  • "Запись - при печати расписания врача выводить телефоны пациентов"
  • "Запись - при печати расписания врача выводить номер медицинской карты перед ФИО"
  • "Запись - при сохранении визита ДМС пациента с незаполненным диспетчером выдавать предупреждение" - если для пациента, заключившего договор со страховой компанией, в форме "Визит" не указан диспетчер, то при выходе из формы пользователь получит предупреждение.
  • "Запись - В контекстном меню блокировать выбор статуса "Пришел" (только через форму)" - запрет на изменение статуса визита на "Пришел" через контекстное меню в форме "Запись".
  • "Запись (оформл.) - выводить строки, не помещающиеся по высоте (1=Да 2=Нет 3=Если видно более 50% по высоте)" - задает режим отображения текста в ячейках формы "Запись". Одна строчка (или ее часть) будет отображена в любом случае.
  • "Запись (оформл.) - Жирность шрифта (0=стандартный, 1=жирный)" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - размер шрифта" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - цвет шрифта" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - цвет шрифта для врача по умолчанию" - влияет на стиль текста, отображаемого в ячейках формы "Запись".
  • "Запись (оформл.) - Цвета врачей брать из таблицы врачей (Нет=генерировать автоматически)" - в случае выбора варианта подсветки "Врач" цвет ячейки будет браться из таблицы "Пользователи" или генерироваться автоматически.
  • "Запись (оформл.) - ширина пиктограмм (в пикселях)" - ширина рисунков в левой части ячеек формы "Запись".
  • "Запись (оформл.) - ширина рамки в пикселях" - толщина рамки при выделении ячейки в форме "Запись".
  • "Запись (текст) - выводить N медкарты перед ФИО пациента"
  • "Запись (текст) - Выводить время в пустых клетках записи на прием" - отображать время в пустых клетках в форме "Запись".
  • "Запись (текст) - выводить время перед ФИО пациента"
  • "Запись (текст) - Выводить номер телефона пациента"
  • "Запись (текст) - при выводе ФИО пациента сокращать имя-отчество (Иванов И.И. вместо Иванов Иван Иванович)"
  • "Запись (текст) - расписание по кабинетам, белые клетки: 1=выводить спец.врача, 2=сокращенно, 3=не выводить"
  • "Запись (текст) - расписание по кабинетам, цветные клетки - выводить ФИО врача"
  • "Запись (текст) - Расписание по кабинетам, цветные клетки: 1=выводить спец. врача, 2=сокращенно, 3=не выводить"
  • "Запись на прием - Визуализировать запрещающие правила (нерабочее время) в виде квадратиков (только Меди Эстетик)"
  • "Запись на прием - свободное время закрашивать белым (нет=закрашивать цветом врача по умолчанию)" - в режиме "Кабинеты на день" или "Кабинеты на неделю" ячейка закрашивается белым цветом или цветом врача, определенным в форме "Пользователи".
  • "Запись - При печати расписания врача выводить комментарии к оказанным услугам (код услуги+комментарий)"
  • "Запись - При печати расписания врача выводить название курса"
  • "Запись - При печати расписания врача выводить диспетчера ДМС, с которым согласовывался визит"
  • "Запись - При печати "Реестра услуг визита" отображать заголовок" - текст заголовка в отчете "Реестр услуг визита"
  • "Запись - Время утренней смены (кнопка с солнышком)" - время утренней смены в формате "00:00 - 15:00". Используется в форме "Запись" для переключения режисов просмотра.
  • "Запись - Время вечерней смены (кнопка с луной)" - время вечерней смены в формате "14:00 - 21:00". Используется в форме "Запись" для переключения режисов просмотра.
  • "Запись - Полное время работы" - полное время работы клиники в формате "00:00 - 21:00". Используется в форме "Запись" для переключения режисов просмотра.
  • "Запись - В контекстном меню отображать пункт "Копировать бригаду", "Вставить бригаду"
  • "Запись - Возможность наверху формы выбрать услугу, на которую хочет записаться пациент"
  • "Запись - При печати расписания врача выводить комментарий из визита"
  • "Извещения - Выполнять проверку наличия извещений раз в Х секунд" - интервал проверки наличия извещений.
  • "Курсы лечения - При открытии выводить информацию с даты визита минус Х месяцев (пусто=без фильтра)" - при открытии формы "Список курсов/визитов" отображать данные за последние Х месяцев, начиная с даты визита.
  • "Курсы лечения - При печати "Предписано в рамках курса лечения" добавлять внизу подпись" - подпись, добавляемая в конец отчета "Предписано в рамках курса лечения".
  • "Курсы - При печати "Предписано в рамках курса лечения" добавлять внизу подпись" - подпись внизу отчета "Предписано в рамках курса лечения"
  • "Оплата (касса) - выводить "Всего получено наличных за день" - в форме "Оплата" выводится дополнительная информация: "Всего получено наличных за день" - сумма услуг за сегодняшний день с учетом сторнированных услуг.
  • "Оплата (касса) - Номер порта фискального регистратора"
  • "Оплата (касса) - Печатать дубликаты чеков"
  • "Оплата (касса) - При печати нескольких дубликатов чеков, останавливаться после каждого дубликата" - в случае печати нескольких дубликатов чека, после завершения печати каждого дубликата печать будет остановлена и продолжена только после нажатия кнопки OK.
  • "Оплата (касса) - При печати нескольких чеков сразу, останавливаться после каждого чека" - в случае печати нескольких чеков, после завершения печати каждого чека печать будет остановлена и продолжена только после нажатия кнопки OK.
  • "Оплата (касса) - Скорость обмена данными с фискальным регистратором"
  • "Оплата (касса) - Частота обновления списка пациентов (секунды)" - частота обновления информации о услугах, оказанных пациенту в форме "Оплата услуг".
  • "Оплата - Печать чека - Выводить название услуги и цену на 1 строке" - влияет на формирование чека.
  • "Оплата - Печать чека - Выводить ФИО пациента" - влияет на формирование чека.
  • "Оплата - Печать чека - ограничивать кол-во выводимых символов в названии артикула (0=не ограничивать)" - влияет на формирование чека.
  • "Оплата - Печать чека - разбивать название артикула на строки (0=Нет переноса 1=По словам 2=По строке)" - влияет на формирование чека.
  • "Отображать "Отчет по рекламным каналам" в отчетах" - отображение отчета по рекламным каналам в меню "Отчеты"
  • "Отчет ДМС - Во 2 версии отчета выводить N договора после названия страховой компании"
  • "Отчет ДМС - Заголовок отчета"
  • "Отчет ДМС - Название клиники" - используется при формировании отчета "Страховые"
  • "Отчет ДМС - Подпись внизу отчета" - используется при формировании отчета "Страховые"
  • "Отчет ДМС - Показывать поля ввода N и даты счета в форме настроек"
  • "Отчет ДМС - После ФИО пациента, через запятую выводить номер карты"
  • "Отчет ДМС - телефон фирмы" - используется при формировании отчета "Страховые"
  • "Отчет ДМС - шапка для отчета v3" - используется при формировании отчета "Страховые".
  • "Отчет ДМС - используемая по умолчанию версия отчета (только при первом открытии формы)"
  • "Отчеты - "Сводная ведомость по врачам за месяц" - версия по умолчанию"
  • "Отчеты - В сводном отчете сумму возвратов брать: Да=из таблицы оплат (нет кассы) Нет=из протокола кассы" - откуда берется сумма возврата в отчете "Сводный отчет".
  • "Отчеты - Используемая версия кассового отчета"
  • "Отчеты - Отображать "Кассовый отчет"
  • "Отчеты - Отображать "Сводный отчет" в списке отчетов"
  • "Отчеты - Отображать отчет "Сводная ведомость по врачам за месяц в списке отчетов"
  • "Отчеты ДМС - используемая по умолчанию версия отчета "реестр операций" (при первом открытии формы)"
  • "Отчет "Дни рождения" - Выводить с адресом" - вывод в отчете "Дни рождения" адресов пациентов
  • "Отчет "Продажи" - Округлять суммы полученных денег (0=до рубля, 2=до копейки)"
  • "Отчет "Продажи" - Выводить сначала детализацию, потом промежуточные итоги"
  • "Отчет "Продажи" - Размер шрифта, которым выводятся итоги"
  • "Отчет "Продажи" - Группировать возраста с шагом 5 лет (Да = 5 лет, Нет = каждый год отдельно)"
  • "Отчет "Продажи" - Выводить информацию о % соотношении количеств по строке к общей сумме по отчету"
  • "Оплата - при работе с ФР допускать оплату через терминал" - возможность указывать тип оплаты "Терминал" при использовании фискального регистратора
  • "Пациенты - VIP статус имеет 5 градаций (нет=2 градации, галочка)" - VIP статус выбирается из списка либо галочкой.
  • "Пациенты - В переводах тип перевода по умолчанию" - числовое значение типа перевода по умолчанию при вводе новой записи в сабформе "Переводы" формы "Пациенты" (1 - Продажа сертификата, 2 - Использование сертификата, 3 - Списание долга, 4 - Внесение/возврат наличных, 5 - Перевод на другого пациента, 6 - Перевод от юрлица)
  • "Пациенты - включить автоопределение пола на основании ФИО"
  • "Пациенты - Выбирать рекламные каналы одним щелчком"
  • "Пациенты - Выводить закладку "Медкарты"
  • "Пациенты - Выводить информацию о лимите оплаты ДМС услуг"
  • "Пациенты - Выводить количество визитов/получено денег за последний год" - отображение дополнительной информации в правой части формы
  • "Пациенты - Задержка в миллисекундах перед отправкой запроса на обновление списка пациентов (пусто=без задержки)" - задержка при обновлении навигационного списка в случае фильтра по ФИО пациента
  • "Пациенты - Нумерация договоров: 1=каждый год заново, 2=непрерывная"
  • "Пациенты - Отображать галочку "Наличие машины"
  • "Пациенты - Отображать закладку "Визиты"
  • "Пациенты - Отображать закладку "Оплаты"
  • "Пациенты - Отображать закладку "Скидки"
  • "Пациенты - Отображать поле "email"
  • "Пациенты - Отображать поле "Аллергии"
  • "Пациенты - Отображать поле "Глава семьи"
  • "Пациенты - Отображать поле "Группа крови"
  • "Пациенты - Отображать поле "Заболевания" (гепатит)"
  • "Пациенты - Отображать поле "Место работы"
  • "Пациенты - Отображать поле "Основной диагноз"
  • "Пациенты - Отображать поле "Рассылка смс разрешена"
  • "Пациенты - Отображать поле "ФИО родителя"
  • "Пациенты - Отображать время и место рождения"
  • "Пациенты - Отображать поле "Архив"
  • "Пациенты - отображать поле "Профессия, должность"
  • "Пациенты - Отображать строчку с описанием ДМС компании (N и даты договора)
  • "Пациенты - Раздельный учет фамилии имени отчества" - в форме "Пациенты" отображаются либо поля "ФИО" и "Телефон", либо поля "Фамилия", "Имя", "Отчество", "Телефон", "Телефон 2", "Телефон 3".
  • "Пациенты - Телефон должен соответствовать маске +*(***) ***-**-**" - телефон пациента должен соответствовать шаблону, например, +8(921)1234-56-78.
  • "Пациенты - Разносить платежные операции по вкладкам в соответствующим с типом операции" - в секции сабформ формы "Пациенты" будет отображаться либо сабформа "Переводы" с общей информацией по пациенту либо данные будут разнесены в 4 сабформы "Аванс", "ДМС", "Безнал", "Разрешения" в зависимости от типа операции.
  • "Пациенты - высота поля "Примечания" - количество строк информации в поле "Примечания"
  • "Пациенты - Цвет фона выделенной строки в табличках внизу формы" - цвет фона выделенной строки в сабформах формы "Пациенты"
  • "Пациенты - Цвет шрифта выделенной строки в табличках внизу формы" - цвет текста в выделенной строке в сабформах формы "Пациенты"
  • "Пациенты - Требовать обязательного заполнения рекламного канала"
  • "Пациенты - Отображать закладку госпитализаций" - возможность редактирования данных о госпитализациях пациента
  • "Пациенты - Разрешить ручное исправление номера медкарты только пользователям с полным доступом"
  • "Пациенты - Вводить адрес в соответствии с КЛАДР, 1=без КЛАДР, 2=только по КЛАДР, 3=КЛАДР с возможностью ручной правки"
  • "Пациенты - Выводить поле "№ договора" (Если Нет, то программа считает что N договора совпадает с N медкарты)"
  • "Пациенты - Выводить поле "Регион" (1=Выводить поле "Регион", 2=Выводить поле "Район")"
  • "Пациенты - Отображать закладку "Больничные"
  • "Пациенты - Отображать менеджера"
  • "Пациенты - Отображать оператора"
  • "Пациенты - Отображать поле "Выполненное лечение"
  • "Пациенты - Отображать поле "Паспорт выдан"
  • "Пациенты - Отображать поле "Паспортные данные"
  • "Пациенты - Отображать поле "Плательщик"
  • "Пациенты - Отображать поле "Рекомендатель"
  • "Пациенты - Отображать поле "Скидка по умолчанию"
  • "Пациенты - Отображать поле "СНИЛС"
  • "Пациенты - Отображать поля "ФИО в родительном падеже" и "ФИО в дательном падеже"
  • "Пациенты - Помечать в навигационном списке пациентов с неполностью заполненными данными"
  • "Пациенты - Регион по умолчанию (если поле "Регион" используется)"
  • "Пациенты - Справа от информации о ДМС выводить сумму Да=ДМС визитов за срок действия полиса, Нет=Все оказанные услуги"
  • "Первичным считается пациент, который не лечился Х месяцев. Х=пусто - который вообще не лечился."
  • "Печать расписания врачей - относить записи ко 2 колонке (минуты)" - время разделения колонок на утро/вечер при печати расписания врачей из формы "Расписание".
  • "Печать расписания врачей - относить записи ко 2 колонке (часы)" - время разделения колонок на утро/вечер при печати расписания врачей из формы "Расписание".
  • "Печать расписания врачей - подпись" - подпись при печати расписания врачей из формы "Расписание".
  • "Прейскурант - в дереве групп прайса по умолчанию отображать пиктограмму N" - в форме "Прейскуранты" в дереве групп услуг будет отображаться пиктограмма N или пиктограмма, заданная для группы услуг в справочнике групп. Если константа не равна "Да", то в дереве групп отображаются пиктограммы открытой и закрытой папки.
  • "Прейскурант - отображать используемое оборудование" - отображение в форме "Прейскуранты" колонки "Оборудование", в меню "Отчеты" становится доступен отчет "Окупаемость оборудования".
  • "Прейскурант - Подпись "Утверждаю" (выводится при печати прейскуранта)" - используется при печати прейскуранта из формы "Прайс"
  • "Прейскурант - Путь к логотипу (имя файла, допускается .bmp, .jpg)" - используется при печати прейскуранта из формы "Прайс"
  • "Прейскурант - Текст шапки (выводится при печати прейскуранта)" - используется при печати прейскуранты из формы "Прайс"
  • "Прейскурант - Требовать обязательного заполнения кода услуги" - при редактировании записей в форме "Прайс" выдавать предупреждение в случае незаполненного кода услуги.
  • "Прейскурант - скрывать в выпадающих списках прейскуранты со статусом "устарел" - влияет на отображение информации в списках выбора прейскурантов.
  • "Прейскурант - Отображать колонку "Срок выполнения, дни"
  • "Прейскурант - Запрещать одновременное использование оборудования для разных пациентов"
  • "Прейскурант - Отображать колонку "Группа услуг"
  • "Прейскурант - Отображать колонку "Длительность процедуры, мин", в Записи автоматически считать длительность визита"
  • "Прейскурант - Отображать колонку "Код"
  • "Прейскурант - Отображать колонку "Поставщик по умолчанию"
  • "Прейскурант - При добавлении составной услуги в Визит дочерние услуги добавлять: Да=в Назначения, Нет=в оказанные услуги
  • "Премиальные проценты (сложная версия) - начислять Да = от выработки, Нет= от полученных денег" - способ начисления премиальных процентов.
  • "Премиальные проценты (сложная версия) - вычитать долги из суммы, на которую начисляются премиальные" - влияет на вычисление премиальных процентов врачей.
  • "Премиальные проценты (сложная версия) - Курсы расчитывать отдельно, по сумме услуг курса, после завершения курса" - влияет на вычисление премиальных процентов врачей
  • "Премиальные проценты (сложная версия) - Начислять премиальные врачу №2: 1=от суммы услуг,2=от суммы оплат,3=не начислять" - влияет на вычисление премиальных процентов врачей
  • "При запуске выводить администраторам невыполненные напоминания на ближайшие Х дней (0=не выводить никогда)" - переходить при запуске программы к форме "Напоминания" при наличии просроченных или невыполненных на следующие несколько дней напоминаний. Автоматическое открытие формы "Напоминания" при запуске программы производится только для администраторов (см. справку по справочнику "Врачи").
  • "Программа - дата обновления исполняемого модуля (обновляется автоматически, пусто=не проверять)" - при запуске выдавать предупреждение при наличии новой версии программы. Если константа не задана, то проверка осуществляться не будет.
  • "Программа - размер исполняемого модуля (обновляется автоматически, 0=не проверять)" - при запуске выдавать предупреждение при наличии новой версии программы. Если константа не задана, то проверка осуществляться не будет.
  • "Расписание врачей - Конец приема, минуты" - время работы клиники
  • "Расписание врачей - Конец приема, часы" - время работы клиники
  • "Расписание врачей - Начало приема, минуты" - время работы клиники
  • "Расписание врачей - Начало приема, часы" - время работы клиники
  • "Расписание врачей (из формы Записи пациентов) - период по умолчанию (М=месяц,Н=неделя,О=всегда,В=выбр.диапазон)" - период по умолчанию при редактировании расписания врачей из формы "Запись"
  • "Расписание врачей - Список значений в выпадающем списке "Примечание", через ";" - список значений, которые будут показыны в выпадающем списке поля "Примечание" формы "Расписание работы врачей"
  • "Резервное копирование - выполнять автоматическое архивирование бэкапа" - после создания резервной копии базы данных, выполнять архивацию файла.
  • "Резервное копирование - Количество изменений документа, которые "помнит" система" - количество версий документов, доступных для просмотра в форме "История изменений документа".
  • "Резервное копирование - Путь к общей папке на сервере"
  • "Резервное копирование - Путь к папке с архивными копиями на сервере"
  • "Резервное копирование - Путь к программе архиватору"
  • "Резервное копирование - Путь к сетевой папке для хранения файлов"
  • "Резервное копирование - Сетевой путь к общей папке на сервере"
  • "Резервное копирование (изменения услуг): 3=не сохр., 2=ВСЕ, 1=только статус "Пришел", 0="Пришел" за прошедшие даты" - в зависимости от константы сохраняется информация о добавленных, удаленных и измененных услугах, удовлетворяющих условию. Информация отображается в форме "История изменения услуг" в меню "Администрирование".
  • "Словарь - при вводе списка пунктов запятую считать разделителем" -
  • "Словарь - при выводе списка слов по умолчанию выводить только первые Х слов" - количество слов отображаемых по умолчанию в правой части формы "Словарь".
  • "Справочник "Пользователи" - Запретить редактирование галочки "Работающий врач" всем кроме sa"
  • "ТМЦ - При работе с несколькими клиниками, вести учет ТМЦ по каждой клинике отдельно"
  • "ТМЦ - Отображать название артикула (код) ТМЦ"
  • "ТМЦ - Во всех формах редактирования ТМЦ отображать кто и когда создал запись"
  • "ТМЦ - Запрещать любые изменения до указанной даты включительно"
  • "ТМЦ - Запрещать образование отрицательного остатка на складе"
  • "ТМЦ - отчет "Сводка за период" считать по: FIFO (нет - по средним ценам)"
  • "ТМЦ - При автоматическом перерасчете списания ТМЦ в визите не изменять значения, скорректированные вручную"
  • "ТМЦ - Путь к списоку приходов ТМЦ, экспортированных из 1С"
  • "Файлы - Максимальный размер превью-файла по вертикали, в пикселях" - размер по вертикали превью графического файла, сохраняемого в базе данных вместе с оригинальным файлом, прикрепленным к врачебному документу или пациенту
  • "Файлы - Максимальный размер превью-файла по горизонтали, в пикселях" - размер по горизонтали превью графического файла, сохраняемого в базе данных вместе с оригинальным файлом, прикрепленным к врачебному документу или пациенту
  • "Файлы - Качество preview файла (от 1=минимум до 5=максимум)" - уровень сжатия превью графического файла
  • "Хеликс - Идентификатор МИС" - установки для обмена данными с лабораториями
  • "Хеликс - Идентификатор места забора" - установки для обмена данными с лабораториями
  • "Хеликс - При получении результатов, создавать врачебный документ от имени врача с doctor_id" - идентификационный номер врача, от имени которого будет создан врачебный документ при получении результатов анализов
  • "Хеликс - Английская аббревиатура клиники (места забора) - установки для обмена данными с лабораториями
  • "Юридические лица (ДМС) - Выводить суммы" - отображать в сафборме "Пациенты" формы "Юридические лица" колонки "Все услуги" - сумма стоимостей всех услуг, оказанных пациенту или на которые пациент записан, и "Оказанные услуги" - сумма стоимостей всех услуг оказанных пациенту, оплату которых производит страховая фирма (т.е. услуг со статусом "Пришел") и формой оплаты "ДМС". Возможность скрывать информацию о суммах предназначена для больших клиник, для повышения быстродействия системы.
  • "email - login pop3" - логин для сервера входящей почты.
  • "email - login smtp" - логин для сервера исходящей почты.
  • "email - password pop3" - пароль для сервера входящей почты.
  • "email - password smtp" - пароль для сервера исходящей почты.
  • "email - pop3 сервер" - адрес сервера для входящей почты (например, pop.crm-soft.ru).
  • "email - smtp сервер" - адрес сервера для исходящей почты (например, smtp.crm-soft.ru).
  • "email - порт pop3" - порт pop3 на почтовом сервере для входящей почты.
  • "email - порт smtp" - порт smtp на почтовом сервере для исходящей почты.
  • "e-mail (from)" - e-mail, с которого будет отправляться сообщение.
  • "e-mail (to)" - e-mail, на который будет отправляться сообщение.
  • "php - Синхронизация включена" - автоматический запуск обмена информацией между подразделениями клиники. К программе должен быть подключен модуль "Удаленный обмен информацией".
  • "php проверка наличия входящей информации, раз в Х секунд" - интервал срабатывания таймера для приема информации об изменениях в базах данных подразделений клиники. К программе должен быть подключен модуль "Удаленный обмен информацией".
  • "php рассылка изменений происходит раз в Х секунд" - интервал срабатывания таймера для отсылки информации об изменениях в базе данных в подразделения клиники. К программе должен быть подключен модуль "Удаленный обмен информацией".
  • "Хеликс - ftp host"
  • "Хеликс - ftp login"
  • "Хеликс - ftp password"

Если константа может принимать только одно из двух значений - "да/нет", то в колонке "Значения" следует указать "Да" или "Нет" (регистр букв не имеет значения). При двойном щелчке в данной колонке "Да" меняется на "Нет" и наоборот.

Пользователь может только редактировать название и значения констант. Добавление и удаление записей запрещено.

Пользователь может отфильтровать список констант по названию и номеру константы.

В программе существует группа констант, задающая значения, индивидуальные для каждой клиники. Это константы с номерами от 500 до 600. Такие константы используются для замены определенной последовательности символов (тэгов) при печати документов, сформированных на основе шаблонов. Подробнее можно посмотреть в разделе "Константы клиники".

При необходимости использования в программе дополнительных констант следует обратиться к разработчику.


АДМИНИСТРИРОВАНИЕ

Константы клиники

В данном разделе справки описывается работа с группой констант, значения которых можно переопределить для нескольких клиник.

Константы с номерами от 500 до 600 пользователи могут задавать и изменять самостоятельно. В том числе пользователи могут самостоятельно создавать новые константы. Название константы должно начинаться с префикса "Const". При печати печатных форм и врачебных документов, если программа находит тэг, название которого совпадает с первым словом названия константы, то вместо тэга подставляется значение константы. Если в программе работают несколько клиник, то для каждой клиники можно задать свое значение константы.

Начало названия константы до первого пробела должно совпадать с названием тэга. При печати документа в тексте шаблона ищется последовательность символов, с которой начинается название константы (до первого пробела). При нахождении она заменяется на строку из колонки "Значение" или на "________", если строка пустая. Название тэга не должно быть составной частью другого тэга. В противном случае возможна неправильная замена в тексте документа.

Если название константы начинается на ConstPict, то считается, что значение константы задает путь к графическому файлу, который будет подставлен в шаблон документа вместо соответствующего тэга. Использовать константы ConstPict* имеет смысл, если в программе включена работа с клиниками, например, для вставки подписи в договоры или логотипа во врачебные шаблоны, если мы хотим использовать одну и ту же ПФ (врачебный шаблон) для клиник, с разными логотипами и подписями.

С помощью констант "ConstPict1 - рисунок 1", "ConstPict2 - рисунок 2", "ConstPict3 - рисунок 3" в любую печатную форму или врачебный шаблон можно вставить рисунок. Для этого необходимо создать рисунок в каком-либо графическом формате (jpg, png, bmp) и поместить его в общую сетевую папку. К папке должен быть организован доступ (на чтение) для всех пользователей программы. В значении константы прописываем путь с указанием имени файла для вставки, например "\\server\CRM-Soft_public\DoctorovDDsign.jpg". Качество рисунка при выводе на печать зависит от качества изображения в файле.

В настоящий момент в этой группе определены следующие константы:

  • "ConstName - Название"
  • "ConstINN - ИНН"
  • "ConstJurAdr - Юр. адрес"
  • "ConstFaktAdr - Факт. адрес"
  • "ConstRS - р.с."
  • "ConstLic - Лицензия №"
  • "ConstKS - к.с."
  • "ConstBank - банк"
  • "ConstBIK - БИК"
  • "ConstDPosition - Договор подписывает: должность"
  • "ConstDFIO - Договор подписывает: ФИО"
  • "ConstLiDate - лицензия дата"
  • "ConstLiDateTill - лицензия дата окончания"
  • "ConstFirmPhones - телефоны"
  • "ConstKPP - КПП"
  • "ConstCity - город"
  • "ConstRodDFIO - ФИО директора в родительном падеже"
  • "ConstRodDPosition - Договор подписывает: должность в родительном падеже"
  • "ConstSecondLic - № второй лицензии"
  • "ConstFullName - Полное название"
  • "ConstOGRN - ОГРН"
  • "ConstOKPO - ОКПО"
  • "ConstEmail - Email"
  • "ConstBFIO - ФИО главного бухгалтера"
  • "ConstPict1 - рисунок 1"
  • "ConstPict2 - рисунок 2"
  • "ConstPict3 - рисунок 3"
  • "ConstSmsText - Название"

Далее приведен пример создания константы:

Предположим, пользователь хочет использовать в шаблоне документа тэг, определяющий время работы клиники. Он выбирает в выпадающем списке "Редактировать константы для клиники" значение "Константы по умолчанию" и добавляет константу с названием "ConstWorkTime - время работы клиники". Название константы не фиксировано, оно должно начинаться на "Const" или "ConstPict" и не быть частью других названий констант. Например, при наличии константы "ConstName" недопустимо название "ConstNameFull", "ConstFullName" - допустимо. "ConstSmsText -" - это шаблоны СМС, их количество может быть любое, после тире идет имя шаблона для удобства выбора.

Пользователь задает уникальный номер константы в диапазоне от 500 до 600, например, 555 и ее значение, "08-00 - 20-00".

Далее пользователь выбирает в выпадающем списке "Редактировать константы для клиники" нужные клиники и опять добавляет константу. При этом если в поле "Номер" задать значение 555, то название константы заполнится автоматически. Для каждой выбранной клиники задается собственное время работы.

В требуемом месте шаблона документа пользователь указывает тэг с названием "ConstWorkTime". При печати документа этот тэг заменится на значение константы, зависящее от клиники, выбранной в главном меню программы. Если для выбранной клиники значение не определено или в программу не включен модуль работы с клиниками, то подставится значение из списка "Константы по умолчанию".


АДМИНИСТРИРОВАНИЕ

Справочник "Константы пользователя"

В данном разделе справки перечислены константы и параметры, влияющие на работу программы, которые возможно настроить индивидуально для каждого пользователя.

  • "Автоматическое сохранение - при потере фокуса форма пытается сохранить данные" - при выходе из форм "Пациенты", "Документы", "Юридические лица", "Шаблоны" программа будет пытаться сохранить данные. При невозможности сохранения будет выдано предупреждение.
  • "Администрирование - При закрытии программы очищать папку для копирования файлов (attachments)"
  • "В словаре в дереве автоматически сворачивать все ветки, кроме текущей" - в форме "Словарь" при выборе узла дерева все остальные ветки будет автоматически свернуты.
  • "В словаре в дереве сохранять состояние между открытиями (Да=сохранять, Нет=сбрасывать)" - при открытии формы "Словарь" будет восстановлено предыдущее состояние формы.
  • "Визит - При создании нового визита автоматически открывать форму выбора пациента" - если при вызове формы пациент не определен, будет открыта форма выбора пациента.
  • "Визит - услуги показывать по умолчанию в виде таблички" - в форме редактирования визита услуги можно отображать либо в виде таблички, либо выводить подробную информацию о каждой оказанной пациенту услуге. Константа определяет, какой вид формы "Визит" отображается по умолчанию.
  • "Выбор услуги - Сортировка по умолчанию: Код/Название" - сортировка списка услуг в форме "Выбор услуги"
  • "Дизайнер пользовательских отчетов - высота секции дизайна параметров, %"
  • "Дизайнер пользовательских отчетов - высота секции значений параметров, %"
  • "Дизайнер пользовательских отчетов - высота секции результатов, %"
  • "Дизайнер пользовательских отчетов - ширина навигационного списка, %"
  • "Документы - высота сабформы в процентах (20% - 40%) или пикселях (200 - 400)" - высота сабформ в форме "Документы", заданная в пикселях или процентах относительно высоты экрана.
  • "Документы - открывать в режиме редактирования" - записи в форме "Документы" будут всегда находиться в режиме редактирования.
  • "Документы - отображать навигационную панель" - скрыть/отобразить навигационную панель в форме "Документы".
  • "Документы - отображать панель прикрепления файлов" - скрыть/отобразить панель прикрепления файлов в форме "Документы".
  • "Документы - отображать панель свойств текста" - скрыть/отобразить панель свойст текста в форме "Документы".
  • "Документы - отображать сабформы (услуги / напоминания)" - скрыть/отобразить сабформы в форме "Документы".
  • "Документы - при просмотре истории навигации учитывать только измененные документы" - при переходе в предыдущему/последующему документу с помощью кнопок в тулбаре формы "Документы" будут учитываться только измененные документы.
  • "Документы - При создании документа по умолчанию показывать только избранные шаблоны"
  • "Запись на прием - в первой колонке отображать: Да=понедельник, Нет=текущую дату" - в зависимости от константы в режиме выбора врача первая колонка будет соответствовать понедельнику текущей недели или текущей дате.
  • "Запись на прием - максимальная ширина колонки"
  • "Запись на прием - отображаемая по умолчанию закладка по врачам"
  • "Запись на прием - отображаемая по умолчанию закладка по кабинетам"
  • "Запись на прием - по умолчанию подсвечивать 1=VIP, 2=Врача, 3=Форму оплаты, 4=Специальность, 5=Статус, 6=ДМС компанию" - выбор значения по умолчанию для выпадающего списка "Подсвечивать" для отображения различными цветами ячеек.
  • "Запись на прием - В выборе врача выводить специальность (Сокращенная специальность: ФИО врача)" - отображать специальность в выпадающем списке выбора врача.
  • "Запись на прием - Возможность выбора врача для каждой колонки" - возможность в режиме просмотра расписания на день выбирать врача для каждой колонки по отдельности.
  • "Запись на прием - Высота одной строки в пикселах. 0 означает автонастройку." - если константа равна 0, то программа автоматически подстроит высоту клетки, так чтобы на по вертикали клетки расписания занимали все имеющееся на экране место.
  • "Запись на прием - Количество колонок (дней) при показе одного доктора" - при начальной установке программы количество колонок задается равным 7 (по количеству дней недели). Изменение этой константы имеет смысл, если в пользователя широкий монитор.
  • "Запись на прием - Открывать карточку визита в режиме редактирования" - если значение константы равно "Нет", то после открытия карточки Визита администратору нужно нажать кнопку перехода в режим редактирования, чтобы получить возможность вносить изменения.
  • "Запись на прием - При выборе врача скрывать не работающих врачей" - в системе нельзя удалять уволившихся врачей, если на них есть ссылки, например есть документы, принадлежащие этому врачу, либо есть услуги, оказанные врачом. Кроме того, часть зарегистрированных в системе пользователей (администраторы) не занимаются приемом пациентов. Поэтому со временем список врачей становится довольно большим. Чтобы облегчить работу администраторов, можно задать значение константы равным "Да". В этом случае при выборе врача в форме "Запись" в списке будут отображаться только те пользователи системы, для которых в форме "Врачи" (Справочники - Врачи) поставлена галочка "Работает".
  • "Запись на прием - при нажатии на "Печать": 1=Предпросмотр, 2=Печать, 3=Открыть в Ворде" - задает режим просмотра или печати документов из формы.
  • "Запись на прием - При создании визита выбирать по умолчанию последнего пациента с которым работали" - по умолчанию константа равна "Нет". Если изменить значение на "Да", то при создании нового визита программа будет подставлять последнего пациента, с которым пользователь работал в форме Пациентов.
  • "Запись на прием - Ширина одной колонки в пикселах. 0 означает автонастройку." - если константа равна 0, то программа автоматически подстроит ширину клетки, так чтобы на по горизонтали клетки расписания занимали все имеющееся на экране место.
  • "Запись на прием - Ширина подписи Времени приема в пикселах" - задает ширину подписей времени (9:00, 9:30 и т.д.), расположенных слева от клеток записи на прием.
  • "Запись - по умолчанию открывать режим (1=Врачи день, 2=Кабинеты день, 3=Врач неделя, 4=Каб.неделя)" - режим по умолчанию при открытии формы "Запись"
  • "Отчет "Продажи" - в первую очередь по умолчанию группировать по"
  • "Отчет "Продажи" - во вторую очередь по умолчанию группировать по"
  • "Отчет "Продажи" - по умолчанию период: 1=тек. день, 2=тек. месяц, 3=квартал"
  • "Отчет "Продажи" - Состояние галочек "Выводить колонки" - список колонок для вывода в отчете (заполняется программой при выходе из формы"
  • "Пациенты - По умолчанию отображать закладку" - название закладки, которая будет автоматически выбрана при первом открытии формы "Пациенты"
  • "Пациенты - при нажатии на "Печать": 1=Предпросмотр, 2=Печать, 3=Открыть в Ворде" - автоматическое действие при выборе шаблона документа из выпадающего списка "Напечатать" в форме "Пациенты".
  • "Прейскурант - Ширина колонки с деревом групп" - ширина левой части формы "Прайс".
  • "Премиальные проценты врачей (сложное начисление) - кол-во колонок в форме" - количество колонок в форме "Премиальные проценты врачей". Максимальное количество колонок - 50.
  • "Рекламные каналы - Ширина дерева (в процентах от ширины экрана)"
  • "Файлы - Графические файлы открывать с помощью программы" - полный путь до программы, с помощью которой будут открываться графические файлы, прикрепленные к врачебным документам или пациентам

Если константа может принимать только одно из двух значений - "Да/Нет", то в колонке "Значения" следует указать "Да" или "Нет" (регистр букв не важен). При двойном щелчке в данной колонке "Да" меняется на "Нет" и наоборот.

Дополнительную информацию можно посмотреть в соответствующем разделе справки.

Пользователь может только редактировать название и значения констант. Добавление и удаление записей запрещено. При необходимости использования в программе дополнительных констант следует обратиться к разработчику.

При выборе пункта меню "Сброс настроек текущего пользователя" происходит копирование значений констант главного администратора (пользователь с логином "sa") в константы текущего пользователя. При этом все сделанные изменения пропадают.

При открытии формы пользователем, входящим в группу "Администраторы" на форме появляются дополнительные элементы [1] и [2].

Выпадающий список выбора врача [1] служит для отображения констант выбранного пользователя.

При выборе [2] сбрасываются настройки выбранного пользователя, т.е. происходит копирование значений констант главного администратора (пользователь с логином "sa") в константы выбранного пользователя.


АДМИНИСТРИРОВАНИЕ

Настройка названий колонок в таблицах

В данном разделе описывается возможность настраивать названия отображаемых в таблицах колонок, их размеры, порядок следования и выравнивание индивидуально для каждого пользователя.

В программе реализована возможность по-разному настраивать таблицы в формах в зависимости от предпочтений и требований пользователей. Практически для каждой таблицы в контекстном меню администратора системы (пользователя sa) есть пункт "Настроить колонки". При выборе данного пункта откроется форма настройки таблиц:

Форма создается автоматически на основе данных таблицы. Для отображения колонок в таблице требуется перенести нужные столбцы из правой в левую часть. Затем можно задать порядок следования столбцов, их размеры, названия заголовков, выравнивание заголовков и данных в столбце. Переносить столбцы и задавать порядок можно как с помощью кнопок "вверх", "вниз", "вправо", "влево", так и с помощью мыши. Одновременно можно выделять несколько столбцов.

Пункт контекстного меню "настройка колонок" доступен только администратору базы данных (пользователю sa). Другие пользователи могут менять шарину колонок с помощью мышки, и изменять порядок следования колонок, перетаскивая их мышкой. Новое расположение колонок и их размеры сохранятся при закрытии формы. Каждый пользователь может сбросить свои настройки названий колонок для всех таблиц и пользовательские константы, выбрав пункт "Сбросить настройки текущего пользователя" в меню. При этом все данные будут изменены на настройки главного администратора системы - пользователя с логином "sa".

При обновлении версии программы, в случае если в программе были добавлены новые таблицы, или колонки в существующей таблице, сотрудник разработчика может выполнить общий сброс названий колонок. В этом случае всем пользователям будут скопированы настройки пользователя sa, плюс параметры отображения новых колонок.


АДМИНИСТРИРОВАНИЕ

Безопасность и защита данных

При запуске программы пользователь должен ввести логин и пароль, без этого программа не будет работать. Программа допускает сохранение логина и пароля в .ini файле, но делать это не рекомендуется. Авторизация пользователей (проверка логина и пароля) производится с помощью встроенных средств MS SQL Server. MS SQL Server используется в огромном количестве организаций по всему миру, в том числе для хранения конфиденциальных данных. Надежность и безопасность MS SQL Server является общепризнанной.

Физическое хранение данных.
Согласно стандартам безопасности, при хранении конфиденциальных данных рекомендуется располагать сервер в закрытом помещении с ограниченным доступом. Если злоумышленник украдет сервер, он сможет получить доступ к данным. Существуют специальные системы, позволяющие производить шифрование данных. Если Вы интересуетесь защитой на серьезном уровне, Вы можете позвонить по телефону (812) 930-3663 и договориться о консультации. Наша компания занимается поставкой и настройкой специальных систем, предназначенных для шифрования данных на серверах, ноутбуках и т.п., контролем доступа и т.д., но данный вопрос выходит за рамки справки, которую Вы сейчас читаете.

То же замечание относится к резервным копиям на dvd, ленты и т.п. - рекомендуется хранить резервные копии в защищенном месте. В программе предусмотрена возможность автоматического шифрования ежедневных резервных копий данных с использованием криптографически стойкого алгоритма AES со значительной длиной ключа. Автоматическое шифрование резервных копий включается по запросу Заказчика.

Администрирование сервера.
Сотрудники, обладающие правом администрирования сервера, автоматически получают полный доступ к данным. Для защиты сервера рекомендуется пользоваться услугами профессиональных системных администраторов, которым Вы доверяете.

Пересылка данных.
Программа допускает возможность пересылки данных на другую площадку. При этом пересылаемый архив шифруется с использованием криптографически стойкого алгоритма AES. Advanced Encryption Standard (AES), также известный, как Rijndael — симметричный алгоритм блочного шифрования (размер блока 128 бит, ключ 128/192/256 бит), финалист конкурса AES, принят в качестве американского стандарта шифрования правительством США. В данный момент AES является одним из самых распространённых алгоритмов симметричного шифрования.

Человеческий фактор.
Следует иметь в виду, что самая совершенная система защиты информации бесполезна, если логины и пароли для доступа в систему написаны на бумажке, приклеенной к монитору. То же самое можно сказать про слишком простые логины и пароли. По статистике, большая часть утечек информации происходит в результате действий инсайдеров - людей, имеющих доступ к системе, либо в результате халатности сотрудников.


АДМИНИСТРИРОВАНИЕ

Извещения

В статье описывается возможность создания и просмотра извещений.

В программе реализована возможность создания сотрудниками клиники сообщений для оповещения о наступлении различных событий.

Создание извещений возможно из форм "Пациенты" и "Запись". Для создания извещений нужно щелкнуть левой клавишей мыши с нажатой клавишей "Alt", "Ctrl" или комбинацией клавиш "Alt+Ctrl" на свободном месте в правой части формы "Пациенты" или на клетке визита в форме "Запись". При этом откроется форма:

Список кому формируется следующим образом:

Сначала идут все активные администраторы. Разделитель (строка из минусов). Потом идут все активные пользователи. Разделитель (строка из минусов). И наконец идут все прочие пользователи по алфавиту.

Извещение может быть отослано немедленно или с отсрочкой. Для этого из выпадающего списка "Отсрочка извещений" нужно выбрать одно из значений 5/10/15/30/60 минут/24 часа/неделя/месяц.

В выпадающем списке "Тип извещения" доступны следующие варианты:

  • Сообщение, созданное вручную
  • Пациент пришел
  • Напоминание самому себе
  • Задача
  • Сообщение активным администраторам

Клавиши "Alt" и "Ctrl" определяют некоторые параметры извещений по умолчанию:

При щелчке с нажатой клавишей "Ctrl" открывается окно отправки извещения врачу который ведет прием (врачу визита) или лечащему врачу пациента (при открытии из формы "Пациенты").

С нажатой клавишей "Alt" открывается окно отправки извещения самому себе с отсрочкой 15 минут.

С нажатой комбинацией клавиш "Alt+Ctrl" открывается окно отправки извещения всем активным администраторам текущей клиники. Вместо выпадающего списка "Кому" выводится список активных администраторов через запятую.

После выбора параметров извещения, указания текста извещения и нажатия на кнопку "Сформировать извещение" извещение будет сохранено в базе данных.

Для получения извещений на компьютере должна быть установлена и запущена дополнительная программа "Извещения". С частотой, заданной в константе "Извещения - выполнять проверку наличия извещений раз в Х секунд", программа просматривает список извещений и выбирает из них те, для которых адресат входит в список сотрудников, для которых данный компьютер помечен как рабочее место пользователя, и время извещения меньше текущего. Если при этом запущена основная программа, то пользователь увидит на экране сообщение:

После вывода на экран сообщение считается прочитанным и в дальнейшем не отображается.

Для того чтобы пометить компьютер как рабочее место врача, нужно в основной программе в форме "Пользователи" из контекстного меню ячейки столбца "Компьютер" выбрать соответствующий пункт:


АДМИНИСТРИРОВАНИЕ

Настройка файла "med.ini"

В данном разделе описываются параметры, которые можно настроить в файле "med.ini".

При запуске, программа считывает информацию с настройками из ини файла. Название ини файла может совпадать с именем ехе, т.е. например ехе "crm_soft_doctor.exe", ini файл "crm_soft_doctor.ini". Если настроечный файл с совпадающим именем не найден, то программа ищет файл с именем "med.ini". В большинстве случаев, используется стандартное имя настроечного файла "med.ini".

В файле указываются основные параметры, требуемые для установления связи с sql-сервером:

  • Имя сервера, состоит из имени (или ip в сети) компьютера, обратного слеша, имени sql server (задается при установке). По умолчанию это имя компьютера\sqlexpress
  • Название базы данных
  • Логин и пароль пользователя. Если логин и пароль не указаны, или указаны неверно, программа выполнит запрос этих данных. В подавляющем большинстве случаев, логин и пароль не указываются.

Если имя сервера или название базы данных в med.ini указаны неверно, следует выйти из программы и задать правильные значения.

Если невозможно соединиться с сервером, используя указанные логин и пароль, программа предоставит возможность задать их повторно. Возможность задать логин и пароль в ини файле в основном используется при тестировании. В рабочем режиме, из соображений безопасности, указывать пароль в ини файле не рекомендуется.

В базе данных всегда существует учетная запись пользователя "sa" с паролем, установленным администратором базы данных. Ее можно использовать для задания логина и пароля других пользователей. Все настройки, добавление пользователей, и прочие административные действия, производятся из-под логина sa. Администрации клиник рекомендуется надежно хранить пароль sa, и не терять. Сотрудникам техподдержки рекомендуется обращать внимание руководства клиентов на важность надежного сохранения пароля.

Дополнительную информацию можно посмотреть в разделе Справочник "Пользователи".

Разбор файла med.ini по строкам (курсивом выделены значения):

[main] | Название секции параметров. Обязательно идет первой строчкой.
server=HOOM-1FEDDDF197\SQLEXPRESS | Имя сервера. Должно быть одинаковым во всех ini файлах на всех компьютерах. При проблемах с определением имени сервера, например в распределенных сетях, иногда задается с использованием ip-адреса сервера, вместо имени. Например, "192.168.1.1\SQLEXPRESS". В этом случае системный администратор должен обеспечить неизменность ip сервера.
database=vera | Имя базы данных
user=qwe | Имя пользователя. В большинстве случаев не указывается. Используется обычно сотрудниками техподдержки во время отладки, когда надо много раз подряд запускать программу.
password=123 | Пароль пользователя. В большинстве случаев не указывается. Используется обычно сотрудниками техподдержки во время отладки, когда надо много раз подряд запускать программу. При обычной работе, заполнять в med.ini пароль не рекомендуется, из соображений безопасности.
provider=max | Версия драйверов, используемая программой для связи с сервером. Рекомендуемое значение "max", при этом используется последняя версия из найденных драйверов. Другие допустимые значения от OLE DB до MS SQL Server 2012: SQLOLEDB.1, SQLNCLI, SQLNCLI.1, SQLNCLI10, SQLNCLI10.1, SQLNCLI11. Информацию можно увидеть в программе, выбрав пункт верхнего тулбара «Помощь» и подпункт «О программе». Подробнее см. статью справки Администрирование - Обновление драйверов, используемых программой для связи с сервером
programm-id=1 | Позволяет запускать на одном компьютере несколько экземпляров программы. Используется в случае, если Заказчик просит дополнительно установить тестовую версию программы. Например, для обучения, или для проверки работы каких-либо новых режимов. В этом случае в каждом настроечном файле должен быть указан отличающийся programm-id
key-id=123456789 | id ключа
key-database=g82 | База ключа. Параметр используется крайне редко, программистами при отладке программы.
db-name=g82 | Используется программистами при отладке программы, для активации фишек, привязанных к имени базы.
default-clinic=2 | id клиники по умолчанию при запуске программы (если включена работа с клиниками)
allow-recalc=On | Показывает пункт меню Администрирование - Обновить данные
helix-exchange=Off | При наличии в клинике работы с Хеликсом устанавливает таймаут в секундах для автоматического обмена анализами и их результатами. 0 - не проводить обмен анализами. OFF - запрещает обмен анализами при старта, а также обновление справочников
alfalab-exchange=Off | при наличии в клинике работы с Альфа Лаб устанавливает таймаут в секундах для автоматического обмена анализами и их результатами. 0 - не проводить обмен анализами. OFF - запрещает обмен анализами при старта, а также обновление справочников
kassa-n=1 | Список ID касс через запятую, подключенных к этому компьютеру
kassa-default=2 | Касса, которая указывается как касса визита, при создании нового визита на этом компьютере
log-level=0 | уровень логирования SQL запросов. 0 - не логировать, 1 - при ошибках, 2 - все

Следующая табличка содержат параметры, используемые при обновлении версии программы. См. также статью Администрирование - Автоматическое обновление программы. В большинстве случаев, эти параметры прописываются в отдельном файле updater.ini, но могут быть включены и в файл med.ini. Данные параметры используются при запуске программы через апдейтер.

[files] | Название секции
1=crm-soft-med.chm | файлы для автоматического обновления при запуске программы
2=GrdVkc32.dll | файлы для автоматического обновления при запуске программы
3=crm-soft-upd.exe | файлы для автоматического обновления при запуске программы
4=updater.ini | файлы для автоматического обновления при запуске программы
[updater] | Название секции
WriteToLog=1 | обновление (crm-soft-upd.exe): писать ошибки в лог файл
WriteToDlg=1 | обновление (crm-soft-upd.exe): выводить ошибки на экран
Autostart=1 | обновление (crm-soft-upd.exe): запускать после работы основной файл
TestAlwaysCopy=1 | обновление (crm-soft-upd.exe): копировать всегда (0 - работать в штатном режиме)
[db] | Название секции
UseDbConnect=1 | обновление (crm-soft-upd.exe): обновлять из БД. Всегда должен быть равен 1, другие значения более не поддерживаются.
DbLogin=updater | обновление (crm-soft-upd.exe): логин для подключения к базе для обновления
DbPass=124 | обновление (crm-soft-upd.exe): пароль для подключения к базе для обновления

Устарело

auto-backup=off | Включение или выключение автоматического создания резервной копии при первом за день включении программы. Устаревший параметр, сейчас вместо него используется константа 358 [Рез. копирование - Создавать рез.копию при первом запуске программы в течение дня(Да/Нет,или дни между полными бэкапами)]
test-mode=off |
god-mode=off |
checkmail=off |
php-send=off |
php-receive=off |
operation_system=winXP | используется в одном месте значение WIN2003 для скрытия иконок меню в Записи
post-database= |
post-restore= |


Опросы пациентов

Рекламные каналы

В разделе описывается возможность получения информации о способах получения пациентами информации, благодаря которым они узнали о клинике.

В программе реализован механизм сбора информации о действенности того или иного вида рекламы.

Возможные виды рекламы вносятся в справочник "Рекламные каналы". Для удобства пользователя справочник представлен в двух режимах:

Для переключения между режимами служит кнопка [image] в тулбаре.

Для каждого пациента можно указать рекламный канал, благодаря которому пациент узнал о клинике. Для этого в форме "Пациенты" при редактировании пациента нужно нажать кнопку "Рекламный канал" рядом с соответствующим полем.

После нажатия на кнопку откроется форма выбора рекламного канала:

Вторая кнопка очищает значение рекламного канала для пациента.

Выбор рекламного канала также доступен при проведении анкетирования, описанного в разделе справки "Анкетирование".

Вывод накопленной информации происходит в отчете "Рекламные каналы".


Опросы пациентов

Анкетирование

В разделе описывается возможность анкетирования пациентов.

Программа позволяет осуществлять анкетирование пациентов. Анкетирование возможно для как для существующих пациентов, так и для впервые пришедших в клинику и еще не введенных в базу данных. Анкета может быть не привязана к конкретному пациенту. В настоящее время при анкетировании осуществляется сбор информации о поводе обращения (какие группы услуг интересуют пациента), о рекламных каналах (откуда пациент узнал о клинике), о рекламных акциях, заинтересовавших пациента. Список рекламных акций и каналов редактируются соответствующих справочниках.

Просмотр информации о существующих анкетах осуществляется в форме "Анкеты", которая вызывается из меню "Опросы".

С помощью полей [1] возможно отфильтровать список анкет по дате и клинике. Кнопка [2] очищает фильтр. Кнопки [3] добавления новой записи, удаления записи являются стандартными. При нажатии на кнопку добавления новой записи или при двойном щелчке на имеющейся записи откроется форма редактирования анкеты:

В форме возможно указать несколько поводов обращения и рекламных акций и только один рекламный канал. Сохранение записей осуществялется нажатием на кнопку "Записать данные". Кнопка "Очистить" только снимает галочки для выбранных поводов обращения и рекламных акций и каналов, но не удаляет саму анкету. Для отказа от добавления новой анкеты достаточно выйти из формы без сохранения. Удаление существующей анкеты возможно только из формы "Анкеты".


Опросы пациентов

Опросы

В разделе описывается возможность осуществления опросов пациентов.

Программа позволяет осуществлять опросы пациентов на основе заранее подготовленных списков вопросов и ответов.

В первую очередь заполняется справочник "Опросы - список опросов" доступный из меню "Опросы". Затем открывается форма "Опросы - вопросы и ответы":

В форме одновременно заполняется список вопросов и ответов. Если добавленная запись является вопросом, то поле "№ ответа" должно быть пустым. В поле "После ответа перейти к вопросу №" задается номер следующего вопроса. В этом же поле определяется и последовательность перехода в случае выбора определенного варианта ответа. Если поле оставить пустым, то переход будет осуществляться последовательно, согласно номерам вопросов. Программа не отслеживает правильность переходов в опросе.

Ввод, удаление и редактирование опросов осуществляется из сабформы "Опросы" формы "Пациенты". Добавление и удаление опросов происходит с помощью контекстного меню. При добавлении записи открывается форма "Добавить новый опрос". Требуется выбрать опрос из выпадающего списка, задать дату опроса и нажать кнопку "Записать данные".

После этого откроется форма редактирования опроса.

Редактирование осуществляется выбором нужного ответа из списка. Переход к следующему/предыдущему вопросу происходит с помощью соответствующих кнопок. Переход осуществляется согласно правилам, определенным в форме "Опросы - вопросы и ответы". В правой части формы отображается сформированный опрос. С помощью контекстного меню возможно открыть форму предварительного просмотра опроса и при необходимости распечатать его.

Редактирование существующих опросов осуществляется при двойном щелчке на выбранном опросе. Редактирование происходит в вышеописанной форме.

В форме "Опросы", доступной из меню "Опросы" отображается полный список осуществленных опросов.

Возможно отфильтровать список опросов по дате, редактировать опросы с помощью двойного щелчка на записи и удалять опросы.


ТМЦ

Приход

Форма предназначена для редактирования списка поступивших на фирму товарно-материальных ценностей.

[1] - возможно отфильтровать список материалов, поступивших на фирму, по дате прихода, задав интервал или выбрав дату из уже имеющегося списка дат приходов, по группе материалов, конкретному материалу, складу, на который поступил материал, и поставщику. При первом открытии формы задается фильтр по дате прихода - текущий месяц.

[2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающих списках, задает интервал дат - текущий месяц.

[3] - выводит на печать содержимое таблицы.

Кнопки [4] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

При добавлении и редактировании данных поля "Дата", "Склад ТМЦ", "ТМЦ", "Количество в упаковке", "Количество упаковок" и "Стоимость" являются обязательными для заполнения. Данные в колонке "Итого штук" вычисляются автоматически, сама колонка недоступна для редактирования.


ТМЦ

Инвентаризация

Форма предназначена для проведения инвентаризации товарно-материальных ценностей.

Для правильного учета ТМЦ на фирме возможно проведение инвентаризаций. Данные о наличии того или иного материала на конкретную дату заносятся в базу данных и впоследствии доступны для просмотра. Информация об остатках ТМЦ расчитывается начиная с последней инвентаризацией, бывшей перед датой остатков. Если при формировании остатков система не находит предшествовавшую инвентаризацию, за дату начала расчетов принимается 1 января 2008 года.

[1] - список материалов, имеющихся на фирме, возможно отфильтровать по дате инвентаризации, группе материалов, складу, на котором находится материал.

[2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающих списках, сбрасывает дату инвентаризации.

Кнопки [3] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

При нажатии на кнопку "Расчитать план" [4] вычисляется предположительное наличие на складе материала на утро заданной даты. К количеству материала, зафиксированного на дату последней перед выбранной датой инвентаризации, прибавляются данные об автоматическом списании, переброске, приходе и списании материала с даты последней инвентаризации по заданную дату. При этом заполняются 2 колонки, "Кол-во" и "Кол-во плановое". При расчете отчетов по остаткам ТМЦ, используется колонка "Кол-во". Колонка "Кол-во плановое" нужна для справки, чтобы после корректировки колонки "Кол-во" можно было сравнить фактическое количество с расчетным.

Поля "Дата", "Склад ТМЦ", "ТМЦ", "Количество" являются обязательными для заполнения.


ТМЦ

Переброска

Форма предназначена для проведения переброски товарно-материальных ценностей с одного склада на другой.

[1] - список материалов, переводимых между различными складами, возможно отфильтровать по дате переброски, группе материалов, перебрасываемому матералу, начальному и конечному складу.

[2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающих списках, сбрасывает дату переброски.

Кнопки [3] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

При добавлении и редактировании данных поля "Дата", "Со склада", "На склад", "ТМЦ", "Количество штук в упаковке" и "Количество упаковок" являются обязательными для заполнения. Данные в колонке "Итого" вычисляются автоматически, сама колонка недоступна для редактирования.


ТМЦ

Списание

Форма предназначена для редактирования списка списываемых товарно-материальных ценностей.

[1] - возможно отфильтровать список списываемых материалов по дате списания, группе материалов, конкретному материалу, складу, на котором находился материал, и сотруднику, ответственному за списание.

[2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающих списках, сбрасывает дату списания.

[3] - выводит на печать содержимое таблицы.

Кнопки [4] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

При добавлении и редактировании данных поля "Дата списания", "Склад ТМЦ", "ТМЦ", "Количество" являются обязательными для заполнения.

Списание материалов в программе производится тремя способами:

  • Автоматическое списание - каждой из оказываемых в клинике услуг можно сопоставить набор ТМЦ, списываемых при оказании услуги.
  • При редактировании документа врач может указать список ТМЦ, израсходованных при оказании конкретной услуги.
  • В форме "Списание" ответственный за ТМЦ сотрудник может ввести данные о списании товаров. При разработке программы предполагалось, что форма "Списание" будет использоваться для ввода информации об испортившихся либо утерянных ТМЦ, но это не обязательно.


ТМЦ

Список операций по товару

Форма предназначена для просмотра списка операций, произведенными с товарно-материальными ценностями.

Форма позводяет получить итоговую информацию о действиях, производимых с материалами: приходом, переброской со склада на склад, списанием, автоматическим списанием при оказании определенных услуг. Данные доступны только для просмотра.

[1] - для формирования списка операций необходимо задать дату операции, дату инвентаризации и конкретный материал. Дата инвентаризации выбирается из выпадающего списка дат, всех когда-либо проводившихся инвентаризаций. Если инвентаризации на фирме еще не проводились необходимо выбрать "01.01.2008". Дата инвентаризации должна быть меньше, чем дата операции.

[2] - при наличии галочки "Выводить описание операции" в колонку "Комментарий" добавится дополнительная информация об операции. Например, для операции "Приход" добавится название поставщика. Если галочка не установлена, однотипные операции, произошедшие в один день, суммируются в одну строчку.

[3] - выводит на печать содержимое таблицы. при наличии галочки "Выводить описание операции" в отчете появится дополнительная колонка "Комментарий". Всего в отчете может выводится информация по четырем складам одновременно. В зависимости от того, в каждом ли выпадающем списке складов ТМЦ [4] задан склад, некоторые колонки могут отсутствовать.

[4] - Выпадающие списки складов ТМЦ позволяют выбрать склады, информация по которым выводится в таблице. Одновременно можно выбирать не больше четырех складов. По умолчанию при открытии формы из выпадающих списков выбираются склады ТМЦ в зависимости от приоритета, заданного в справочнике "Список складов ТМЦ". В первом выпадающем списке будет выбран склад с приоритетом 1 и т.д.


ТМЦ

Отчет "Сводка за период"

Данный отчет позводяет получить сводную информацию об остатках материалов на складах фирмы и список операций, произведенных с товарно-материальными ценностями, за определенный период.

При первом открытии формы устанавливается интервал дат - текущий месяц. Для формирования отчета необходимо задать обе даты.

При выборе склада ТМЦ из выпадающего списка в отчет будут включены данные о материлах, находящихся только на этом складе.

Задав все параметры и нажав на кнопку "Сформировать отчет" пользователь получает отчет:

Данные в отчете сгруппированны по группам ТМЦ. Подсчитывается сумма стоимости материалов, пришедших на склад, по каждой группе и итоговая сумма.


ТМЦ

Отчет "Остатки ТМЦ"

Данный отчет позводяет получить список материалов, находящихся на складах фирмы на определенную дату.

Для формирования отчета необходимо задать дату отчета и дату инвентаризации. Дата инвентаризации выбирается из выпадающего списка дат, всех когда-либо проводившихся инвентаризаций. Если инвентаризации на фирме еще не проводились необходимо выбрать "01.01.2008". Дата инвентаризации должна быть меньше, чем дата отчета.

Выпадающие списки складов ТМЦ позволяют задать названия складов для просмотра наличия материала на данном складе. Одновременно в отчете может выводиться информация не больше чем по четырем складам. По умолчанию при открытии формы из выпадающих списков выбираются склады ТМЦ в зависимости от приоритета, заданного в справочнике "Список складов ТМЦ". В первом выпадающем списке будет выбран склад с приоритетом 1 и т.д.

Задав все параметры и нажав на кнопку "Сформировать отчет" пользователь получает отчет:


ТМЦ

Нормы списания ТМЦ

Форма предназначена для редактирования списка товарно-материальных ценностей, автоматически списываемых при оказании определенных услуг.

Для некоторых услуг может быть точно известно количество того или иного материала, расходуемого при оказании услуги. Было бы желательно, чтобы при добавлении услуги в форме "Визит" нужное количество ТМЦ списывалось автоматически.

[1] - возможно отфильтровать список материалов, подлежащих списанию, по оказываемой услуге, по группе материалов, конкретному материалу, складу, на котором находится материал.

[2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающих списках.

Кнопки [3] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

При добавлении и редактировании данных поля "Услуга", "Склад ТМЦ", "ТМЦ" и "Количество списываемых ТМЦ" являются обязательными для заполнения.


ТМЦ

Заполнить автоматическое списание

Форма предназначена для автоматического списания материалов, использованных при оказании услуг.

При выполнении автоматического списания для услуг каждого визита из выбранного периода будет произведено списание материалов на основании данных, введенных в форме "Автоматическое списание ТМЦ". Данные, введенные или измененные вручную в сабформе "ТМЦ" формы "Визит" будут утеряны.

Для выполнения автоматического списания требуется указать период и нажать на кнопку "Списание".


ТМЦ

Список складов ТМЦ

Справочник предназначен для ввода и редактирования данных о складах, предназначенных для хранения товарно-материальных ценностей.

При добавлении и редактировании записей обязательно для заполнения только поле "Склад ТМЦ". В колонке "Порядок вывода в отчетах" можно задать склады, которые будут автоматически выбираться в выпадающих списках складов ТМЦ при первом открытии форм "Список операций по товару", "Остатки ТМЦ" и отображаться в отчетах, сделанных на основании этих форм. Достаточно задать приоритет от 1 до 4 для четырех выбранных складов.


ТМЦ

Справочник ТМЦ

Справочник предназначен для редактирования списка товарно-материальных ценностей.

[1] - возможно отфильтровать список материалов по группе материалов и конкретному материалу.

[2] - кнопка сброса фильтра. Очищает выбранные значения в выпадающих списках.

Кнопки [3] добавления новой записи, удаления записи и переключения режима запрета редактирования являются стандартными, и работают одинаково во всех формах.

При добавлении и редактировании данных поля "Группа ТМЦ" и "ТМЦ" являются обязательными для заполнения. Данные из колонки "Количество в упаковке по умолчанию" будут автоматически подставлены в столбец "Количество в упаковке" в форме "Приход" при выборе соответствующего материала.


ПРОФОСМОТРЫ

Пациенты

Форма предназначена для редактирования списка профосмотров пациентов.

Форма вызывается при нажатии на кнопку [image] в основном тулбаре или при выборе соответствующего пункта в меню "Профосмотры".

Поля наверху формы [1] нужны для фильтрации записей списка пациентов слева. В данном списке присутствует первым элементом "Все пациенты", этот пункт отобразит все визиты всех пациентов, попадающие под фильтр над списком.

[2] карточка пациента для профосмотра. Тут же по плюсику можно добавить нового.

[3] создание, редактирование и удаление в таблице профосмотров

[4] - кнопка позволяет загрузить из файла Excel подготовленный список пациентов, проходящих профосмотр. Microsoft Excel должен быть установлен на компьютере. До начала импорта необходимо выбрать фирму, для которой будут загружены данные. Импорт осуществляется из активного (выбранного в момент открытия) листа. Будет предложено сопоставить колонки из Excel с данными в таблице, указать необходимо ли пропустить первую строку с шапкой. Номера пунктов из приказа 302 распознаются автоматически по префиксам "п ", "п." или просто "п", и преобразуются в услуги. При получении ошибки на каком-то из этапов импорта данные с ошибкой в Excel будут помечены красным фоном с текстом ошибки в комментариии, и предложено отменить все изменения прекратив импорт. Вы можете поправить ошибки в файле запустить импорт повторно. Обязательно перед импортом закройте Excel с файлом, который будет загружаться.

[5] - позволяет добавить вредность или специальность одному осмотру.

[6] общий статус осмотра, вычисляется автоматически из статусов пройденных исследований и проведеных анализов.

[7] - итоги по соответствующим колонкам.

Список исследований и анализов представлен колонками с разделением на две: статус (проставляется пользователем) и стоимость (берется автоматически из прайса). Если для данного осмотра услуга не оказывается, то ее ячейки окрашены в серый цвет.


ПРОФОСМОТРЫ

Фирмы

Справочник предназначен для ввода и редактирования данных о фирмах, заключивших договора на проведение профосмотров.

Поле "Название" обязательно для заполнения. Значения, введеные в колонке "Тип осмотра", автоматически подставляются в колонку "Тип осмотра" при вводе новых пациентов в форме "Профосмотры". Здесь же указываем по какому прейскуранту считаем услуги, а также номер и дату действия договора по профосмотрам.


ПРОФОСМОТРЫ

Услуги, вредности, исследования

Список необходимых услуг для профосмотров.

Сотрудникам конкретной специальности может оказываться определенный набор услуг, в зависимости от её вредности. Регулируется это приказом 302, в котором в двух приложениях расписаны факторы вредности каждой специальности. Все эти данныезагружены в Прейскурант в виде обычных и составных услуг.


ПРОФОСМОТРЫ

Отчет по профосмотрам

Данный отчет является основным инструментом для анализа прохождения профосмотров в различных разрезах.

При формировании отчета возможно задать фильтр по диапазону дат и фирме-клиенту [1]. По умолчанию отчет строится по профосмотрам, пройденным в течение текущего месяца. Поставив галочку "Включать осмотры без дат" в отчет можно добавить записи, для которых не проставлено поле "Дата осмотра". Для формирования отчета необходимо чтобы стояла хотя бы одна галочка "Учитывать осмотренных" (пациенты полностью прошедшие профосмотр) или "Учитывать неосмотренных". Остальные настройки - необязательны.

Выпадающие списки [2] "Группировать по" позволяют выводить информацию в различных разрезах:

  • Год
  • Месяц
  • День
  • Фирма
  • Профессия
  • Фамилия
  • Вид осмотра
  • Услуга
  • Без группировки

По умолчанию выбрана группировка Фирма/Услуга

Задав все параметры и нажав на кнопку "Сформировать отчет" пользователь получает отчет:


АДМИНИСТРИРОВАНИЕ

Экспорт/импорт шаблонов и печатных форм

В данном разделе справки описаны импорт и экспорт шаблонов и печатных форм для переноса между серверами.

Экспорт шаблонов

Экспорт шаблонов возможен только под логином sa.

Для того чтобы сохранить шаблон на диске нажимаем кнопку [image], открывается окно выбора места для сохранения файла. Выбираем папку, куда хотим сохранить шаблон, нажимаем "сохранить".

Шаблон сохраняется в папке в виде rtf-файла, файлы с рисунками и параметрами шаблона сохраняются в виде текстовых txt-файлов.

При экспорте всех шаблонов они по умолчанию сохраняются в папке «attachments», поэтому перед экспортом необходимо ее очистить на том компьютере, на котором осуществляется экспорт. После этого нажимаем кнопку [image].

Если в базе были шаблоны с именами, которые нельзя сохранить на диск, например содержат недопустимые знаки (двоеточие и. т. д.), то имя файла переименуется в «Нераспознанное название шаблона».

Если в базе есть шаблоны с таким же названием, то к имени шаблона прибавится дата.

Импорт шаблонов.

Импорт шаблонов возможен только под логином sa.

Для того чтобы открыть шаблон с диска нажимаем кнопку [image], потом [image], откроется окно выбора папки, из которой вы хотите загрузить шаблон, выбираем нужный файл, нажимаем открыть.

Для массового импорта шаблонов нажимаем кнопку [image], выбираем папку, в которой лежат шаблоны (по умолчанию предлагается «attachments»), нажимаем «ОК», программа предлагает выбрать действие при обнаружении файлов с одинаковым названием:

Выбираем необходимое действие, нажимаем «ок».

После сообщения об окончании импорта нажимаем кнопку [image].

Импорт завершен.

Экспорт Печатных форм.

Экспорт печатных форм возможен только под логином sa.

Для того чтобы загрузить на диск печатные формы, необходимо нажать кнопку [image] в верхнем тулбаре.

Программа предложит выбрать папку для сохранения, выбираем, нажимаем «ок», появляется сообщение «Экспорт шаблонов завершен» и открывается папка с сохраненными печатными формами.

Импорт Печатных форм.

Импорт печатных форм возможен только под логином sa.

Для того чтобы загрузить в программу печатные формы, нажимаем в верхнем тулбаре кнопку [image], программа предлагает выбрать папку для сохранения, после выбора нажимаем «ок», экспорт печатных форм завершен.