Электронное справочное издание

«Союз Промышленников и Предпринимателей Санкт-Петербурга»

Информационная система Союза промышленников и предпринимателей Санкт-Петербурга содержит следующую информацию:

– о предприятиях входящих в региональное объединение работодателей «Союз промышленников и предпринимателей Санкт-Петербурга»;

– о предприятиях входящих в состав коллективных членов регионального объединения работодателей «Союз промышленников и предпринимателей Санкт-Петербурга»;

– о членах общественной организации «Союз промышленников и предпринимателей Санкт-Петербурга» (физические лица) и об организациях, которые они представляют.

Возможности системы позволяют эффективно использовать информационный массив базы данных для формирования и сохранения собственных пользовательских списков по различным критериям поиска; возможность внесения собственных пометок и замечаний; возможность экспорта данных.
Издание предназначено для руководителей и специалистов, принимающих решения о выборе партнеров, поставщиков, подрядчиков и субподрядчиков.


Список организаций

Главным элементом программы является «список организаций». Списки бывают временными и постоянными.

Временные списки формируются автоматически либо при запуске программы, либо при удалении всех списков организаций из перечня, либо при открытии какого-либо объединения бизнеса в отдельном окне. Временный список в отличие от постоянного существует только в памяти программы, поэтому при открытии последнего, такой список будет автоматически удален из перечня (рисунок 1.1). Временный список можно редактировать и сохранять как постоянный, такой список хранится в отдельном файле, который в последствие можно переносить с одного компьютера на другой.

Рисунок 1.1


Вид окна

Как видно из рисунка 1.2, в верхней части главного окна расположены «Кнопки управления» (выделено красным цветом) и «Панель инструментов», которая дублирует команды меню «Файл». Слева от панели инструментов расположен перечень списков (выделено синим цветом).

Нижняя левая часть окна состоит из трех закладок:

- товары и услуги;

- список организаций;

- поиск.

Нижняя правая часть окна отображает информацию об организациях.

При просмотре информации об организациях (при выделении одного из объединений бизнеса) на вкладке «Список организаций» правая часть окна будет поделена на две части; в верхней части будут отображаться организации, входящие в выделенное объединение бизнеса, в нижней - информация о выделенной организации.

При просмотре «Первых лиц» и наличии биографии первого лица предприятия правая часть также будет поделена на две части, при чем в верхней части будет отображаться биография. Организации, в которых вложена биография первых лиц, отмечены в списке организаций голубым цветом.

Рисунок 1.2

В содержании информации об организации Вы можете увидеть следующие рисунки (кнопки):

- при нажатии открывает информационный рисунок организации;

- при нажатии открывает фотографию контактного лица или отдела;

- при нажатии открывает информацию о продукте;

- указывает что указанный адрес является почтовым.


Отображение организаций

Следует знать, что:

- на вкладке «Список организаций» в списке (выборке; рисунок 1.3) отображаются все организации, входящие в текущий список;

- на вкладке «Товары и услуги» в правой части окна отображаются организации, входящие в выбранный Вами вид товаров или услуг. Аналогично на вкладке «Список организаций» при выборе одного из объединений бизнеса, отображаются организации, входящие в это объединение;

- на вкладке «Поиск» отображаются найденные в ходе поиска организации.

Примечание: в окне «Список» отображаются все организации, входящие в список.

Рисунок 1.3


Члены ОО СПП СПб

Для просмотра информации о Членах Общественного Объединения Союза Промышленников и Предпринимателей Санкт-Петербурга, необходимо нажать соответствующую кнопку, расположенную сверху основного окна приложения. При этом откроется новое окно, содержащее две вкладки:

- на вкладке «Члены ОО СПП СПб» отображаются все персоны, входящие в союз;

- на вкладке «Поиск» отображаются найденные в ходе поиска персоны.

Рисунок 1.4


Редактирование списков

Со списками доступны следующие операции:

- добавление организаций из других списков;

- удаление организаций из списка;

- добавление и удаление списков;

- изменение настроек списков.

Добавление организаций в список осуществляется их «перетаскиванием» при помощи мыши из других списков. Для того, чтобы добавить сразу несколько организаций, воспользуйтесь клавишей Shift и удерживая ее перетащите выбранные Вами организации (рисунок 1.5).

Рисунок 1.5


Быстрый поиск

В момент просмотра списка существует возможность быстрого перехода (поиска) организации по первым буквам названия. При этом вводимые Вами буквы будут отображаться в левой верхней части выборки (рисунок 1.6.1). Для перехода между найденными организациями воспользуйтесь клавишами Home и End.

Рисунок 1.6.1

Также существует возможность производить поиск по включению текста. Для отображения диалога «Быстрый поиск» (рисунок 1.6.2) нажмите клавишу F3 или Ctrl + F.

Рисунок 1.6.2


Команды меню

Меню файл
 | Сохранить список
 | Сохранить список как...
 | Удалить текущий список
 | Изменить настройки данного списка...
 | Открыть список в отдельном окне
 | Экспорт
 | Печать
 | Изменить комментарий к организации
 | Сохранить организации как список...
 | Удалить выбранные организации из списка
 | Отменить
 | Вернуть
 | Выход
Настройки
 | Сортировка по умолчанию
 | Вид по умолчанию
Справка
 | Вызов справки
 | О программе...
 | О базе данных...
Окна


Команда меню «Сохранить список»

Данная команда предназначена для быстрого сохранения текущего списка.

В случае, если в главном окне текущим является временный список или постоянный, который не редактировался с момента его открытия, данная команда будет недоступной. В окне «Список» данная команда доступна всегда, так как в этом случае она сохраняет не только сам список, но также размеры и положение окна.

Для выполнения данной команды используйте следующую комбинацией клавиш: Ctrl + S

Примечание: Если список является временным, то будет вызвано диалоговое окно «Сохранение списка...»


Команда меню «Сохранить список как...»

Данная команда предназначена для сохранения текущего списка под новым именем. Команда вызывает диалоговое окно «Сохранение списка...» (рисунок 2.1).

В случае, если открыт постоянный список, будет создана его копия с новым именем; если временный, то он будет сохранен и станет постоянным.

Опция «Важный список» позволяет выделить сохраняемый Вами список организаций среди остальных. В перечне такой список будет выделен другим цветом и будет находиться в начале списка. При создании копии или изменении настроек постоянного списка в правом верхнем углу диалогового окна отображается имя файла, в котором он храниться. Все файлы, содержащие постоянные списки, лежат в директории «Base».

Примечание: перечень списков загружается программой при ее запуске.

Рисунок 2.1


Команда меню «Удалить данный список»

Данная команда предназначена для удаления текущего списка без возможности восстановления.

Команда вызывает диалоговое окно для подтверждения операции.

При удалении текущего списка организаций в главном окне программы будет открыт первый постоянный список из перечня. В случае если такого нет, будет автоматически создан временный список «Все организации».


Команда меню «Изменить настройки данного списка...»

Данная команда предназначена для изменения настроек постоянного списка. Команда вызывает диалоговое окно «Настройки списка...», аналогичное по виду диалоговому окну «Сохранение списка...».


Команда меню «Открыть список в отдельном окне»

Данная команда предназначена для открытия списков в отдельном окне - «Список» (рисунок 2.2).

В отличии от главного окна программы, окно «Список» имеет компактный вид, т.е. не отображает в себе информацию об организациях, однако просмотреть информацию все же можно, воспользовавшись командой контекстного меню «Информация об организации». Окно «Список» поддерживает все принятые в главном окне программы команды. Основная функция такого окна - «трафик организаций» из одного списка в другой, как описано в разделе «Редактирование списков».

При сохранении списка организаций окно «Список» сохраняет свои размеры и положение на экране. При повторном открытии данного списка сохраненные настройки будут восстановлены.

Тип отображения окна позволяет сделать открытые в отдельных окнах списки - поверх остальных, что в некоторых случаях бывает полезным. Данная настройка сохраняется программой автоматически и будет применена при следующем запуске.

Примечание: один и тот же список организаций не может быть открыт дважды, т.е. в разных окнах.

Рисунок 2.2


Команда меню «Экспорт»

Данная команда предназначена для экспорта информации об организациях в файл формата RTF. Команда вызывает диалоговое окно - «Экспорт» (рисунок 2.3).

При нажатии на кнопку «Экспорт» на экран будет выведен запрос о сохранении файла. Пользователь принимает решения: какие организации экспортировать (все или выделенные) и какие поля должны попасть в файл. Введенные пользователем настройки запоминаются программой автоматически. Кроме того, Вы можете воспользоваться контекстным меню, нажав на списке полей правую клавишу мыши, которое позволяет выбрать сразу все поля или наоборот отменить выбор.

Примечание: настройки диалогового окна «Экспорт» являются общими с диалоговым окном «Печать». Поле «Название организации» является обязательным и его экспорт нельзя отменить.

Рисунок 2.3


Команда меню «Печать»

Данная команда предназначена для вывода на печать информации об организациях. Команда вызывает диалоговое окно - «Печать» (рисунок 2.4), аналогичное по виду диалоговому окну «Экспорт», в отличие от которого имеет дополнительную опцию - «Предварительный просмотр».

Для предварительного просмотра документа (рисунок 2.5) необходимо включить опцию «Предварительный просмотр».

Примечание: процесс печати на принтер можно остановить с помощью кнопки «Отмена»

Рисунок 2.4 | Рисунок 2.5

Диалоговое окно «Предварительный просмотр» предназначено для отображения и дальнейшей печати информации об организациях.

В верхней части окна расположены следующие элементы управления:

- кнопка «Печать» производит печать документа;

- выпадающий список «Масштаб» позволяет выбрать нужный Вам масштаб, также его можно ввести вручную;

- кнопки перемещения помогают удобно перемещаться по документу, аналогично с масштабом - номер нужной Вам страницы можно ввести вручную.

Диалоговое окно «Предварительный просмотр» запоминает свои размеры, положение на экране и установленный масштаб.

Примечание: процесс печати на принтер можно остановить с помощью появляющийся кнопки «Отмена» (рисунок 2.6).

Рисунок 2.6


Команда меню «Изменить комментарий к организации»

Данная команда предназначена для назначения, изменения или удаления комментария к организации. Команда вызывает диалоговое окно - «Редактор комментария» (рисунок 2.7). Организации, у которых есть комментарий, отмечаются специальным значком (рисунок 2.8).

Для выполнения данной команды можно использовать клавишу Enter или двойное нажатие левой клавиши мыши по имени организации в списке.

Рисунок 2.7

Рисунок 2.8


Команда меню «Сохранить организации как список...»

Данная команда предназначена для создания нового списка организаций из выборки. Команда вызывает диалоговое окно «Создание списка...» (рисунок 2.9), аналогичное диалоговому окну «Сохранение списка...».

С помощью этой команды можно создавать списки организаций из любой выборки в главном окне.

Примечание: команда создает список организаций на основе всех организаций в выборке.

Рисунок 2.9


Команда меню «Удалить выбранные организации из списка...»

Данная команда позволяет удалять выбранные организации из текущего списка.

Также для выполнения данной команды можно воспользоваться клавишей Delete.


Команда меню «Отменить»

Данная команда предназначена для отмены последнего действия над списком, такие как добавление или удаление организаций.

При нажатии на кнопку «Отменить» правой клавишей мыши будет вызвано контекстное меню (рисунок 2.10), в котором можно отменить сразу несколько действий. Верхняя строка меню - самое последнее действие над списком.

Пример:

Из рисунка видно, что пользователь сначала удалили 9 организаций из списка, затем добавил 9 организаций из другого списка и в конце удалил 8 организаций. Следовательно, если воспользоваться этой командой один раз, то в список вернуться 8 удаленных организаций.

Примечание: программа помнит только 10 последних действий. При сохранении списка - отмена предыдущих действий станет недоступна.

Рисунок 2.10


Команда меню «Вернуть»

Данная команда предназначена для возврата последнего отмененного действия над списком, таким как добавление или удаление организаций.

При нажатии на кнопку «Вернуть» правой клавишей мыши будет вызвано контекстное меню (рисунок 2.11), в котором можно вернуть сразу несколько действий. Верхняя строка меню - самое последнее отмененное действие над списком.

Примечание: программа помнит только 10 последних отмененных действий. При сохранении списка или появлении нового действия над списком - возврат предыдущих действий станет недоступным.

Рисунок 2.11


Команда меню «Выход»

Данная команда меню выполняет закрытие приложения.

В случае, если в программе есть открытые несохраненные списки, пользователю перед выходом будет предложено их сохранить.


Сортировка по умолчанию

Данное меню позволяет выбрать один из двух вариантов:

- по умолчанию;

- по алфавиту.

Программа запоминает какой вариант был выбран пользователем. При запуске программы у всех выборок организаций устанавливается тип сортировки, который был выбран с помощью данного меню. Также данная настройка является начальным значением типа сортировки для списков, открывающихся в отдельных окнах.


Вид по умолчанию

Данное меню позволяет выбрать один из двух вариантов:

- организации;

- первые лица.

Программа запоминает какой вариант был выбран пользователем. При запуске программы у всех выборок организаций устанавливается тип вида, который был выбран с помощью данного меню. Также данная настройка является начальным значением типа вида для списков, открывающихся в отдельных окнах.


Вызов справки

Позволяет получить информацию о возможностях и доступных командах программы.


Команда меню «О программе...»

Открывает диалоговое окно, в котором отображается информация об авторских правах и номере версии программы.


Команда меню «О базе данных...»

Открывает диалоговое окно, в котором отображается информация об имени открытой базы данных.


Команда меню «Окна»

Данное меню позволяет переключаться между списками, открытыми в отдельных окнах. Если таковых нет, то меню будет содержать в себе один элемент - «Нет открытых окон со списками».


Диалоговое окно «Классификатор»

Данное диалоговое окно предназначено для выбора товаров и услуг из классификатора, по которым будет производиться поиск.

Левая часть окна содержит в себе дерево товаров и услуг, которые знает программа (рисунок 3.1). С помощью поля для ввода и кнопки «Найти» можно ограничить набор показываемых услуг. Для того, чтобы дерево снова отображало все виды услуг, следует удалить из поля ввода текст и нажать кнопку «Найти». В правой части окна находится список из товаров и услуг, которые Вы выбрали и, соответственно, по которым будет производиться поиск организаций.

Рисунок 3.1


Диалоговое окно «Объединения бизнеса»

Данное диалоговое окно предназначено для выбора объединений бизнеса, по которым будет производиться поиск (рисунок 3.2).

Для того, чтобы выбрать все объединения бизнеса или, наоборот, отменить выбор, Вы можете воспользоваться контекстным меню, нажав правую клавишу мыши над списком (рисунок 3.3).

Рисунок 3.2

Рисунок 3.3


Диалоговое окно «Информация об организации»

Данное диалоговое окно предназначено для просмотра информации об организации в отдельном окне (рисунок 3.4).

Для вызова такого окна достаточно воспользоваться одноименной командой контекстного меню окна «Список» или нажать на ссылку в главном окне при просмотре информации о первых лицах организаций (рисунок 3.5). Диалоговое окно «Информация об организации» запоминает свои размеры и положение на экране.

Рисунок 3.4

Рисунок 3.5